Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
evolution-data-server wants to emerge -- why?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
jagdpanther
Guru
Guru


Joined: 22 Nov 2003
Posts: 585

PostPosted: Tue Aug 02, 2005 4:04 am    Post subject: evolution-data-server wants to emerge -- why? Reply with quote

running

Code:
emerge -pv -u --deep world


gives gnome-extra/evolution-data-server and several of evolution-data-server prerequsits. I don't use evolution and grepping for evolution in /var/lib/portage/world gives nothing.

What is now requiring evolution-data-server or how to I query to find out?
Back to top
View user's profile Send private message
JTHM
Tux's lil' helper
Tux's lil' helper


Joined: 31 Jul 2005
Posts: 115
Location: South Farms

PostPosted: Tue Aug 02, 2005 4:24 am    Post subject: Reply with quote

Try an emerge -pv -ut (t for tree) --deep world (or "emerge -uDpvt world" :F). That should at least tell you what's requiring the package. I just saw this exact same issue not five minutes ago in another post, but I can't for the life of me find it now. I'll let you know if it turns up.
_________________
Any problem can be solved. You just need to throw enough time and ninjas at it.
Back to top
View user's profile Send private message
JTHM
Tux's lil' helper
Tux's lil' helper


Joined: 31 Jul 2005
Posts: 115
Location: South Farms

PostPosted: Tue Aug 02, 2005 4:43 am    Post subject: Reply with quote

Found it:
https://forums.gentoo.org/viewtopic-t-365821-highlight-.html
_________________
Any problem can be solved. You just need to throw enough time and ninjas at it.
Back to top
View user's profile Send private message
hra
n00b
n00b


Joined: 02 Aug 2005
Posts: 27
Location: Haarlem, NL

PostPosted: Tue Aug 02, 2005 8:52 am    Post subject: Reply with quote

I had the same problem this morning so i did some investigation. After some digging and looking in CVS i found out someone added some use flags to make.default "by request of the gnome team", namely 'eds' and 'gstreamer'

See http://www.gentoo.org/cgi-bin/viewcvs.cgi/profiles/default-linux/amd64/make.defaults?rev=1.9&view=log f.e. (Rev. 1.9)

adding -eds to your use flags should prolly fix things. No clue as to why eds should be in the default profile...
Back to top
View user's profile Send private message
smurfd
Apprentice
Apprentice


Joined: 04 May 2005
Posts: 176

PostPosted: Tue Aug 02, 2005 9:07 am    Post subject: Reply with quote

some gnome stuff is/can be, using the evolution-data-server.
thats most likely why.
Back to top
View user's profile Send private message
jagdpanther
Guru
Guru


Joined: 22 Nov 2003
Posts: 585

PostPosted: Tue Aug 02, 2005 5:13 pm    Post subject: Reply with quote

Thanks the " emerge -pv -ut --deep world" shows:

Code:
[nomerge      ] net-im/gaim-1.4.0-r2  -cjk -debug +eds* -gnutls -krb4 +nas +nls +perl -silc +spell +
[ebuild  N    ]  gnome-extra/evolution-data-server-1.2.1-r1  -debug -doc +ipv6 -kerberos -ldap +mozi
[ebuild  N    ]   www-client/mozilla-1.7.10-r1  +crypt -debug +gnome +ipv6 +java -ldap -mozcalendar
rm -postgres +ssl +truetype -xinerama -xprint 30,198 kB


It looks like the new eds flag shows up for gaim which then requires evolution-data-server and mozilla. Guess I'll try adding "-eds" to my use flags as hra suggested.

Thanks for the feedback.
Back to top
View user's profile Send private message
Joffer
Guru
Guru


Joined: 10 Sep 2002
Posts: 585
Location: Arendal, Norway

PostPosted: Tue Aug 02, 2005 7:42 pm    Post subject: Reply with quote

jagdpanther wrote:
Thanks the " emerge -pv -ut --deep world" shows:

Code:
[nomerge      ] net-im/gaim-1.4.0-r2  -cjk -debug +eds* -gnutls -krb4 +nas +nls +perl -silc +spell +
[ebuild  N    ]  gnome-extra/evolution-data-server-1.2.1-r1  -debug -doc +ipv6 -kerberos -ldap +mozi
[ebuild  N    ]   www-client/mozilla-1.7.10-r1  +crypt -debug +gnome +ipv6 +java -ldap -mozcalendar
rm -postgres +ssl +truetype -xinerama -xprint 30,198 kB


It looks like the new eds flag shows up for gaim which then requires evolution-data-server and mozilla. Guess I'll try adding "-eds" to my use flags as hra suggested.

Thanks for the feedback.

I did the same ting today (-eds) since I don't use Evolution and some other "strange" packages that wanted to get installed after my last sync..
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum