Joined: 12 May 2004
|Posted: Mon Jul 04, 2005 1:16 pm Post subject: [ GLSA 200507-02 ] WordPress: Multiple vulnerabilities
|Gentoo Linux Security Advisory
Title: WordPress: Multiple vulnerabilities (GLSA 200507-02)
Date: July 04, 2005
WordPress contains PHP script injection, cross-site scripting and path disclosure vulnerabilities.
WordPress is a PHP and MySQL based content management and publishing system.
Vulnerable: < 184.108.40.206
Unaffected: >= 220.127.116.11
Architectures: All supported architectures
James Bercegay of the GulfTech Security Research Team discovered that WordPress insufficiently checks data passed to the XML-RPC server. He also discovered that WordPress has several cross-site scripting and full path disclosure vulnerabilities.
An attacker could use the PHP script injection vulnerabilities to execute arbitrary PHP script commands. Furthermore the cross-site scripting vulnerabilities could be exploited to execute arbitrary script code in a user's browser session in context of a vulnerable site.
There are no known workarounds at this time.
All WordPress users should upgrade to the latest available version:
|# emerge --sync
# emerge --ask --oneshot --verbose ">=www-apps/wordpress-18.104.22.168"
Last edited by GLSA on Fri May 18, 2007 4:17 am; edited 3 times in total