Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Can't create a user!!!
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
crimson
Guru
Guru


Joined: 27 Apr 2002
Posts: 430
Location: Cedar Rapids, IA

PostPosted: Thu Mar 20, 2003 8:40 am    Post subject: Can't create a user!!! Reply with quote

This is odd! I've never had this problem before, but now I just created a user and as root tried: "su crimson". I get: Unable to cd to "/home/crimson" .

I also have made sure that permissions are OK, and that I actually CAN cd to it. I cannot log in as a regular user! Help!
Back to top
View user's profile Send private message
spOOwn
Apprentice
Apprentice


Joined: 02 Nov 2002
Posts: 259
Location: Belgium

PostPosted: Thu Mar 20, 2003 8:56 am    Post subject: Reply with quote

is /home/crimson dir created ???

berore creating a user, you must do this directory...

check it !!
Back to top
View user's profile Send private message
pjp
Administrator
Administrator


Joined: 16 Apr 2002
Posts: 16616

PostPosted: Thu Mar 20, 2003 5:39 pm    Post subject: Reply with quote

Perhaps SA3: Adding users can be helpful.

Moved from Installing Gentoo.
_________________
Find them! Fix them! Fight them! Finish them! -- GEN Matthew B. Ridgway
Back to top
View user's profile Send private message
crimson
Guru
Guru


Joined: 27 Apr 2002
Posts: 430
Location: Cedar Rapids, IA

PostPosted: Thu Mar 20, 2003 6:32 pm    Post subject: Reply with quote

yes spoown the directory is created, I'm not an idiot! Like I said, I checked permissions and everything was fine. Would this have something to do with ext3 quotas? I enabled them in the kernel this time around.... Still that doesn't seem right.
Back to top
View user's profile Send private message
crimson
Guru
Guru


Joined: 27 Apr 2002
Posts: 430
Location: Cedar Rapids, IA

PostPosted: Thu Mar 20, 2003 6:36 pm    Post subject: Reply with quote

I even emerged that superadduser program and had that create the user and directory for me. I still get that error!

Here are the permissions on the folder /home/crimson:

drwx--x--x 3 crimson wheel crimson

All of the files in the directory (except .. of course) have acceptable ownership.

WTF do I do?
Back to top
View user's profile Send private message
pjp
Administrator
Administrator


Joined: 16 Apr 2002
Posts: 16616

PostPosted: Thu Mar 20, 2003 6:36 pm    Post subject: Reply with quote

what is the output of the groups command for the user?
_________________
Find them! Fix them! Fight them! Finish them! -- GEN Matthew B. Ridgway
Back to top
View user's profile Send private message
crimson
Guru
Guru


Joined: 27 Apr 2002
Posts: 430
Location: Cedar Rapids, IA

PostPosted: Thu Mar 20, 2003 6:53 pm    Post subject: Reply with quote

audio users wheel . Also here is the output of trying to login from the actual console:
Code:

illuminati.localdomain.login: crimson
password:

login(pam_unix)[19980]: session opened for user crimson by (uid=0)
Last Login: Thursday March 20 on 3

Displays my nice ascii penguin motd

No directory /home/crimson!
login(pam_unix)[19980]: session closed for user crimson
[pam_console]: getgrnam failed for cd-writer.

illuminati.localdomain.login:
Back to top
View user's profile Send private message
pjp
Administrator
Administrator


Joined: 16 Apr 2002
Posts: 16616

PostPosted: Thu Mar 20, 2003 7:08 pm    Post subject: Reply with quote

What is the entry for the user in /etc/passwd ?
_________________
Find them! Fix them! Fight them! Finish them! -- GEN Matthew B. Ridgway
Back to top
View user's profile Send private message
crimson
Guru
Guru


Joined: 27 Apr 2002
Posts: 430
Location: Cedar Rapids, IA

PostPosted: Thu Mar 20, 2003 10:40 pm    Post subject: Reply with quote

ok in /etc/passwd I have

crimson:x:1000:10:Adam Knutson,,,:/home/crimson:/bin/bash

in /etc/passwd- I have

crimson:x:1000:10::/home/crimson:/bin/bash

:( this sucks.
Back to top
View user's profile Send private message
crimson
Guru
Guru


Joined: 27 Apr 2002
Posts: 430
Location: Cedar Rapids, IA

PostPosted: Fri Mar 21, 2003 9:24 am    Post subject: Reply with quote

I tried re-emerging pam and that didn't help. I wonder if I should try starting from stage 3 again, because that worked last time.. Are there any packages I could re-emerge that might solve this?
Back to top
View user's profile Send private message
Ethereal
n00b
n00b


Joined: 19 Mar 2003
Posts: 38
Location: Russia, Moscow

PostPosted: Fri Mar 21, 2003 8:56 pm    Post subject: Reply with quote

Maybe you need to
#chown -R crimson /home/crimson
?
Back to top
View user's profile Send private message
crimson
Guru
Guru


Joined: 27 Apr 2002
Posts: 430
Location: Cedar Rapids, IA

PostPosted: Fri Mar 21, 2003 10:16 pm    Post subject: Reply with quote

I wish it were that easy. Like I said before, the permissions on all of the files and directories are rwx for user crimson, group users
Back to top
View user's profile Send private message
Ethereal
n00b
n00b


Joined: 19 Mar 2003
Posts: 38
Location: Russia, Moscow

PostPosted: Sat Mar 22, 2003 10:29 am    Post subject: Reply with quote

Are you using PAM? Maybe that's the source of problems?
Back to top
View user's profile Send private message
crimson
Guru
Guru


Joined: 27 Apr 2002
Posts: 430
Location: Cedar Rapids, IA

PostPosted: Mon Mar 24, 2003 6:27 am    Post subject: Reply with quote

I don't know exactly what the problem was. I just reinstalled gentoo again, and maybe it was a USE flag or something but it's working fine again.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum