Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
mjpegtools - odd behavior..
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
MasterRa
n00b
n00b


Joined: 13 Dec 2002
Posts: 21
Location: Little Rock, AR USA

PostPosted: Mon Feb 17, 2003 8:50 pm    Post subject: mjpegtools - odd behavior.. Reply with quote

I've got an avi file from my digicam encoded with the mjpg/mjpeg codec.. i need to get it into something a little more playable.. like an mpeg file. I've installed mjpegtools, and using lavtrans i've converted it to jpeg files (about 200 of them.. it's a 16 second file). Well, let me back up. If i use lav2yuv and then pipe it to mpeg2enc, everything works fine.. problem is that mpeg2enc will not let you specify a 15fps frame rate.. obviously my video looks kinda funny at twice the frame rate. So if anyone knows a simple way to change the framerate of an mpeg file to 15fps, that will solve my problem. I looked, and didn't find anything.. so i used lavtrans to break the avi up into 200 jpeg files.. problem is, the files arn't valid. I don't know what they are.. a hex edit shows something about AVI in the header of the file, which obviously isn't right.. I figured maybe it was some odd format, and that it will understand it.. but when i try to load them back into jpeg2yuv, it complains about an missing Huffman something or other.. which i figure means the header is wrong and the file is bad..

anyone have any idea why this is happening? :)

Thanks!
Back to top
View user's profile Send private message
paranouei
n00b
n00b


Joined: 27 Jun 2002
Posts: 30
Location: Málaga, España (Spain)

PostPosted: Wed Feb 19, 2003 12:32 pm    Post subject: Reply with quote

Sorry, I don't know about the framerate, but you could also use mencoder to convert the file to a divx file:

mencoder -ovc lavc -lavcopts vcodec=mpeg4:vhq:vbitrate=700 yourmjpegfile.avi -o newfile.avi

Cheers
_________________
DVD Ripping, Divx, VCD, SVCD, CVCD... in Linux
Back to top
View user's profile Send private message
anewsome
n00b
n00b


Joined: 11 Mar 2003
Posts: 4

PostPosted: Wed Mar 12, 2003 1:37 am    Post subject: Re: mjpegtools - odd behavior.. Reply with quote

The guys on the mjpeg mailing list can help you figure this out pretty easily.
Back to top
View user's profile Send private message
gilesjuk
Guru
Guru


Joined: 11 Feb 2003
Posts: 412
Location: Staffordshire, UK

PostPosted: Wed Mar 12, 2003 7:08 pm    Post subject: Re: mjpegtools - odd behavior.. Reply with quote

Use Avidemux instead?

It's slowly becoming the VirtualDub for Linux.

You'll probably need to add the filter "swap uv" if you import video from lavrec.
_________________
^<^>^<^>^
G. Jones
-=-=-=-=-=-
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum