Joined: 12 May 2004
|Posted: Mon May 09, 2005 9:04 am Post subject: [ GLSA 200505-04 ] GnuTLS: Denial of Service vulnerability
|Gentoo Linux Security Advisory
Title: GnuTLS: Denial of Service vulnerability (GLSA 200505-04)
Date: May 09, 2005
The GnuTLS library is vulnerable to Denial of Service attacks.
GnuTLS is a free TLS 1.0 and SSL 3.0 implementation for the GNU project.
Vulnerable: < 1.2.3
Unaffected: >= 1.2.3
Unaffected: >= 1.0.25 < 1.0.26
Architectures: All supported architectures
A vulnerability has been discovered in the record packet parsing in the GnuTLS library. Additionally, a flaw was also found in the RSA key export functionality.
A remote attacker could exploit this vulnerability and cause a Denial of Service to any application that utilizes the GnuTLS library.
There is no known workaround at this time.
All GnuTLS users should remove the existing installation and upgrade to the latest version:
Due to small API changes with the previous version, please do the following to ensure your applications are using the latest GnuTLS that you just emerged.
|# emerge --sync
# emerge --unmerge gnutls
# emerge --ask --oneshot --verbose net-libs/gnutls
Previously exported RSA keys can be fixed by executing the following command on the key files:
|# revdep-rebuild --soname-regexp libgnutls.so.1[0-1] |
|# certtool -k infile outfile |
Last edited by GLSA on Sat Nov 18, 2006 4:16 am; edited 3 times in total