Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Configuring old Apple LaserWriter with CUPS
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message

Joined: 15 Jan 2004
Posts: 50
Location: Los Angeles

PostPosted: Thu May 05, 2005 7:41 pm    Post subject: Configuring old Apple LaserWriter with CUPS Reply with quote

I'm trying to get Linux to use my old Apple LaserWriter Select 310, and getting nowhere!
I've used CUPS to set it up with numerous PPD files and configurations. The page is sent to the printer (parallel port lp0) because the printer light blinks, indicating activity, but none of the 30 or so test pages I've tried with different configurations printed.

I was able to get a test page to print by setting it up in KDE's printer setup in the Control Center, using the generic postscript driver. I still couln't print from an application however. I suspect it's somthing to do with postscript conversion. This old printer uses postscript level 1, I think, so when offered in the driver configuration, I specify "convert to PS level1" (but I have tried it both ways). Do I need to setup enscript or something to do the conversion? If so, show should I go about it?

I created a postscript file with the a2ps command, and did "lp" to print it. It did print, but taking up about half a page in landscape mode enclosed in a box and very small type. Looks lt's just a matter of sending proper postscript to the printer?

The printer works fine in Windows (with the driver for LaserWriter NT), so I know it's functional. I even located the PPD file in Windows and copied that to the CUPS directory (restarting cupsd after each new PPD is copied). Still didn't work.
I've tried the PPD files for LaserWriter Select 310 & 360, LaserWriter NT & NTX, HP LJ2, etc., etc.

After reading the Gentoo Printing Guide, I re-emerged cups 7 foomatic after adding cups, foomaticdb & ppds to my USE flags, edited /etc/cups.conf so
FileDevice was yes. Didn't help.

I spent all afternoon yesterday on this till I had a headace & my eyes were glazed from reading,, Gentoo forums & Google searches.
This is not the first time I have tried to fix this either.
Can anyone give me some clues to shorten the pain?

Gentoo w/kernel 2.6.11-gentoo-r6
CUPS is cups-1.1.23-r1
KDE is 3.3.2
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum