Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Screen goes blank after 15 minutes.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
pr0vidence
n00b
n00b


Joined: 12 Apr 2002
Posts: 47
Location: Connecticut

PostPosted: Fri Apr 12, 2002 1:12 am    Post subject: Screen goes blank after 15 minutes. Reply with quote

Hello all.

Just wanna say I think Gentoo is a fantastic distro. Keep up the good work.

Enough of that :)

When using my Gentoo box (or any other Linux distro for that matter), or, perhaps I should say, when NOT using my box (or maybe waiting many, many hours for something to compile), the screen will blank itself out after ~15 minutes. I would like to shut this feature off, does anyone know how? I have tried killing apmd, even shutting off power management at CMOS level. I don't know what's next.

Thanks all for the help.
Back to top
View user's profile Send private message
DaemonCat
Guest





PostPosted: Fri Apr 12, 2002 9:18 pm    Post subject: 15 minute black out Reply with quote

It's a "term thing"! the variable is "blank". I'm using "BSD style init", (Slackware) so the setting is in /etc/rc.d/rc.M , which is the initialization script for the "multi user" modes. I assume that the Sys-V style has a similar script somewhare. The line to look for is:
/bin/setterm -blank 15
Simply comment it out by inserting a "#" at the beginning of the line, OR change the "15" to "0" and it's gone for everybody.
If you just want to disable it on a "per user" basis,
/bin/setterm -blank 0
at the command prompt after you log in should do it.
Check the manpage for "setterm" for all kinds of goodies!
man setterm
at the command prompt.
Back to top
snowmoon
n00b
n00b


Joined: 05 Jun 2002
Posts: 64
Location: Albany,NY USA

PostPosted: Thu Jan 23, 2003 4:20 am    Post subject: Reply with quote

xset -dpms

might also work.
Back to top
View user's profile Send private message
pjp
Administrator
Administrator


Joined: 16 Apr 2002
Posts: 16489

PostPosted: Fri May 02, 2003 2:34 pm    Post subject: Reply with quote

Other possibilities:There might be a problem with this during installation as noted in Setterm Set During install to stop screen blanks?.
_________________
42
Back to top
View user's profile Send private message
msalerno
Veteran
Veteran


Joined: 17 Dec 2002
Posts: 1338
Location: Sweating in South Florida

PostPosted: Fri Nov 19, 2004 10:06 pm    Post subject: Reply with quote

This should do the trick:

Code:
echo "setterm -blank" >> /etc/conf.d/local.start

_________________
When harmonious relationships dissolve
Then respect and devotion arise;
When a nation falls to chaos
Then loyalty and patriotism are born.
-Lao Tse
Back to top
View user's profile Send private message
kimchi_sg
Advocate
Advocate


Joined: 26 Nov 2004
Posts: 2915
Location: Singapore

PostPosted: Thu Apr 21, 2005 6:30 pm    Post subject: Reply with quote

setterm -blank -powersave off -powerdown
_________________
Murphy's Law of Gentoo installation: If a compile can fail, it will.

MacGillicuddy's Corollary: At the most inopportune time.

Please search and read the FAQs before posting.
Back to top
View user's profile Send private message
david9999
n00b
n00b


Joined: 13 Sep 2010
Posts: 1

PostPosted: Mon Sep 13, 2010 9:03 am    Post subject: Reply with quote

For some reason my screen goes blank when I have no activity. I have screen saver set to two hours and "active screen saver when idle" unchecked. I also have power-management disabled.

I've noticed this behavior when using totem but not sure if it's just with this program or not. It goes out during a movie and I have to touch the mouse to bring the picture back. Any ideas?
Back to top
View user's profile Send private message
k9dog
n00b
n00b


Joined: 22 Jun 2009
Posts: 20
Location: Denmark

PostPosted: Sat Aug 12, 2017 10:00 pm    Post subject: Reply with quote

I don't think there is a way to block blanking in Linux (currently) fx.during media playing. You can change the period in the system setting, but a signal to not start blanking during continuous media is still missing it seems or at least not well defined.
There is many good media applications and libraries out there (VLC, Kodi ... just to mention a few), so I think distros lacking this feature, makes it hard to consider at least most distros good platforms for Media Centers. (At least I haven't heard of any implementation to do this). In Windows there is a feature that can block the blanking and sleep of normal system behavior. The exact behavior I think most users miss, is partly illustrated by the usage and description of https://dlaa.me/Insomnia/. Don't misunderstand me, I love Gentoo and this laptop gave up Window somewhere during Window 7 when Microsoft decided everything looked better if the system memory and cpu was eaten by useless .net and security updates that was meant to solve problems that should have been fixed in a way that didn't hurt performance of the overall system. Ah well considering the stripping of the last traces of any skin in Windows 10 it doesn't really matter. Gentoo is the place to be now.
Hehe sorry about that. Windows is properly okay. But I do think there is a long dark path from Windows NT to Windows 10 that shouldn't have been taken. Microsoft come many good improvements along the way. Personally I don't really feel they develop the system as an OS any more. And I think there is a big issue with drivers in every OS upgrade, that mostly mean you have to do new investments again and again.
When it comes to Linux, I think the best thing that could have happened was what Linus did for Minix and the cross development in the years to come.
Gentoo have truly continued in that spirit. I'm not entirely sure where the blanking should be blocked. Kernel/driver, X, desktop, tool like laptop_mode or some combination. I think the later, which might explain why there isn't a common implementation.
Back to top
View user's profile Send private message
Ant P.
Advocate
Advocate


Joined: 18 Apr 2009
Posts: 4338

PostPosted: Sat Aug 12, 2017 10:42 pm    Post subject: Reply with quote

k9dog wrote:
I don't think there is a way to block blanking in Linux (currently) fx.during media playing.

Works fine in mpv.
_________________
Your PID1 sucks // runit-scripts
Back to top
View user's profile Send private message
szatox
Veteran
Veteran


Joined: 27 Aug 2013
Posts: 1432

PostPosted: Sat Aug 12, 2017 11:00 pm    Post subject: Reply with quote

Some media players simulate pressing a key on a relatively short interval, which blocks screensavers (and other "user iddle" triggers)
Back to top
View user's profile Send private message
Ant P.
Advocate
Advocate


Joined: 18 Apr 2009
Posts: 4338

PostPosted: Sat Aug 12, 2017 11:11 pm    Post subject: Reply with quote

mpv just calls `xdg-screensaver suspend`, which in turn runs... xset. As you can see from the replies from 14 years ago in this thread, we've had a solution to this for quite a while...
_________________
Your PID1 sucks // runit-scripts
Back to top
View user's profile Send private message
k9dog
n00b
n00b


Joined: 22 Jun 2009
Posts: 20
Location: Denmark

PostPosted: Fri Sep 08, 2017 9:38 pm    Post subject: Reply with quote

szatox wrote:
Some media players simulate pressing a key on a relatively short interval, which blocks screensavers (and other "user iddle" triggers)


Thanks for the information. Nice to know that there at least is a used work-around, even if not all players implement it. At least it is a place to start. :) I feel like Linux has become a more user friendly environment over the last decade,so not too unlikely we'll get a more native method eventually (I guess the keypress work-around is fine until then). I guess we'll just need to ask developers to incorporate it more widely until the system does :) Just have to reninbd them to only do it while videos are actually playing.
.
Back to top
View user's profile Send private message
szatox
Veteran
Veteran


Joined: 27 Aug 2013
Posts: 1432

PostPosted: Sat Sep 09, 2017 2:13 pm    Post subject: Reply with quote

You're welcome.
Also, I recently had to find a way to suppress screensaver for players that do _not_ simulate keypress, and I found a few switches for xset.

'xset q' prits current settings
'xset s 0' disables screensaver (you can reenable it later by setting a non-zero timeout - value is in seconds)
'xset -dpms' disables power saving features, so your monitor will not suspend/power off. Enable it again with xset +dpms.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum