Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Hey devs! Gentoo 2005.0 won't boot
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Gentoo on AMD64
View previous topic :: View next topic  
Author Message
Vermyndax
Apprentice
Apprentice


Joined: 13 Dec 2003
Posts: 208

PostPosted: Mon Mar 28, 2005 4:09 am    Post subject: [SOLVED] Hey devs! Gentoo 2005.0 won't boot Reply with quote

Just tried out the new AMD64 universal ISO image and I'm sorry to report that this CD (like the first 2004.3) does not boot on the ABIT AV8 motherboard. You guys released a fixed 2004.3 that worked fine, however... but looks like the first 2005.0 exhibits the same problem.

Yes, I checked it against the MD5 sum and the CD reads fine in Windows.

mod edit: removed "on ABIT AV8" at the end of the subject to reflect that it's a general problem. --Earthwings
_________________
AMD64 3500+ (not overclocked)
ABIT AV8; 1 GB CorsairXMS 2-2-2-5 RAM
2x160gb SATA Maxtor HD - raid0
BFG 6800 GT OC 256mb AGP 8x
Leadtek WinFast XP 2000 Deluxe TV Tuner
Gentoo AMD64 / Windows XP Professional x64


Last edited by Vermyndax on Tue Mar 29, 2005 12:20 pm; edited 2 times in total
Back to top
View user's profile Send private message
cowdog
n00b
n00b


Joined: 28 Mar 2005
Posts: 1
Location: SW Montana

PostPosted: Mon Mar 28, 2005 4:27 am    Post subject: Reply with quote

Same problem with 2005.0 AMD64 (minimal) here on an Epox 8KDA3J.
Back to top
View user's profile Send private message
Schmokin
n00b
n00b


Joined: 21 Dec 2004
Posts: 47
Location: Salem, OR

PostPosted: Mon Mar 28, 2005 4:56 am    Post subject: Reply with quote

Same here. I tried both minimal and universal multiple times. Don't really think motherboard counts but MSI K8N Neo2 Platinum.
Back to top
View user's profile Send private message
Droopdude
n00b
n00b


Joined: 08 Aug 2003
Posts: 48

PostPosted: Mon Mar 28, 2005 5:15 am    Post subject: Reply with quote

Hate to be a me too, but same problem here with an Asus K8V SE Deluxe and bios firmware 1005.
Back to top
View user's profile Send private message
azca
n00b
n00b


Joined: 28 Mar 2005
Posts: 2

PostPosted: Mon Mar 28, 2005 6:47 am    Post subject: Reply with quote

same thing, cd seems to be non-bootable

Tiger K8W (S2875) MB
Back to top
View user's profile Send private message
Earthwings
Bodhisattva
Bodhisattva


Joined: 14 Apr 2003
Posts: 7753
Location: Germany

PostPosted: Mon Mar 28, 2005 7:04 am    Post subject: Reply with quote

Can someone create a bugreport about it please if there is none yet?
Back to top
View user's profile Send private message
Russ[]
n00b
n00b


Joined: 20 Nov 2004
Posts: 14

PostPosted: Mon Mar 28, 2005 7:08 am    Post subject: Reply with quote

doesn't work here either. (another random mobo)
Back to top
View user's profile Send private message
kimchi_sg
Advocate
Advocate


Joined: 26 Nov 2004
Posts: 2915
Location: Singapore

PostPosted: Mon Mar 28, 2005 7:11 am    Post subject: Reply with quote

Don't complain here, look for a open bug about this on https://bugs.gentoo.org or file a new one if there isn't.
_________________
Murphy's Law of Gentoo installation: If a compile can fail, it will.

MacGillicuddy's Corollary: At the most inopportune time.

Please search and read the FAQs before posting.
Back to top
View user's profile Send private message
weyhan
Apprentice
Apprentice


Joined: 27 May 2003
Posts: 245

PostPosted: Mon Mar 28, 2005 7:51 am    Post subject: Reply with quote

Err... guys, how does it not boot?
_________________
Han.
Back to top
View user's profile Send private message
zendron
Tux's lil' helper
Tux's lil' helper


Joined: 28 Jul 2002
Posts: 82

PostPosted: Mon Mar 28, 2005 8:55 am    Post subject: Reply with quote

The o. poster already filed a bug report .
Back to top
View user's profile Send private message
weyhan
Apprentice
Apprentice


Joined: 27 May 2003
Posts: 245

PostPosted: Mon Mar 28, 2005 9:01 am    Post subject: Reply with quote

zendron wrote:
The o. poster already filed a bug report .
Yes, saw that. Still no description about how it fail to boot...
_________________
Han.
Back to top
View user's profile Send private message
Shark63
n00b
n00b


Joined: 16 Aug 2004
Posts: 11

PostPosted: Mon Mar 28, 2005 9:27 am    Post subject: Reply with quote

i opened .iso file with WinISO and it says this cd is NON-BOOTABLE, somebody forgot to make it bootable!
Back to top
View user's profile Send private message
weyhan
Apprentice
Apprentice


Joined: 27 May 2003
Posts: 245

PostPosted: Mon Mar 28, 2005 9:32 am    Post subject: Reply with quote

Shark63 wrote:
i opened .iso file with WinISO and it says this cd is NON-BOOTABLE, somebody forgot to make it bootable!
Shoot. Was thinking of installing tonight...
_________________
Han.
Back to top
View user's profile Send private message
dapsaille
Advocate
Advocate


Joined: 02 Aug 2004
Posts: 2366
Location: Paris

PostPosted: Mon Mar 28, 2005 9:41 am    Post subject: Reply with quote

hahahahaha sort of funny .... but it isn't :?

don't boot for me too :/ on vmware and notebook for amd64 cd :p

Does someone have a trick for making it bootable ?? pleasee ..lol

OOT it's my birthday today so i am really happy about 2005.0 amd64 but ... now .. i'm sad OOT
Back to top
View user's profile Send private message
weyhan
Apprentice
Apprentice


Joined: 27 May 2003
Posts: 245

PostPosted: Mon Mar 28, 2005 9:45 am    Post subject: Reply with quote

dapsaille wrote:
hahahahaha sort of funny .... but it isn't :?

don't boot for me too :/ on vmware and notebook for amd64 cd :p

Does someone have a trick for making it bootable ?? pleasee ..lol

OOT it's my birthday today so i am really happy about 2005.0 amd64 but ... now .. i'm sad OOT
Looks like time to research on how to make it bootable... Anyone have prior experience?
_________________
Han.
Back to top
View user's profile Send private message
azca
n00b
n00b


Joined: 28 Mar 2005
Posts: 2

PostPosted: Mon Mar 28, 2005 9:50 am    Post subject: Reply with quote

YES THIS CD IS NON-BOOTABLE :)
Back to top
View user's profile Send private message
dapsaille
Advocate
Advocate


Joined: 02 Aug 2004
Posts: 2366
Location: Paris

PostPosted: Mon Mar 28, 2005 9:52 am    Post subject: Reply with quote

No idea ...

but with textpad i can read
2.6.11-gentoo-r3-k8 (root@phi) #1 SMP Thu Mar 17 23:18:59 UTC 2005
in isolinux/gentoo file

maybee a clue for this problem ^^

now we knwo wich kernel is booted for livecd install :p
Back to top
View user's profile Send private message
weyhan
Apprentice
Apprentice


Joined: 27 May 2003
Posts: 245

PostPosted: Mon Mar 28, 2005 9:53 am    Post subject: Reply with quote

azca wrote:
YES THIS CD IS NON-BOOTABLE :)
YES I KNOW :)
we do have the iso so I am thinking I can mount it as loopback and see if I can fix it that way. Even if it means that I need to copy out the content and create a new iso.
_________________
Han.
Back to top
View user's profile Send private message
dapsaille
Advocate
Advocate


Joined: 02 Aug 2004
Posts: 2366
Location: Paris

PostPosted: Mon Mar 28, 2005 9:53 am    Post subject: Reply with quote

hahahahaha i will try swap trick with a normal bootcd LOL
or maybee extract boot section of 2004.3 cd and put it in 2005.0

but does the crc is for files on the cd or for the whole cd ??
if it is for whole cd it won't work ..


Last edited by dapsaille on Mon Mar 28, 2005 9:56 am; edited 1 time in total
Back to top
View user's profile Send private message
weyhan
Apprentice
Apprentice


Joined: 27 May 2003
Posts: 245

PostPosted: Mon Mar 28, 2005 9:56 am    Post subject: Reply with quote

dapsaille wrote:
hahahahaha i will try swap trick with a normal bootcd LOL
possible. I'll give it a go when I get home.
_________________
Han.
Back to top
View user's profile Send private message
dapsaille
Advocate
Advocate


Joined: 02 Aug 2004
Posts: 2366
Location: Paris

PostPosted: Mon Mar 28, 2005 10:05 am    Post subject: Reply with quote

swaptrick don't work in vmware it complain about kernel gentoo not found .. but it is on the cdrom so .. maybee i did something wrong ...

blah ..
Back to top
View user's profile Send private message
dapsaille
Advocate
Advocate


Joined: 02 Aug 2004
Posts: 2366
Location: Paris

PostPosted: Mon Mar 28, 2005 10:15 am    Post subject: Reply with quote

Vermyndax >> maybee the title may bee modified for the benefit of community ? ^^
Back to top
View user's profile Send private message
Shark63
n00b
n00b


Joined: 16 Aug 2004
Posts: 11

PostPosted: Mon Mar 28, 2005 10:22 am    Post subject: Reply with quote

hey guys! i made it bootable :)

i'll write out the procedure, it's completely unofficial, do it at your own risk!

1. first extract content of .iso file to your home directory, for example /home/shark/gentoo-2005.0/
2. open shell and go to this directory
3. execute the following command (use path you've used for last parameter!):

Code:
mkisofs -o gentoo-2005.0.iso -b isolinux/isolinux.bin -c isolinux/boot.cat -l -no-emul-boot -boot-load-size 4 -boot-info-table /home/shark/gentoo-2005.0/


4. if everything goes well you'll have iso file made (gentoo-2005.0.iso in /home/shark/gentoo-2005.0/ in my case) and bootable :)


i didn't start the installation yet, but cd was bootable and it was nice to see splashscreen with 2005.0 written :D

let me know how it goes

EDIT
added -l parameter to command so it works properly now


Last edited by Shark63 on Mon Mar 28, 2005 11:00 am; edited 2 times in total
Back to top
View user's profile Send private message
weyhan
Apprentice
Apprentice


Joined: 27 May 2003
Posts: 245

PostPosted: Mon Mar 28, 2005 10:26 am    Post subject: Reply with quote

Shark63 wrote:
hey guy! i made it bootable :)

i'll write out the procedure, it's completely unofficial, do it at your own risk!

1. first extract content of .iso file to your home directory, for example /home/shark/gentoo-2005.0/
2. open shell and go to this directory
3. execute the following command (use path you've used for last parameter!):

Code:
mkisofs -o gentoo-2005.0.iso -b isolinux/isolinux.bin -c isolinux/boot.cat -no-emul-boot -boot-load-size 4 -boot-info-table /home/shark/gentoo-2005.0/


4. if everything goes well you'll have iso file made and bootable :)


i didn't start the installation yet, but cd was bootable and it was nice to see splashscreen with 2005.0 written :D

let me know how it goes


That was what I was talking about. :wink: Thanks for the instruction though. save me some research time.
_________________
Han.
Back to top
View user's profile Send private message
dapsaille
Advocate
Advocate


Joined: 02 Aug 2004
Posts: 2366
Location: Paris

PostPosted: Mon Mar 28, 2005 10:30 am    Post subject: Reply with quote

Ok thanks for the tip but .. i don't have gentoo installed i was waiting for 2005 and the end of lib32 for installing it so .. i'm stuck in windows .. do you have a methode for do it in windows ? or can i do it with cygwin ? Thanks in advance and great to see that someone have booted this 2005.0 successfully

but installation didn't work for the moment ?? ... well so don't bother with my request i will wait a little for a definitve solution :p

It's amazing to see that the livecd have not been tested ..... O_o

EDIT=You didn't start the installation .. ok i was thinking the installation didn't start^^ ok i install cygwin and i hope this will work .. or maybee.. can you upload your unofficial iso somewhere please if you can ?


EDIT 2= This is the key for windows users :p http://smithii.com/?q=node/view/9


Last edited by dapsaille on Mon Mar 28, 2005 10:46 am; edited 3 times in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on AMD64 All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum