Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Cups
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
ed-gentoo
n00b
n00b


Joined: 07 Jan 2003
Posts: 38
Location: Netherlands

PostPosted: Mon Jan 13, 2003 7:54 pm    Post subject: Cups Reply with quote

This one is about cups printing.

I have emerged cups and gimp-print. First I couldn't connect to the local host, but solved that by using http://0:631 (solved with my error log). Next I wanted to add my epson color stylus 880 (parralel) and saw their were no ports, I rembered I don't have parrel enabled in my kernel (should do that) so I decided to install my epson photo stylus 810 instead (usb). So I selected the usb port 1 (which to choose if you have the option of 12??) and the first driver (of the 5! same ones) listed titled epson photo stylus 810. I went to print a test page. There it goes wrong. It first said couldn't find hostname so i put it in the hosts file as 10.0.0.127 hostname for the pc is connected to an adsl modem which is dhcp server. Then retried to print the test page and then nothing comes out and the job stays on 1% what is wrong here?

Any ideas welcome to solve which usb port (printer connected to usb hub which is found by kernel), which of the drivers! And any other important things
_________________
Why Linux?

For I think it's the most interesting, stable, and configurable OS there is!
..... that's if you have the motivation!

(info about my computer systems can be found on my site under the link systems)
Back to top
View user's profile Send private message
ronmon
Veteran
Veteran


Joined: 15 Apr 2002
Posts: 1043
Location: Key West, FL

PostPosted: Tue Jan 14, 2003 1:08 am    Post subject: Reply with quote

The web interface for CUPS is kind of neat looking, but I've never been able to do a complete configuration with it. Inevitably, I end up doing a lot of hand editing on cupsd.conf and printers.conf, which you will find in /etc/cups/. I have a parallel laser printer and an Epson Photo Stylus 820 USB. Here's the section from printers.conf for the Stylus. Note the URI.

Code:

<Printer Stylus> (<DefaultPrinter PrinterName> if it is your only or primary printer)
Info Epson Stylus Photo 820
Location clubhouse
DeviceURI usb:/dev/usb/lp0
State Idle
Accepting Yes
JobSheets none none
QuotaPeriod 0
PageLimit 0
KLimit 0
</Printer>
Back to top
View user's profile Send private message
Roel
n00b
n00b


Joined: 09 Apr 2002
Posts: 31
Location: Helmond, The netherlands

PostPosted: Tue Jan 14, 2003 3:23 pm    Post subject: Reply with quote

ed-gentoo: I think your /etc/hosts isn't alright, if 't can't find localhost.
Your /etc/hosts file should look like this:

Code:

# /etc/hosts:  This file describes a number of hostname-to-address
#              mappings for the TCP/IP subsystem.  It is mostly
#              used at boot time, when no name servers are running.
#              On small systems, this file can be used instead of a
#              "named" name server.  Just add the names, addresses
#              and any aliases to this file...
# $Header: /home/cvsroot/gentoo-src/rc-scripts/etc/hosts,v 1.7 2002/11/18 19:39:22 azarah Exp $
#

127.0.0.1       localhost
192.168.1.1    yourhostname # replace this ip and hostname with yours!


This is my setup and it works..
[/code][/quote]
_________________
Woei.
Back to top
View user's profile Send private message
int1
Tux's lil' helper
Tux's lil' helper


Joined: 08 Nov 2002
Posts: 139

PostPosted: Wed Jan 15, 2003 6:19 am    Post subject: Reply with quote

If you are using KDE, I strongly suggest using control-center's peripheral configuration section to setup printers in CUPS. It's a wonderful tool, and I've never had to do any manual modification of my cups conf files.

int1
Back to top
View user's profile Send private message
ed-gentoo
n00b
n00b


Joined: 07 Jan 2003
Posts: 38
Location: Netherlands

PostPosted: Wed Jan 15, 2003 6:22 am    Post subject: Reply with quote

Okay, did some changes yesterday. Changed the hosts file with 127.0.0.1 localhost and 127.0.0.1 hostname this because I use dhcp and have multiple computers running. Now I have to use the standard localhost:631 to connect to cups.

I changed my port but now luck there. What I did find out is that it proces upto 6% then waits a while and then comes with printer not connected. It's connected to a usb 4 port hub which the kernel regonises an is turned on. I still don't have any parralel ports, and still have 5 entries for each driver! Should I reinstall cups and gimpprint, can this be done without removeing other things? This because they're installed as dependencies for something else, not sure what because it emerge over night.
_________________
Why Linux?

For I think it's the most interesting, stable, and configurable OS there is!
..... that's if you have the motivation!

(info about my computer systems can be found on my site under the link systems)
Back to top
View user's profile Send private message
rommel
Veteran
Veteran


Joined: 19 Apr 2002
Posts: 1140
Location: Williamsburg Virginia

PostPosted: Wed Jan 15, 2003 7:18 pm    Post subject: Reply with quote

add parport, parport_pc, and lp to the kernel then load them either through modules.autoload or using insmod or modprobe. also be sure you have usb filesytem enabled as well as usb printer support.
again remember anything compiled as a module and not directly in add to mdules.autoload
Back to top
View user's profile Send private message
ed-gentoo
n00b
n00b


Joined: 07 Jan 2003
Posts: 38
Location: Netherlands

PostPosted: Thu Jan 16, 2003 5:28 am    Post subject: Reply with quote

okay. I'll try that see what then happens. What is better, adding it directly to the kernel or as modules?
_________________
Why Linux?

For I think it's the most interesting, stable, and configurable OS there is!
..... that's if you have the motivation!

(info about my computer systems can be found on my site under the link systems)
Back to top
View user's profile Send private message
Roel
n00b
n00b


Joined: 09 Apr 2002
Posts: 31
Location: Helmond, The netherlands

PostPosted: Thu Jan 16, 2003 12:45 pm    Post subject: Reply with quote

I would say modules... With modules you can load/unload them on the fly. If you have a problem with you port, you don't have to reboot.
_________________
Woei.
Back to top
View user's profile Send private message
mtPete
n00b
n00b


Joined: 20 Jul 2002
Posts: 40

PostPosted: Fri Feb 21, 2003 3:16 am    Post subject: Reply with quote

Roel wrote:
ed-gentoo: I think your /etc/hosts isn't alright, if 't can't find localhost.
Your /etc/hosts file should look like this:

Code:

# /etc/hosts:  This file describes a number of hostname-to-address
#              mappings for the TCP/IP subsystem.  It is mostly
#              used at boot time, when no name servers are running.
#              On small systems, this file can be used instead of a
#              "named" name server.  Just add the names, addresses
#              and any aliases to this file...
# $Header: /home/cvsroot/gentoo-src/rc-scripts/etc/hosts,v 1.7 2002/11/18 19:39:22 azarah Exp $
#

127.0.0.1       localhost
192.168.1.1    yourhostname # replace this ip and hostname with yours!


This is my setup and it works..
[/code]
[/quote]

What do you do if your ip is set by DHCP?

I'm getting the following error when I try to print a test page in the cups webadmin (regular printing used too, but does not now work):

Code:
Hostname could not be found. Please check the name and try again.


Where Hostname is my computers name. I checked the /etc/hostname file and it was in there. My /etc/hosts file just lists the 127.0.0.1 ip.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum