Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problems with lirc
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
JHuizingh
Tux's lil' helper
Tux's lil' helper


Joined: 05 Jul 2002
Posts: 100

PostPosted: Fri Jan 21, 2005 10:29 pm    Post subject: Problems with lirc Reply with quote

I've had mythtv working for a while with 3 hauppage pvr 250 tuner cards, and I'm just getting around to trying to get a remote to work.

lircl version 0.7.0-r1 installed without a problem.

I'm using kernel 2.6.9-gentoo-r9.

When I modprobe the lirc_dev, I get the following information from dmesg:

Code:
lirc_dev: IR Remote Control driver registered, at major 61


When I modprobe lirc_i2c, I get the following message:

Code:
lirc_i2c: chip found @ 0x18 (Hauppauge IR)
ivtv: i2c attach [client=Hauppauge IR,ok]
lirc_dev: lirc_register_plugin:sample_rate: 10
lirc_i2c: chip found @ 0x18 (Hauppauge IR)
ivtv: i2c attach [client=Hauppauge IR,ok]
lirc_dev: lirc_register_plugin:sample_rate: 10
lirc_i2c: chip found @ 0x18 (Hauppauge IR)
ivtv: i2c attach [client=Hauppauge IR,ok]
lirc_dev: lirc_register_plugin:sample_rate: 10
lirc_dev: lirc_register_plugin: no free slots for plugins!


If I understand it correctly, it looks like it's finding the first 2 happage cards and setting them up, and it can't handle the 3rd, so it prints an error message.

After loading the modules, I have two new devices available, /dev/lirc/0 and /dev/lirc/1


At this point, I tried running both "lircd -d /dev/lirc/1" and "lircd -d /dev/lirc/1" (only 1 at a time though). I started up irw, and tried putting the ir receiver in all three cards for each device. irw never printed out anything. I then checked the batteries in a different remote, and the batteries are good.

Am I doing this right? What are some steps I can take to debug this problem?

Thanks.
Back to top
View user's profile Send private message
phranzee
Guru
Guru


Joined: 22 Nov 2003
Posts: 397
Location: katowice/pl

PostPosted: Thu Feb 17, 2005 2:24 pm    Post subject: Reply with quote

Code:
modprobe lirc_serial
FATAL: Error inserting lirc_serial (/lib/modules/2.6.11-rc4-love1/kernel/drivers/char/lirc/lirc_serial.ko): Input/output error

dmesg:
lirc_serial: auto-detected active low receiver
lirc_dev: lirc_register_plugin:sample_rate: 0
lirc_dev: lirc_register_plugin: no free slots for plugins!
lirc_serial: register_chrdev failed!

2.6.11-rc4-love1

i'll try to compile it into kernel

edit: it didn't work...
_________________
signature fault
post dumped ;]
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum