Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
X on Sun Blade 100
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc
View previous topic :: View next topic  
Author Message
w.hill
Tux's lil' helper
Tux's lil' helper


Joined: 23 Jan 2005
Posts: 133
Location: Perth, Western Australia

PostPosted: Mon Jan 31, 2005 7:31 am    Post subject: X on Sun Blade 100 Reply with quote

Hi. This is my second post. I've installed Gentoo on a Sun Blade 100. I have emerged the latest version of X & am trying to get it to work.

I ran X -configure. Testing the configuration revealed quite a few errors which I'm trying to "push" my way through. Does anyone have X running on A SB100 with its onboard ATI video card? I've got a standard(?) 17" Sun monitor with it.

Thus far I've managed to get a low-res window with a moving mouse pointer. Pressing mouse buttons has no effect - absence of Window Manager?

Ta.
Back to top
View user's profile Send private message
hasues
n00b
n00b


Joined: 04 Mar 2004
Posts: 50

PostPosted: Sat Feb 05, 2005 8:19 pm    Post subject: Config.. Reply with quote

I have been successful on getting X to run on my SunBlade 100 with Linux 2.6.10 and the x.org X Server. The main thing of importance is to put the "reference clock" entry in there. Note that I am not using frame buffer either, as I was tired of dealing with the timing issues of the ATI card (I know there is obviously a way to work around this, as the Boot CD has the correct timings, but I'm not sure of all the arguments I would have to pass to the driver at boot time from the boot loader). Here is my config if you are interested:



Section "Files"
# FontPath "unix/:7100" # local font server
# if the local font server has problems, we can fall back on these
FontPath "/usr/lib/X11/fonts/misc"
FontPath "/usr/lib/X11/fonts/cyrillic"
FontPath "/usr/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/Type1"
FontPath "/usr/lib/X11/fonts/Speedo"
FontPath "/usr/lib/X11/fonts/100dpi"
FontPath "/usr/lib/X11/fonts/75dpi"
EndSection

Section "Module"
# Load "GLcore"
Load "bitmap"
Load "dbe"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
# Load "glx"
Load "int10"
# Load "pex5"
Load "record"
# Load "speedo"
Load "type1"
Load "vbe"
# Load "xie"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "keyboard"
Option "CoreKeyboard"
Option "XkbRules" "xfree86"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
EndSection

Section "Device"
Identifier "Generic Video Card"
Driver "ati"
Option "UseFBDev" "false"
Option "reference_clock" "28.636 Mhz"
EndSection

Section "Monitor"
Identifier "Generic Monitor"
HorizSync 30-68
VertRefresh 50-85
Option "DPMS"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Generic Video Card"
Monitor "Generic Monitor"
DefaultDepth 24
SubSection "Display"
Depth 16
Modes "1152x864"
EndSubSection
SubSection "Display"
Depth 24
Modes "1152x864"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
EndSection

Section "DRI"
Mode 0666
EndSection



Now, as far as sound goes, my only option is using ALSA. I noticed a warning for something pertaining to a 32 bit emulation call, etc, but I don't see a way to get sound working.

I shut off support for 32 bit emulated sound (as it was mentioned in Gentoo's warning in the ebuild for alsa-1.0.8, but now I get:

* Loading ALSA modules ...
* Loading: snd-card-0 ... [ ok ]
* Loading: snd-seq-oss ... [ ok ]
* Loading: snd-pcm-oss ... [ ok ]
* Restoring Mixer Levels ...
* No mixer config in /etc/asound.state, you have to unmute your card! [ !! ]
ah0319001lk001 linux # alsamixer

alsamixer: function snd_ctl_open failed for default: Invalid argument

Any takers?
_________________
Lettuce, Pickles, hold the mayo!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum