Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
openssl will not compile [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc
View previous topic :: View next topic  
Author Message
ibtim13
Tux's lil' helper
Tux's lil' helper


Joined: 12 Sep 2003
Posts: 81
Location: Troy, NY

PostPosted: Sat Jan 08, 2005 4:25 pm    Post subject: openssl will not compile [SOLVED] Reply with quote

I'm doing a fresh install of gentoo on my ultra2 and openssl will not compile.
I get the message:

Code:

{standard input}: Assembler messages:
{standard input}:92:Error: Architecture mismatch on "fsub32s".
{standard input}:92: (Requires v9z|v9b; requested architecture is v9.)
{standard input}:125:Error: Architecture mismatch on "fsub32s".
{standard input}:125: (Requires v9z|v9b; requested architecture is v9.)
{standard input}:130:Error: Architecture mismatch on "fzero".
{standard input}:130: (Requires v9z|v9b; requested architecture is v9.)
make[1]: *** [tmdiff.o] Error 1


when it fails.

I don't know what's wrong, my
CFLAGS="-mcpu=ultrasparc -O3 -pipe -mvis"

but I have the same CFLAGS on my other ultra2 and
it works fine.

anyone know what the deal is?

Thanks
_________________
Grrr, can't think of anything clever right now, I'll go back and edit this later (9/12/2003)


Last edited by ibtim13 on Sun Jan 09, 2005 10:34 pm; edited 1 time in total
Back to top
View user's profile Send private message
fctk
Veteran
Veteran


Joined: 28 Jan 2004
Posts: 1424
Location: Milan, Italy, EU

PostPosted: Sun Jan 09, 2005 2:28 pm    Post subject: Reply with quote

did you check https://bugs.gentoo.org/ ?
Back to top
View user's profile Send private message
Weeve
Retired Dev
Retired Dev


Joined: 30 Oct 2002
Posts: 641

PostPosted: Sun Jan 09, 2005 5:15 pm    Post subject: Reply with quote

I'm guessing you set your CHOST in make.conf to sparc64-unknown-linux-gnu, or something other than sparc-unknown-linux-gnu. If that's the case, please change it to sparc-unknown-linux-gnu as setting it to anything else will cause problems like this. You'll probably want to start over as well as things like gcc and glibc won't have build in the ways they need to.
Back to top
View user's profile Send private message
ibtim13
Tux's lil' helper
Tux's lil' helper


Joined: 12 Sep 2003
Posts: 81
Location: Troy, NY

PostPosted: Sun Jan 09, 2005 8:15 pm    Post subject: Reply with quote

I did not see any bugs pertaining to this.

Also, unfortunately, my CHOST="sparc-unkown-linux-gnu"
so that is not the problem.

Thanks for the suggestions.
_________________
Grrr, can't think of anything clever right now, I'll go back and edit this later (9/12/2003)
Back to top
View user's profile Send private message
ibtim13
Tux's lil' helper
Tux's lil' helper


Joined: 12 Sep 2003
Posts: 81
Location: Troy, NY

PostPosted: Sun Jan 09, 2005 10:34 pm    Post subject: Reply with quote

AHA! openssl doesn't like -mvis in CFLAGS
I took it out, emerged openssl, put it back in, and finished my system.
No other packages seem to have a problem with it, but if I find any more I'll edit this.
_________________
Grrr, can't think of anything clever right now, I'll go back and edit this later (9/12/2003)
Back to top
View user's profile Send private message
Weeve
Retired Dev
Retired Dev


Joined: 30 Oct 2002
Posts: 641

PostPosted: Sun Jan 09, 2005 11:16 pm    Post subject: Reply with quote

If you would, please file a bug about this so we can filter the -mvis flag for openssl to keep this from happening in the future.

Thanks
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum