Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Service 'metalog' already provide 'logger'!;
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
sminons
n00b
n00b


Joined: 28 Dec 2003
Posts: 49

PostPosted: Sun Dec 26, 2004 12:55 pm    Post subject: Service 'metalog' already provide 'logger'!; Reply with quote

After emerging or unmerging I get the following message

Code:
 
Regenerating /etc/ld.so.cache...
 * Caching service dependencies...
 *  Service 'metalog' already provide 'logger'!;
 *  Not adding service 'syslog-ng'...


What does it mean, and how do I remove that message?
Back to top
View user's profile Send private message
steveb
Advocate
Advocate


Joined: 18 Sep 2002
Posts: 4564

PostPosted: Sun Dec 26, 2004 1:41 pm    Post subject: Reply with quote

this means, that you once had or still have installed metalog and syslog-ng.

if you only want to use metalog, then unmerge syslog-ng and then remove syslog-ng with rc-update del syslog-ng and then delete /etc/init.d/syslog-ng

if you only want to use syslog-ng, then unmerge metalog and remove metalgo with rc-update del metalog and then delete /etc/init.d/metalog


cheers

SteveB
Back to top
View user's profile Send private message
sminons
n00b
n00b


Joined: 28 Dec 2003
Posts: 49

PostPosted: Mon Dec 27, 2004 1:16 pm    Post subject: Reply with quote

Thank you..that worked :)
Back to top
View user's profile Send private message
steveb
Advocate
Advocate


Joined: 18 Sep 2002
Posts: 4564

PostPosted: Tue Dec 28, 2004 7:23 am    Post subject: Reply with quote

;)
Back to top
View user's profile Send private message
newtonian
Guru
Guru


Joined: 19 Jan 2005
Posts: 465
Location: Hokkaido Japan

PostPosted: Mon Dec 05, 2005 4:21 pm    Post subject: the advice listed here also fixes: Reply with quote

Quote:
* You need to create /etc/syslog-ng/syslog-ng.conf first.
* An example can be found in /etc/syslog-ng/syslog-ng.conf.sample
* ERROR: Problem starting needed services.
* "myProgram" was not started.



Just did a :
Code:
rm /etc/init.d/syslog-ng


to get rid of my error message. Thanks for the fix.

Cheers,
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum