Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Samba hates me
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
gsfgf
Veteran
Veteran


Joined: 08 May 2002
Posts: 1266

PostPosted: Thu May 30, 2002 9:52 pm    Post subject: Samba hates me Reply with quote

I am running samba 2.2.4 and it doesn't work. I can see my com in windoze, but i can't connect to it. It must be samba b/c i can connect to other coms from vmware. Error is:

Code:

\\Laptop is not accessable

The network path was not found.


Here's the smb.conf
Code:
[global]

   workgroup = HOME

   server string = Samba Server %v

   log file = /var/log/samba/log.%m

   max log size = 50

  guest account = pcguest


   security = share

  encrypt passwords = yes
  smb passwd file = /etc/samba/private/smbpasswd

   socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192


   dns proxy = no

guest ok = yes

#============================ Share Definitions ==============================


[main]
    comment = Laptop
    path = /
    writeable = yes
    browseable = yes

   print command = lpr-cups -P %p -o raw %s -r   # using client side printer drivers.
Back to top
View user's profile Send private message
lx
Veteran
Veteran


Joined: 28 May 2002
Posts: 1012
Location: Netherlands

PostPosted: Thu May 30, 2002 10:06 pm    Post subject: Reply with quote

Here's mine it works, but I allow the quest account, well I'm behind a firewall and trust my users, btw. nothing of interrest on shared partition.

Quote:
# Samba config file created using SWAT
# from Alex (127.0.0.1)
# Date: 2001/12/13 18:34:59

# Global parameters
[global]
security = SHARE
encrypt passwords = Yes
log file = /var/log/samba/%m.log
max log size = 0
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
dns proxy = No
hosts allow = 10.0.0.0/255.255.255.0
printing = cups
load printers = yes
printcap name = /etc/printcap
[printers]
comment = All Printers
path = /var/spool/samba
printable = Yes
browseable = No
guest ok = Yes

[Shared]
path = /shared
read only = No
guest ok = Yes
[/quote]
_________________
"Remember there's a big difference between kneeling down and bending over.", Frank Zappa
Back to top
View user's profile Send private message
gsfgf
Veteran
Veteran


Joined: 08 May 2002
Posts: 1266

PostPosted: Fri May 31, 2002 1:38 am    Post subject: Reply with quote

same prob w/ the other config file. Also, i noticed that smbd, nmbd -D, and smbd -D don't show up on pas -aux. nmbd does.
Back to top
View user's profile Send private message
Silvaran
n00b
n00b


Joined: 24 Apr 2002
Posts: 8

PostPosted: Fri May 31, 2002 3:35 am    Post subject: Reply with quote

I just used the stock smb.conf file that comes with the distribution (I think it's smb.conf.sample or something). Then I changed the workgroup name, server string and nt description field to whatever I wanted. I removed printing support (just commented it out -- I don't have a printer) and under the [homes] section I set 'browsable = yes'...

If you log in as a specific user, don't forget to specify your user directory, or homes:

Code:
smbclient -U myusername //computer_name/homes

or

Code:
smbclient -U myusername //computer_name/myusername

Seems to work all right for me... Windows should pick it up too, just use the above machine spec (//computer_name/homes) but reverse the slashes.
_________________
Should you immerse yourself in the fluidity of life, only to drown in its revelations?
Back to top
View user's profile Send private message
gsfgf
Veteran
Veteran


Joined: 08 May 2002
Posts: 1266

PostPosted: Fri May 31, 2002 4:45 am    Post subject: Reply with quote

yea, i'm using the stock config w/ cosmetic changes and i switched security to user b/c in my experience, that works better. I'll try one from another box and see what happens.
Back to top
View user's profile Send private message
lx
Veteran
Veteran


Joined: 28 May 2002
Posts: 1012
Location: Netherlands

PostPosted: Fri May 31, 2002 7:24 am    Post subject: Reply with quote

gsfgf wrote:
same prob w/ the other config file. Also, i noticed that smbd, nmbd -D, and smbd -D don't show up on pas -aux. nmbd does.

/usr/bin/smbd and /usr/bin/nmbd are both running on my system, if they're not samba ain't running.

Try
Code:
/etc/init.d/samba restart

You also have to do this when making changes to the smb.conf file.

Stating the obvious, I assume you have run rc-update add samba default, or any other runlevel.

Cya, lX
_________________
"Remember there's a big difference between kneeling down and bending over.", Frank Zappa
Back to top
View user's profile Send private message
gsfgf
Veteran
Veteran


Joined: 08 May 2002
Posts: 1266

PostPosted: Fri May 31, 2002 6:12 pm    Post subject: Reply with quote

i'v tried everything and smbd will not start. I guess its time to dl an old or beta version.
Back to top
View user's profile Send private message
gsfgf
Veteran
Veteran


Joined: 08 May 2002
Posts: 1266

PostPosted: Fri May 31, 2002 8:45 pm    Post subject: Reply with quote

i dl'd the latest cvs version and installed it. same problem. Dl'd 2.2.3a. same problem.
Back to top
View user's profile Send private message
Utoxin
Guru
Guru


Joined: 19 Apr 2002
Posts: 411
Location: Springville, UT

PostPosted: Fri May 31, 2002 10:59 pm    Post subject: Reply with quote

Go check here to get a lot of help on figureing out exactly what your problem might be.
Back to top
View user's profile Send private message
gsfgf
Veteran
Veteran


Joined: 08 May 2002
Posts: 1266

PostPosted: Sat Jun 01, 2002 2:02 am    Post subject: Reply with quote

I know what the problem is. smbd will not run. I have tried many versions. smbd doens't show up in ps -aux. i have tried running smbd and smbd -D nmbd does show up which explains how i can see, but not access it from windoze.
Back to top
View user's profile Send private message
Utoxin
Guru
Guru


Joined: 19 Apr 2002
Posts: 411
Location: Springville, UT

PostPosted: Sat Jun 01, 2002 2:18 am    Post subject: Reply with quote

Somewhere in that guide I posted, I believe it mentions setting the debug level of the log files. Do so. You should get some info in the samba logs that will tell you /why/ smbd won't start.
Back to top
View user's profile Send private message
gsfgf
Veteran
Veteran


Joined: 08 May 2002
Posts: 1266

PostPosted: Sat Jun 01, 2002 4:14 pm    Post subject: Reply with quote

Utoxin wrote:
Somewhere in that guide I posted, I believe it mentions setting the debug level of the log files. Do so. You should get some info in the samba logs that will tell you /why/ smbd won't start.

It's not makeing log entries.
Back to top
View user's profile Send private message
gsfgf
Veteran
Veteran


Joined: 08 May 2002
Posts: 1266

PostPosted: Sat Jun 01, 2002 4:15 pm    Post subject: Reply with quote

got it by running smbd -i
Code:
smbd version 2.2.4 started.
Copyright Andrew Tridgell and the Samba Team 1992-2002
bind failed on port 139 socket_addr = 0.0.0.0.
Error = Address already in use
Back to top
View user's profile Send private message
gsfgf
Veteran
Veteran


Joined: 08 May 2002
Posts: 1266

PostPosted: Sat Jun 01, 2002 4:26 pm    Post subject: Reply with quote

i rebooted and it works. woohoo
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum