Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
gaim-cvs having problems with aspell-0.50.3
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
count
Apprentice
Apprentice


Joined: 28 May 2002
Posts: 242
Location: Dalton, MA

PostPosted: Wed Jan 08, 2003 7:56 pm    Post subject: gaim-cvs having problems with aspell-0.50.3 Reply with quote

Anyone know of any problems concerning gaim-cvs-0.60-r2 and aspell-0.50.3? I was running gaim-cvs fine untill aspell was updated from 0.50.2-r1 to 0.50.3 when gaim wouldn't start or re-compile.

Thanks!
_________________
- Joseph Monti
_________________
This message is free software; you can redistribute it and/or modify it under the terms of the GNU General Public License as published by the Free Software Foundation. For more info visit http://joemonti.org/
Back to top
View user's profile Send private message
dufnutz
Apprentice
Apprentice


Joined: 01 May 2002
Posts: 209

PostPosted: Thu Jan 09, 2003 12:50 am    Post subject: Reply with quote

same problem here, i downgraded aspell to get gaim-cvs working again
Back to top
View user's profile Send private message
count
Apprentice
Apprentice


Joined: 28 May 2002
Posts: 242
Location: Dalton, MA

PostPosted: Thu Jan 09, 2003 2:49 pm    Post subject: Reply with quote

Would this problem warrent a bug report?
_________________
- Joseph Monti
_________________
This message is free software; you can redistribute it and/or modify it under the terms of the GNU General Public License as published by the Free Software Foundation. For more info visit http://joemonti.org/
Back to top
View user's profile Send private message
Lin_Matt
Guru
Guru


Joined: 23 Jun 2002
Posts: 581
Location: TechWasteland (Mississippi)

PostPosted: Thu Jan 09, 2003 4:32 pm    Post subject: Reply with quote

I'm running a freshly emerged copy of gaim-cvs with aspell-0.50.3. Never noticed any problems with em co-existing... Do you have a copy of the errors you were getting?
Back to top
View user's profile Send private message
count
Apprentice
Apprentice


Joined: 28 May 2002
Posts: 242
Location: Dalton, MA

PostPosted: Thu Jan 09, 2003 5:36 pm    Post subject: Reply with quote

Here's my emerge info
Code:
Portage 2.0.46-r4 (default-x86-1.4, gcc-which: no gcc in (/sbin:/bin:/usr/sbin:/usr/bin)
sh: line 1: -dumpversion: command not found, glibc-2.3.1-r2)
=================================================================
System uname: 2.4.19-gentoo-r10 i686 AMD Athlon(tm) Processor
USE="x86 oss apm avi cups encode gif jpeg mikmod mmx mpeg nls pdflib png qtmt quicktime truetype xml2 xv zlib gdbm berkdb slang readline arts tetex svga tcltk guile sdl gpm tcpd python imlib oggvorbis motif opengl mozilla cdr 3dnow X kde qt gtk gtk2 bonobo evo gtkhtml ncurses gnome alsa esd xmms dvd flash pam ssl crypt socks5 java perl libwww libg++ samba pda spell"ARCH="x86"
COMPILER="gcc3"
CHOST="i686-pc-linux-gnu"
CFLAGS="-march=athlon-tbird -O3 -pipe -fforce-addr -fomit-frame-pointer -funroll-loops -frerun-loop-opt -frerun-cse-after-loop -falign-functions=4"
CXXFLAGS="-march=athlon-tbird -O3 -pipe -fforce-addr -fomit-frame-pointer -funroll-loops -frerun-loop-opt -frerun-cse-after-loop -falign-functions=4"
ACCEPT_KEYWORDS="x86"
CONFIG_PROTECT="/etc /var/qmail/control /usr/share/config /usr/kde/3/share/config:/usr/X11R6/lib/X11/xkb:/usr/share/config"
CONFIG_PROTECT_MASK="/etc/init.d /etc/gconf /etc/env.d"
MAKEOPTS="-j2"
JDK_HOME="/opt/sun-jdk-1.4.1"
JAVA_HOME="/opt/sun-jdk-1.4.1"
AUTOCLEAN="yes"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
GENTOO_MIRRORS="http://gentoo.linux.no/"


Here's the error in the output
Code:
/bin/sh ../libtool --silent --mode=link gcc  -march=athlon-tbird -O3 -pipe -fforce-addr -fomit-frame-pointer -funroll-loops -frerun-loop-opt -frerun-cse-after-loop -falign-functions=4 -I/opt/include -I.. -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/pango-1.0 -I/usr/include/freetype2 -I/usr/X11R6/include -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include   -DGTK_ENABLE_BROKEN  -I/usr/kde/3/include/artsc   -o gaim -export-dynamic about.o aim.o away.o browser.o buddy.o buddy_chat.o conversation.o core.o dialogs.o ft.o gaimrc.o gtkimhtml.o html.o idle.o list.o log.o md5.o module.o multi.o perl.o prefs.o proxy.o prpl.o server.o session.o socket.o sound.o themes.o util.o -Wl,--export-dynamic -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgdk_pixbuf-2.0 -lm -lpangoxft-1.0 -lpangox-1.0 -lpango-1.0 -lgobject-2.0 -lgmodule-2.0 -ldl -lglib-2.0   -L/usr/lib -lesd -laudiofile -lm -lasound -L/usr/kde/3/lib -ldl -lartsc -lpthread  -rdynamic -L/usr/local/lib /usr/lib/perl5/5.8.0/i686-linux/auto/DynaLoader/DynaLoader.a -L/usr/lib/perl5/5.8.0/i686-linux/CORE -lperl -lnsl -ldl -lm -lcrypt -lutil -L/usr/X11R6/lib -lXss -L/usr/X11R6/lib -lSM -lICE  -Wl,--export-dynamic -lgtkspell -lpspell -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgdk_pixbuf-2.0 -lm -lpangoxft-1.0 -lpangox-1.0 -lpango-1.0 -lgobject-2.0 -lgmodule-2.0 -ldl -lglib-2.0   -lnsl
libtool: link: cannot find the library `/usr/lib/libaspell-common.la'
make[3]: *** [gaim] Error 1
make[3]: Leaving directory `/var/tmp/portage/gaim-cvs-0.60-r2/work/gaim/src'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/gaim-cvs-0.60-r2/work/gaim/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/gaim-cvs-0.60-r2/work/gaim'
make: *** [all] Error 2

!!! ERROR: net-im/gaim-cvs-0.60-r2 failed.
!!! Function src_compile, Line 52, Exitcode 2
!!! (no error message)


The key line there is
Code:
libtool: link: cannot find the library `/usr/lib/libaspell-common.la'
I'm pretty sure that file is there with aspell-0.50.2-r1, but not with aspell-0.50.3

I've tried recompiling pango, atk, and aspell, but nothing worked (every time clearing /var/tmp/portage/)
_________________
- Joseph Monti
_________________
This message is free software; you can redistribute it and/or modify it under the terms of the GNU General Public License as published by the Free Software Foundation. For more info visit http://joemonti.org/
Back to top
View user's profile Send private message
Lin_Matt
Guru
Guru


Joined: 23 Jun 2002
Posts: 581
Location: TechWasteland (Mississippi)

PostPosted: Thu Jan 09, 2003 5:47 pm    Post subject: Reply with quote

This is actually easy enough to fix. You have two options here:

1. Make a symlink from /usr/lib/libaspell.la to /usr/lib/libaspell-common.la; or
2. Do a "grep libaspell-common.la /usr/lib/*.la" to see what library is trying to use libaspell-common.la to get libaspell link info. You can then either re-emerge that package or just edit the file to point to libaspell.la.

I'd recommend the second option as it's a more permanent fix, but either way should get you up and running.
Back to top
View user's profile Send private message
count
Apprentice
Apprentice


Joined: 28 May 2002
Posts: 242
Location: Dalton, MA

PostPosted: Thu Jan 09, 2003 6:03 pm    Post subject: Reply with quote

Good Call!

Option 2 worked great. I knew there was a dependancy to gaim-cvs that was causing the problem, just couldnt figure out what.

The problem package was gtkspell. Not sure if this was the only one because I remerged other packages that could have also needed /usr/lib/libaspell-common.la

Thanks!
_________________
- Joseph Monti
_________________
This message is free software; you can redistribute it and/or modify it under the terms of the GNU General Public License as published by the Free Software Foundation. For more info visit http://joemonti.org/
Back to top
View user's profile Send private message
Lin_Matt
Guru
Guru


Joined: 23 Jun 2002
Posts: 581
Location: TechWasteland (Mississippi)

PostPosted: Thu Jan 09, 2003 6:04 pm    Post subject: Reply with quote

np... Glad that got ya goin...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum