Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Laggy desktop when downloading
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
aanund
Tux's lil' helper
Tux's lil' helper


Joined: 29 Aug 2002
Posts: 147

PostPosted: Wed Dec 25, 2002 8:26 pm    Post subject: Laggy desktop when downloading Reply with quote

Hi, I have FINALLY switched totally to gentoo (no more windows for me (jay jay)), and it is working out marginally better than expected:=)

BUT one thing still troubles me, whenever I start moving files across network, my desktop gets laggy and unresponsive. I never experienced this in windows, and I would like to know if I can eliminate this problem in linux, or if it is just the price to "pay".

The problem is really noticable if i play mp3's from my local hdd at the same time, since xmms will stall for up to a couple of seconds, and in general give me nice "pauses".

I know this sounds like my hdd is messed up, but it was fine until installing gentoo:P

Moving files cross network means downloading files from web via phoenix or mozilla, or copying files from a samba mount, usually using nautilus or a terminal.

Playing movies and such from samba mount work fine,
dma is turned on,
p4 1800 256ddr (yes yes, getting more:P), 40GB WD hdd, asus mx4b.

Thoughts?
Back to top
View user's profile Send private message
idl
Retired Dev
Retired Dev


Joined: 24 Dec 2002
Posts: 1728
Location: Nottingham, UK

PostPosted: Wed Dec 25, 2002 8:32 pm    Post subject: Reply with quote

try:

hdparm -d 1 /dev/hdX
hdparm -X66 /dev/hdX

replace hdX with the drive you have gentoo installed on
Back to top
View user's profile Send private message
Malakin
Veteran
Veteran


Joined: 14 Apr 2002
Posts: 1692
Location: Victoria BC Canada

PostPosted: Wed Dec 25, 2002 9:55 pm    Post subject: Reply with quote

See what results this gives you "hdparm -t /dev/hda"

You could also try a vanilla sources kernel.

What you're experiencing definitely isn't normal ;)
Back to top
View user's profile Send private message
kerframil
l33t
l33t


Joined: 19 Apr 2002
Posts: 710
Location: London, UK

PostPosted: Thu Dec 26, 2002 6:30 am    Post subject: Reply with quote

Various general suggestions (and no, it isn't normal):
  • Upgrade your BIOS and check for optimal settings
  • Definitely use hdparm, but check your drive's actual capabilities. -X66 only sets Ultra DMA 2 level. hdparm -i should tell you what your drive is capable of. Also use -u1 which unmasks interrupts - that could help a lot. And -c1 for 32-bit transfers.
  • Renice your X server. I posted something on that and I can't remember where now. I'll put this in Tips'n'Tricks where it belongs as soon as I can. But you can do this live by determing the process ID of X then doing something like: renice -10 <pid>. This can sort out things like your mouse cursor lagging amongst other things.
  • If you're using latest gentoo-sources, try with and without premptive.
  • If you're using a jiffies value (hardwired in your kernel config) of 100, try increasing it to something like 1000. That will increase the rate of the task scheduler and could increase multitasking performance - particularly for faster processors.

I usually use gentoo-sources-r10 and preemptive on a desktop. As you make a specific mention of networking causing the problem, well, it sounds like your network device might be generating too many interrupts. I wonder what card you're using and whether there are any options to control its behaviour. Also check whether it is sharing an interrupt/IRQ (not good). If you're using ACPI, then here are a few more suggestions:
  • Try not using it (use APM instead). It's not always optimal especially as far as IRQ assignments go. Some systems have been known to assign almost everything on the same IRQ with ACPI. Apparently they should get routed through to virtual interrupts anyway, but I have read conclusive evidence that this is still not a good thing. And that applies to Windows too, although it has a more developed ACPI core at present I think.
  • Try using a newer ACPI core. In gentoo-sources-r10 you can set USE="acpi4linux" then emerge to get that

Sometimes changing the physical slot that a PCI card uses can make things better (strange but true).
And make sure you've compiled RTC support into your kernel (not sure how important that is in your case, but it's a good idea anyway).
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum