Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
xfree crashes on startup
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
AngusYoung
Retired Dev
Retired Dev


Joined: 20 Dec 2002
Posts: 473
Location: Campinas, SP - Brazil

PostPosted: Fri Dec 20, 2002 12:31 am    Post subject: xfree crashes on startup Reply with quote

Hello guys, I am a Gentoo newbie and I am having some problems with xfree 4.2.1.
The problem is that Xfree crashes on startup ... althought I can ping to this machine the mouse and keyboard gives me no response.

Here goes some usefull information:
Hardware
1 - AMD Athlon 950 on an Asus A7S333 motherboard (chipset SiS 745)
2 - My graphics card is a Nvidia GeForce 2 MX 400 with 64Mb
3 - My monitor is a Samsung Syncmaster 550v

Software
1 - xfree 4.2.1
2 - Kernel 2.4.19 with
a) DRM (xfree DRI support) enabled
b) No USB support (I already tried what was informed here: https://forums.gentoo.org/viewtopic.php?t=26261&highlight=xfree)
c) No Input Core Support
3 - Nvidia drivers

The /etc/X11/XF86Config file was generated using the xf86config, and it has the correct settings acording to my hardware. I only changed it to start using the nvidia drivers.

I'll be glad if anyone can help me ... (and if I correct the problem by myself I'll post here what I did).

Thanks!

P.S.: sorry for the bad english
_________________
N.U.S.: A cross platform C++ application development framework
My blog (in Portuguese)
Back to top
View user's profile Send private message
pilla
Administrator
Administrator


Joined: 07 Aug 2002
Posts: 7588
Location: Pelotas, BR

PostPosted: Fri Dec 20, 2002 1:55 am    Post subject: Reply with quote

I think you should enable input core support.

Do a
Code:

startx >& error

to get the error message.
Back to top
View user's profile Send private message
DarrenM
l33t
l33t


Joined: 25 Apr 2002
Posts: 653
Location: Sydney, Australia

PostPosted: Fri Dec 20, 2002 2:27 am    Post subject: Reply with quote

You can also look in /var/log/XFree86.0.log to see what the problem is.
Back to top
View user's profile Send private message
kipper
Tux's lil' helper
Tux's lil' helper


Joined: 20 Apr 2002
Posts: 112

PostPosted: Fri Dec 20, 2002 1:18 pm    Post subject: Reply with quote

Angus, what is the error message you get when xfree crashes? That will help us to solve your problem.
Back to top
View user's profile Send private message
AngusYoung
Retired Dev
Retired Dev


Joined: 20 Dec 2002
Posts: 473
Location: Campinas, SP - Brazil

PostPosted: Fri Dec 20, 2002 3:20 pm    Post subject: Reply with quote

Hello guys, I did what you asked me for, and
1 - Enabling Input Core into the kernel didn't solve the problem

Some things that appear in my XFree log (my complete xfree log can be seen at http://www.angusyoung.kit.net/tmp/xfree.log):

********* this appear a lot of times ********
(II) NVIDIA(0): Not using default mode "1024x768" (bad mode clock/interlace/doublescan)
(II) NVIDIA(0): Not using default mode "512x384" (bad mode clock/interlace/doublescan)
(II) NVIDIA(0): Not using default mode "1024x768" (hsync out of range)
(II) NVIDIA(0): Not using default mode "512x384" (hsync out of range)

********* this appear at the end of the file ********

(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension LBX
(II) Initializing built-in extension XC-APPGROUP
(II) Initializing built-in extension SECURITY
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFree86-Bigfont
(II) Initializing built-in extension RENDER
(II) [GLX]: Calling GlxExtensionInit
(**) Option "Protocol" "Microsoft"
(**) Mouse1: Protocol: "Microsoft"
(**) Option "CorePointer"
(**) Mouse1: Core Pointer
(**) Option "Device" "/dev/tty0"
(**) Option "BaudRate" "1200"
(**) Option "StopBits" "1"
(**) Option "DataBits" "7"
(**) Option "Parity" "None"
(**) Option "Vmin" "1"
(**) Option "Vtime" "0"
(**) Option "FlowControl" "None"
(==) Mouse1: Buttons: 3
(**) Mouse1: BaudRate: 1200
(II) Keyboard "Keyboard1" handled by legacy driver
(II) XINPUT: Adding extended input device "Mouse1" (type: MOUSE)

Thanks
_________________
N.U.S.: A cross platform C++ application development framework
My blog (in Portuguese)
Back to top
View user's profile Send private message
AngusYoung
Retired Dev
Retired Dev


Joined: 20 Dec 2002
Posts: 473
Location: Campinas, SP - Brazil

PostPosted: Fri Dec 20, 2002 8:13 pm    Post subject: Reply with quote

Hello guys!!! I'm glad to say that I solved the problem! Let me explain what was wrong and what I did ...

First of all -> what was wrong:
1 - Well, I configured my mouse as /dev/tty0 and this was my in use by my keyboard !!!

What I did:
1 - I simply changed the mouse device, in the XF86Config file.
Now, the device option, under the mouse section, looks like this:
Section "InputDevice"
...
Option "Protocol" "Microsoft"
Option "Device" "/dev/cua0"

Thank you all for helping me solving this problem!
_________________
N.U.S.: A cross platform C++ application development framework
My blog (in Portuguese)
Back to top
View user's profile Send private message
kipper
Tux's lil' helper
Tux's lil' helper


Joined: 20 Apr 2002
Posts: 112

PostPosted: Mon Dec 23, 2002 1:32 pm    Post subject: Reply with quote

Glad to hear it was a quick fix.

cheers,
kipper
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum