Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Weird CPU noise
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
rsepulve
n00b
n00b


Joined: 26 Jul 2002
Posts: 2

PostPosted: Fri Jul 26, 2002 6:06 pm    Post subject: Weird CPU noise Reply with quote

I recently installed Gentoo on my Dell Inspiron 8100. Previously, I had been running RedHat 7.2.

It's been great but for one annoying problem. I now notice a high-pitched, and rather loud whining noise (it sounds like an electrical whine) coming from my laptop. My laptop was completely silent running under RedHat 7.2 (other than the fans turning on occasionally).

I believe the sound is CPU related. When I run off the battery (which makes the CPU run at 800MHz) the noise is less noticable than under AC power (1.2GHz). When the CPU load is at or near 100% the noise completely disappears. The noise bothers me so much that I actually wrote a program that loops forever and I run it with a low priority. It makes the noise go away and doesn't seem to affect performance, but I shouldn't have to do that.

Finally, the noise starts fairly early in the boot process, but I haven't been able to isolate exactly when it starts, but definitely before the file systems are mounted.

Anyone ever experience anything like this? Any suggestions? I'm think of recompiling the kernel with a slightly different configuration. Maybe something in the kernel is causing it?

Thanks.
Back to top
View user's profile Send private message
pjp
Administrator
Administrator


Joined: 16 Apr 2002
Posts: 16620

PostPosted: Fri Jul 26, 2002 6:36 pm    Post subject: Reply with quote

Very strange. I would offer to you www.google.com/linux. Also, I recall something about 'stepping' through the boot process by way of <enter> to continue. Been a while since I've rebooted (and paid attention to it), but I thought there was a prompt for this. Maybe that was RedHat.
_________________
Find them! Fix them! Fight them! Finish them! -- GEN Matthew B. Ridgway
Back to top
View user's profile Send private message
TripKnot
Apprentice
Apprentice


Joined: 29 May 2002
Posts: 213

PostPosted: Fri Jul 26, 2002 7:26 pm    Post subject: Reply with quote

This is a problem with APM, specifically the make CPU idle calls option. Whats happening is when the CPU is idle it throttles the CPU. At high CPU usage there is little throttling so the noise is less noticable. When on battery the CPU is already throttled to a lower state full time and the APM throttling feature may not be used. Solution is to disable this in the kernel. The only APM feature I use on my I4000 is console blanking. The rest of your APM features can be set via the bios, which actually work in linux as opposed to being overrided in wondows.
Back to top
View user's profile Send private message
cranch
n00b
n00b


Joined: 02 Jul 2002
Posts: 47

PostPosted: Fri Jul 26, 2002 10:21 pm    Post subject: Reply with quote

That is bizare that you ask this. I was just going to post something about it. My 8100 does the same thing at idle time. When it is being used heavily, then the noise seems to go away. I'll edit my bios options and see if it helps.

Speaking of 8100's. What does it take to get it into suspend mode. Mine will continously run the screensave, but never hit standby or suspend. If I shut the lid, the display blanks, but the machine never powers down. This an APM feature as well?
Back to top
View user's profile Send private message
rsepulve
n00b
n00b


Joined: 26 Jul 2002
Posts: 2

PostPosted: Sat Jul 27, 2002 7:47 pm    Post subject: Reply with quote

I had indeed enabled the "Make CPU Idle calls when idle" kernel option. I haven't yet rebuilt my kernel, but I disabled the Intel SpeedStep stuff in the APM Bios and that fixed the problem. Thanks for your help.

Cranch -- I don't have my screensaver set to suspend the laptop, but when I close the lid or do Fn-Suspend, my laptop suspends itself. I didn't do anything special to get this to work other than make sure that my Bios settings were correct (e.g., Supsend when lid is closed). Also, my laptop doesn't put itself to sleep when I close the lid and have AC power connected, only when it's running off battery. You can change that behavior in the bios.
Back to top
View user's profile Send private message
TripKnot
Apprentice
Apprentice


Joined: 29 May 2002
Posts: 213

PostPosted: Sat Jul 27, 2002 10:34 pm    Post subject: Reply with quote

Although disabling the speedstep worked for now, I would still disable that make idle call in the kernel and then reenable speedstep so you can benefit from the lower core freq when running on the battery.
Back to top
View user's profile Send private message
BradN
Advocate
Advocate


Joined: 19 Apr 2002
Posts: 2391
Location: Wisconsin (USA)

PostPosted: Sun Jul 28, 2002 9:40 pm    Post subject: Reply with quote

My AMD based Vaio does a similar thing, although without any "make CPU idle calls" or anything. It isn't annoying enough for me to want to do anything about it though.
Back to top
View user's profile Send private message
Veauger
n00b
n00b


Joined: 08 Mar 2003
Posts: 33

PostPosted: Tue Feb 10, 2004 8:54 am    Post subject: Reply with quote

Just fixed this in my Dell Latitude by disabling speedstep and ACPI.

From what I've been able to google:

Buzzing noises in devices like this are usually caused by the transformers. If you have opened a power supply before, you've seen them -- they're the round things wrapped in thin copper wire, which surrounds a ferrite core. This copper material is covered with varnish. When this varnish starts to decay, most likely from heat, the metal starts to seperate from the ferrite core, and buzzing results.

Now I dont know if this applies here at all, but if certain ACPI states in the machine reroute current through one of these failing transformers, or change the current moving through one, its possible that this is what is causing the buzz, and why we are able to turn it 'on and off' with software.

I hear that on these transformers, buzz can be fixed by spreading some silicone paste on the surface of the metal wrapping.

Any electrical engineers like to comment on this? Would be nice to have a physical fix to this.
Back to top
View user's profile Send private message
ColinAnderson
Tux's lil' helper
Tux's lil' helper


Joined: 26 Nov 2003
Posts: 89

PostPosted: Tue Feb 10, 2004 3:24 pm    Post subject: Reply with quote

Anything like this!?!? https://forums.gentoo.org/viewtopic.php?t=134553

I'm going to disable the APM stuff and anything related to speedstep. Thanks. :-)

I hope it works!
_________________
~Colin
Back to top
View user's profile Send private message
ColinAnderson
Tux's lil' helper
Tux's lil' helper


Joined: 26 Nov 2003
Posts: 89

PostPosted: Tue Feb 10, 2004 3:59 pm    Post subject: Reply with quote

I've tried disabling APM (both in the kernel and with the apm=off parameter on bootup). Didn't work. I disabled SpeedStep in the BIOS. Didn't work. I re-enabled SpeedStep in the BIOS, but disabled Smart CPU Mode (which slows the processor in idle states, etc, etc.) and it DID work. But I'm confused. Isn't the Smart CPU Mode and SpeedStep the same thing? Any insight would be appreciated. They both describe about the same thing in the BIOS information.
_________________
~Colin
Back to top
View user's profile Send private message
ColinAnderson
Tux's lil' helper
Tux's lil' helper


Joined: 26 Nov 2003
Posts: 89

PostPosted: Tue Feb 10, 2004 4:10 pm    Post subject: Reply with quote

Good Lord!!!! That didn't fix the noise. It's not as loud and constant, but it still chirps when text is scrolling on screen (mainly when compiling). This is driving me insane. :(
_________________
~Colin
Back to top
View user's profile Send private message
Veauger
n00b
n00b


Joined: 08 Mar 2003
Posts: 33

PostPosted: Wed Feb 11, 2004 6:00 am    Post subject: Reply with quote

Well, mine would actually stop buzzing when I scrolled. If the above fixes didn't work, you're probably out of luck. And the manufacturer won't do much about it either. Very unfortunate. I'll be buying power books from now on. They don't buzz. Either that or build my own -- at least that way I can only blame myself.
Back to top
View user's profile Send private message
Desecrater
n00b
n00b


Joined: 08 Feb 2004
Posts: 32

PostPosted: Wed Feb 11, 2004 7:02 am    Post subject: Reply with quote

I had a similar problem when running Reedhat 9, when my CPU would idle it made the nooise and as soon as I touched a key or moved the mouse it stopped. I hadnt treid to fix it yet, but if it happens again I can refer here :D
Back to top
View user's profile Send private message
sekh
n00b
n00b


Joined: 20 Dec 2002
Posts: 55

PostPosted: Fri Apr 02, 2004 12:20 pm    Post subject: Reply with quote

Hi.

I'm on a dell inspiron 8600.

for me what causes this seems to be the 'processor' option under ACPI.

I tries compiling it as a module instead of compiling it into the kernel. This caused the noise to vanish. As soon as i
Code:
insmod processor
The whining is back!
If i do a
Code:
rmmod processor
it goes away (it also does a nasty kernel panic and such :P but the system seems to survive.

Anyone know excactly what this processor option does and if it's needed?

Another thing i was curious about was that as a sub-option of processor there is something called 'thermal'. It says that it is highly recommended that this is enabled as the cpu might otherwise be damaged.

My question is then: does this 'highly recommended use' only count when the processor feature is enabled? If not i guess i might have to enable the processor feature again to get the thermal feature in there too :(

Any kernel/acpi experts have any input on this?
Back to top
View user's profile Send private message
DexterF
n00b
n00b


Joined: 25 Jul 2004
Posts: 1

PostPosted: Sun Jul 25, 2004 10:01 pm    Post subject: Reply with quote

I've got a whining noise from my Samsung SpinPoint hard disk after I moved from a VIA 686 southbridge to nForce2 MCP (on a rather cheap ECS N2U400-A).

Now the interesting point is: it only occurs with 2.6 kernels.
Tried Slackware, tried Knoppix, no difference. As soon as I boot a 2.4 or WinXP the disk falls silent.
Back to top
View user's profile Send private message
ercxy
n00b
n00b


Joined: 26 Apr 2004
Posts: 55
Location: MA

PostPosted: Mon Sep 13, 2004 3:44 am    Post subject: Reply with quote

I have lattitude d600 and i have been trying to understand this noise.. It is good to know that i am not alone..
I have nosie with 2.6 kernels and everything fine with 2.4 kernels..
I am going to disable acpi as suggested , let's see what happens
Back to top
View user's profile Send private message
galooo
n00b
n00b


Joined: 13 Sep 2004
Posts: 1

PostPosted: Mon Sep 13, 2004 11:44 pm    Post subject: I have the same problem ! Reply with quote

Hello

(im french, sorry for my bad english ... :wink: )

I have a weird problem on my computer; a strange noise, very "acute".
I though it was my fan CPU, but no ... :(

It seems that its a electronical noise ... but i dont know what ... I think its my CPU ..
:(

But i dont know from where come this fucking noise ! :evil:

PS : i'm on Win XP pro, with CPU Athlon XP 2400 +, MotherBoard MSI K7N2 Delta
Back to top
View user's profile Send private message
Fudor
n00b
n00b


Joined: 29 Jun 2004
Posts: 33
Location: Montreal, Ca

PostPosted: Tue Sep 14, 2004 6:16 am    Post subject: Reply with quote

I also have the same problem as you and I have an athlon xp 2800+ on a asus a7n8x mobo with onboard soundstorm sound.

There are two things I know you can do which seem to help alot while not completly getting rid of the problem. For some reason, setting you pc speaker sound in alsamixer to the maximum while muting your microphone seems to reduce the noise alot!

It used to drive me insane, but now its bareable. Hope this helps
Back to top
View user's profile Send private message
Rumil
Tux's lil' helper
Tux's lil' helper


Joined: 08 Dec 2003
Posts: 108
Location: Krakow, Poland

PostPosted: Tue Sep 14, 2004 7:36 pm    Post subject: Reply with quote

If you have "CPU Disconnect" option in your BIOS try to set it to "Disabled".
If you don't have it, but have nforce2-based motherboard try setting PCI offset 6F to 0F, 9F or 1F (setpci -s 0:00.0 6F.B=0F). Helped in my case. If you have motherboard based on different chipset search on the Internet for correct register and value to set to disable "CPU Dissconnect".
Back to top
View user's profile Send private message
chINeSe mIDgEts
Apprentice
Apprentice


Joined: 02 Mar 2004
Posts: 209
Location: look behind you

PostPosted: Tue Sep 14, 2004 8:28 pm    Post subject: Reply with quote

this happened to my desktop....for some reason one of the mounting levers (intel) came undone, so the fan was on half-assedly so it did make that noise sometimes
_________________
...it must have been very demanding having to learn how to use Microsoft Office, right up there with other lofty challenges like learning how to zip your fly without getting your dick caught.
Back to top
View user's profile Send private message
KhanReaper
n00b
n00b


Joined: 21 Sep 2004
Posts: 37

PostPosted: Tue Sep 21, 2004 3:23 pm    Post subject: Definitive Solution Reply with quote

For the past two years of owning an Inspiron 8200, only since the major distros moved to kernel 2.6 has this problem affected me. From my analyses, the problem originated with something to do with the laptop's power management features--both ACPI and APM--however, I never found an optimal configuration that would allow for some power management to work while abating the whining.

Has the community reached consensus as to identify a definitive solution to this problem? Might anyone be willing to share a kernel configuration with me?

And, out of curiosity, has anyone gotten any of the laptop's power management features to work? If so, what features, with which interface APM or ACPI, and what bios version? How about getting these things to work with NVIDIA's drivers?

I would like to say that I have been able to fix nearly every problem that Linux has thrown at me in the past seven years; but this one has stumped me completely. In fact, it has decreased the likelihood that I would ever buy a new laptop from Dell.
Back to top
View user's profile Send private message
chickaroo
Tux's lil' helper
Tux's lil' helper


Joined: 21 Sep 2004
Posts: 102
Location: #!/usr/bin/girl

PostPosted: Wed Sep 22, 2004 3:45 am    Post subject: Reply with quote

Code:
emerge setiathome


:D
_________________
Registered Linux user #364515 (Jun, 2004)
Back to top
View user's profile Send private message
psilo23
n00b
n00b


Joined: 28 Oct 2004
Posts: 7
Location: Purdue University

PostPosted: Mon Nov 01, 2004 6:28 pm    Post subject: Reply with quote

What is interesting, is that I only really notice this whine on my Inspiron 8600 when I boot and am on the battery. If I boot with AC on and then remove the power plug, my powersaving functions kick in (based on http://www.gentoo.org/doc/en/power-management-guide.xml) , the CPU gets scaled, but I don't notice a whine. Furthermore, I noticed that if I boot with battery and scale the frequency (either manually or with speedfreqd) I get a more noticeable whine at full Mhz and less whine at reduced (~1/3) MHz. Again, booting with AC on, removing the power plug, and then scaling the frequences has no whine at either full or reduced MHz. Very strange.

aloha
psilo
Back to top
View user's profile Send private message
moixa
n00b
n00b


Joined: 02 May 2003
Posts: 10

PostPosted: Tue Nov 16, 2004 9:44 am    Post subject: patch fixing it.. Reply with quote

Hi guys,

I whipped up this patch some time ago. Works fine for me and gets rid of that silly sound. I believe to have found the instructions for it somewhere in the linux-kernel-list.

Code:

--- linux-2.6.8-gentoo-r1/include/asm-i386/param.h.org  2004-08-22 14:07:17.842457000 +0200
+++ linux-2.6.8-gentoo-r1/include/asm-i386/param.h      2004-08-22 14:07:32.142457000 +0200
@@ -2,7 +2,7 @@
 #define _ASMi386_PARAM_H
 
 #ifdef __KERNEL__
-# define HZ            1000            /* Internal kernel timer frequency */
+# define HZ            100             /* Internal kernel timer frequency */
 # define USER_HZ       100             /* .. some user interfaces are in "ticks" */
 # define CLOCKS_PER_SEC                (USER_HZ)       /* like times() */
 #endif


If any of you can explain what side-effects this possibly could have (I don't experience any), please post!

Cheers,
Tobias
_________________
--
GPG-Key: 0xEF37FF28 (1024/4096 - DSA/ELG-E)
Fingerprint: 3C4B 155F 2621 CEAF D3A6 0CCB 937C 9597 EF37 FF28
Back to top
View user's profile Send private message
mouse256
n00b
n00b


Joined: 05 Aug 2004
Posts: 32

PostPosted: Wed Dec 15, 2004 10:57 am    Post subject: Reply with quote

thanks rumil!

I also had the problem with asus a7nx8 (nforce 2), disabling acpi and so on in kernel as suggested did not work, but the setpci from rumil did the job!
I made a script to add the command to the default runlevel, now I just hear it for some seconds while booting :-)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum