Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Weird post "dissociation" and error
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo Forums Feedback
View previous topic :: View next topic  
Author Message
Mnemia
Guru
Guru


Joined: 17 May 2002
Posts: 476

PostPosted: Wed Dec 11, 2002 10:32 pm    Post subject: Weird post "dissociation" and error Reply with quote

I posted to a thread at https://forums.gentoo.org/viewtopic.php?t=25551. Immediately after I posted I got an error saying "Error mailing message" or something along those lines. I had never seen that one before so I thought I'd mention it here. It posted my message anyway, and it has my avatar there, but it's like the post is only "half there". If you search for that thread the guy who posted before me shows up as the last poster, not me, despite my post being at the bottom. And I don't think it incremented my post count (though I could be wrong, I don't pay much attention to that).

Just thought I should mention it in case it's a sign of something being messed up.
Back to top
View user's profile Send private message
rac
Bodhisattva
Bodhisattva


Joined: 30 May 2002
Posts: 6553
Location: Japanifornia

PostPosted: Wed Dec 11, 2002 10:48 pm    Post subject: Reply with quote

I've seen this before, too. I haven't actually traced through the code, but this is what I think is happening. The logic goes something like this:
  • record the post
  • attach it to the topic
  • send email notifications to everybody watching the thread
  • update summary information, like who posted to the thread last and the post count in the thread, and the poster's post count
...if an exception gets thrown in step 3, it doesn't get to step 4. Nitro has mentioned that there was some mailing bug having to do with users that registered at certain times using non-English language settings, but I'm not exactly clear on the details.
_________________
For every higher wall, there is a taller ladder
Back to top
View user's profile Send private message
klieber
Administrator
Administrator


Joined: 17 Apr 2002
Posts: 3657
Location: San Francisco, CA

PostPosted: Wed Dec 11, 2002 11:47 pm    Post subject: Reply with quote

rac wrote:
Nitro has mentioned that there was some mailing bug having to do with users that registered at certain times using non-English language settings, but I'm not exactly clear on the details.

We're currently running phpBB 2.0.3, but the language packs are still at 2.0.1 (mainly because they haven't been updated on phpBB.com) There are apparently some differences in the variable names between the two versions. When someone runs into one of those instances, php barfs because of the variable mis-match and causes (we think) the error in question.

So, this should get fixed as soon as phpbb.com releases new language packs that are 2.0.3 compliant.

--kurt
_________________
The problem with political jokes is that they get elected
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo Forums Feedback All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum