Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
KDE 3.0.1
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
spendabuck
Apprentice
Apprentice


Joined: 28 Apr 2002
Posts: 256

PostPosted: Thu May 23, 2002 2:28 pm    Post subject: KDE 3.0.1 Reply with quote

Did anyone get to download 3.0.1? I checked the ftp sites and can't find the files, the gentoo folders are empty. :?
Back to top
View user's profile Send private message
Guest






PostPosted: Thu May 23, 2002 3:35 pm    Post subject: Reply with quote

I wanna upgrade too ...
Back to top
dek
l33t
l33t


Joined: 16 May 2002
Posts: 657
Location: Germany

PostPosted: Thu May 23, 2002 4:18 pm    Post subject: Reply with quote

Looks like the ebuils aren't finished yet. We need to be patient. 8)
Back to top
View user's profile Send private message
roman
n00b
n00b


Joined: 20 May 2002
Posts: 17

PostPosted: Thu May 23, 2002 6:16 pm    Post subject: Reply with quote

with small work you can do it.

Unmask the kde

Patch the md5 digest

emerge :-)
Back to top
View user's profile Send private message
FINITE
Guru
Guru


Joined: 10 May 2002
Posts: 449

PostPosted: Fri May 24, 2002 12:51 am    Post subject: Reply with quote

What do you mean unmask the kde? I see that this needs to be done but what is it that IT is. Err, how do I unmask kde? I got the md5 thing though, or I understand it. Thanks.
Back to top
View user's profile Send private message
suka
Developer
Developer


Joined: 22 Apr 2002
Posts: 383

PostPosted: Fri May 24, 2002 12:50 pm    Post subject: Reply with quote

FINITE wrote:
What do you mean unmask the kde? I see that this needs to be done but what is it that IT is. Err, how do I unmask kde? I got the md5 thing though, or I understand it. Thanks.


Edit /usr/portage/profiles/package.mask and put a # in front of all the lines concerning KDE 3.0.1 (right at the top of the file).

The md5 sums problem seems to already have been corrected, so just unmasking should work

A simple
Code:
emerge kde
should now bring your desktop up-to-date :D
Back to top
View user's profile Send private message
Guest






PostPosted: Fri May 24, 2002 3:27 pm    Post subject: Reply with quote

Ok I've been out for awhile and I'm just reading the posts. about the md5 patch how do I code it?
Back to top
dek
l33t
l33t


Joined: 16 May 2002
Posts: 657
Location: Germany

PostPosted: Fri May 24, 2002 4:15 pm    Post subject: Reply with quote

I emerge KDE 3.0.1 at the moment. The md5 patching of kdemultimedia is no longer needed. It is fixed. But i got a message after emerging kdemultimedia, which said alsa was disabled because of a bug in this package. You should use the oss-emulation instead.
I'll report as soon as i can say more about it.
Back to top
View user's profile Send private message
katakombi
n00b
n00b


Joined: 03 May 2002
Posts: 27

PostPosted: Fri May 24, 2002 5:45 pm    Post subject: weird! Reply with quote

you finally managed to emerge it?

for me, emerge kdelibs fails due to a wrong libpng.
It demands 1.2.3, which doesn't seem to be available.
How did you come around this problem?

or must i do emerge kde to fullfil all deps?


kata
Back to top
View user's profile Send private message
ddanier
Tux's lil' helper
Tux's lil' helper


Joined: 19 May 2002
Posts: 87

PostPosted: Fri May 24, 2002 6:01 pm    Post subject: Reply with quote

perhaps try "merge -u world"
then you update everything you need :)

(use "emerge -p -u world" first to see what will be updated)
_________________
My Box said: "Install Win95 or better ..." So I installed Linux.
Back to top
View user's profile Send private message
dek
l33t
l33t


Joined: 16 May 2002
Posts: 657
Location: Germany

PostPosted: Fri May 24, 2002 6:05 pm    Post subject: Reply with quote

I finished some minutes. Looks great so far! Sound works fine.
I used "emerge kde" to update. Some packages like the proper i18n and kdesdk were not included, so i just emerged them afterwards.

I have libpng 1.2.1 installed:
Code:

# emerge -s libpng
[ Results for search key : libpng ]
[ Applications found : 1 ]

*  media-libs/libpng
      Latest version Available: 1.2.1-r1
      Latest version Installed: 1.2.1-r1


The libpng problem you have seems to be a weird one. Version 1.2.1 is the latest available to me and i didn't get any unsolved deps.
Back to top
View user's profile Send private message
dek
l33t
l33t


Joined: 16 May 2002
Posts: 657
Location: Germany

PostPosted: Fri May 24, 2002 6:17 pm    Post subject: Reply with quote

Wooow the kdelibs seem to be greatly improved. I use krusader as my everday filemanager (which depends on kdelibs). The speedup is absolutely awesome! I thought 3.0.1 was just a bugfix release. :D
Back to top
View user's profile Send private message
gentoo-fan
Guest





PostPosted: Fri May 24, 2002 7:38 pm    Post subject: I had the same Problem Reply with quote

I had the same problem with the libpng 1.2.1
You have to copy your libpng-ebuild-script in a way that
the version number within the filename of this script will
show as 1.2.3 instead of 1.2.1.

After this write ebuild <your new libpng.ebuild> digest

(without the <>)

Then run emerge libpng... then libpng 1.2.3 will be
installed...

After this run emerge kde again...
Back to top
spendabuck
Apprentice
Apprentice


Joined: 28 Apr 2002
Posts: 256

PostPosted: Fri May 24, 2002 7:57 pm    Post subject: Reply with quote

I get this error message when I unmask the kde and then tried an "emerge kde"

These are the packages that I would merge, in order.

Calculating dependencies \
!!! Error: couldn't find match for ~kde-base/kdelibs-3.0.1 in kde-base/kde-3.0.1
Back to top
View user's profile Send private message
mellofone
Apprentice
Apprentice


Joined: 13 Apr 2002
Posts: 286

PostPosted: Fri May 24, 2002 9:13 pm    Post subject: Is it safe yet? Reply with quote

I see all of the updates for KDE:

These are the packages that I would merge, in order.

Calculating world dependencies ...done!
[ebuild U ] x11-libs/qt-3.0.4.1 to /
[ebuild U ] kde-base/arts-1.0.1 to /
[ebuild U ] dev-libs/libxml2-2.4.21 to /
[ebuild U ] dev-libs/libxslt-1.0.17 to /
[ebuild U ] app-text/ghostscript-6.53-r2 to /
[ebuild U ] app-text/sgml-common-0.6.3 to /
[ebuild U ] kde-base/kdelibs-3.0.1 to /
[ebuild U ] app-cdr/cdrtools-1.11.23 to /
[ebuild U ] media-video/xanim-2.80.1-r3 to /
[ebuild U ] media-sound/mpg123-0.59r-r1 to /
[ebuild U ] kde-base/kdemultimedia-3.0.1 to /
[ebuild U ] kde-base/kdepim-3.0.1 to /
[ebuild U ] kde-base/kdebase-3.0.1 to /
[ebuild U ] kde-base/kdenetwork-3.0.1 to /
[ebuild U ] kde-base/kdeaddons-3.0.1 to /
[ebuild U ] app-arch/rpm-4.0.4-r1 to /
[ebuild U ] kde-base/kdeadmin-3.0.1 to /
[ebuild U ] kde-base/kdegames-3.0.1 to /
[ebuild U ] media-libs/imlib-1.9.14 to /
[ebuild U ] kde-base/kdegraphics-3.0.1 to /
[ebuild N ] kde-base/kdetoys-3.0.1 to /
[ebuild N ] kde-base/kdeedu-3.0.1 to /
[ebuild U ] kde-base/kdeartwork-3.0.1 to /
[ebuild U ] kde-base/kdeutils-3.0.1 to /
[ebuild U ] kde-base/kde-3.0.1 to /

Has anyone completed them all? I would rather not emerge them all and find out I am missing a lib somewhere, and be forced to redo everything :)
Back to top
View user's profile Send private message
jtanner
Tux's lil' helper
Tux's lil' helper


Joined: 23 May 2002
Posts: 121
Location: Atlanta, GA

PostPosted: Fri May 24, 2002 9:33 pm    Post subject: Reply with quote

Mine failed with an error about a conflict between kdemultimedia and alsa 0.9

kde bug 39574
gentoo bug 2324

Eagerly awaiting 3.0.1-r1

Jim
Back to top
View user's profile Send private message
mellofone
Apprentice
Apprentice


Joined: 13 Apr 2002
Posts: 286

PostPosted: Fri May 24, 2002 9:46 pm    Post subject: Reply with quote

jtanner wrote:
Mine failed with an error about a conflict between kdemultimedia and alsa 0.9

kde bug 39574
gentoo bug 2324

Eagerly awaiting 3.0.1-r1

Jim


Darn :)

I was afraid of that. Luckily I don't use Alsa...Let's see how it goes...
Back to top
View user's profile Send private message
dek
l33t
l33t


Joined: 16 May 2002
Posts: 657
Location: Germany

PostPosted: Sat May 25, 2002 12:18 am    Post subject: Reply with quote

I use alsa with KDE 3.0.1. kdemultimedia gave me an error but was installed properly. I haven't noticed any problems so far.

mellofone: I don't had that many deps. I had most of the non-kde-packages already installed.
What version of QT are you running ? QT3.0.3 should work as well. I know QT really takes a lot of time to compile.
Back to top
View user's profile Send private message
Mnemia
Guru
Guru


Joined: 17 May 2002
Posts: 476

PostPosted: Sat May 25, 2002 12:23 am    Post subject: Reply with quote

My QT 3.0.4.1 compile failed with some sort of conflict involving 'libmng'. The QT ebuild gave some errors saying that I had numerous undefined references in my compiled /usr/lib/libmng.so file.

I find this kinda strange since that library had just been recompiled by emerge --update world and was the package just prior to QT.

And yes, I did an emerge rsync right before I did the update.

I'd guess this is a possible bug in the QT ebuild.
Back to top
View user's profile Send private message
mellofone
Apprentice
Apprentice


Joined: 13 Apr 2002
Posts: 286

PostPosted: Sat May 25, 2002 12:54 am    Post subject: Reply with quote

Shoot. I knew I should have waited. :)

It failed at the rpm-4.0.4-r1.

Posted the output on bugzilla:

https://bugs.gentoo.org/show_bug.cgi?id=3002
Back to top
View user's profile Send private message
shakti
Guru
Guru


Joined: 15 May 2002
Posts: 358
Location: omnipresent

PostPosted: Sat May 25, 2002 2:13 am    Post subject: Reply with quote

i just upgraded to 3.0.1 and besides the alsa bug error msg it went smooth, just emerge -u world again and vola. 3 1/2 hours to run in total and by the first look everything works, just got some extra/double menuentries but thats fixed... sound works...
_________________
Using Gentoo since 2002.
Back to top
View user's profile Send private message
mellofone
Apprentice
Apprentice


Joined: 13 Apr 2002
Posts: 286

PostPosted: Sat May 25, 2002 4:09 am    Post subject: Reply with quote

Fixed the problem and everything seems to be working ok. So far :)
Back to top
View user's profile Send private message
Mnemia
Guru
Guru


Joined: 17 May 2002
Posts: 476

PostPosted: Sat May 25, 2002 6:00 am    Post subject: Reply with quote

I fixed my QT problem too, by referring to gentoo bug 2859.

Had to manually reemerge the lcms library even though I already had the latest version.

But anyway my problems are solved now and my new KDE 3.0.1 is up and running.
8)
Back to top
View user's profile Send private message
shakti
Guru
Guru


Joined: 15 May 2002
Posts: 358
Location: omnipresent

PostPosted: Sat May 25, 2002 6:05 am    Post subject: Reply with quote

nice , now i just wait to get a fix for alsa much better then oss
_________________
Using Gentoo since 2002.
Back to top
View user's profile Send private message
mb
Guru
Guru


Joined: 25 Apr 2002
Posts: 355
Location: Hessen | .de

PostPosted: Sat May 25, 2002 10:15 am    Post subject: Reply with quote

kde 3.0.1 with gcc 3.0.4 -> no problems so far, but kmidi in kdemultimedia still refuses to compile...

btw: lots of errors when compiling with gcc3.1 -> arts + kdelibs fail to compile... also glibc

seems gcc3.1 is not ready for prime-time :cry:



#mb
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum