Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
wolfenstein occupies sound device after quiting
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gamers & Players
View previous topic :: View next topic  
Author Message
mb
Guru
Guru


Joined: 25 Apr 2002
Posts: 355
Location: Hessen | .de

PostPosted: Tue May 21, 2002 12:10 pm    Post subject: wolfenstein occupies sound device after quiting Reply with quote

hi... not gentoo related but anyway...

rtcw seems to occupy / not freeing my sound device (maestro3), after quiting the game, no other process (e.g. artsd, xmms) seems to be able to access the device, starting rtcw again works...

i have to remove/reload the sound module in order to get other apps running... does anybody have similiar problems ??


#mb
Back to top
View user's profile Send private message
MacMasta
Guru
Guru


Joined: 18 Apr 2002
Posts: 545
Location: Anchorage, AK

PostPosted: Thu May 23, 2002 6:49 am    Post subject: Running in WINE or Multiplay? Reply with quote

I know that I have RtCW running in the most recent build of wine (not even winex) both single- and multi-player, and it works fine...might want to try installing it like that.

~Mac~
Back to top
View user's profile Send private message
mb
Guru
Guru


Joined: 25 Apr 2002
Posts: 355
Location: Hessen | .de

PostPosted: Thu May 23, 2002 7:38 am    Post subject: Reply with quote

well.. there are native linux executables for rtcw... imo this is faster :wink:

#mb
Back to top
View user's profile Send private message
Beforegod
Bodhisattva
Bodhisattva


Joined: 10 Apr 2002
Posts: 1493
Location: Frankfurt/Main

PostPosted: Thu May 23, 2002 10:24 am    Post subject: Reply with quote

this should be an q3 engine error..

with quake 3 arena the this occurs too..

Theres only one way to deal this :

make a script!

My Q3 Script :

---
#!bin/sh
xinit /usr/share/games/quake3/quake3.x86
killall quake3.x86

-----

Cheers,
BeforeGod
Back to top
View user's profile Send private message
AutoBot
l33t
l33t


Joined: 22 Apr 2002
Posts: 968
Location: Usually Out

PostPosted: Thu May 23, 2002 2:48 pm    Post subject: Reply with quote

Is this error only prone to certain types of sound cards, I play RTCW for linux daily without any problem.
_________________
This message self destructed a long time ago.
Back to top
View user's profile Send private message
mb
Guru
Guru


Joined: 25 Apr 2002
Posts: 355
Location: Hessen | .de

PostPosted: Fri May 24, 2002 7:13 am    Post subject: Reply with quote

ok.. thx... i'm going to make a reload_crappy_sounddevice.sh and will wait until john c. has fixed this...

thx,
#mb
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gamers & Players All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum