Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
2.6.6 + tv card = no workie
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
86reddawg
n00b
n00b


Joined: 13 Nov 2003
Posts: 12

PostPosted: Tue Jul 06, 2004 3:06 am    Post subject: 2.6.6 + tv card = no workie Reply with quote

hey guys, haven't used my tvcard in a while, but i don't rememeber it being this difficult to set up.. anyone know what i'm doing wrong? I'm running a hauppauge wintv card with kernel 2.6.6


TVTIME:
Code:
root@tuff tuff # tvtime
Running tvtime 0.9.12.
rtctimer: Cannot open /dev/rtc: No such file or directory
rtctimer: Cannot open /dev/misc/rtc: No such file or directory
 
    Enhanced Real Time Clock support in your kernel is necessary for
    smooth video.  We strongly recommend that you load the 'rtc' kernel
    module before starting tvtime, and make sure that your user has
    access to the device file (/dev/rtc or /dev/misc/rtc).  See our
    support page at http://tvtime.net/ for more information.
 
Reading configuration from /etc/tvtime/tvtime.xml
Reading configuration from /root/.tvtime/tvtime.xml
videoinput: Can't read frame. Error was: Input/output error (0).
videoinput: Can't read frame. Error was: Input/output error (0).
videoinput: Can't read frame. Error was: Input/output error (0).
Segmentation fault


Tvtime used to run without segmentation fault (but still no video) until i emerged the nvidia-glx thinking that was my problem - now that i did that, it crashes like above...


XAWTV:
Code:

root@tuff tuff # xawtv
This is xawtv-3.86, running on Linux/i686 (2.6.6)
Warning: Cannot convert string "-*-ledfixed-medium-r-*--39-*-*-*-c-*-*-*" to type FontStruct
Warning: translation table syntax error: Unknown keysym name:  key
Warning: ... found while parsing '<Key>key: Command(setstation,"2")'
Warning: String to TranslationTable conversion encountered errors
Warning: translation table syntax error: Unknown keysym name:  key
Warning: ... found while parsing '<Key>key: Command(setstation,"2")'
Warning: String to TranslationTable conversion encountered errors
Warning: translation table syntax error: Unknown keysym name:  key
Warning: ... found while parsing '<Key>key: Command(setstation,"2")'
Warning: String to TranslationTable conversion encountered errors


the window pops up as a light blue-green color with some weird stuff there, but looks like just garbage (no moving picture or sound though)



Code:

root@tuff tuff # lsmod
Module                  Size  Used by
tuner                  17100  0
nvidia               4818740  12
tvaudio                20684  0
msp3400                22036  0
bttv                  144204  0
video_buf              17092  1 bttv
i2c_algo_bit            8840  1 bttv
btcx_risc               4232  1 bttv
sco                    12032  0
rfcomm                 35480  2
bnep                   11456  0
l2cap                  23040  6 rfcomm,bnep
hci_usb                13056  2


Code:

root@tuff tuff # less /var/log/messages | grep bttv
Jul  6 08:20:43 tuff bttv: driver version 0.9.14 loaded
Jul  6 08:20:43 tuff bttv: using 8 buffers with 2080k (520 pages) each for capture
Jul  6 08:20:43 tuff bttv: Bt8xx card found (0).
Jul  6 08:20:43 tuff bttv0: Bt878 (rev 2) at 0000:00:0c.0, irq: 11, latency: 64, mmio: 0xe3022000
Jul  6 08:20:43 tuff bttv0: detected: Hauppauge WinTV [card=10], PCI subsystem ID is 0070:13eb
Jul  6 08:20:43 tuff bttv0: using: Hauppauge (bt878) [card=10,autodetected]
Jul  6 08:20:43 tuff bttv0: gpio: en=00000000, out=00000000 in=00ffffdb [init]
Jul  6 08:20:43 tuff bttv0: Hauppauge/Voodoo msp34xx: reset line init [5]
Jul  6 08:20:43 tuff bttv0: Hauppauge eeprom: model=37281, tuner=Philips FM1236 (2), radio=yes
Jul  6 08:20:43 tuff bttv0: using tuner=2
Jul  6 08:20:43 tuff bttv0: i2c: checking for MSP34xx @ 0x80... found
Jul  6 08:20:43 tuff bttv0: i2c: checking for TDA9875 @ 0xb0... not found
Jul  6 08:20:43 tuff bttv0: i2c: checking for TDA7432 @ 0x8a... not found
Jul  6 08:20:43 tuff bttv0: registered device video0
Jul  6 08:20:43 tuff bttv0: registered device vbi0
Jul  6 08:20:43 tuff bttv0: registered device radio0
Jul  6 08:20:43 tuff bttv0: PLL: 28636363 => 35468950 .. ok
Jul  6 08:22:01 tuff bttv0: timeout: drop=0 irq=0/0, risc=2f2f301c, bits: FMTCHG VSYNC HSYNC OFLOW HLOCK VPRES RISCI
Jul  6 08:22:03 tuff bttv0: reset, reinitialize
Jul  6 08:22:03 tuff bttv0: PLL: 28636363 => 35468950 . ok
Jul  6 08:22:04 tuff bttv0: timeout: drop=0 irq=0/0, risc=2f2f301c, bits: VSYNC HSYNC OFLOW RISCI
Jul  6 08:22:07 tuff bttv0: reset, reinitialize
Jul  6 08:22:07 tuff bttv0: PLL: 28636363 => 35468950 . ok
Jul  6 08:22:07 tuff bttv0: PLL can sleep, using XTAL (28636363).
Jul  6 08:22:14 tuff bttv0: timeout: drop=0 irq=0/0, risc=2f2f303c, bits: FMTCHG VSYNC HSYNC OFLOW HLOCK RISCI
Jul  6 08:22:14 tuff bttv0: reset, reinitialize
Jul  6 08:22:14 tuff bttv0: PLL can sleep, using XTAL (28636363).
Jul  6 08:22:17 tuff bttv0: timeout: drop=0 irq=0/0, risc=2f2f301c, bits: VSYNC HSYNC OFLOW HLOCK VPRES RISCI
Jul  6 08:22:19 tuff bttv0: reset, reinitialize
Jul  6 08:22:19 tuff bttv0: PLL can sleep, using XTAL (28636363).
Jul  6 08:22:20 tuff bttv0: timeout: drop=0 irq=0/0, risc=2f2f303c, bits: VSYNC HSYNC OFLOW RISCI
Jul  6 08:22:24 tuff bttv0: reset, reinitialize




Code:

CONFIG_I2C=y
CONFIG_I2C_CHARDEV=y
CONFIG_I2C_ALGOBIT=m
CONFIG_VIDEO_DEV=y
CONFIG_VIDEO_BT848=m
CONFIG_VIDEO_TUNER=m
CONFIG_VIDEO_BUF=m
CONFIG_VIDEO_BTCX=m
CONFIG_VIDEO_IR=m


any ideas?
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 45636
Location: 56N 3W

PostPosted: Tue Jul 06, 2004 7:02 pm    Post subject: Reply with quote

86reddawg,

Like its says, TVTIME wants to use the rtc. It probably also needs
Code:
echo 1024 > /proc/sys/dev/rtc/max-user-freq
in /etc/conf.d/local.start to allow normal users to set it up. The value of 1024 keeps mplayer happy.

xawtv won't follow symbolic links (unless its been fixed recently).
Start it with
Code:
xawtv -c /dev/v4l/video0
so it can find the real video device file.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
86reddawg
n00b
n00b


Joined: 13 Nov 2003
Posts: 12

PostPosted: Tue Jul 06, 2004 9:35 pm    Post subject: Reply with quote

Code:

root@tuff tuff # echo 1024 > /proc/sys/dev/rtc/max-user-freq
root@tuff tuff # tvtime
Running tvtime 0.9.12.
Reading configuration from /etc/tvtime/tvtime.xml
Reading configuration from /root/.tvtime/tvtime.xml
videoinput: Can't read frame. Error was: Input/output error (0).
videoinput: Can't read frame. Error was: Input/output error (0).
videoinput: Can't read frame. Error was: Input/output error (0).
Segmentation fault

that didn't seem to do anything for the segmentation fault and even giving xawtv the v4l device, it doesn't do anything good either - just a blank screen....


Code:

root@tuff tuff # xawtv -c /dev/v4l/video0
This is xawtv-3.86, running on Linux/i686 (2.6.6)
Warning: Cannot convert string "-*-ledfixed-medium-r-*--39-*-*-*-c-*-*-*" to type FontStruct
Warning: translation table syntax error: Unknown keysym name:  key
Warning: ... found while parsing '<Key>key: Command(setstation,"2")'
Warning: String to TranslationTable conversion encountered errors
Warning: translation table syntax error: Unknown keysym name:  key
Warning: ... found while parsing '<Key>key: Command(setstation,"2")'
Warning: String to TranslationTable conversion encountered errors
Warning: translation table syntax error: Unknown keysym name:  key
Warning: ... found while parsing '<Key>key: Command(setstation,"2")'
Warning: String to TranslationTable conversion encountered errors
v4l2: read: Input/output error
Back to top
View user's profile Send private message
86reddawg
n00b
n00b


Joined: 13 Nov 2003
Posts: 12

PostPosted: Fri Jul 30, 2004 2:14 pm    Post subject: Reply with quote

well in case any of you guys have this problem as well, i fixed it... ended up removing my ide controller card and putting the tv card in it's spot - viola, everything works perfectly now...
Back to top
View user's profile Send private message
kormoc
Apprentice
Apprentice


Joined: 17 Jun 2002
Posts: 250

PostPosted: Sat Jul 31, 2004 10:12 am    Post subject: Reply with quote

Deleted

Last edited by kormoc on Mon Dec 24, 2018 9:00 am; edited 1 time in total
Back to top
View user's profile Send private message
86reddawg
n00b
n00b


Joined: 13 Nov 2003
Posts: 12

PostPosted: Sat Jul 31, 2004 1:22 pm    Post subject: Reply with quote

yea, that's what i'm using right now - just emerged xmltv as well - everything is neato :D
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum