Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
dependancies & packages.mask
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
LaSAR
n00b
n00b


Joined: 12 Apr 2002
Posts: 63
Location: Antwerp, Belgium

PostPosted: Tue Nov 19, 2002 7:56 am    Post subject: dependancies & packages.mask Reply with quote

emerge -u world is acting rather weird lately .
emerge -u world -p gives me:
Code:

These are the packages that I would merge, in order.

Calculating world dependencies ...done!

[ebuild    U ] x11-libs/qt-2.3.2-r1
[ebuild    U ] media-libs/libpng-1.0.12-r1
[ebuild    U ] net-www/opera-6.0
[ebuild    U ] media-sound/alsa-driver-0.9.0_rc2
[ebuild    U ] media-libs/alsa-lib-0.9.0_rc2
[ebuild    U ] media-sound/alsa-utils-0.9.0_rc2
....


while i got both a newer version of opera and alsa and both are not found in my packages.mask.

Code:

Searching...
[ Results for search key : alsa-driver ]
[ Applications found : 1 ]

*  media-sound/alsa-driver
      Latest version available: 0.9.0_rc2
      Latest version installed: 0.9.0_rc5
      Size of downloaded files: 1,259 kB
      Homepage:    http://www.alsa-project.org/
      Description: Advanced Linux Sound Architecture kernel modules


or is there any other way of masking packages? has it got something to do with the new unstable feature? and how can i see twhich package is in unstable?
Back to top
View user's profile Send private message
m0pr0be
Guru
Guru


Joined: 29 Aug 2002
Posts: 308

PostPosted: Tue Nov 19, 2002 11:01 am    Post subject: Reply with quote

Hi,

you have to set ACCEPT_KEYWORDS="~arch" in your /etc/make.conf, if you want to use testing-only ebuilds.
beware, the packages installed may not run at all (although they run fine for me)
Back to top
View user's profile Send private message
LaSAR
n00b
n00b


Joined: 12 Apr 2002
Posts: 63
Location: Antwerp, Belgium

PostPosted: Tue Nov 19, 2002 1:12 pm    Post subject: Reply with quote

i already run the packages and am only using stable (i removed these packages form packages.mask before the stalbe/unstable feature was there).
The question is how do i prevent emerge -u world from downgrading these now 'unstable' packages ? (i want to keep running stable packages).
And is there a simpel way one can see if a package is stable or unstable?
Back to top
View user's profile Send private message
m0pr0be
Guru
Guru


Joined: 29 Aug 2002
Posts: 308

PostPosted: Tue Nov 19, 2002 1:46 pm    Post subject: Reply with quote

you can control what packages should be "world" just edit the /var/cache/edb/world file and remove the entries for the specified packages.

Christoph
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum