Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problem with GIMP app in Gnome [RESOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
ric_man
n00b
n00b


Joined: 01 Dec 2003
Posts: 26
Location: Melbourne, Australia

PostPosted: Tue May 11, 2004 8:12 am    Post subject: Problem with GIMP app in Gnome [RESOLVED] Reply with quote

Hi all,

(This was originally posted in Multimedia, but after a day or two of thinking, I think it's more suited to be a desktop env question. The Moderators can reassign it if they think it doesn't belong here.)

I'm running GIMP 1.2.5 in GNOME 2.4 (using nVidia drivers) on Gentoo Linux.

I've emerge'd GIMP and attempted to use it, and while mostly all the options work, I can't seem to get the color selector panel to show anything with the exception of the tabs across the top - no options, no colors to select from, nothing but the tabs... and every tab is blank... have a look at this screen shot, and it may clarify what I'm "prattling" on about:

Screen shot of color selector pop up box.

All the tabs look like that one, regardless of what I choose.

I've also run it with --verbose, and this is what I see:

Code:
/home/evilric $ gimp --verbose
parsing "/etc/gimp/1.2/gtkrc"
parsing "/home/evilric/.gimp-1.2/gtkrc"
parsing "/home/evilric/.gimp-1.2/unitrc"
parsing "/etc/gimp/1.2/gimprc"
parsing "/home/evilric/.gimp-1.2/gimprc"
parsing "/home/evilric/.gimp-1.2/parasiterc"
parsing "/home/evilric/.gimp-1.2/pluginrc"
query plug-in: "/usr/lib/gimp/1.2/plug-ins/view3d"
writing "/home/evilric/.gimp-1.2/pluginrc"
Starting extensions: extension_script_fu
load module: "/usr/lib/gimp/1.2/modules/libcolorsel_gtk.so"
load module: "/usr/lib/gimp/1.2/modules/libcolorsel_triangle.so"
load module: "/usr/lib/gimp/1.2/modules/libcolorsel_water.so"
parsing "/home/evilric/.gimp-1.2/sessionrc"


Those modules mentioned are where they're supposed to be, and it appears that the permissions are set so that a user can see / use them.

If this is of help -- I had the same problem with gRIP... it would display the application and the tabs, but there were no options to choose from on the tabs...

I'm willing to try any suggestions. I've even recompiled gimp with "easier" compiler settings and I have not noticed any difference.

Any suggestions on how to get my color selection screens working correctly? Any suggestions as to where I can start looking?

...Ric
_________________
Running Gentoo as a desktop on a Toshiba Satellite P20 (P25 to some of you). Learning heaps!


Last edited by ric_man on Wed Feb 23, 2005 12:05 pm; edited 4 times in total
Back to top
View user's profile Send private message
Celtis
l33t
l33t


Joined: 05 Jul 2003
Posts: 737

PostPosted: Tue May 11, 2004 9:27 am    Post subject: Reply with quote

Try the suggestions mentioned in either here or here
Back to top
View user's profile Send private message
ric_man
n00b
n00b


Joined: 01 Dec 2003
Posts: 26
Location: Melbourne, Australia

PostPosted: Tue May 11, 2004 2:26 pm    Post subject: Reply with quote

Thanks for the suggestions, and I tried all that but couldn't get it to work...

Basically, I've given up getting Gimp 1.2.5 to work, and installed Gimp 2.0.0... simple enough:
Code:
ACCEPT_KEYWORDS="~x86" emerge gimp
emerge unmerge gimp-1.2.5
ln -s /usr/bin/gimp-2.0 /usr/bin/gimp

Now I've got Gimp working nicely.

I still have no clues as to why some of the menus in Gimp 1.2.5 just didn't work. I'm sure it was something to do with the fact I had two GTK versions, but I couldn't figure out how to resolve it correctly.

Thanks for your help, and those links... I should figure out how to use search better on this forum, but I just keep getting meaningless results, or I don't type in the correct keywords...

...Ric
_________________
Running Gentoo as a desktop on a Toshiba Satellite P20 (P25 to some of you). Learning heaps!
Back to top
View user's profile Send private message
ric_man
n00b
n00b


Joined: 01 Dec 2003
Posts: 26
Location: Melbourne, Australia

PostPosted: Thu Jun 24, 2004 9:31 am    Post subject: Reply with quote

Just as a footnote to this whole thing, I did notice that some other applications did have blank tabs too (like Grip).

Last night (22/06/2004) I removed gtk2 from my make.conf file:
Code:
USE="-gtk2 alsa acpi apache2 avi cdr doc dvd dvdr java mozilla mysql pcmcia perl pnp sse tcltk tiff usb wmf xml"

and then emerged the whole system
Code:
emerge -uDv world


Whether it was an upgrade from Gnome 2.4 to 2.6 or whether I was getting rid of gtk2 (and doing a Deep emerge) I can't tell you specifically, but it appears to have fixed the problems with the blank tabs.

Also worth noting is that GIMP2 is now apart of the stable branch of Gentoo, so I didn't need to go back.
_________________
Running Gentoo as a desktop on a Toshiba Satellite P20 (P25 to some of you). Learning heaps!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum