Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
2.6.7_rc3-love1 aka 'Feels like love'
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
ryceck
Apprentice
Apprentice


Joined: 13 Jan 2004
Posts: 195

PostPosted: Sun Jun 13, 2004 10:46 pm    Post subject: Reply with quote

Safrax wrote:
Anyone else noticed strange swap behavior with this kernel? According to top I have 256MB of ram free but yet I've got 86mb of crap in swap. Have the kernel developers gone insane and started trying to copy Microsoft's memory mismanagement or something?


Dont' have that problem.... What the output of?
Code:
$>free


Perhaps u accidentally started windows 98 or something... :wink: :lol:
Back to top
View user's profile Send private message
Safrax
Guru
Guru


Joined: 23 Apr 2002
Posts: 422

PostPosted: Sun Jun 13, 2004 11:15 pm    Post subject: Reply with quote

ryceck wrote:
Safrax wrote:
Anyone else noticed strange swap behavior with this kernel? According to top I have 256MB of ram free but yet I've got 86mb of crap in swap. Have the kernel developers gone insane and started trying to copy Microsoft's memory mismanagement or something?


Dont' have that problem.... What the output of?
Code:
$>free


Perhaps u accidentally started windows 98 or something... :wink: :lol:


Nah. I don't have win98 anymore. Won't touch it. EVIL++

I was compiling some stuff and heard a lot of hd thrashing. Curious I checked top (and free) they both showed swap being used but ram still being free.
Back to top
View user's profile Send private message
alari
n00b
n00b


Joined: 23 Feb 2004
Posts: 47
Location: Tartu, Estonia

PostPosted: Sun Jun 13, 2004 11:22 pm    Post subject: Reply with quote

Fresh love running smoothly here...
No lockups so far...
Back to top
View user's profile Send private message
Master_Of_Disaster
l33t
l33t


Joined: 28 Feb 2003
Posts: 610
Location: 15.05072° East, 48.13747° North (aka Mauer), Austria

PostPosted: Mon Jun 14, 2004 6:53 am    Post subject: Reply with quote

Up and running on new love, everything seems to be fine except bootsplash... I recognized an error in my siimage patch. All .vendor and .device lines in siimage.h must be removed to make it compile. I'll post an updated version later this day.
_________________
post tenebras lux, post fenestras tux
Registered Linux User Nr. 312509
Adopt an unanswered post today!
Back to top
View user's profile Send private message
robmoss
Retired Dev
Retired Dev


Joined: 27 May 2003
Posts: 2634
Location: Jesus College, Oxford

PostPosted: Mon Jun 14, 2004 7:12 am    Post subject: Reply with quote

I have a compile failure:

Code:
  CC      drivers/pci/msi.o
drivers/pci/msi.c: In function `msi_address_init':
drivers/pci/msi.c:265: error: invalid operands to binary <<
make[2]: *** [drivers/pci/msi.o] Error 1
make[1]: *** [drivers/pci] Error 2
make: *** [drivers] Error 2


My .config is available from here:

http://home.jesus.ox.ac.uk/~rmoss/portage/.config

I'm fairly sure it's GCC 3.4.0 specific, as I've seen errors like this before only with 3.4.0.
_________________
Reality is for those who can't face Science Fiction.

emerge -U will kill your Gentoo
ecatmur, Lord of Portage Bash Scripts
Back to top
View user's profile Send private message
primero.gentoo
Guru
Guru


Joined: 23 Dec 2003
Posts: 402

PostPosted: Mon Jun 14, 2004 7:30 am    Post subject: Reply with quote

msi error is not gcc 3.4 related. I think is broken at all , at least it is also for me with gcc 3.3.3-r6.
Love is working fine for me, also Bootsplash and reiser4 (that i use only for a test partition now).

Just a question. Does anyone had success with systrace kernel patch and love-sources? i tried several times without luck ... if anyone has suggest it would be wonderfull :)

Bye
_________________
"Linux, the choice of a GNU generation"
==Micro$oft - just say NO==
(L#USER 353039)
Back to top
View user's profile Send private message
Pink
Veteran
Veteran


Joined: 24 Jul 2003
Posts: 1062

PostPosted: Mon Jun 14, 2004 8:08 am    Post subject: Reply with quote

robmoss2k wrote:
I have a compile failure:

Code:
  CC      drivers/pci/msi.o
drivers/pci/msi.c: In function `msi_address_init':
drivers/pci/msi.c:265: error: invalid operands to binary <<
make[2]: *** [drivers/pci/msi.o] Error 1
make[1]: *** [drivers/pci] Error 2
make: *** [drivers] Error 2


My .config is available from here:

http://home.jesus.ox.ac.uk/~rmoss/portage/.config

I'm fairly sure it's GCC 3.4.0 specific, as I've seen errors like this before only with 3.4.0.


Yeah, it's not a GCC thing, turn of local APIC support for uniprocessors and your config compiles fine.
_________________
usefuljaja.com - VPS Tutorials
Back to top
View user's profile Send private message
robmoss
Retired Dev
Retired Dev


Joined: 27 May 2003
Posts: 2634
Location: Jesus College, Oxford

PostPosted: Mon Jun 14, 2004 8:15 am    Post subject: Reply with quote

Oh bugger, I quite like APIC support. :(

Oh well, I suppose I could try and fix it...
_________________
Reality is for those who can't face Science Fiction.

emerge -U will kill your Gentoo
ecatmur, Lord of Portage Bash Scripts
Back to top
View user's profile Send private message
evermind
Guru
Guru


Joined: 10 Jan 2004
Posts: 322

PostPosted: Mon Jun 14, 2004 9:14 am    Post subject: Reply with quote

robmoss2k wrote:
I have a compile failure:

Code:
  CC      drivers/pci/msi.o
drivers/pci/msi.c: In function `msi_address_init':
drivers/pci/msi.c:265: error: invalid operands to binary <<
make[2]: *** [drivers/pci/msi.o] Error 1
make[1]: *** [drivers/pci] Error 2
make: *** [drivers] Error 2


My .config is available from here:

http://home.jesus.ox.ac.uk/~rmoss/portage/.config

I'm fairly sure it's GCC 3.4.0 specific, as I've seen errors like this before only with 3.4.0.


have a look at http://lkml.org/lkml/2004/6/10/122
this patch solved it for me
Back to top
View user's profile Send private message
evermind
Guru
Guru


Joined: 10 Jan 2004
Posts: 322

PostPosted: Mon Jun 14, 2004 10:22 am    Post subject: Reply with quote

DaMouse wrote:
Con Kolivas made a nifty schedular and also the autoswap stuff so I thought I'd pop a patch against love1 to give it staircase.

http://www.evilrealms.net/~damouse/kernel-stuff/patch-2.6.7-rc3-love1-cons-work.bz2

-DaMouse


does it work without freezing?
Back to top
View user's profile Send private message
primero.gentoo
Guru
Guru


Joined: 23 Dec 2003
Posts: 402

PostPosted: Mon Jun 14, 2004 10:30 am    Post subject: Reply with quote

PickledOnion wrote:

Yeah, it's not a GCC thing, turn of local APIC support for uniprocessors and your config compiles fine.


I've not yet understood vey well what APIC is ... some clarify ? :)

Bye
_________________
"Linux, the choice of a GNU generation"
==Micro$oft - just say NO==
(L#USER 353039)
Back to top
View user's profile Send private message
robmoss
Retired Dev
Retired Dev


Joined: 27 May 2003
Posts: 2634
Location: Jesus College, Oxford

PostPosted: Mon Jun 14, 2004 1:30 pm    Post subject: Reply with quote

primero.gentoo wrote:
I've not yet understood vey well what APIC is ... some clarify ? :)


http://www.mega-tokyo.com/osfaq2/index.php/Tell%20me%20about%20APIC
_________________
Reality is for those who can't face Science Fiction.

emerge -U will kill your Gentoo
ecatmur, Lord of Portage Bash Scripts
Back to top
View user's profile Send private message
boroshan
l33t
l33t


Joined: 16 Apr 2003
Posts: 730
Location: upside down

PostPosted: Wed Jun 16, 2004 9:15 am    Post subject: Reply with quote

primero.gentoo wrote:


I've not yet understood vey well what APIC is ... some clarify ? :)

Bye
What was it you told me recently? Oh yes: GIYF
_________________
Don't let THEM immanentize the Eschaton!
Back to top
View user's profile Send private message
Taily
Tux's lil' helper
Tux's lil' helper


Joined: 19 Jun 2004
Posts: 115

PostPosted: Sat Jun 19, 2004 3:37 pm    Post subject: Reply with quote

Okey so i get this problem when compiling
AS arch/i386/kernel/vsyscall.o
CC arch/i386/kernel/time_hpet.o
make[1]: *** No rule to make target `arch/i386/kernel/std_resources.o', needed by `arch/i386/kernel/built-in.o'. Stop.
make: *** [arch/i386/kernel] Error 2

there is no std_res file, although in the linux-2.6.6 before applying the patches, there is..

Im trying to compile this on my xbox tho, but i don't see why that would make a difference at this point, or, woudl it be safe to disable std_res?

Iwe tried to compile love-sources-2.6.7_rc3-r1 and love-sources-2.6.7_rc3-r2
both with and without the xbox 2.6 kernel patches, but nothing works

EDIT: nvm, i took std_resources.c and .h from the 2.6.6 tar and it works now
Back to top
View user's profile Send private message
djm
Arch/Herd Tester
Arch/Herd Tester


Joined: 12 Apr 2004
Posts: 690
Location: Wadham College, Oxford

PostPosted: Mon Jun 21, 2004 1:33 am    Post subject: Reply with quote

When I ripped cds with this kernel the files had no sound (I could play cds and rip/play dvds ok though), so I'm back on 2.6.7-rc1-love1 :(
_________________
the forums.gentoo.org poster formally known as metal leper
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3, 4
Page 4 of 4

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum