Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
2.6.6-love3 aka "Spice Must Flow"
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4, 5, 6, 7, 8  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Gandalf the White
Guru
Guru


Joined: 17 Dec 2003
Posts: 320
Location: Verdun, Canada

PostPosted: Fri May 21, 2004 7:54 pm    Post subject: Re: Compilation error in fs/ext3/balloc.o Reply with quote

gringotts wrote:
[Should we open a new thread? (we have still 2.6.6-love3)]



Done

https://forums.gentoo.org/viewtopic.php?t=176099
Back to top
View user's profile Send private message
primero.gentoo
Guru
Guru


Joined: 23 Dec 2003
Posts: 402

PostPosted: Fri May 21, 2004 8:00 pm    Post subject: Reply with quote

Code:

  CC [M]  fs/ext3/balloc.o
fs/ext3/balloc.c: In function `ext3_should_retry_alloc':
fs/ext3/balloc.c:1001: error: structure has no member named `journal_info'
make[2]: *** [fs/ext3/balloc.o] Error 1
make[1]: *** [fs/ext3] Error 2
make: *** [fs] Error 2



Same error as other people.

Solved removing ext3 support since i don't need it.

Bye
_________________
"Linux, the choice of a GNU generation"
==Micro$oft - just say NO==
(L#USER 353039)
Back to top
View user's profile Send private message
jewps
n00b
n00b


Joined: 29 Mar 2004
Posts: 74

PostPosted: Fri May 21, 2004 9:33 pm    Post subject: Reply with quote

silverter wrote:

I jump in the same boot as you guys, steel300 help us out of this one. I tried to follow https://forums.gentoo.org/viewtopic.php?t=170548 forum link, but no go. I think I'm just too stupid to get it done.

thanks and regards,


The guide provided doesn't really work with the 2.6.6 kernels, there seems to be a test patch avail. but i can't figure out how to patch the kern with em.. They're a little different then other kernels (2.6.5)..

oh well :(
Back to top
View user's profile Send private message
neenee
Veteran
Veteran


Joined: 20 Jul 2003
Posts: 1786

PostPosted: Fri May 21, 2004 10:33 pm    Post subject: Reply with quote

primero.gentoo wrote:
Code:

  CC [M]  fs/ext3/balloc.o
fs/ext3/balloc.c: In function `ext3_should_retry_alloc':
fs/ext3/balloc.c:1001: error: structure has no member named `journal_info'
make[2]: *** [fs/ext3/balloc.o] Error 1
make[1]: *** [fs/ext3] Error 2
make: *** [fs] Error 2



Same error as other people.

Solved removing ext3 support since i don't need it.

Bye


the real fix would be:

Code:
nano +1001 fs/ext3/balloc.c
replace 'journal_info' with 'fs_context'


enjoy :wink:
_________________
proud to be a scout and a chronic penguin hugger
Legion of Lore - site
Back to top
View user's profile Send private message
gungholady
Guru
Guru


Joined: 19 Oct 2003
Posts: 392

PostPosted: Fri May 21, 2004 11:09 pm    Post subject: Reply with quote

PickledOnion wrote:
Anyone who wants win4lin to compile needs to change the following:
Code:
(Line 1532 arch/i386/mki-adapter26/mki26.c using 2.6.6-love4)


Change

   MKIA_ASSERT(atomic_read(&pageinfop->counter) >= 2);

to

   MKIA_ASSERT(page_count(pageinfop) >= 2);


Or, if you patch by hand, change line 22193 of the love patch as above, or if you do win4lin by hand, line 1906 in the mki-adapter26_1_3_5.patch

It works fine on mine so hurrah!

HTH.

/edit: sorry for the multiple edits but I wanted to test it first and have only just been able to reboot - it works fine for all those wanting win4lin and love. :D


Whoopee. Because of this I now have love-sources-2.6.6-r4 working with Win4Lin and bootsplash. The same version of nvidia that I was using for love-sources-2.6.6-r1 did not work. The version that did work was nvidia-kernel-1.0.5341-r1. I updated to the same version of nvidia-glx, but I'm going to have to figure out what I need to edit because glx is not working. I'm using xorg-x11 so I had to edit the nvidia-glx-1.0.5341-r1 ebuild to keep it from trying to install xfree which was blocked by xorg.
Back to top
View user's profile Send private message
Swishy
Guru
Guru


Joined: 06 Jun 2002
Posts: 491
Location: NZ

PostPosted: Sat May 22, 2004 12:42 am    Post subject: make mrproper issues .. Reply with quote

Just noticed an issue with running make mrproper when bootstrapping a install with love-sources
vanilla 2.6.6. works fine , however with love-sources patches applied it blows up with

# make mrproper
CLEAN include/asm
rm: cannot remove `include/asm': Is a directory
make: *** [mrproper] Error 1
#

so im assuming theres an issue in one of the Makefiles .....still havent found it :?

Cheers
Dale.
_________________
Theres no substitute for C.I.
Back to top
View user's profile Send private message
AstralStorm
Tux's lil' helper
Tux's lil' helper


Joined: 06 Nov 2003
Posts: 80
Location: /dev/null

PostPosted: Sat May 22, 2004 5:25 am    Post subject: Reply with quote

Confirming that issue. It required me to modify Catalyst script to accept genkernel options.
It is caused by include/asm not being a link - it should be...
I don't know what's the reason for not being it.
Back to top
View user's profile Send private message
Swishy
Guru
Guru


Joined: 06 Jun 2002
Posts: 491
Location: NZ

PostPosted: Sat May 22, 2004 5:33 am    Post subject: Reply with quote

Yeah worked around it by manually removing and make mrproper make defconfig etc , all is now well in the world ;-)

Dale.
_________________
Theres no substitute for C.I.
Back to top
View user's profile Send private message
fieryred2k
n00b
n00b


Joined: 23 Mar 2004
Posts: 13

PostPosted: Sat May 22, 2004 6:17 am    Post subject: Reply with quote

Quote:
the real fix would be:

Code:

nano +1001 fs/ext3/balloc.c
replace 'journal_info' with 'fs_context'


enjoy


OOOohhh thank you neenee... this was really starting to bug me... *starts bowing* I'm not worthy... I'm not worthy... I'm scum... I suck!
Back to top
View user's profile Send private message
_benj_
n00b
n00b


Joined: 05 May 2004
Posts: 32

PostPosted: Sat May 22, 2004 9:08 am    Post subject: Reply with quote

love5 works very fine here :D
_________________
we are microsoft: what you are experiencing is an undocumented feature, not a bug.
Back to top
View user's profile Send private message
ivanova
Apprentice
Apprentice


Joined: 12 Apr 2004
Posts: 158
Location: South Africa

PostPosted: Sun May 23, 2004 10:17 pm    Post subject: Reply with quote

Anyone got lirc working with 2.6.6-love4? I tried the patches from http://www.elektronikschule.de/~genannt/kernel-patche/lirc/ but I get compile errors.

edit:
Nevermind- I got it working now. Privoxy messed with the patch. :twisted:

Everything is working nicely now - even my sound skipping with high HD activity is solved with this kernel. :wink: :lol:
_________________
Ladies and Gentlemen... we are floating in space.
Back to top
View user's profile Send private message
fourhead
l33t
l33t


Joined: 03 Sep 2003
Posts: 875
Location: Cologne, Germany

PostPosted: Wed Jun 02, 2004 3:40 pm    Post subject: Reply with quote

I WANT LOVE SOURCES!!

but this link never works for me:

http://www.public.iastate.edu/~jpcox

all i can get there is this:

Parent Directory 02-Feb-2004 21:49 -
Anguish.png 24-May-2004 13:14 189k
gnome-volume-manager 29-May-2004 11:28 1k
screenshot.png 29-Apr-2004 13:30 428k
xorg_instructions 15-Apr-2004 19:57 1k

not much :-(

i'm trying to emerge 2.6.6-love4 which - as far as i know - has reiser4 + supermount which is what i need and want. so where to get it? could someone provide a link?

thanks,
tom
Back to top
View user's profile Send private message
Kevin72594
Guru
Guru


Joined: 30 Dec 2003
Posts: 307

PostPosted: Wed Jun 02, 2004 4:12 pm    Post subject: Reply with quote

I need that link too if anyone has it, or just paste the ebuild in...thanks
Back to top
View user's profile Send private message
WaVeX
Tux's lil' helper
Tux's lil' helper


Joined: 15 Mar 2004
Posts: 102
Location: USA, Michigan or Ohio

PostPosted: Wed Jun 02, 2004 4:54 pm    Post subject: Reply with quote

I may be able to host but not sure. My hosting service has 30gb per month bandwidth on it and I don't want to go over that.

If thats enough bandwidth I could try.
Back to top
View user's profile Send private message
kallamej
Administrator
Administrator


Joined: 27 Jun 2003
Posts: 4830
Location: Gothenburg, Sweden

PostPosted: Wed Jun 02, 2004 7:30 pm    Post subject: Reply with quote

Try this thread. I haven't tried the links, though.
_________________
Please read our FAQ Forum, it answers many of your questions.
irc: #gentoo-forums on irc.freenode.net
Back to top
View user's profile Send private message
Kevin72594
Guru
Guru


Joined: 30 Dec 2003
Posts: 307

PostPosted: Wed Jun 02, 2004 7:42 pm    Post subject: Reply with quote

thanks a bunch, I'm emerging as we speak and will soon be compiling, finally :lol:
Back to top
View user's profile Send private message
fourhead
l33t
l33t


Joined: 03 Sep 2003
Posts: 875
Location: Cologne, Germany

PostPosted: Wed Jun 02, 2004 9:54 pm    Post subject: Reply with quote

thanks, i was able to download them now. actually, i could host them, at least the last five or six patches or so. i have ~20mb free on my webspace account and unlimited traffic. so if there's some interest in that, i'd do that and only charge $5 per download ;-) no, just kidding. well, i'll just upload the 2.6.6-love4 patch that's the one ihave right now.

tom
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3, 4, 5, 6, 7, 8
Page 8 of 8

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum