Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Ultra 60 w/ Creator3D
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc
View previous topic :: View next topic  
Author Message
jbwillia
Tux's lil' helper
Tux's lil' helper


Joined: 07 May 2004
Posts: 108
Location: TN, USA

PostPosted: Thu May 13, 2004 3:03 pm    Post subject: Ultra 60 w/ Creator3D Reply with quote

I'm looking for an XF86config-4 file that works with the creator3D graphics card. I've seen partial listings on previous threads, but I'd really like to find a file w/ all the key elements (w/o comments) ... everything elsewhere seems to be geared for the x86 platform.

Can someone with an Ultra system w/ creator3D please post?
Back to top
View user's profile Send private message
Ferris
Retired Dev
Retired Dev


Joined: 13 Jan 2003
Posts: 426
Location: N. Virginia (USA)

PostPosted: Fri May 14, 2004 1:24 am    Post subject: Reply with quote

I don't claim this is optimal, but in relevant part, something like this should work. Assumes
a 2.4.xx kernel, sun keyboard & mouse, Creator, running xorg-x11 (but xfree-4.3.xx is the
same to what is posted). I am not showing any of the font information, as that is the same
no matter what your CPU. On a U60, the Creator card is Vertical, not Horizontal, but
that line appearing below is just description not used by xfree (xorg).

Code:

Section "ServerLayout"
  Screen         0 "Screen0" 0 0
  InputDevice   "Mouse0" "CorePointer"
  InputDevice   "Keyboard0" "CoreKeyboard"
  Option        "HandleSpecialKeys" "Always"
  Option        "DontVTSwitch"  "off"
EndSection
Section "ServerFlags"
  Option        "StandbyTime"   "10"
  Option        "SuspendTime"   "20"
  Option        "OffTime"       "30"
EndSection

Section "Module"
  Load  "dbe"
  Load  "type1"
  Load  "speedo"
  Load  "dri"
  Load  "glx"
  Load  "freetype"
  Load  "record"
  Load  "extmod"
EndSection

Section "InputDevice"
  Identifier  "Keyboard0"
  Driver      "keyboard"
  Option      "Protocol"    "Standard"
  Option      "XkbKeycodes" "sun(type5)"
  Option      "XkbModel"    "type5"
  Option      "XkbRules"    "sun"
  Option      "XkbLayout"   "en_US"
  Option      "XkbGeometry" "sun(type5)"
EndSection

Section "InputDevice"
  Identifier  "Mouse0"
  Driver      "mouse"
  Option      "Protocol" "MouseSystems"
  Option      "Device" "/dev/sunmouse"
  Option        "Emulate3Buttons"       "false"
EndSection
Section "Monitor"
  Identifier   "Monitor0"
  VendorName   "Sun"
  ModelName    "GDM-20E20"
  Option       "DPMS"   "on"
EndSection

Section "Device"
  Identifier  "Card0"
  BoardName   "Sun|FFB2+ Horizontal Creator 3D (ffb)"
  VendorName  "Sun Microsystems"
  Driver      "sunffb"
EndSection

Section "Screen"
  Identifier   "Screen0"
  Device       "Card0"
  Monitor      "Monitor0"
  DefaultDepth 24
    SubSection   "Display"
        Depth     24
        Modes     "1280x1024"
  EndSubSection
 EndSection
 Section "DRI"
 Group          "video"
 Mode           0666
EndSection


Much of the commentary, like Board name, vendor name, is just that: comments. Key points
are the driver name, depth must be 24, and the sorts of things it takes to get your keyboard
to work. There are other sets of options which will get a sun keyboard to work; the ones
I've shown are a set generated by trial and error, and which work for me with a type 5
keyboard.

If you are using kernel 2.6.x, keyboard and mouse definitions are different; documentation is
at http://dev.gentoo.org/~ciaranm/ (they are probably more like what you are used to).

OK, what did I omit? The
Code:

Section "Files"
  RgbPath       "/usr/X11R6/lib/X11/rgb"
  ModulePath    "/usr/X11R6/lib/modules"
  FontPath      "/usr/share/fonts/misc:unscaled"

  ..............
  ..............

EndSection

for whatever and wherever your fonts are.

Hope this can get you started,
Ferris
Back to top
View user's profile Send private message
jbwillia
Tux's lil' helper
Tux's lil' helper


Joined: 07 May 2004
Posts: 108
Location: TN, USA

PostPosted: Fri May 14, 2004 7:10 am    Post subject: keyboard problems Reply with quote

First off I am now running Xorg because I first ran into this problm in XFree. I got upset and decided to just switch while it's early. However, I see now that I have the exact same problem here. I had a configuration, but I edited it to fit what you just posted.

What's happening is: once I run startx my keyboard flatout dies. It becomes completely unresponsive and even the Caps Lock, Num Lock, etc. lights stop working. It is a Type 6 keyboard with the mouse running through it. This is my first SPARC, so that may be the norm. However, the mouse works fine. The screen is black and I have the standard X cursor that moves around perfectly. Mouse buttons have no effect though. I'm not getting any kind of menus or anything. I have fluxbox installed, but now that I think of it I never did add that to xinit. My only option after running startx is to ssh into the box and reboot. I've tried killiing X but it just makes the screen black without giving my tty's back, and the keyboard is still unresponsive (even to the three finger salute).

Below is my config:

Code:
Section "Files"
        RgbPath     "/usr/X11R6/lib/X11/rgb"
        FontPath        "/usr/lib/X11/fonts/local/"
        FontPath        "/usr/lib/X11/fonts/misc/"
        FontPath        "/usr/lib/X11/fonts/75dpi/:unscaled"
        FontPath        "/usr/lib/X11/fonts/100dpi/:unscaled"
        FontPath        "/usr/lib/X11/fonts/Type1/"
        FontPath        "/usr/lib/X11/fonts/CID/"
        FontPath        "/usr/lib/X11/fonts/Speedo/"   
        FontPath        "/usr/lib/X11/fonts/75dpi/"   
        FontPath        "/usr/lib/X11/fonts/100dpi/"   
EndSection

Section "ServerLayout"
        Identifier      "ServerLayout0"
        Screen           0 "Screen0" 0 0
        InputDevice     "Mouse0" "CorePointer"
        InputDevice     "Keyboard0" "CoreKeyboard"
        Option          "HandleSpecialKeys" "Always"
        Option          "DontVTSwitch" "off"
EndSection

Section "ServerFlags"
        Option          "StandbyTime"   "10"
        Option          "SuspendTime"   "20"
        Option          "OffTime"       "30"
EndSection

Section "Module"
        Load    "GLcore"
        Load    "bitmap"
        Load    "dbe"
        Load    "ddc"
        Load    "dri"
        Load    "extmod"
        Load    "freetype"
        Load    "glx"
        Load    "int10"
        Load    "record"
        Load    "speedo"
        Load    "type1"
        Load    "vbe"
EndSection

Section "InputDevice"
        Identifier      "Keyboard0"
        Driver          "keyboard"
        Option          "Protocol"      "Standard"
        Option          "XkbKeycodes"   "sun(type6)"
        Option          "XkbModel"      "type6"
        Option          "XkbRules"      "sun"
        Option          "XkbLayout"     "en_US"
        Option          "XkbGeometry"   "sun(type6)"
EndSection

Section "InputDevice"
        Identifier      "Mouse0"
        Driver          "mouse"
        Option          "Protocol"              "MouseSystems"
        Option          "Device"                "/dev/sunmouse"
        Option          "Emulate3Buttons"       "false"
EndSection

Section "Monitor"
        Identifier      "Monitor0"
        VendorName      "Sun Microsystems"
        ModelName       "GDM-5410 (Sony)"
        HorizSync       30-121
        VertRefresh     48-160
        Option          "DPMS"          "on"
EndSection

Section "Device"
        Identifier      "Card0"
        BoardName       "Sun|FFB2+ Vertical Creator 3d (ffb)"
        VendorName      "Sun Microsystems"
        Driver          "sunffb"
EndSection

Section "Screen"
        Identifier      "Screen0"
        Device          "Card0"
        Monitor         "Monitor0"
        DefaultDepth    24
        SubSection "Display"
                Depth           24
                Modes           "1600x1200"
        EndSubSection
EndSection

Section "DRI"
        Group   "video"
        Mode    0666
EndSection


and the error from the log:

Code:
(II) Keyboard "Keyboard0" handled by legacy driver
(II) XINPUT: Adding extended input device "Mouse0" (type: MOUSE)
(EE) Couldn't load XKB keymap, falling back to pre-XKB keymap
(II) Server_Terminate keybinding not found
Back to top
View user's profile Send private message
jbwillia
Tux's lil' helper
Tux's lil' helper


Joined: 07 May 2004
Posts: 108
Location: TN, USA

PostPosted: Fri May 14, 2004 8:03 am    Post subject: Reply with quote

Also, I'm on the 2.4.26 kernel. Speaking of which, how do you get the 2.6 source; do you actually have to get it from kernel.org because I'm using ~ARCH and 2.4.26 is all that's available in the portage tree.
Back to top
View user's profile Send private message
Ferris
Retired Dev
Retired Dev


Joined: 13 Jan 2003
Posts: 426
Location: N. Virginia (USA)

PostPosted: Fri May 14, 2004 6:28 pm    Post subject: Reply with quote

Second point first. 2.6.x kernels are in sys-kernel/development-sources; you will want
2.6.5 or 2.6.6. See http://dev.gentoo.org/~ciaranm/docs/sparc-2.6.x/ for installation
information.

First point. You might have to ask someone with a type6 keyboard for the answer, but as
a starting point, there does not seem to be a separate XkbGeometry for sun(type6).

You can try type5, type5euro, type5unix, type5_se. (I am looking in /usr/X11R6/lib/X11/xkb/geometry/sun). If nothing works, you will have to ask someone with a type6 keyboard;
there are such people, but I am not one of them.
Back to top
View user's profile Send private message
Mark Clegg
Apprentice
Apprentice


Joined: 05 Jan 2004
Posts: 269
Location: ZZ9 Plural Z Alpha

PostPosted: Fri May 14, 2004 7:13 pm    Post subject: Reply with quote

Type 6 keyboard user here....

I've got

Code:
Section "InputDevice"
        Identifier   "Keyboard0"
        Driver       "keyboard"
#       Option       "Protocol" "Standard"
#       Option       "XkbKeyCodes" "sun(type5)"
        Option       "XkbLayout" "gb"
#       Option       "XkbModel" "type5"
#       Option       "XkbRules" "xfree86"
EndSection


But I'm using kernel 2.6 so that probably doesn't help much.

I think if you remove the "XkbLayout" "gb" line and uncomment the 4 commented lines, then that is what I had for 2.4. ... I think - I've been on 2.6 for a while now.
Back to top
View user's profile Send private message
jbwillia
Tux's lil' helper
Tux's lil' helper


Joined: 07 May 2004
Posts: 108
Location: TN, USA

PostPosted: Sun May 16, 2004 10:16 am    Post subject: voila, I found it Reply with quote

The problem is in the X server module glx. If I comment that out everything appears to work fine. I am about to try and get my WM (fluxbox) working. I really want GL functionality, hopefully I'll be able to figure out why it's causing this. I'm just happy to not have to reboot every time it doesn't work now!!!
Back to top
View user's profile Send private message
jbwillia
Tux's lil' helper
Tux's lil' helper


Joined: 07 May 2004
Posts: 108
Location: TN, USA

PostPosted: Sun May 16, 2004 10:28 am    Post subject: Reply with quote

CORRECTION, it's apparently something to do with the communication between dri and glx. b/c if I comment out one and not the other it works fine. They just will not work together.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum