Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Kernel 2.4 vs 2.6
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Finnish
View previous topic :: View next topic  
Author Message
FutureGuru
n00b
n00b


Joined: 10 May 2004
Posts: 29
Location: Tampere, Finland

PostPosted: Mon May 10, 2004 11:34 am    Post subject: Kernel 2.4 vs 2.6 Reply with quote

Aloitteleva osaaja kaipaa kokeneiden kommentteja eri kerneleistä.

2.6:sta puhutaan kovasti, mutta ei pelkästään myönteistä. Onko se buginen ja ns. "Full of unplaeasant surprises" vai oikeasti käytettävä kernel ?

Käyttöympäristö on seuraava:
HP Omnibook XE4100
Intel Celeron 1.2 GHz
256 Mb RAM
20 GB IDE hd
DVD
USB rullahiiri
Dlink 650+ pcmcia wlan

Tuplabootti WinXP:n kanssa

Rohkeaa komenttia - kiitos.
Back to top
View user's profile Send private message
jounihat
Apprentice
Apprentice


Joined: 26 Oct 2003
Posts: 205
Location: Finland

PostPosted: Mon May 10, 2004 12:04 pm    Post subject: Re: Kernel 2.4 vs 2.6 Reply with quote

2.6 alkaa nyt .5-versiossa olla bugiton, ja todella nopea se kyllä on verrattuna 2.4:seen. Minulla oli aluksi ongelmia kernelin alsan kanssa, mutta myöhemmin huomasin niiden ongelmien johtuneen itse asiassa SDL:stä. Eli käytännössä minulla ei ole ollut 2.6 kernelin kanssa ongelmia missään vaiheessa. Tuo sinun koneesi ei näyttäisi olevan mikään 10 000:n megawatin liekinheitin, joten 2.6:sen nopeus saattaa tuoda mukavampaa käytettävyyttä.

Minä siis suosittelen. Tietysti ongelmia saattaa tulla, mutta niitä on harvemmin helppo ennustaa.
_________________
Jouni Hätinen

-There's really only one reasonable OS, and that's Open Source!
Back to top
View user's profile Send private message
hanta
Tux's lil' helper
Tux's lil' helper


Joined: 28 Jun 2002
Posts: 115
Location: Vantaa - Finland

PostPosted: Mon May 10, 2004 4:59 pm    Post subject: Reply with quote

minulla oli aiemmin ongelmia USB-scannerin kanssa, mutta nyt tuntuvat nuokin ratkenneen. hyvin on toiminut ja varsinkin joistain 'epävirallisista' patchatuista kerneleistä löytyvä Nick's scheduler on aivan loistava.

minäkin tappelin aikani alsan kanssa, mutta sekin alkaa tosiaan olemaan jo mennyttä. nforce-emoja varten kannattaa kyllä edelleen hankkia valmiiksi patchattu kerneli tai patchata se itse.

tietty 2.6:n etuna on sekin, että glibc:n voi kääntää nptl-tuella ;)
_________________
Janne
Back to top
View user's profile Send private message
Julle
n00b
n00b


Joined: 18 Feb 2003
Posts: 21
Location: Oulu, Finland

PostPosted: Tue May 11, 2004 7:52 am    Post subject: Reply with quote

Varoituksen sana. Itelläni on IBM ThinkPad 600x enkä ole saanut pcmcia verkkokorttia toimimaan 2.6 kernelin kanssa. Väittävät sen onnistuvan, mutta kovin monella tuntuu olevan ongelmia juuri tämän kans.

Jos joku pystyy kumoamaan väitteeni hyvä niin, ja vois samalla heittää vinkkiä miten homma toimiin.

Muuten ei ole mitään pahaa sanottavaa 2.6:sesta.
Back to top
View user's profile Send private message
jaska
Bodhisattva
Bodhisattva


Joined: 06 Jun 2003
Posts: 725
Location: Finland

PostPosted: Tue May 11, 2004 9:13 pm    Post subject: Reply with quote

Olen käyttänyt 2.6 sarjan kerneliä 2.6.0-test4:ta lähtien eikä koskaan ole ollut pahempia ongelmia kuin hyppivä alsa mutta vika oli kylläkin jossain muualla, ja ide-scsi emulaatio ei ole toiminut kunnolla mutta onneksi atapi pottamine oli toimiva vaihtoehto. Nykyään käytän love-sources kerneleitä, vaikka kertovat love-sources kernelin olevan täynnä epävakaata koodia mutta tuloksena on erittäin nopea ja tasainen kone. Yleensä tavallisella 2.6 kernelillä vain harvoin xmms hyppii jos käännän kerneliä, nyt en edes yrittämällä saa xmms:ää pomppimaan.
Back to top
View user's profile Send private message
zeb
Tux's lil' helper
Tux's lil' helper


Joined: 19 Apr 2002
Posts: 79
Location: Finland

PostPosted: Wed May 12, 2004 3:36 pm    Post subject: Reply with quote

2.6.5 on toiminut erittäin hyvin täällä. Pyöri ongelmitta yli kuukauden kovassa käytössä. Suosittelen elevator=deadline koska vakioasetuksella nytkii vähän suuria tiedostoja kopioidessa.
Back to top
View user's profile Send private message
Mikessu
Moderator
Moderator


Joined: 11 Oct 2003
Posts: 219
Location: Oulu, Finland

PostPosted: Wed May 12, 2004 4:19 pm    Post subject: Reply with quote

Hyviä kokemuksia minullakin on 2.6-kerneleistä, ei ole kaatunut kertaakaan, enkä ole bugeja huomannut, eli ihan oikeasti käytettävä kerneli tämä on, voin suositella käyttämään. Noissa muissa jakelupaketeissakin alkaa suurimmassa osassa olemaan jo tämä 2.6-sarjan kerneli (SuSE 9.1, Fedora 2:teen on kai tulossa?, Mandrake 10).

2.6-sarjan kerneli on minulla ollut käytössä muutaman kuukauden, tällä hetkellä gentoo-dev-sources 2.6.5-r1
Back to top
View user's profile Send private message
FutureGuru
n00b
n00b


Joined: 10 May 2004
Posts: 29
Location: Tampere, Finland

PostPosted: Wed May 12, 2004 8:28 pm    Post subject: Reply with quote

Laitoin 2.6.5-r1 kernelin ja tuntuisi pelaavan.

Paitsi.....

Taitaa olla jo uuden topicin paikka, mutta avaudun tähän silti.

Alsa, tuo pirullinen Alsa, ei vain ota toimiakseen. Herjaa, ettei äänikorttia olisi asennettu. Tietääkseni kukaan ei ole sitä läppärini sisältä poiskaan ottanut.

vi82xxx modulia pitäisi käytää, kernelin sisältämiä ajureita. Neuvoa?
_________________
Heh, that aint gonna take no more than 15 minutes. - Me 24 hours ago
Back to top
View user's profile Send private message
hanta
Tux's lil' helper
Tux's lil' helper


Joined: 28 Jun 2002
Posts: 115
Location: Vantaa - Finland

PostPosted: Wed May 12, 2004 10:32 pm    Post subject: Reply with quote

FutureGuru wrote:
Laitoin 2.6.5-r1 kernelin ja tuntuisi pelaavan.

seuraavaksi sitten nptl ;)

FutureGuru wrote:
Alsa, tuo pirullinen Alsa, ei vain ota toimiakseen. Herjaa, ettei äänikorttia olisi asennettu. Tietääkseni kukaan ei ole sitä läppärini sisältä poiskaan ottanut.

vi82xxx modulia pitäisi käytää, kernelin sisältämiä ajureita. Neuvoa?

minä sain aikoinani alsa lopulta pelaamaan kääntämällä OSS Mixer API:n OSS PCM API:n ja itse ajurin moduleiksi ja loput kamat sisään. tietty tuon lisäksi vanha alsa-drivers paketti pitää poistaa järjestelmästä ja alsa-tools, alsa-utils sekä alsa-lib voi olla syytä asentaa uusiksi.
_________________
Janne
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Finnish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum