Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Gnome 2.6 emerge ongelma
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Finnish
View previous topic :: View next topic  
Author Message
Juha_K
n00b
n00b


Joined: 29 Feb 2004
Posts: 18
Location: Finland

PostPosted: Mon May 03, 2004 10:33 am    Post subject: Gnome 2.6 emerge ongelma Reply with quote

Terve!
On tässä pieni ongelma gnome 2.6 asennuksen kanssa. Käytännössä kun heitin eka:
Code:

emerge gnome

Niin 2.4 gnome asentui. No nytpä tahtoisi päivittää 2.6 versioon, mutta kun heitän käskyt niin tulee seuraavaa valitusta :roll:

Code:

mylly juha # emerge gnome-2.6
Calculating dependencies
!!! Problem in gnome-base/gnome-2.6 dependencies.
!!! "Specific key requires an operator (gnome-base/gnome-2.6) (try adding an '=')"
root@mylly
mylly juha #


Kenelläkään tietoa mikä tuossa mättää ja kuinka korjata? :oops:
Back to top
View user's profile Send private message
Flammie
Developer
Developer


Joined: 02 Jun 2003
Posts: 633
Location: Dublin, Ireland

PostPosted: Mon May 03, 2004 11:23 am    Post subject: Re: Gnome 2.6 emerge ongelma Reply with quote

Juha_K wrote:
Terve!
On tässä pieni ongelma gnome 2.6 asennuksen kanssa. Käytännössä kun heitin eka:
Code:

emerge gnome

Niin 2.4 gnome asentui. No nytpä tahtoisi päivittää 2.6 versioon, mutta kun heitän käskyt niin tulee seuraavaa valitusta :roll:


Gnome 2.6 taitaa edelleen olla hardmaskattu, se pitää erikseen unmaskata että sen saa asennettua. Nopein tapa on etsiä gnome-2.6-osio tiedostosta /usr/portage/profile/package.mask ja dumpata se kokonaan tiedostoon /etc/portage/package.unmask.

Quote:
Code:

mylly juha # emerge gnome-2.6
Calculating dependencies
!!! Problem in gnome-base/gnome-2.6 dependencies.
!!! "Specific key requires an operator (gnome-base/gnome-2.6) (try adding an '=')"
root@mylly
mylly juha #


Ohjeviestissähän tuo kerrotaan vaikka se näyttääkin hieman kryptiseltä, version määrittelemiseksi pitää lisätä yhtäsuuruusmerkki paketin eteen. Joku vanha portage vielä hyväksyi sen ilmankin mutta sitten se korjattiin.
Code:

# emerge =gnome-base/gnome-2.6
Back to top
View user's profile Send private message
Juha_K
n00b
n00b


Joined: 29 Feb 2004
Posts: 18
Location: Finland

PostPosted: Mon May 03, 2004 12:08 pm    Post subject: Reply with quote

Ok, tässä yritin seurata ohjeitasi :)

Elikkä menin tutksiskelemaan /usr/portage/profile/package.mask tiedostoa ja kopion sieltä seuraavat rivit /etc/portage/package.unmask tiedostoon. /etc/portage hakemistoa ei ollut aikaisemmin, joten näppäränä poikana loin sen itse. Joka tapauksessa /etc/portage/package.unmask tiedoston sisältö on nyt seuraava:

Code:
# <foser@gentoo.org> (20 Apr 2004)
# gnome meta update tracker
=gnome-base/gnome-2.6_p1
=gnome-base/gnome-2.6.1_p1


# <foser@gentoo.org> (18 Mar 2004)
# The big gnome 2.6 mask
>=gnome-base/gnome-2.5
>=gnome-base/gconf-2.5
>=gnome-base/ORBit2-2.10
>=gnome-base/control-center-2.5
>=gnome-base/eel-2.5
>=gnome-base/nautilus-2.5
>=gnome-base/gnome-applets-2.5
>=gnome-base/gnome-desktop-2.5
>=gnome-base/libbonobo-2.5
>=gnome-base/libbonoboui-2.5
>=gnome-base/libglade-2.3
>=gnome-base/libgnome-2.5
>=gnome-base/libgnomecanvas-2.5
>=gnome-base/libgnomeui-2.5
>=gnome-base/libgnomeprint-2.5
>=gnome-base/libgnomeprintui-2.5
=gnome-extra/libgtkhtml-2.6*
=gnome-extra/libgtkhtml-2.5*
>=gnome-base/libgtop-2.5
>=gnome-base/librsvg-2.6
>=gnome-base/gnome-vfs-2.5
gnome-base/gnome-keyring
>=gnome-base/gnome-panel-2.5
>=gnome-base/gnome-session-2.5
>=gnome-extra/gconf-editor-2.5
>=gnome-extra/bug-buddy-2.5
>=gnome-extra/nautilus-cd-burner-0.6.5
>=gnome-extra/nautilus-media-0.7
>=gnome-extra/yelp-2.5
>=gnome-extra/zenity-2.5
>=gnome-extra/gnome-utils-2.5
>=gnome-extra/gnome2-user-docs-2.5
>=gnome-extra/gnome-games-2.5
>=gnome-extra/gnome-media-2.5
>=gnome-extra/gnome-system-monitor-2.5
>=gnome-extra/gucharmap-1.3
>=gnome-extra/gcalctool-4.3.50
>=media-gfx/eog-2.5
>=net-www/epiphany-1.2
net-analyzer/gnome-netstatus
=net-print/gnome-cups-manager-0.17-r03202004
>=app-arch/file-roller-2.5
>=app-editors/gedit-2.5
>=app-text/ggv-2.5
>=app-text/gpdf-0.125
>=x11-terms/gnome-terminal-2.5
>=x11-themes/gnome-themes-2.5
>=x11-themes/gnome-icon-theme-1.1
>=x11-libs/gtksourceview-0.9
>=x11-libs/libwnck-2.5
>=x11-wm/metacity-2.7
 gst
>=media-libs/gstreamer-0.8
>=media-libs/gst-plugins-0.8
>=media-plugins/gst-plugins-oss-0.8
>=media-plugins/gst-plugins-gnomevfs-0.8
>=media-plugins/gst-plugins-mad-0.8
>=media-plugins/gst-plugins-ogg-0.8
>=media-plugins/gst-plugins-vorbis-0.8
>=media-plugins/gst-plugins-esd-0.8
>=media-plugins/gst-plugins-alsa-0.8
>=media-plugins/gst-plugins-ffmpeg-0.8
>=media-plugins/gst-plugins-mpeg2dec-0.8
>=media-plugins/gst-plugins-flac-0.8
>=media-plugins/gst-plugins-libpng-0.8
>=media-plugins/gst-plugins-xvideo-0.8
>=media-plugins/gst-plugins-a52dec-0.8
>=media-plugins/gst-plugins-cdparanoia-0.8
>=media-plugins/gst-plugins-swfdec-0.8.0
 gnome-accessibility
>=gnome-base/gail-1.5
>=app-accessibility/gnopernicus-0.8.1
>=app-accessibility/gok-0.9.5
>=gnome-extra/at-spi-1.4
>=app-accessibility/gnome-mag-0.10.10
# these two were already in the tree before announcing them as gnome 2.6
# packages, so we'll let them be.
>=app-accessibility/gnome-speech-0.3.2
>=gnome-extra/libgail-gnome-1.0.3

# End of gnome 2.6 mask
#


Poistin siis nuitten rivien edessä olevat risuaijat, kun eikös ne ole kommentteja varten(?)

Sitten laittelin

Code:

mylly profiles # emerge =gnome-base/gnome-2.6
Calculating dependencies
!!! all ebuilds that could satisfy "=gnome-base/gnome-2.6" have been masked.
!!! possible candidates are:
- gnome-base/gnome-2.6 (masked by: ~keyword)
 
!!! Error calculating dependencies. Please correct.
root@mylly
mylly profiles #

Ja tuommosta erroria tulee. Ilmeisesti en ole oikein onnistunut tässä unmask hommelissa :?

Poistin myös viittaukset gnomeen siitä /usr/portage/profile/package.mask tiedostosta. Ei avittanut. Ymmärsinkö tuon unmask hommelin ihan päin puita? 8)
Back to top
View user's profile Send private message
Flammie
Developer
Developer


Joined: 02 Jun 2003
Posts: 633
Location: Dublin, Ireland

PostPosted: Mon May 03, 2004 12:34 pm    Post subject: Reply with quote

Juha_K wrote:

Code:

mylly profiles # emerge =gnome-base/gnome-2.6
Calculating dependencies
!!! all ebuilds that could satisfy "=gnome-base/gnome-2.6" have been masked.
!!! possible candidates are:
- gnome-base/gnome-2.6 (masked by: ~keyword)
 
!!! Error calculating dependencies. Please correct.
root@mylly
mylly profiles #


~keyword on ns. unstable osa gentoon jakelua, paketit jotka kuuluvat siihen vaativat ACCEPT_KEYWORDS="~arch", missä arch on arkkitehtuuri. make.conf:ssa on kommentoituna ohjeet alkua varten, mutta kannattaa lukea se handbookin toinen osa läpi ennen jatkamista kuitenkin, se selvittänee aika paljon portagen toiminnallisuutta.
Back to top
View user's profile Send private message
Juha_K
n00b
n00b


Joined: 29 Feb 2004
Posts: 18
Location: Finland

PostPosted: Mon May 03, 2004 12:57 pm    Post subject: Reply with quote

Jes, nyt rupesi asentumaan 8)
Kiitoksia avusta Flammie. Asennuskäsky oli
Code:
ACCEPT_KEYWORDS="~x86" emerge =gnome-base/gnome-2.6


Muutama paketti esti asennuken aloittamista, mutta ne lähti ihan kiltisti pois. Lisätietoja sain täältä:
http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?part=2&chap=2#doc_chap3

Palailen asiaan kääntämisen jälkeen, niin tietoa tulee muille että onnistuuko ihan näin vai tuleeko Gentoon uudestaan asennus eteen :D

Edit:
Ok, parin tunnin asentelun jälkeen Gnome 2.6 toimii jopa. Loistavaa :D


Last edited by Juha_K on Mon May 03, 2004 3:10 pm; edited 1 time in total
Back to top
View user's profile Send private message
Useful Idiot
Guru
Guru


Joined: 30 Aug 2002
Posts: 329
Location: Finland

PostPosted: Mon May 03, 2004 1:18 pm    Post subject: Reply with quote

Tolle 'ACCEPCT_KEYWORDS="~arch" emerge <paketti>' komennolle on nykyisin parempikin vaihtoehto, eli kannattaa pistää ne pakettikohtaiset keywordit /etc/portage/package.keywords tiedostoon. Ei tule sitten myöhemmissä päivityksissä ongelmia.
_________________
[size=9]We are all in the gutter, but some of us are looking at the stars.
Back to top
View user's profile Send private message
hanta
Tux's lil' helper
Tux's lil' helper


Joined: 28 Jun 2002
Posts: 115
Location: Vantaa - Finland

PostPosted: Mon May 03, 2004 4:35 pm    Post subject: Reply with quote

Flammie wrote:
~keyword on ns. unstable osa gentoon jakelua, paketit jotka kuuluvat siihen vaativat ACCEPT_KEYWORDS="~arch", missä arch on arkkitehtuuri.

voin toki olla väärässäkin, mutta minun mielestäni ~arch on pikemminkin testing kuin unstable.
_________________
Janne
Back to top
View user's profile Send private message
Flammie
Developer
Developer


Joined: 02 Jun 2003
Posts: 633
Location: Dublin, Ireland

PostPosted: Mon May 03, 2004 4:52 pm    Post subject: Reply with quote

hanta wrote:
voin toki olla väärässäkin, mutta minun mielestäni ~arch on pikemminkin testing kuin unstable.


Testing voisi olla osuvampi siinä että ne paketit useimmiten ovat testaamattomia. Ja hardmaskatut varmaan vertautuisivat experimentaliin.
Back to top
View user's profile Send private message
gentonix
n00b
n00b


Joined: 29 May 2003
Posts: 35

PostPosted: Wed May 05, 2004 6:39 am    Post subject: Reply with quote

Itsellänikin on hieman ongelmia Gnome 2.6:n asentamisen kanssa.
Code:

USE="-gif -doc" ACCEPT_KEYWORDS="~x86" emerge -pv =gnome-base/gnome-2.6 >packages

Antaa tulokseksi yli 120 dependencyä jotka halutaan myös asentaa, joukossa mm. sellaiset tunnetut gnome-komponentit kuin qt, arts, lynx jne...

Mistähän tämä mahtaisi johtua että näin paljon ylimääräistä tavaraa yrittää tunkea mukaan? Haluaisin ihan vaan minimaalisen Gnomen asennuksen.

USE-flageja on make.confissa aika vähän, eli
USE="X gnome truetype gtk2 -qt -kde alsa cdr jpeg png java"

Edit. tässä hieman otosta listasta:
Code:

[ebuild  N    ] gnome-base/eel-2.6.1   541 kB
[ebuild  N    ] sys-apps/eject-2.0.13   58 kB
[ebuild  N    ] net-misc/curl-7.11.1  -ipv6 -ldap +ssl  1,103 kB
[ebuild  N    ] kde-base/kde-env-3-r2   [empty/missing/bad digest]
[ebuild  N    ] media-libs/lcms-1.12  +jpeg +python -tiff +zlib  554 kB
[ebuild  N    ] media-libs/libmng-1.0.5   608 kB
[ebuild  N    ] x11-libs/qt-3.3.2  +cups -doc -firebird -gif -icc -ipv6 -mysql -
nas -odbc +opengl -postgres -sqlite -xinerama +zlib  14,096 kB
[ebuild  N    ] kde-base/arts-1.2.2  +alsa -artswrappersuid -esd +mad +oggvorbis
  948 kB
[ebuild  N    ] media-libs/libao-0.8.5  +alsa +arts -esd -mmap -nas  261 kB
...
[ebuild  N    ] x11-terms/gnome-terminal-2.6.1   1,952 kB
[ebuild  N    ] sys-apps/apmd-3.2.1_p4  +X +nls  92 kB
[ebuild  N    ] gnome-base/gnome-applets-2.6.0  -acpi +apm -doc -gstreamer -ipv6
...
Back to top
View user's profile Send private message
Useful Idiot
Guru
Guru


Joined: 30 Aug 2002
Posts: 329
Location: Finland

PostPosted: Wed May 05, 2004 6:49 am    Post subject: Reply with quote

Emergen --tree vivulla näkee, että mikä on riippuvainen mistäkin. Sen avulla voit sitten ruveta poistelemaan paketeilta USE lippuja tarpeen mukaan.
_________________
[size=9]We are all in the gutter, but some of us are looking at the stars.
Back to top
View user's profile Send private message
gentonix
n00b
n00b


Joined: 29 May 2003
Posts: 35

PostPosted: Wed May 05, 2004 12:39 pm    Post subject: Reply with quote

Kiitos kiitos. Näköjään -oggvorbis estää nuo kde:n osien asentamiset.
Back to top
View user's profile Send private message
hkroger
n00b
n00b


Joined: 09 Aug 2003
Posts: 28

PostPosted: Wed May 26, 2004 1:21 pm    Post subject: Reply with quote

gentonix wrote:
Haluaisin ihan vaan minimaalisen Gnomen asennuksen.


Siinä tapauksessa suosittelen, ettet asenna tuolla gnome-base/gnome:lla tuota ollenkaan, koska tuo gnome-base/gnome ei itseasiassa ole vain välttämättömät komponentit vaan se asentelee kaikkea turhaa sälää mukana. Sama kde:ssa. Helpompi, jos asennat emergellä gdm:n ja sitten vaikka nautiluksen. Luulis, että noiden asentaminen riippuvuuksineen asentaan gnome:n peruskamat ilman ylimääräisiä.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Finnish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum