Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
apm + autopoweroff
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
pr0gm4
n00b
n00b


Joined: 14 Jul 2002
Posts: 15

PostPosted: Sun Jul 14, 2002 4:05 pm    Post subject: apm + autopoweroff Reply with quote

hi,

ich habe hier ein nb und wuerde gerne wenn ich es runterfahre das es sich automatisch abschaltet.

ich habe im kernel apm aktiviert und apmd installiert,
diesen dann per rc-update add apmd default in die init scripte eingebaut.

aber es schaltet sich trozdem nicht ab.

muss ich da noch ihrgendwowas ihrgendwie konfigurieren ?

mfg
pr0gm4
Back to top
View user's profile Send private message
spyro
Tux's lil' helper
Tux's lil' helper


Joined: 30 Jun 2002
Posts: 88

PostPosted: Sun Jul 14, 2002 5:02 pm    Post subject: Reply with quote

mein rechner geht auch nicht aus.
der flusht nur die laufwerke und bleibt dann stehen.

.spyro
Back to top
View user's profile Send private message
MTZ
Tux's lil' helper
Tux's lil' helper


Joined: 13 Jul 2002
Posts: 86
Location: Germany - near FFM

PostPosted: Sun Jul 14, 2002 5:12 pm    Post subject: Reply with quote

Ebenfalls meiner, waere durchaus dran interesiert das es funzeln wuerde. Die Festplatten gehen alle schoen aus aber dann brummt der Rechner weiter.

----
PS: Soweit ich mich erinnern kann musste man bei aelteren SuSE Versionen auch noch irgendwas dazuschreiben. Aber was genau ... keine Ahnung mehr.

Greetz
MTZ
Back to top
View user's profile Send private message
pr0gm4
n00b
n00b


Joined: 14 Jul 2002
Posts: 15

PostPosted: Sun Jul 14, 2002 6:45 pm    Post subject: Reply with quote

Hmmm
das sind 18 notebooks fuer computer raeume ...

und wenn die schueler wegdappen (halt) sollten die ausgehen wenn die die in die verpackung stopfen ;)

mfg
pr0gm4
Back to top
View user's profile Send private message
juwe
n00b
n00b


Joined: 11 Jul 2002
Posts: 26

PostPosted: Sun Jul 14, 2002 7:41 pm    Post subject: Reply with quote

Der entsprechende Parameter, der dem Kernel übergeben werden muß lautet:
Code:

apm=real-mode-poweroff

Blöderweise funktioniert aber auch dies bei mir nicht.
Damals mit SuSE ging es aber so.
Back to top
View user's profile Send private message
Beforegod
Bodhisattva
Bodhisattva


Joined: 10 Apr 2002
Posts: 1493
Location: Frankfurt/Main

PostPosted: Sun Jul 14, 2002 7:45 pm    Post subject: Reply with quote

Ein "halt -p" als root sollte genügen um die Kiste auszuschalten..
man kann natürlich auch ein alias erstellen das ein halt , halt -p ausführt!
Back to top
View user's profile Send private message
zypher
Retired Dev
Retired Dev


Joined: 10 Jun 2002
Posts: 413
Location: Cologne, ger.

PostPosted: Sun Jul 14, 2002 7:56 pm    Post subject: Reply with quote

Bei mir half es, apm in der Kernel config aus zu lassen und ACPI einzuschalten.
Keine weiteren Options, nur ein Sternchen bei "ACPI Support"
_________________
linux user 65882
Back to top
View user's profile Send private message
spyro
Tux's lil' helper
Tux's lil' helper


Joined: 30 Jun 2002
Posts: 88

PostPosted: Sun Jul 14, 2002 8:02 pm    Post subject: Reply with quote

'apm=real-mode-poweroff' hab ich auch im kernel drin funzt bei mir auch nicht. ich werd mal acpi versuchen. und apm wieder rausnehmen.

.spyro
Back to top
View user's profile Send private message
viz
n00b
n00b


Joined: 08 Jul 2002
Posts: 42
Location: Germany

PostPosted: Fri Jul 19, 2002 2:40 pm    Post subject: Reply with quote

Hatte ebenfalls das Problem, dass mein Rechner nicht mehr ausging. Aber gestern nacht um 3 *g* konnte ich das Problem fuer mich loesen: Nachdem ich nochmal die Kernel-Config ueberarbeitet habe, habe ich festgestellt, dass der SMP Support unter der Rubrik "Processor Type and Features" aktiviert war. Wenn man sich dort die Hilfe durchliest, stellt man fest, dass die APM Optionen deaktiviert werden, wenn SMP Support aktiviert ist.
Um es kurz zu machen:

SMP Support: deaktivieren
APM Support: Modul oder direkt in den Kernel (ich nutze es als Modul)
unter APM -> "Make CPU idle calls when idle" : aktivieren (vielleicht gehts auch ohne diese Option ;) )


Dann sollte sich die Kiste ordnungsgemaess herunterfahren und ausschalten lassen. Ich werde es aber auch auf meinem Laptop testen.
Gruss,

- viz
Back to top
View user's profile Send private message
spyro
Tux's lil' helper
Tux's lil' helper


Joined: 30 Jun 2002
Posts: 88

PostPosted: Fri Jul 19, 2002 3:22 pm    Post subject: Reply with quote

hm ... das hab ich auch an. evtl. sollte ich meine kernel config auch nochma auf sachen durchsuchen die ich eh nicht hab. ich werd das mal testen.
thx für den hinweis.

.spyro
Back to top
View user's profile Send private message
Jazz_Rabbit
Tux's lil' helper
Tux's lil' helper


Joined: 16 Jul 2002
Posts: 129
Location: Vienna

PostPosted: Tue Jul 23, 2002 11:03 am    Post subject: Reply with quote

Weiß jemand was über den Hypernation mode (Ruhezustand) ??
Gibts das unter GNU/Linux?
_________________
.=->< Jazz_Rabbit ><-=.
Back to top
View user's profile Send private message
^-Codemasta-^
n00b
n00b


Joined: 17 Jul 2002
Posts: 31

PostPosted: Tue Jul 23, 2002 12:56 pm    Post subject: Reply with quote

Also das mit dem "Make cpu idle calls when idle" würd ich raus lassen!
Habe meinen PC die ganze nahct laufen lassen, als ich morgens aufwachte, stand da:
"Kernel panic: cought unrecognized idle call"
und es ging nix mehr, naja, reboot half :)

mfg codi
Back to top
View user's profile Send private message
tux-fan
Tux's lil' helper
Tux's lil' helper


Joined: 10 Apr 2002
Posts: 131
Location: Paderborn, Germany

PostPosted: Tue Jul 23, 2002 3:17 pm    Post subject: Reply with quote

Hab APM im Kernel abgeschaltet und dafür ACPI aktiviert.
Im ACPI Menü bis auf den letzen Menüpunkt (irgendwas mit debug ?) alles eingeschaltet.
Damit geht's bei mir.

Dual PII-400 auf Asus P2B-DS
Back to top
View user's profile Send private message
dc
n00b
n00b


Joined: 29 Jul 2002
Posts: 7
Location: Hildesheim (Germany)

PostPosted: Mon Jul 29, 2002 3:38 pm    Post subject: Reply with quote

Jazz_Rabbit wrote:
Weiß jemand was über den Hypernation mode (Ruhezustand) ??
Gibts das unter GNU/Linux?


Es gibt zwei Arten des Ruhezustandes: Hardware- und Software-Hibernation. Die Hardware-Variante hat mit dem OS nichts zu tun, es wird der RAM etc. (meist) in eine extra Partition geschrieben oder in eine Datei auf einem FAT-Dateisystem. Windows ME/ 2k/ XP unterstuetzt Software-Hibernation, wo sich das OS um den Ruhezustand kuemmert. Ersteres ist natuerlich die bessere Loesung, aber leider habe viele neuere Laptops dieses nicht mehr und verlassen sich auf das Betriebssystem.

Linux kann das seit kurzem auch, allerdings nicht ganz problemfrei. Falls Du es ausprobieren moechtest, findest Du weiter Informationen unter http://swsusp.sf.net/ . Bei mir funktioniert es recht gut, leider wacht mein Maustreiber unter X nicht richtig auf.

Viel Spass am Geraet!

Dennis
Back to top
View user's profile Send private message
asdinos
n00b
n00b


Joined: 03 Oct 2002
Posts: 23

PostPosted: Thu Oct 03, 2002 11:26 am    Post subject: Reply with quote

hey viz,

dein vorschlag hat auch fuer mein system bestens funktioniert. allerdings erhielt ich beim kernel kompilieren mit DEAKTIVIERTEM SMP eine fehlermeldung.

loesung: make mrproper

aber achtung, vorher die config file sichern!

ciao

asdinos
Back to top
View user's profile Send private message
bitcrawler
n00b
n00b


Joined: 25 Dec 2003
Posts: 37

PostPosted: Sat May 15, 2004 8:39 am    Post subject: Reply with quote

@asdinos:

Welche Fehlermeldung war das genau, wenn man fragen darf?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum