Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
(SOLVED) artwiz fonts and gnome2, kde3
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
aLEczapKA
Apprentice
Apprentice


Joined: 13 Jun 2003
Posts: 192

PostPosted: Fri Jul 25, 2003 4:34 am    Post subject: (SOLVED) artwiz fonts and gnome2, kde3 Reply with quote

I am big fan of artwiz fonts - in my opinion they rock! You desktop gets the style with them - and I really can't live without them. So I was very disapointed when somebody answered on my question: "how to make artwiz fonts working under gnome2 (or with gtk2 apps)?" he said: no way, you can't do it.

But as you can see they work! Not all of them - but for now: snap, glisp, glisp-bold, edges, snap and drift. There are still few to work on but this will be solved too (with your help I hope).

The trick is that the fonts must be seen by as truetype. When I emerged artwiz-fonts - and ran fc-cache -fv I got this:

Code:
fc-cache: "/usr/share/fonts/artwiz": caching, 0 fonts, 0 dirs


so 0 fonts = you can't select them under gnome font selector.
However I found today some old copy of mine with artwiz-fonts from the days when I was trying to make them work with different locales and just something light up in my head. So I added them to fontconfig and ran fc-cache again.

Code:
fc-cache: "/home/data/fonts/artwiz": caching, 5 fonts, 0 dirs


After manualy fixing the fonts.cache-1 file (cause they were seen as lucida) I got them working under gnome2.

I am not sure why artwiz-fonts provided by gentoo don't work. Is it because of fonts.alias or because of fonts themselfs. I can see they have different file size that the copy I own.

I hope somebody who knows much more about syntax of fonts.cache files, would make it better, and make other artwiz fonts working as well.

HTH

UPDATE
Okey, I have also anorexia font working - had to play with xmbdfed.
Hold now for now - I will have to fix all of the fonts, cause they are really messed up. Will post here new fonts when they are done.

UPDATE 17.08.2003
There was an error in fonts.alias file. Cure font was ommited. re-emrge or re-downlaod the fonts please.

UPDATE 18.08.2003
Fixed glisp-bold.


Last edited by aLEczapKA on Mon Aug 18, 2003 4:21 pm; edited 4 times in total
Back to top
View user's profile Send private message
aLEczapKA
Apprentice
Apprentice


Joined: 13 Jun 2003
Posts: 192

PostPosted: Sat Jul 26, 2003 1:44 am    Post subject: Reply with quote

Is it really only me who likes here artwiz fonts? 8O

geez.. I feel like freak :twisted:
Back to top
View user's profile Send private message
[smeagol]
Apprentice
Apprentice


Joined: 24 Oct 2002
Posts: 152

PostPosted: Sat Jul 26, 2003 2:05 am    Post subject: Reply with quote

I like them too.

:D

could you paste what you ahve for snap?

fc-cache didn't generate that for me :(
_________________
In God We Trust, All Others We monitor.
Back to top
View user's profile Send private message
rojaro
l33t
l33t


Joined: 06 May 2002
Posts: 732

PostPosted: Sat Jul 26, 2003 1:11 pm    Post subject: Reply with quote

aLEczapKA wrote:
geez.. I feel like freak :twisted:

hehe ... never knew a bigger freak than you :mrgreen:
_________________
A mathematician is a machine for turning coffee into theorems. ~ Alfred Renyi (*1921 - †1970)
Back to top
View user's profile Send private message
Voffinn
n00b
n00b


Joined: 29 Jun 2003
Posts: 73
Location: Kópavogur, Iceland.

PostPosted: Sat Jul 26, 2003 1:59 pm    Post subject: Reply with quote

woha, i like your desktop.

is that fluxbox and what file manager is that ?
Back to top
View user's profile Send private message
aLEczapKA
Apprentice
Apprentice


Joined: 13 Jun 2003
Posts: 192

PostPosted: Sat Jul 26, 2003 6:35 pm    Post subject: Reply with quote

Window Manager is Fluxbox (devel realease). File manager is nautilus with industrial theme.

About fonts: almost ready I have all of them working with gnome2/gtk2, kde. (and fluxbox ofkoz). Just few more tests and will post them here.
_________________
while true; do eject /dev/cdrom; eject -t /dev/cdrom; done
Back to top
View user's profile Send private message
aLEczapKA
Apprentice
Apprentice


Joined: 13 Jun 2003
Posts: 192

PostPosted: Sat Jul 26, 2003 6:37 pm    Post subject: Reply with quote

rojaro wrote:
hehe ... never knew a bigger freak than you :mrgreen:


and look who's talking! 8)
_________________
while true; do eject /dev/cdrom; eject -t /dev/cdrom; done
Back to top
View user's profile Send private message
aLEczapKA
Apprentice
Apprentice


Joined: 13 Jun 2003
Posts: 192

PostPosted: Sun Jul 27, 2003 1:39 am    Post subject: Reply with quote

Oki, after 2 days of hard work I finally fixed all of the fonts.
They work, they look cool and they rock! :wink:

You must download new fonts, install them and restart X.
You should unmerge artwiz-fonts package (fonts there are broken).

Read the instruction how to install.

Download new artwiz fonts here.


Have Fun!
_________________
while true; do eject /dev/cdrom; eject -t /dev/cdrom; done
Back to top
View user's profile Send private message
Kurtz
n00b
n00b


Joined: 18 Jun 2003
Posts: 58

PostPosted: Sun Jul 27, 2003 8:42 am    Post subject: Reply with quote

Thank you very much for this fine piece of work. I especially like artwiz' terminal fonts, and your patch finally solves my MC-line-drawing troubles.

Thanks!
Back to top
View user's profile Send private message
Ox-
Guru
Guru


Joined: 19 Jun 2003
Posts: 305

PostPosted: Sun Jul 27, 2003 9:52 am    Post subject: Reply with quote

aLEczapKA wrote:

You should unmerge artwiz-fonts package (fonts there are broken).


If I don't unmerge they should still work right? The gentoo fonts aren't indexed by fc-cache, and your new fonts are installed into a new directory. Am I wrong?
Back to top
View user's profile Send private message
aLEczapKA
Apprentice
Apprentice


Joined: 13 Jun 2003
Posts: 192

PostPosted: Sun Jul 27, 2003 2:17 pm    Post subject: Reply with quote

If you've changed your configuration like written in README you acctually don't use fonts from artwiz-fonts package anymore.

To check it, you might run xfontsel and select foundry: artwiz, family: edges - as I recall this font didn't show up at all when used from artwiz-fonts package.

And the reason I made the fixes was that the old fonts should not be used, this is the idea behind - to replace broken thing with fixed. :wink:
Besides new fonts support hinting so will work with eg. Fluxbox when you have antialiased turned on.
_________________
while true; do eject /dev/cdrom; eject -t /dev/cdrom; done
Back to top
View user's profile Send private message
|Spiller|
n00b
n00b


Joined: 15 May 2003
Posts: 20
Location: Macedonia, Europe

PostPosted: Mon Jul 28, 2003 3:48 pm    Post subject: Reply with quote

Hmm.. I can see the fonts in xfontsel but they are not available in gnome or kde. Any ideas?

EDIT - solved.. they do show up at the end (in gnome)
Back to top
View user's profile Send private message
aethyr
Veteran
Veteran


Joined: 06 Apr 2003
Posts: 1085
Location: NYC

PostPosted: Mon Jul 28, 2003 8:59 pm    Post subject: Reply with quote

Did you submit a bug report detailing the problem and the changes you took to fix it?

I'm sure many people would like to be able to use these fonts on a GTK2/QT3 system (without having to find this thread first).
Back to top
View user's profile Send private message
aLEczapKA
Apprentice
Apprentice


Joined: 13 Jun 2003
Posts: 192

PostPosted: Mon Jul 28, 2003 10:38 pm    Post subject: Reply with quote

Right, wanted to to do it but I saw that Alex already did it.

There should be a new build soon as written on bugs.gentoo.org

kewl!
_________________
while true; do eject /dev/cdrom; eject -t /dev/cdrom; done
Back to top
View user's profile Send private message
crimson
Guru
Guru


Joined: 27 Apr 2002
Posts: 430
Location: Cedar Rapids, IA

PostPosted: Mon Aug 04, 2003 5:55 pm    Post subject: Reply with quote

I downloaded your font package from fluxbox's site aleczapka, and it works in gtk1, but not gtk2. How do I fix this?
Back to top
View user's profile Send private message
aLEczapKA
Apprentice
Apprentice


Joined: 13 Jun 2003
Posts: 192

PostPosted: Mon Aug 04, 2003 9:41 pm    Post subject: Reply with quote

Did you properly configured fontconfig or xfs? (then run fc-cache, and restarted X)

If they showed up in gtk1 apps it means you probably added entry in your /etc/X11/XF86Config, right?

And what about KDE3? do you have it installed? Can you check?
_________________
while true; do eject /dev/cdrom; eject -t /dev/cdrom; done
Back to top
View user's profile Send private message
dob
Apprentice
Apprentice


Joined: 04 Oct 2002
Posts: 199
Location: S.L.P.

PostPosted: Mon Aug 04, 2003 11:40 pm    Post subject: Reply with quote

aLEczapKA wrote:
Is it really only me who likes here artwiz fonts? 8O

geez.. I feel like freak :twisted:


I like them too, but they're so small that it hurts my eyes trying to read them, and they're not iso-8859-15 (no extended characters like éà ê, and no €uro)

Still, I followed your method and was glad to get them working again in fluxbox wit antialiasing.

Aqui's the only one that I find readable though, on my 17" monitor @ 1152x864
Back to top
View user's profile Send private message
aLEczapKA
Apprentice
Apprentice


Joined: 13 Jun 2003
Posts: 192

PostPosted: Tue Aug 05, 2003 12:44 am    Post subject: Reply with quote

dob wrote:
Aqui's the only one that I find readable though, on my 17" monitor @ 1152x864


Try snap, I have 19'' monitor (running 1280x1024) and it looks good.
_________________
while true; do eject /dev/cdrom; eject -t /dev/cdrom; done
Back to top
View user's profile Send private message
d3c3it
l33t
l33t


Joined: 01 Mar 2003
Posts: 765
Location: Manchester, UK

PostPosted: Tue Aug 05, 2003 12:23 pm    Post subject: Reply with quote

aLEczapKA wrote:
Oki, after 2 days of hard work I finally fixed all of the fonts.
They work, they look cool and they rock! :wink:

You must download new fonts, install them and restart X.
You should unmerge artwiz-fonts package (fonts there are broken).

Read the instruction how to install.

Download new artwiz fonts here.

Have Fun!

whats that font program? im using switch2 which is kinda basic do i have to emerge gnome-base or something for that?

as for the fonts i tried what they said on fluxbox but it didnt work *least the fonts werent showing up in switch2* im going to try this ebuild later
_________________
Some people go to counselling,
others use linux
Back to top
View user's profile Send private message
aLEczapKA
Apprentice
Apprentice


Joined: 13 Jun 2003
Posts: 192

PostPosted: Tue Aug 05, 2003 4:48 pm    Post subject: Reply with quote

I used XmBDFEd - a bdf font editor.

You don't need anything for switch2 to work, if you can't see the fonts there you probably didn't configure your fontconfig / xfs.
_________________
while true; do eject /dev/cdrom; eject -t /dev/cdrom; done
Back to top
View user's profile Send private message
crimson
Guru
Guru


Joined: 27 Apr 2002
Posts: 430
Location: Cedar Rapids, IA

PostPosted: Tue Aug 05, 2003 4:58 pm    Post subject: Reply with quote

I have the same problem as d3c3it. I can't see the fonts in gtk2..(switch2). xfs and everything has been working fine so far.. I did the /etc/init.d/xfs restart, and I've restarted my computer. I ran fc-cache. What do I have to do to get it configured?
Back to top
View user's profile Send private message
Unne
l33t
l33t


Joined: 21 Jul 2003
Posts: 616

PostPosted: Tue Aug 05, 2003 10:09 pm    Post subject: Reply with quote

I've just about lost the last shreds of my sanity. I got the artwiz fonts to work no problem at all, I followed the new README directions, edited XF86Config and /etc/fonts/local.conf. My problem is that half of the fonts will NOT display the ~ character in QT or GTK2 apps. I can set GTK2 (using switch2) and KDE (using kcontrol) to use all the artwiz fonts, no problem. They all show up fine too, no problem. Except for the ~. That's the ONLY character that doesn't display, I tried just about every other character and they all show up fine; it just displays nothing instead of showing a ~. It doesn't even show a blank little ASCII box, it just doesn't display any character at all. If I hit backspace, it "deletes" the mystical invisible ~, but again, nothing shows on the screen.

All my other non-artwiz fonts work just fine and ~ happily displays wherever I type it. Even in a few artwiz fonts, it displays fine, for example smoothansi; the ~ works fine with that. And it's ONLY in QT and GTK2 apps. In a fluxbox window title, ~ shows up fine with the glisp font. In GTK1.2 apps ~ shows up fine with glisp. If I do an "aterm -fn glisp" it looks hideous but ~ shows up fine. The problem is only for about half the fonts. glisp is among the fonts that has this problem, and that's the one I want to use. But it's kind of hard to use it, when Firebird compiled against GTK2 won't show a ~ in URLs, for example. kcharselect shows a blank box where the ~ should be, for example. Not a weird ASCII box like it shows for all the other extended characters, it just shows pure blank nothingness.

I even spent an hour or two learning how to convert .pcf files to .bdf format using fstobdf, and I opened up glisp.bdf in xmbdfed and sure enough, the ~ character is right there. I converted glisp.bdf back into a .pcf file myself and reloaded it with fc-cache -fv and sure enough, no ~ in Konqueror or Gaim or any other QT or GTK2 apps. I tried messing around with locales, setting LC_TYPE and LC_ALL, I tried loading xfs, I tried messing with Xft config files, I tried "nodeadkeys" in my XF86Config file, etc. Still no ~. Does anyone else have this problem? Is it possible we could get a .ttf format of the fonts, maybe? I don't know if that'd help.
Back to top
View user's profile Send private message
aLEczapKA
Apprentice
Apprentice


Joined: 13 Jun 2003
Posts: 192

PostPosted: Sun Aug 10, 2003 12:51 am    Post subject: Reply with quote

crimson wrote:
I have the same problem as d3c3it. I can't see the fonts in gtk2..(switch2). xfs and everything has been working fine so far.. I did the /etc/init.d/xfs restart, and I've restarted my computer. I ran fc-cache. What do I have to do to get it configured?


can you see the fonts with fc-list?
_________________
while true; do eject /dev/cdrom; eject -t /dev/cdrom; done
Back to top
View user's profile Send private message
aLEczapKA
Apprentice
Apprentice


Joined: 13 Jun 2003
Posts: 192

PostPosted: Sun Aug 10, 2003 12:52 am    Post subject: Reply with quote

Unne wrote:
I've just about lost the last shreds of my sanity. I got the artwiz fonts to work no problem at all, I followed the new README directions, edited XF86Config and /etc/fonts/local.conf. My problem is that half of the fonts will NOT display the ~ character in QT or GTK2 apps. I can set GTK2 (using switch2) and KDE (using kcontrol) to use all the artwiz fonts, no problem. They all show up fine too, no problem. Except for the ~. That's the ONLY character that doesn't display, I tried just about every other character and they all show up fine; it just displays nothing instead of showing a ~. It doesn't even show a blank little ASCII box, it just doesn't display any character at all. If I hit backspace, it "deletes" the mystical invisible ~, but again, nothing shows on the screen.

All my other non-artwiz fonts work just fine and ~ happily displays wherever I type it. Even in a few artwiz fonts, it displays fine, for example smoothansi; the ~ works fine with that. And it's ONLY in QT and GTK2 apps. In a fluxbox window title, ~ shows up fine with the glisp font. In GTK1.2 apps ~ shows up fine with glisp. If I do an "aterm -fn glisp" it looks hideous but ~ shows up fine. The problem is only for about half the fonts. glisp is among the fonts that has this problem, and that's the one I want to use. But it's kind of hard to use it, when Firebird compiled against GTK2 won't show a ~ in URLs, for example. kcharselect shows a blank box where the ~ should be, for example. Not a weird ASCII box like it shows for all the other extended characters, it just shows pure blank nothingness.

I even spent an hour or two learning how to convert .pcf files to .bdf format using fstobdf, and I opened up glisp.bdf in xmbdfed and sure enough, the ~ character is right there. I converted glisp.bdf back into a .pcf file myself and reloaded it with fc-cache -fv and sure enough, no ~ in Konqueror or Gaim or any other QT or GTK2 apps. I tried messing around with locales, setting LC_TYPE and LC_ALL, I tried loading xfs, I tried messing with Xft config files, I tried "nodeadkeys" in my XF86Config file, etc. Still no ~. Does anyone else have this problem? Is it possible we could get a .ttf format of the fonts, maybe? I don't know if that'd help.


you're right, didn't notice that before - I try to fix it.
_________________
while true; do eject /dev/cdrom; eject -t /dev/cdrom; done
Back to top
View user's profile Send private message
aLEczapKA
Apprentice
Apprentice


Joined: 13 Jun 2003
Posts: 192

PostPosted: Sun Aug 10, 2003 12:58 am    Post subject: Reply with quote

Quote:
Is it possible we could get a .ttf format of the fonts, maybe? I don't know if that'd help.


I've spend like 3 days trying to search on the web how to convert pcf/bdf fonts into TTF - this was the first thing which came to my mind, when I wanted artwiz fonts working in gtk2/kde3 apps. However didn't find anything - answers for that question was usually: impossible or do your own ttf fonts. As far as I am aware there is no converter between pcf/bdf<->ttf.
_________________
while true; do eject /dev/cdrom; eject -t /dev/cdrom; done
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum