Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
radeon 9000 w/ ati driver problem plus how-to configure ATI
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
jcmc2000
n00b
n00b


Joined: 19 Apr 2002
Posts: 25
Location: Reston, Virginia

PostPosted: Sun Jul 20, 2003 9:03 pm    Post subject: radeon 9000 w/ ati driver problem plus how-to configure ATI Reply with quote

I truely hate to post another radeon topic but I don't see this issue anywhere on the forum.

using:
ati radeon 9000 video card
xfree 4.3.0-r2
ati-drivers 2.9.13
2.4.20-gentoo-r5 (w/static agpguart support, no dri in the kernel, no kernel ati drivers)
opengl-update ati

glxinfo:
Code:
name of display: :0.0
display: :0  screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context
client glx vendor string: SGI
client glx version string: 1.2
client glx extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
    GLX_ARB_get_proc_address, GLX_ATI_pixel_format_float,
    GLX_ATI_render_texture
GLX extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: Radeon 9000/Mobility Fire GL 8800 Prototype DDR Pentium III (SSE)
OpenGL version string: 1.3 (X4.3.0-2.9.13)
OpenGL extensions:
    GL_ARB_multitexture, GL_EXT_texture_env_add, GL_EXT_compiled_vertex_array,
    GL_S3_s3tc, GL_ARB_point_parameters, GL_ARB_texture_border_clamp,
    GL_ARB_texture_compression, GL_ARB_texture_cube_map,
    GL_ARB_texture_env_add, GL_ARB_texture_env_combine,
    GL_ARB_texture_env_crossbar, GL_ARB_texture_env_dot3,
    GL_ARB_texture_mirrored_repeat, GL_ARB_transpose_matrix,
    GL_ARB_vertex_blend, GL_ARB_vertex_program, GL_ARB_window_pos,
    GL_ATI_element_array, GL_ATI_envmap_bumpmap, GL_ATI_fragment_shader,
    GL_ATI_map_object_buffer, GL_ATI_texture_env_combine3,
    GL_ATI_texture_mirror_once, GL_ATI_vertex_array_object,
    GL_ATI_vertex_attrib_array_object, GL_ATI_vertex_streams,
    GL_ATIX_texture_env_combine3, GL_ATIX_texture_env_route,
    GL_ATIX_vertex_shader_output_point_size, GL_EXT_abgr, GL_EXT_bgra,
    GL_EXT_blend_color, GL_EXT_blend_func_separate, GL_EXT_blend_minmax,
    GL_EXT_blend_subtract, GL_EXT_clip_volume_hint,
    GL_EXT_draw_range_elements, GL_EXT_fog_coord, GL_EXT_multi_draw_arrays,
    GL_EXT_packed_pixels, GL_EXT_point_parameters, GL_EXT_rescale_normal,
    GL_EXT_polygon_offset, GL_EXT_secondary_color,
    GL_EXT_separate_specular_color, GL_EXT_stencil_wrap,
    GL_EXT_texgen_reflection, GL_EXT_texture3D,
    GL_EXT_texture_compression_s3tc, GL_EXT_texture_cube_map,
    GL_EXT_texture_edge_clamp, GL_EXT_texture_env_combine,
    GL_EXT_texture_env_dot3, GL_EXT_texture_filter_anisotropic,
    GL_EXT_texture_lod_bias, GL_EXT_texture_object, GL_EXT_texture_rectangle,
    GL_EXT_vertex_array, GL_EXT_vertex_shader, GL_HP_occlusion_test,
    GL_NV_texgen_reflection, GL_NV_blend_square, GL_NV_occlusion_query,
    GL_SGI_color_matrix, GL_SGI_texture_edge_clamp,
    GL_SGIS_texture_border_clamp, GL_SGIS_texture_lod,
    GL_SGIS_generate_mipmap, GL_SGIS_multitexture, GL_SUN_multi_draw_arrays
glu version: 1.3
glu extensions:
    GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess

   visual  x  bf lv rg d st colorbuffer ax dp st accumbuffer  ms  cav
 id dep cl sp sz l  ci b ro  r  g  b  a bf th cl  r  g  b  a ns b eat
----------------------------------------------------------------------
0x23 24 tc  0 24  0 r  y  .  8  8  8  8  0 24  8 16 16 16 16  0 0 Slow
0x24 24 tc  0 24  0 r  .  .  8  8  8  8  0 24  8 16 16 16 16  0 0 Slow
0x25 24 tc  0 24  0 r  y  .  8  8  8  8  0 24  0 16 16 16 16  0 0 Slow
0x26 24 tc  0 24  0 r  .  .  8  8  8  8  0 24  0 16 16 16 16  0 0 Slow
0x27 24 tc  0 24  0 r  y  .  8  8  8  8  0 24  8  0  0  0  0  0 0 None
0x28 24 tc  0 24  0 r  .  .  8  8  8  8  0 24  8  0  0  0  0  0 0 None
0x29 24 tc  0 24  0 r  y  .  8  8  8  8  0 24  0  0  0  0  0  0 0 None
0x2a 24 tc  0 24  0 r  .  .  8  8  8  8  0 24  0  0  0  0  0  0 0 None
0x2b 24 dc  0 24  0 r  y  .  8  8  8  8  0 24  8 16 16 16 16  0 0 Slow
0x2c 24 dc  0 24  0 r  .  .  8  8  8  8  0 24  8 16 16 16 16  0 0 Slow
0x2d 24 dc  0 24  0 r  y  .  8  8  8  8  0 24  0 16 16 16 16  0 0 Slow
0x2e 24 dc  0 24  0 r  .  .  8  8  8  8  0 24  0 16 16 16 16  0 0 Slow
0x2f 24 dc  0 24  0 r  y  .  8  8  8  8  0 24  8  0  0  0  0  0 0 None
0x30 24 dc  0 24  0 r  .  .  8  8  8  8  0 24  8  0  0  0  0  0 0 None
0x31 24 dc  0 24  0 r  y  .  8  8  8  8  0 24  0  0  0  0  0  0 0 None
0x32 24 dc  0 24  0 r  .  .  8  8  8  8  0 24  0  0  0  0  0  0 0 None


glxgears:

Code:
8311 frames in 5.0 seconds = 1662.200 FPS
9561 frames in 5.0 seconds = 1912.200 FPS
9570 frames in 5.0 seconds = 1914.000 FPS
9587 frames in 5.0 seconds = 1917.400 FPS
9580 frames in 5.0 seconds = 1916.000 FPS
9309 frames in 5.0 seconds = 1861.800 FPS


Not bad, not great!

so whats the problem??? Well when ever I move the mouse while holding the left mouse button down, or randomly for no reason at all, or while glxgears is running I get static on the screen. Similiar to snow you get on a tv that is turned on but as no signal with cable.

It also occurs when I type to fast, or move a program window around to fast.

So am I the only one with this problem?

any suggestions on how to get rid of this?

I guess I can try the xfree-drm/dri route, but I hate to try it since I was able to get this up and running with very little effort after reading the many posts on the forum about getting these cards to work.

thanks! :cry:


Last edited by jcmc2000 on Mon Jul 21, 2003 9:04 am; edited 1 time in total
Back to top
View user's profile Send private message
jcmc2000
n00b
n00b


Joined: 19 Apr 2002
Posts: 25
Location: Reston, Virginia

PostPosted: Mon Jul 21, 2003 4:01 am    Post subject: update on radeon 9000 trouble Reply with quote

Well I have been at this for many many many hours.....still no luck.:x

Here is what I have done so far:
    I changed the xf86config: changed agp driver from internal to external, and then back again.

    I have tried different window manager: currently using kde 3.1.2, problem still occurs.

    recompiled the kernel so that /dev/agpgart is a module instead of static.....this didnt work.

    I re-emerged the ati-drivers....no luck


I am now compiling a kernel that doesn't have frame buffer support in it....thinking that this may be part of the problem. I will post when I have info on the results of this idea.

I will include the ati part of my xf86config just in-case someone finds a mistake that I have overlooked.

Code:
# === ATI device section ===

Section "Device"
    Identifier                          "ATI Graphics Adapter"
    Driver                              "fglrx"
# === disable PnP Monitor  ===
    #Option                              "NoDDC"
# === disable/enable XAA/DRI ===
    Option "no_accel"                   "no"
    Option "no_dri"                     "no"
# === FireGL DDX driver module specific settings ===
# === Screen Management ===
    Option "DesktopSetup"               "0x00000000"
    Option "MonitorLayout"              "AUTO, AUTO"
    Option "IgnoreEDID"                 "off"
    Option "HSync2"                     "unspecified"
    Option "VRefresh2"                  "unspecified"
    Option "ScreenOverlap"              "0"
    Option "GammaCorrectionI"           "0x06419064"
    Option "GammaCorrectionII"          "0x00000000"
# === OpenGL specific profiles/settings ===
    Option "Capabilities"               "0x00000000"
# === Video Overlay for the Xv extension ===
    Option "VideoOverlay"               "on"
# === OpenGL Overlay ===
# Note: When OpenGL Overlay is enabled, Video Overlay
#       will be disabled automatically
    Option "OpenGLOverlay"              "off"
# === Misc Options ===
    Option "UseFastTLS"                 "0"
    Option "BlockSignalsOnLock"         "on"
    Option "UseInternalAGPGART"         "yes"
    Option "ForceGenericCPU"            "no"
    BusID "PCI:1:0:0"    # vendor=1002, device=496e
    Screen 0
EndSection
Back to top
View user's profile Send private message
jcmc2000
n00b
n00b


Joined: 19 Apr 2002
Posts: 25
Location: Reston, Virginia

PostPosted: Mon Jul 21, 2003 5:03 am    Post subject: just thought I would add how I got the driver working Reply with quote

Just posting how I got the driver to work (well sort of work in my case):)

I am on a dell dimension 4100, pIII 800mhz, 512MB ram, SB Live!, ATI Radeon 9000, and other useless stuff in it.

kernel config: (parts that matter, I guess)
gentoo-2.4.20-r5
Code:

->processor type and features
   -> mtrr support (static)
->character devices
   -> /dev/agpgart support (module)
   -> intel i810/i815/i830m support (static)
   ->[b]direct rendering manager[/b]
      (unchecked everything that was checked by default and then unchecked drm)


move the new kernel to /boot ( back up old one first!)
boot the new kernel

I emerged xfree 4.3.0-r2
I did NOT emerge xfree-drm, I read that this conflicts with the ATI drivers
I emerged ati-drivers 2.9.13
I emerged opengl-update
Code:
/usr/sbin/opengl-update ati (as root)


Then do
Code:
/opt/ati/bin/fglrxconfig (as root)


Follow the prompts and answer the questions as they pertain to your environment.
Code:

for me it was:
1: PS/2 or USB with PS/2 protocol
2 :PS/2 Wheel Mouse (X11 generic ps/2 wheel mouse driver) I later changed this to auto)
3: y
4: /dev/mouse (did this because I have devfsd.conf setup to create this symbolic link)
5: Dell 101-key PC
6: U.S. English
7: Single Head
enter
8: default (changed it by hand after)
9: default (changed it by hand after)
10: change modes
11: selected 1600x1200 (which is what I use)
12: option 2
13: n
14: limited to group 'video' - only group members can access the OpenGL ICD
15: default
16: y (might be part of my problem as well, I will test this later)
17: default (FireGL workstation boards: fast)
18: n (use inline)


I then added my user account to the video group.

The things I changed in my XF86Config-4 file are:
Code:

# change protocol to "Auto" cause I am lazy
# added "ZAxisMapping" "4 5" cause I like my little mouse wheel

Section "InputDevice"
    Identifier   "Mouse1"
    Driver "mouse"
    Option "Protocol"   "Auto"
    Option "Device"     "/dev/mouse"
    Option "ZAxisMapping" "4 5"
EndSection


# Set the HorizSync to 30.0 - 130.0 (this is what my monitor supports)
# Set the VertRefresh 48.0 - 170.0 (this is what my monitor supports)

#MAKE SURE you set these according to what your monitor supports, if you leave them
#blank X will pick the best mode for you....suggested

Section "Monitor"
    Identifier  "Monitor0"
    HorizSync 30.0 - 130.0
    VertRefresh 48.0 - 170.0
    Option "DPMS"
EndSection


# (changed this because fglrxcofig set it to "PCI:1:0:1) which is the secondary device!!!!

Section "Device"
    Identifier                          "ATI Graphics Adapter"
    Driver                              "fglrx"
   <snip>
    BusID "PCI:1:0:0"    # vendor=1002, device=496e
EndSection

 


# the BusID "PCI:1:0:0" line may be different use this to find what it is in your system:

As root:
Code:

bash# /usr/X11R6/bin/scanpci 

(my output)

pci bus 0x0001 cardnum 0x00 function 0x00: vendor 0x1002 device 0x4966
 ATI Technologies Inc Radeon R250 If [Radeon 9000]

pci bus 0x0001 cardnum 0x00 function 0x01: vendor 0x1002 device 0x496e
 ATI Technologies Inc Radeon R250 [Radeon 9000] (Secondary)



so from this create the line as follows:
Code:

BusID "PCI:<pci bus>:<cardnum>:<function>"    #vendor=<vendor>,device=<device>

remove the 0x from the outputfirst, for me this generates this line:


BusID "PCI:1:0:0"    # vendor=1002, device=4966


I also changed this section in XF86Config-4 (so X starts up in the mode I like):
Code:

# changed Modes to "1600x1200@85 which is supported by my monitor this keeps X from
# guessing the mode to run in, just in case it picks one I don't like
# Also made sure depth was set to 24 (ati cards don't do 32)

Section "Screen"
    Identifier  "Screen0"
    Device      "ATI Graphics Adapter"
    Monitor     "Monitor0"
    DefaultDepth 24
    #Option "backingstore"

    Subsection "Display"
        Depth       24
        Modes       "1600x1200@85"
        ViewPort    0 0  # initial origin if mode is smaller than desktop
    EndSubsection
EndSection


The XF86Config-4 file should be placed in /etc/X11/

Now set your preference xdm|kdm|gdm as well as xsession preference in /etc/rc.conf

Code:

rc-update add xdm default


reload and hopefully everything works!!!

I hope this helps someone that is going crazy trying to get the ATI Radeons working!!! :)
Back to top
View user's profile Send private message
jcmc2000
n00b
n00b


Joined: 19 Apr 2002
Posts: 25
Location: Reston, Virginia

PostPosted: Mon Jul 21, 2003 6:49 am    Post subject: another update Reply with quote

Still working on this problem....it is now making me insane!!! :evil:

I have recompiled the kernel to get rid of the framebuffer support, this didn't fix anything.
I have changed all the fglrx options in xf86config one at a time, still not working.
tried disabling silken mouse but for some reason I can't get it to disable, so I will assume this won't fix it either.

So my next thought is to recompile the ATI drivers with a very conservative CFLAG setting.

more to come
Back to top
View user's profile Send private message
jcmc2000
n00b
n00b


Joined: 19 Apr 2002
Posts: 25
Location: Reston, Virginia

PostPosted: Mon Jul 21, 2003 7:02 am    Post subject: Reply with quote

My last post shows how tired I am....I actually thought changing CFLAGS would make a difference on a binary driver. :oops:

So I am moving on to other things to see if I can make this work correctly. I will try a few more things and then I will have no choice but to go with xfree-drm, and xfree radeon drivers and hope for the best there.
Back to top
View user's profile Send private message
jcmc2000
n00b
n00b


Joined: 19 Apr 2002
Posts: 25
Location: Reston, Virginia

PostPosted: Mon Jul 21, 2003 7:36 am    Post subject: Reply with quote

More information on this problem:

I disabled accelation to see what I got, that removed all of the static on the screen. The problem there is when using the scroll whell on the mouse it scrolled as fast a snail. Not going to work for me.

So I re-enabled it, and then disabled DRI. That has severely decreased the static but it still shows up a bit here and there. At least the mouse scrolls fast, my guess is as long as acceleration is on silken mouse is loaded.

this is much better but now I have no 3d support, so I will have to keep trying.
Back to top
View user's profile Send private message
jcmc2000
n00b
n00b


Joined: 19 Apr 2002
Posts: 25
Location: Reston, Virginia

PostPosted: Mon Jul 21, 2003 9:02 am    Post subject: Reply with quote

Everything I tried just wasn't producing the results I wanted, so I went ahead and switched to the xfree-drm and xfree radeon driver setup.

Steps
Code:

The kernel is still compiled the same as in my first post to this topic


Fist emerge unmerge ati-drivers
emerge xfree-drm 4.3.0-r6
opengl-update xfree


Then I changed the XF86Config-4 so that it uses radeon driver

Code:

# commented out the old fglrx stuff first

Section "Device"
   Identifier   "card0"
   Driver      "radeon"
   VendorName   "ATI TEchnologies Inc"
   BoardName   "Radeon 9000"
   BusID      "PCI:1:0:0"
   Option      "AGPMode"   "4"
   Option      "AGPFastWrite"   "True"
   Option      "EnablePageFlip"   "true"
EndSection

Section "Screen"
    Identifier  "Screen0"
    #Device      "ATI Graphics Adapter"
    Device   "card0"
    Monitor     "Monitor0"
    DefaultDepth 24
    #Option "backingstore"

    Subsection "Display"
        Depth       24
        Modes       "1600x1200"
        ViewPort    0 0  # initial origin if mode is smaller than desktop
    EndSubsection
EndSection


added agpgart to /etc/modules.autoload

reload to get rid of everything the ati-drivers had running, and to give me a clean boot into this new environment.

Card came up without any problems, I have not noticed the distortion I was getting before except when I run glxgears. I can live with that and the small occasional distortion I see here and there.

At least I can move the mouse without the screen going crazy and I still have 3d support (although the opengl support is much less than with the ati-driver).

Here is the output from glxinfo:
Code:

name of display: :0.0
display: :0  screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context
client glx vendor string: SGI
client glx version string: 1.2
client glx extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
     GLX_NV_vertex_array_range, GLX_MESA_agp_offset
GLX extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context
OpenGL vendor string: Tungsten Graphics, Inc.
OpenGL renderer string: Mesa DRI R200 20020827 AGP 4x x86/MMX/SSE TCL
OpenGL version string: 1.2 Mesa 4.0.4
OpenGL extensions:
    GL_ARB_imaging, GL_ARB_multitexture, GL_ARB_texture_env_add,
    GL_ARB_texture_env_combine, GL_ARB_texture_env_dot3,
    GL_ARB_transpose_matrix, GL_EXT_abgr, GL_EXT_bgra, GL_EXT_blend_color,
    GL_EXT_blend_logic_op, GL_EXT_blend_minmax, GL_EXT_blend_subtract,
    GL_EXT_clip_volume_hint, GL_EXT_convolution, GL_EXT_compiled_vertex_array,
    GL_EXT_histogram, GL_EXT_packed_pixels, GL_EXT_polygon_offset,
    GL_EXT_rescale_normal, GL_EXT_secondary_color, GL_EXT_stencil_wrap,
    GL_EXT_texture3D, GL_EXT_texture_env_add, GL_EXT_texture_env_combine,
    GL_EXT_texture_env_dot3, GL_EXT_texture_filter_anisotropic,
    GL_EXT_texture_object, GL_EXT_texture_lod_bias, GL_EXT_vertex_array,
    GL_IBM_rasterpos_clip, GL_MESA_pack_invert, GL_MESA_ycbcr_texture,
    GL_MESA_window_pos, GL_NV_texgen_reflection, GL_NV_texture_rectangle,
    GL_SGI_color_matrix, GL_SGI_color_table
glu version: 1.3
glu extensions:
    GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess

   visual  x  bf lv rg d st colorbuffer ax dp st accumbuffer  ms  cav
 id dep cl sp sz l  ci b ro  r  g  b  a bf th cl  r  g  b  a ns b eat
----------------------------------------------------------------------
0x23 24 tc  0 24  0 r  .  .  8  8  8  8  0 24  0  0  0  0  0  0 0 None
0x24 24 tc  0 24  0 r  .  .  8  8  8  8  0 24  8  0  0  0  0  0 0 None
0x25 24 tc  0 24  0 r  .  .  8  8  8  8  0 24  0 16 16 16 16  0 0 Slow
0x26 24 tc  0 24  0 r  .  .  8  8  8  8  0 24  8 16 16 16 16  0 0 Slow
0x27 24 tc  0 24  0 r  y  .  8  8  8  8  0 24  0  0  0  0  0  0 0 None
0x28 24 tc  0 24  0 r  y  .  8  8  8  8  0 24  8  0  0  0  0  0 0 None
0x29 24 tc  0 24  0 r  y  .  8  8  8  8  0 24  0 16 16 16 16  0 0 Slow
0x2a 24 tc  0 24  0 r  y  .  8  8  8  8  0 24  8 16 16 16 16  0 0 Slow
0x2b 24 dc  0 24  0 r  .  .  8  8  8  8  0 24  0  0  0  0  0  0 0 None
0x2c 24 dc  0 24  0 r  .  .  8  8  8  8  0 24  8  0  0  0  0  0 0 None
0x2d 24 dc  0 24  0 r  .  .  8  8  8  8  0 24  0 16 16 16 16  0 0 Slow
0x2e 24 dc  0 24  0 r  .  .  8  8  8  8  0 24  8 16 16 16 16  0 0 Slow
0x2f 24 dc  0 24  0 r  y  .  8  8  8  8  0 24  0  0  0  0  0  0 0 None
0x30 24 dc  0 24  0 r  y  .  8  8  8  8  0 24  8  0  0  0  0  0 0 None
0x31 24 dc  0 24  0 r  y  .  8  8  8  8  0 24  0 16 16 16 16  0 0 Slow
0x32 24 dc  0 24  0 r  y  .  8  8  8  8  0 24  8 16 16 16 16  0 0 Slow


here is output from glxgears, which is getting the same frame rate as I got with the ATI-Drivers
Code:

8546 frames in 5.0 seconds = 1709.200 FPS
9647 frames in 5.0 seconds = 1929.400 FPS
9651 frames in 5.0 seconds = 1930.200 FPS
9640 frames in 5.0 seconds = 1928.000 FPS
9438 frames in 5.0 seconds = 1887.600 FPS
6584 frames in 5.0 seconds = 1316.800 FPS


So I have less opengl support but have a less aggravating desktop.

Hope all this posting does someone some good!:)
Back to top
View user's profile Send private message
blong
n00b
n00b


Joined: 25 Jun 2003
Posts: 9
Location: Ebensburg, PA

PostPosted: Wed Jul 30, 2003 4:15 pm    Post subject: ati-drivers Reply with quote

Maybe this has to do with your problem:

I've had problems with ati-drivers-2.9.13 and instead use ati-drivers-2.9.8. 2.9.13 locks my computer up (completely) when I play Neverwinter Nights (always 10 sec into the game). 2.9.8 doesn't have that problem. It does, however, want to hide my mouse behind the OpenGL screen layer for long periods of time (which is annoying when attacking moving targets). xfree-drm is just too slow for NWN (2 FPS). 2.9.8 gives me 40 FPS.
Back to top
View user's profile Send private message
jcmc2000
n00b
n00b


Joined: 19 Apr 2002
Posts: 25
Location: Reston, Virginia

PostPosted: Thu Jul 31, 2003 1:00 pm    Post subject: Reply with quote

I will try downgrading the ati-driver this weekend and see what I get. If it works out I will post to the thread.

Thanks for the suggestion.
Back to top
View user's profile Send private message
jcmc2000
n00b
n00b


Joined: 19 Apr 2002
Posts: 25
Location: Reston, Virginia

PostPosted: Thu Aug 28, 2003 7:47 am    Post subject: Reply with quote

still haven't had a chance to downgrade the ati driver. Life is like that......tried quake 3 and I get 40fps in the game which is pretty bad compared to the happy 125fps I get with the mobility 7500 in my laptop. I will continue to work with this and post results to this thread.
Back to top
View user's profile Send private message
Xrillo
n00b
n00b


Joined: 17 Jun 2004
Posts: 3

PostPosted: Thu Jun 17, 2004 3:49 pm    Post subject: Reply with quote

Hi, I had the exact same problem ( I believe ) a few months ago, nothing I tried worked. So I got used to it and thought no more of it...until the day came when I by accident deleted the contents of /user/lib... and was kind of forced to do a reinstall.

When I was at it I also bought a new HDD ( this is the good part! ) this made me disconnect all cables and stuff. When I later installed everything I noticed how the snow was gone, not a trace of the annoying stuff. That was 2-3 months ago, and today I rebooted for the first time..( had to cut the power... ). I noticed that the tv-out cable wasn't connected to the tv, so I plugged it in and thought it would be nice to watch some stuff on the tv. When I later started the computer IT happened..the snow was back! So naturally I concluded that the tv-out was doing something weird to the card. I unplugged the cable and rebooted. Voila! no snow!

Maybe someone knows why this happens...

Hopefully this may help some other poor bastard. :)
Back to top
View user's profile Send private message
jcmc2000
n00b
n00b


Joined: 19 Apr 2002
Posts: 25
Location: Reston, Virginia

PostPosted: Thu Jun 17, 2004 4:59 pm    Post subject: Reply with quote

Strange, I don't use the TV out. I did a new install last night, I haven't been using Gentoo lately because I am to busy to work on this problem. After the clean install I am still having the snow problem when running anything that is hardware accelerated.

I am getting 1300 - 1500 fps with this card using glxgears, I would think it could do better than that but I am not sure. So if someone could give some stats to compare with I would appreciate it. :D

Obviously the installation steps have changed since I posted all of this. If I find a solution to the snow problem that works for my situation I will post it here.

Thanks for the feedback :D
Back to top
View user's profile Send private message
Xrillo
n00b
n00b


Joined: 17 Jun 2004
Posts: 3

PostPosted: Thu Jun 17, 2004 5:08 pm    Post subject: Reply with quote

I'm getting approx. 1150 fps.

But I rarely use such applications..so I'm ok with that. :)
Back to top
View user's profile Send private message
prompt
n00b
n00b


Joined: 24 Apr 2004
Posts: 4

PostPosted: Tue Oct 12, 2004 6:25 pm    Post subject: ATI Radeon 9000 (RV250) Reply with quote

I have a ATI Radeon 9000 (rv250) and it has got TV out. I have tried to get it to work but it wont. If i run:

Code:

/usr/X11R6/bin/scanpci


It list only 1 pci bus:

Code:

pci bus 0x0001 cardnum 0x00 function 0x00: vendor 0x1002 device 0x4966
 ATI Technologies Inc Radeon RV250 If [Radeon 9000]


It is now i wonder. If i dont have 2 pci bus' on the card how can i tell X how to use my TV?

Btw: Everyting else like 3D accel. and so on is working fine.

Any help will be greatly apreciated.
Thanks in advance!
- Prompt
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum