Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
need advice for Ati Radeon 8500 Xfree86 setup
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
lk42pro
Tux's lil' helper
Tux's lil' helper


Joined: 21 Apr 2002
Posts: 114
Location: New Jersey, USA

PostPosted: Sun Apr 21, 2002 4:37 pm    Post subject: need advice for Ati Radeon 8500 Xfree86 setup Reply with quote

Hi, I have a ATi radeon 8500 card and my XFree86 sometime freezes when i exit it out by using ctrl-alt-backspace. Anyone else that has this card can give me some pointers as to whats the most stable way of setting it up in Xfree86?anything i should add/remove in the linux kernel? thanks alot...
Back to top
View user's profile Send private message
Guest






PostPosted: Mon Apr 22, 2002 9:16 am    Post subject: Reply with quote

I don't have an ati card, infact I don't know anyone who does.. but did you compile dri support for the ati cards in your kernel ?
Back to top
lude
Retired Dev
Retired Dev


Joined: 18 Apr 2002
Posts: 113
Location: New York, NY

PostPosted: Mon Apr 22, 2002 10:22 am    Post subject: Re: need advice for Ati Radeon 8500 Xfree86 setup Reply with quote

lk42pro wrote:
Hi, I have a ATi radeon 8500 card and my XFree86 sometime freezes when i exit it out by using ctrl-alt-backspace. Anyone else that has this card can give me some pointers as to whats the most stable way of setting it up in Xfree86?anything i should add/remove in the linux kernel? thanks alot...


Have you got all the DRI stuff loaded or no? Is Agpgart turned on in the kernel?
Back to top
View user's profile Send private message
lk42pro
Tux's lil' helper
Tux's lil' helper


Joined: 21 Apr 2002
Posts: 114
Location: New Jersey, USA

PostPosted: Mon Apr 22, 2002 2:39 pm    Post subject: Re: need advice for Ati Radeon 8500 Xfree86 setup Reply with quote

lude wrote:
lk42pro wrote:
Hi, I have a ATi radeon 8500 card and my XFree86 sometime freezes when i exit it out by using ctrl-alt-backspace. Anyone else that has this card can give me some pointers as to whats the most stable way of setting it up in Xfree86?anything i should add/remove in the linux kernel? thanks alot...


Have you got all the DRI stuff loaded or no? Is Agpgart turned on in the kernel?

I have DRI=ATI RADEON and AGPGART turned eneabled in the kernel..the xfree86 part i will take a look later on today after i finish my midterm :o
Back to top
View user's profile Send private message
Fragadelic
n00b
n00b


Joined: 18 Apr 2002
Posts: 26

PostPosted: Mon Apr 22, 2002 5:06 pm    Post subject: Reply with quote

I have an ATI AIW Radeon 7500 and I'm having some issues with it as well.

I also have an Athlon so it doesn't help things as I'm getting bit with the Athlon AGP bug.

I installed Gentoo with the BIG iso and started at stage 3.

The standard optimizations are fine. What I did do was to go to http://dri.sourceforge.net and downloaded and installed the dri package from there.

You have to compile the kernel with radeon as a module so that it can be replaced with the one that comes with the dri package from sourceforge.

If I leave mine on 686 settings as well as the kernel, then dri works but it crashes when I run Quake3 - locks the PC hard.

If I throttle down to 486 so the memory usage is non pentium, dri doesn't work.

If you have an Intel CPU, then you should be fine. If you have an Athlon then you have to watch out for the Bug. It seems to show up more on Gentoo as Gentoo is very optimized for the 686 platform. Mandrake 8.2 worked fine with it with the 'mem=nopentium' setting so I'm still looking into it for now.

You won't need the mesa or glut packages as the libraries are included in the dri package.

BTW - only the 4.2.0 version and up of XFree86 supports the 8500 and AIW 7500 Radeons although not fully.

If you really have a problem and don't run 3D stuff like games or whatever then you can get away with setting it up with the framebuffer option compiled in the kernel and have XFree86 also use the framebuffer.
Back to top
View user's profile Send private message
Fragadelic
n00b
n00b


Joined: 18 Apr 2002
Posts: 26

PostPosted: Mon Apr 22, 2002 7:09 pm    Post subject: Reply with quote

You also may have to use

driver "radeon"

instead of

driver "ati"

where you find instances of it in the config file but this isn't always so.
Back to top
View user's profile Send private message
fmalabre
Guru
Guru


Joined: 19 Jun 2002
Posts: 376
Location: Chicago

PostPosted: Tue Jun 25, 2002 9:10 pm    Post subject: Reply with quote

DRI is not supported for the Radeon 8500 yet.
Should be for Q4 this year according to few posts.
Back to top
View user's profile Send private message
Malakin
Veteran
Veteran


Joined: 14 Apr 2002
Posts: 1692
Location: Victoria BC Canada

PostPosted: Wed Jun 26, 2002 6:13 am    Post subject: Reply with quote

Quote:
I also have an Athlon so it doesn't help things as I'm getting bit with the Athlon AGP bug.

Isn't there a workaround for this in newer kernels yet? And this is only older Athlons from what I understand.
Back to top
View user's profile Send private message
fmalabre
Guru
Guru


Joined: 19 Jun 2002
Posts: 376
Location: Chicago

PostPosted: Wed Jun 26, 2002 12:28 pm    Post subject: Reply with quote

The DRI support in the kernel is for Radeon 7500.
Back to top
View user's profile Send private message
Forge
Tux's lil' helper
Tux's lil' helper


Joined: 20 Jun 2002
Posts: 125
Location: KOP, PA, USA

PostPosted: Wed Jul 03, 2002 6:02 pm    Post subject: Reply with quote

Malakin - The 4K page bug/AGP bug only occurs in Spitfire Durons and below, and Tbird Athlons and below.

Duron 950 or lower, Athlon 1.4 and lower = AGP/4K page bug
Duron 1GHz or higher, Athlon XP/MP/4 = no bug


Now, the mem=nopentium hack CAN make systems with the newer CPUs more stable, but this is NOT because it's fixing the 4K page bug (the bug affected isn't IN the CPUs mentioned!), but because the kernel uses an older and slower memory access method, which is less likely to trigger other problems, especially hardware instability.
Back to top
View user's profile Send private message
GentooNewbie
n00b
n00b


Joined: 15 Jun 2002
Posts: 18

PostPosted: Wed Jul 03, 2002 8:14 pm    Post subject: FireGL Reply with quote

Radeon 8500 should not be using the Radeon kernel driver, or the Radeon driver for XFree. Use the FireGL kernel driver and XFree Driver. But this only applies to those cards BUILT by ATI and not cards POWERED by ATI.
Back to top
View user's profile Send private message
GentooNewbie
n00b
n00b


Joined: 15 Jun 2002
Posts: 18

PostPosted: Wed Jul 03, 2002 8:19 pm    Post subject: oops Reply with quote

Here is the FireGL Driver
Back to top
View user's profile Send private message
STiAT
Tux's lil' helper
Tux's lil' helper


Joined: 06 May 2002
Posts: 117
Location: Vienna, Austria

PostPosted: Thu Jul 04, 2002 1:28 am    Post subject: Reply with quote

Radeon 7200 worked fine.

Just enabled radeon support in kernel and selected driver radeon in the xfree config. everything fine...

now i am using an very old 4 MB matrox card *LOL*...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum