Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
New version of portage. Upgrade before further installation?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
meulie
l33t
l33t


Joined: 17 Jun 2003
Posts: 845
Location: a Dutchman living in Norway

PostPosted: Tue Jun 17, 2003 12:13 pm    Post subject: New version of portage. Upgrade before further installation? Reply with quote

Hi!

After doing the 'emerge sync' I get that there is a new version of portage available and that I should upgrade ASAP. Should I do this (how?) before continuing with the installation of Gentoo, or later?


Greetz,
Evert Meulie
Back to top
View user's profile Send private message
patan
n00b
n00b


Joined: 19 Feb 2003
Posts: 66

PostPosted: Tue Jun 17, 2003 12:29 pm    Post subject: Re: New version of portage. Upgrade before further installat Reply with quote

meulie wrote:
Hi!

After doing the 'emerge sync' I get that there is a new version of portage available and that I should upgrade ASAP. Should I do this (how?) before continuing with the installation of Gentoo, or later?


Greetz,
Evert Meulie


Portage will be upgraded if you type.
Code:

emerge portage

It won't affect the installation, but go along and upgrade it.
Back to top
View user's profile Send private message
meulie
l33t
l33t


Joined: 17 Jun 2003
Posts: 845
Location: a Dutchman living in Norway

PostPosted: Tue Jun 17, 2003 1:10 pm    Post subject: Reply with quote

Quote:
emerge portage


breaks at: ncurses-5.3-r1

configure: error: C++ preprocessor "/lib/cpp" fails sanity check
Back to top
View user's profile Send private message
H8
n00b
n00b


Joined: 17 Jun 2003
Posts: 7

PostPosted: Tue Jun 17, 2003 5:52 pm    Post subject: hmm Reply with quote

well Im just a noob but...

http://www.gentoo.org/doc/en/portage-user.xml

I did this and it worked for me.....

Updating Portage

Before using our Portage tree, it's important that you update Portage by doing the following:

Code listing 1.3: Updating Portage

This will show you what packages are going to be updated
# emerge -up system
This will update the necessary packages
# emerge -u system

Now you'll be using the most recent version of portage
Back to top
View user's profile Send private message
ThreeFarthingStone
n00b
n00b


Joined: 25 Feb 2003
Posts: 40
Location: USA

PostPosted: Tue Jun 17, 2003 6:31 pm    Post subject: Re: hmm Reply with quote

H8 wrote:
This will show you what packages are going to be updated
# emerge -up system
This will update the necessary packages
# emerge -u system

Bad idea if you are using stage 1. Don't emerge system until you've run bootstrap.sh, you'll install software not optimized for your computer. You can upgrade portage by
Code:

emerge --nodeps portage
I remember doing this in my installation.
_________________
There are two types of people: those who are in the world, and those who aren't.
Back to top
View user's profile Send private message
Stalione
Guru
Guru


Joined: 21 Apr 2002
Posts: 335

PostPosted: Tue Jun 17, 2003 8:56 pm    Post subject: Reply with quote

during install whenever i got the message regarding upgrade to portage being available I just ignored it and continued to build my system. Once I was done building my system then I upgraded the portage and had no issues at all. In the beginning I recall trying to upgrade it while in the install and it always bombed out on me.
Back to top
View user's profile Send private message
Edweirdo
Guru
Guru


Joined: 28 Jan 2003
Posts: 348
Location: Boston, Mass, USA

PostPosted: Thu Jun 19, 2003 1:09 am    Post subject: Reply with quote

If you are doing a stage1 install, doing the bootstrap causes the latest portage to be installed first anyway.
_________________
Life is too short and too important to { take seriously | use Windows }.
Back to top
View user's profile Send private message
meulie
l33t
l33t


Joined: 17 Jun 2003
Posts: 845
Location: a Dutchman living in Norway

PostPosted: Thu Jun 19, 2003 7:35 am    Post subject: Reply with quote

Good! :)

I'm still in the process of doing the stage123-thingie... Takes ages... :(

But since I'm doing it with VMWare, I can still (kinda) use the machine for other stuff... 8)
Back to top
View user's profile Send private message
CaptainPinko
n00b
n00b


Joined: 03 Jul 2003
Posts: 10

PostPosted: Thu Jul 03, 2003 5:52 pm    Post subject: Used Stage1 and still get the ncuress insanity! Reply with quote

Edweirdo wrote:
If you are doing a stage1 install, doing the bootstrap causes the latest portage to be installed first anyway.


i did a stage1 install and bootstraped but i still get configure: error: C++ preprocessor "/lib/cpp" fails sanity checkat "ncurses-5.3-r1". which prevents me from completeing "emerge system". Should i therefore do "emerge --nodeps portage"?


Anxiously, CaptainPinko
_________________
"There are two infinte things: the universe and human stupidity... and the universe I'm not sure about." -- Albert Einstein
Back to top
View user's profile Send private message
nerrollus
n00b
n00b


Joined: 03 Jul 2003
Posts: 2

PostPosted: Thu Jul 03, 2003 8:41 pm    Post subject: Re: Used Stage1 and still get the ncuress insanity! Reply with quote

CaptainPinko wrote:
Edweirdo wrote:
If you are doing a stage1 install, doing the bootstrap causes the latest portage to be installed first anyway.


i did a stage1 install and bootstraped but i still get configure: error: C++ preprocessor "/lib/cpp" fails sanity checkat "ncurses-5.3-r1". which prevents me from completeing "emerge system". Should i therefore do "emerge --nodeps portage"?


Anxiously, CaptainPinko


If I try doing an emerge portage I get that same failure, and if I try to just do a bootstrap it errors out right away because it can't find the ebuild portage-2.0.25.

I'm gonna try that emerge --nodeps portage to see what that does for me.. I hope it works, I'm dying to try gentoo out. heh
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum