Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Xft/freetype problems
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Discount_God
n00b
n00b


Joined: 03 Jun 2002
Posts: 4
Location: Jacksonville, FL

PostPosted: Thu Jun 20, 2002 6:06 pm    Post subject: Xft/freetype problems Reply with quote

This all got started because I wanted Anti-aliased fonts in Mozilla 1.0, when I heard that Mozilla 1.0 had Xft support, I immediately grabbed it off the ports tree, only to find no anti-aliased fonts. I tried compiling it by hand with the --enable-xft option to configure, but it came out with an error. I temporarily gave up, and when I came back to it a week or so later, it did the same thing (surprise surprise). I even tried actually reading the ebuild script. I discovered that it did indeed compile with Xft support if you had the necessary USE variables enabled, which I did. So, in my last-ditch effort, I re-emerged mozilla. to my surprise, it seemed to want to rebuild XFree86 too; I figured it had to resolve some dependencies to get Xft working right, so I let it proceed. Big Mistake. When it finished emergeing both Mozilla and XFree86 (but nothing else). I discovered that not only did Mozilla not work with anti-aliased fonts, but things that had been using them (KDE, fvwm2, etc.) no longer did. This was nothing like what I wanted. I went through all the relevant config files by hand to see if anything was screwed up. I tried re-installing all my True-Type fonts, I even went as far as rebuilding XFree86 (again). Is there something I haven't tried? I''m really at a loss here.
Back to top
View user's profile Send private message
delta407
Bodhisattva
Bodhisattva


Joined: 23 Apr 2002
Posts: 2876
Location: Chicago, IL

PostPosted: Thu Jun 20, 2002 6:12 pm    Post subject: Reply with quote

Read the thread entitled XFree anti-aliased font tips.
Back to top
View user's profile Send private message
Discount_God
n00b
n00b


Joined: 03 Jun 2002
Posts: 4
Location: Jacksonville, FL

PostPosted: Thu Jun 20, 2002 6:23 pm    Post subject: Re: Reply with quote

Don't you think I did that before I posted here?
Well, I tried everything it said. and to no avail.
Back to top
View user's profile Send private message
kerframil
l33t
l33t


Joined: 19 Apr 2002
Posts: 710
Location: London, UK

PostPosted: Mon Jun 24, 2002 6:11 pm    Post subject: Sounds tricky ... Reply with quote

Quote:
Don't you think I did that before I posted here?

Well, he didn't know that for sure ...

Quote:
I discovered that not only did Mozilla not work with anti-aliased fonts, but things that had been using them (KDE, fvwm2, etc.) no longer did

This is most unfortunate. I have not had this problem myself, but I believe some others have encountered a situation where after re-emerging something the anti-aliasing seems to switch off - and they were talking about KDE. Alas, I cannot recall the threads right now, but have a look/search in the back pages of the Desktop Environments forum and see if you can dig it up. Also, check the Gentoo buglist. Maybe rebuilding X necessitates rebuilding of certain other things which link to Xlib etc? Then again, maybe not - it's just a thought.
Furthermore, I wonder what version of X you were running before you tried to emerge Mozilla? Let me assume you were trying to emerge Mozilla 1.0 (final release), if you look at the ebuild for it you will see:
Code:
RDEPEND=">=x11-base/xfree-4.2.0-r11

If you were running an older version of X than the one listed, then that's why it got rebuilt. All of the stuff I wrote in my anti-aliased font guide was tested on my xfree-4.2.0-r11 install so there shouldn't be a problem with that version of X.
Quote:
Is there something I haven't tried? I''m really at a loss here.

Well, I must admit that this is all very strange. :?
It sounds like you've looked at most of the obvious factors here. Have you tried this:

1) Check that the X Render Extension is running with xdpyinfo | grep RENDER or by using the nice system information which can be found in the KDE Control Center
2) The paths for the fonts are definitely specified in /etc/X11/XftConfig using the dir statement, and are in accordance with your Path statements in XF86Config? Also, you are not trying to anti-alias font collections in paths which do not contain Type1/Truetype fonts (i.e. you haven't inserted a dir statement for such a path)?
3) After executing find / -name "XftConfig", there are no other XftConfig files that may be interfering or overriding the necessary statements?
4) For KDE, try running qtconfig and fiddling with the font options there - there are two pertinent options related directly to Xft and anti-aliasing. More sophisticated than the plain old anti-alias tickbox in the KDE Control Center, and KDE uses Qt anyway (if anyone knows what the KDE tickbox actually really changes, please tell me!!)
5) Are all your fonts absolutely valid? Completely unconfirmed, but I've heard that fonts with errors (such things do exist apparently) can make funny things happen. I recall Mandrake having a lengthy validity check for its TrueType font importing tool to protect against this. Simplify your X configuration as much as possible. Do your XF86Config and XftConfig files look like the defaults?
6) You don't have a sourced config file for Xft in your home folder which may be overriding the master XftConfig? (unlikely as you probably would be aware of it, but you never know)

Ah, that's a point. Try this:

1) Re-emerge qt (yes, I know this is a pain in the backside)
2) Temporarily change your .xinitrc to use a minimal window manager (such as fluxbox) then startx.
2) Check the options in qtconfig
3) Try running a native Qt app to see if it's working (*not* a KDE one)
4) If it does seem to work then re-emerge kdelibs

Emerge freetype first - irrelevant because X has its own version bundled, but just a couple of programs you emerge one day might link against it so you might as well ...

Mozilla has options that can be set which directly relates to font rendering (you can set them in prefs.js). Again, I cannot recall where the post is but there is a very informative one somewhere.

I intend to have Mozilla emerged by tomorrow (I have been putting it off). At that point I will dig out the posts to which I have referred, and will be investigating the issues I have been hearing about further. Anything I may find out will be added to my guide.

I hope something useful can be derived from the above ... ;-)
Back to top
View user's profile Send private message
swaun
n00b
n00b


Joined: 17 Jun 2002
Posts: 23

PostPosted: Mon Jun 24, 2002 8:05 pm    Post subject: I fixed my problem... Reply with quote

I was having the same problem... I turns out that I was using Helvetica (my old font of choice). Helvetica is NOT a TrueType or Type1 font and therefore, is not antialiased. Simply changing my screen font to Arial fixed the problem. Make sure that there is no substituting going on in qtconfig. Somehow I had gotten an Arial->Helvetica substitution that had to be deleted.

Thanks kerframil for the qtconfig tip...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum