Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Fonts - xft - fontconfig
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Herodot
Guru
Guru


Joined: 29 Jul 2002
Posts: 429
Location: Professor Xavier's school for gifted youngsters

PostPosted: Tue Apr 15, 2003 4:02 pm    Post subject: Fonts - xft - fontconfig Reply with quote

Hi,

I had very nice antialiased fonts. Then I upgraded fontconfig from 2.1 to 2.1-r1 and xft from 2.0.1-r1 to 2.0.1-r2, and everything turned ugly. I tried going back to the earlier versions, and my old /etc/fonts/fonts.conf (which I had backed up), but that didn't help.

Helvetica is no longer antialiased. The konsole fonts is small and ugly. Letters everywhere are poorly spaced.

I tried putting
Code:
<match target="font">
     <edit name="antialias" mode="assign">
         <bool>true</bool>
     </edit>
 </match>
in /etc/fonts/local.conf, but that changed nothing.

What should be restarted after changing the font config files?

I'm getting a little bit annoyed with all this font trouble. I seems that there are many different programs controlling fonts, and they are being updated at different times by different people, and we should consider ourselves lucky if we have nice fonts from time to time.</rant>
_________________
Excelsior!
Back to top
View user's profile Send private message
()
l33t
l33t


Joined: 25 Nov 2002
Posts: 610

PostPosted: Tue Apr 15, 2003 4:11 pm    Post subject: Reply with quote

Im also having problems with fonts in Konsole for instance turning small and ugly, in other progs as well. In GVim I can barely read what I'm writing, and in some cases text in Opera 7 is reduced to blurriness. So it turns out I'm not the only one experiencing this? : )
Phoenix 0.5 (Phoenix-bin) complains about FreeType not being able to open TT fonts,
perhaps this is related to our problem? It outputs something like this:
font /usr/X11R6/lib/X11/fonts/truetype/encodings.dir FreeType failed to open, error=0
font /usr/X11R6/lib/X11/fonts/truetype/fonts.cache-1 FreeType failed to open, error=0
font /usr/X11R6/lib/X11/fonts/truetype/fonts.dir FreeType failed to open, error=0
font /usr/X11R6/lib/X11/fonts/truetype/fonts.scale FreeType failed to open, error=0

Myself I have am using XFree 4.30-r2, FreeType 2.1.3-r2 at the moment, as well as the latest Xft and Fontconfig. And like you, I've tried emerging older versions of about the font controlling packages.
Back to top
View user's profile Send private message
Herodot
Guru
Guru


Joined: 29 Jul 2002
Posts: 429
Location: Professor Xavier's school for gifted youngsters

PostPosted: Tue Apr 15, 2003 4:24 pm    Post subject: Reply with quote

Hi,

I saw your message after posting my own. I looks like some of the newest updates have bugs / radically new behaviour. Let's hope this gets solved!

I'd like to suggest a new Gentoo merchandise: A developer doll. Something life size I can punch and strangle when my system borks.
_________________
Excelsior!
Back to top
View user's profile Send private message
()
l33t
l33t


Joined: 25 Nov 2002
Posts: 610

PostPosted: Tue Apr 15, 2003 4:49 pm    Post subject: Reply with quote

But am I right in assuming that you're also struggling with small fonts, basically (not just plain font ugliness)? For instance, in Fluxbox AA used to enlarge text, now it gets smaller.
At least there doesn't seem to be any problems with GTK+ 1.x apps (doesn't use Xft I guess), so I can use XEmacs for text, for now. This must be the weirdest bug I've encountered so far, I wish I knew of a way to properly test the font system (FreeType etc.) for correctness.
Back to top
View user's profile Send private message
Herodot
Guru
Guru


Joined: 29 Jul 2002
Posts: 429
Location: Professor Xavier's school for gifted youngsters

PostPosted: Tue Apr 15, 2003 5:15 pm    Post subject: Reply with quote

No, my problems are not with small fonts only.

I run KDE, but Pan (a gtk program) shows changed fonts as well.
_________________
Excelsior!
Back to top
View user's profile Send private message
()
l33t
l33t


Joined: 25 Nov 2002
Posts: 610

PostPosted: Tue Apr 15, 2003 5:58 pm    Post subject: Reply with quote

Yes, the problems occurs with GTK+ also, but only with 2.x I think. The 1.x series doesn't use Xft.
Back to top
View user's profile Send private message
Attis SH
n00b
n00b


Joined: 23 Feb 2003
Posts: 62
Location: Budapest, Hungary

PostPosted: Tue Apr 15, 2003 9:01 pm    Post subject: Re: Fonts - xft - fontconfig Reply with quote

Herodot wrote:
I had very nice antialiased fonts. Then I upgraded fontconfig from 2.1 to 2.1-r1 and xft from 2.0.1-r1 to 2.0.1-r2, and everything turned ugly. I tried going back to the earlier versions, and my old /etc/fonts/fonts.conf (which I had backed up), but that didn't help.

I had this problem, and I figured out that the bytecode interpreter was disabled in freetype. The problem was that the fonts were antialiased, but they looked bad.

I have rebuilt freetype with BCI enabled and my fonts are nice again. Someone thought the auto-hinter will do nicely in place of the bytecode interpreter, but it performs rather poorly with high quality TrueType fonts.

Quote:
Helvetica is no longer antialiased. The konsole fonts is small and ugly. Letters everywhere are poorly spaced.

Hmm... helvetica isn't antialiased on my system either. I thought it is a bitmap font? Maybe you have a different problem.
Back to top
View user's profile Send private message
Herodot
Guru
Guru


Joined: 29 Jul 2002
Posts: 429
Location: Professor Xavier's school for gifted youngsters

PostPosted: Tue Apr 15, 2003 9:25 pm    Post subject: Reply with quote

Quote:
Maybe you have a different problem.

Probably, since I haven't updated freetype.
_________________
Excelsior!
Back to top
View user's profile Send private message
Herodot
Guru
Guru


Joined: 29 Jul 2002
Posts: 429
Location: Professor Xavier's school for gifted youngsters

PostPosted: Tue Apr 15, 2003 11:08 pm    Post subject: Reply with quote

I've tried just about everything now, and two problems remain: Helvetica wont antialias and the konsole font is messed up. I've emerged and reemerged just about everything, with all combinations of hinters. I've followed the threads on the forums.

Helvetica: Some say this simply cannot antialias. But I've always used it, and it has always been antialiased. Furthermore, KDE uses is as the default font, so I really think it should antialias.

Konsole: Selecting fonts in the konsole is surpricingly convoluted. The enigmatic setting "Linux" uses some unnamed font, which is the one I want. But it's too big. I can either get the font I want with the wrong size, or the wrong font with the correct size. There is no way to beat this system...

So now I'm simply running with Helvetica without antialias, which is bearable for a while. The konsole isn't. Any help will be greatly appreciated!
_________________
Excelsior!
Back to top
View user's profile Send private message
()
l33t
l33t


Joined: 25 Nov 2002
Posts: 610

PostPosted: Tue Apr 15, 2003 11:35 pm    Post subject: Reply with quote

Dont know what to say really, playing around with the KDE font configuration panel doesn't help? Btw, in my fonts.conf Helvetica seems to be aliased to Verdana which is an M$ TT font. Perhaps it doesn't get aliased (no pun intended : ) like it should?
Back to top
View user's profile Send private message
Herodot
Guru
Guru


Joined: 29 Jul 2002
Posts: 429
Location: Professor Xavier's school for gifted youngsters

PostPosted: Wed Apr 16, 2003 12:42 am    Post subject: Reply with quote

You'll never guess what happened... it suddenly started working. I don't know exactly what I did or in what order. It wasn't KDE or QT, that's fer sure.

Helvetica is now antialiased, eventhough there's no Truetype or Type1 Helvetica on the system. It's probably using Verdana or maybe Arial. Actually everything is looking pretty darn nice, much better than ever before. Even the konsole is back to it's good ole font! I'm using Freetype 1.2.4 with autohint. Beautiful!

But another big problem has now entered the scene: All fonts now look the same. In font selectors i all programs, all fonts (mostly ttf from Windows) look like Helvetica/Arial/Verdana. No Times! I'm really at a loss as to where to look for the culprit.

I've said it before and I'll say it again: fonts are a pain. We really need an exhaustive guide for Gentoo. And preferably good, cooperative ebuilds.
_________________
Excelsior!
Back to top
View user's profile Send private message
Herodot
Guru
Guru


Joined: 29 Jul 2002
Posts: 429
Location: Professor Xavier's school for gifted youngsters

PostPosted: Wed Apr 16, 2003 1:20 am    Post subject: Reply with quote

Answering my own questions again. A simple fc-cache solved the problem mentioned. I now have the best looking fonts I have ever seen. All the pieces have fallen into place. KDE is a joy to behold. A quite complex html/css page I have made for Internet Explorer is now rendering perfectly in Konqueror - pixel-perfect. Pan (using gtk or gtk2) is also beautiful, as is Mozilla (using gtk).

I'm so happy I think I'll go to bed!
_________________
Excelsior!
Back to top
View user's profile Send private message
()
l33t
l33t


Joined: 25 Nov 2002
Posts: 610

PostPosted: Wed Apr 16, 2003 8:09 am    Post subject: Reply with quote

So it did come down to fc-cache? : ) In my case I'm thinking it was alignment of the planets or something, I mean I've run fc-cache a couple of times without results :_)
Not properly working font selectors might be what you're seeing, only in v7 Operas font preview has worked like it should I think. Try previewing fonts in Opera 7 or qtconfig.
Back to top
View user's profile Send private message
Herodot
Guru
Guru


Joined: 29 Jul 2002
Posts: 429
Location: Professor Xavier's school for gifted youngsters

PostPosted: Wed Apr 16, 2003 1:42 pm    Post subject: Reply with quote

Quote:
So it did come down to fc-cache? : )
Yes, you were right all along. I'll thank you when I get rich ;-)

Quote:
In my case I'm thinking it was alignment of the planets or something
I fixed that, to no avail. Everybody better update their Kstars and Celestia, btw.

I've used Opera until recently, now Konqueror is my weapon of choice. I haven't seen v7, I'll try it when the bugs get to a reasonable level.

Thanks for your input!
_________________
Excelsior!
Back to top
View user's profile Send private message
spbecker
Retired Dev
Retired Dev


Joined: 10 Dec 2002
Posts: 73

PostPosted: Fri Apr 18, 2003 9:42 pm    Post subject: hmmmm.... Reply with quote

Ok, maybe I'm confused, but what was the actual solution to this problem? I just encountered it today, and I have no idea why. My fonts were fine just this morning...namely the konsole font in KDE. I got home from being on campus, and it was screwed up. As far as I can tell, I did nothing. I did update qt a day or two ago...and I *may* have updated fontconfig, but I don't particularly remember. Also, what package is fc-cache part of? Does it need to be upgraded to fix this?
Back to top
View user's profile Send private message
()
l33t
l33t


Joined: 25 Nov 2002
Posts: 610

PostPosted: Fri Apr 18, 2003 11:19 pm    Post subject: Reply with quote

fc-cache is part of fontconfig I believe. I would try emerging fontconfig, xft and KDE (freetype as well perhaps). Emerging basic KDE (KDE-libs, KDE-base) fixed the problem for me, dunno how though ..
Back to top
View user's profile Send private message
m0sk
n00b
n00b


Joined: 18 Apr 2003
Posts: 39
Location: Belgium

PostPosted: Sat Apr 19, 2003 12:17 am    Post subject: Re: hmmmm.... Reply with quote

spbecker wrote:
My fonts were fine just this morning...namely the konsole font in KDE. I got home from being on campus, and it was screwed up. As far as I can tell, I did nothing. I did update qt a day or two ago...and I *may* have updated fontconfig, but I don't particularly remember.


Experiencing font related problems myself. In particular: I always turn anti-aliasing off for normal sized fonts (in kde control center), but Konsole now all of a sudden uses AA. When I did fc-cache an restarted Konsole, the font changed from Fixed to something Courier-ish (AA'd). Other fonts seem fine, only Konsole acts strange :cry: Anybody knows what's going on?
Back to top
View user's profile Send private message
Beekster
Apprentice
Apprentice


Joined: 26 Nov 2002
Posts: 268
Location: Sydney

PostPosted: Sat Apr 19, 2003 12:32 am    Post subject: Reply with quote

Well, my fonts had a few quirks that I had seen mentioned elsewhere on this forum, including the doublespaced default font in konsole. An update on April 18 fixed everything for me, and gave a very noticeable speed increase in rendering. This has been seen most clearly when clicking "back" in Mozilla, or especially when hitting cntrl+ or cntrl- to enlarge or reduce font size displayed on large pages. Much snappier.

All I can attribute this to is fontconfig-2.1-r1 -> fontconfig-2.1.94-r1. I am quite amazed at how much snappier things are, as well as the fixed konsole font. I have not tried to tweak anything manually.

I'm running a full ~x86 profile, so ymmv. I'd be happy to send screenshots to anyone who wants to see the change(s). The "new" konsole font is also now used in Mozilla's email client for text (not html) messages.
Quote:
1050633021: Started emerge on: Apr 18, 2003 12:30:21
1050633021: *** emerge --update --deep system
1050633024: >>> emerge (1 of 3) media-libs/fontconfig-2.1.94-r1 to /
1050633087: >>> AUTOCLEAN: media-libs/fontconfig
1050633095: >>> unmerge success: media-libs/fontconfig-2.1-r1
1050633095: ::: completed emerge (1 of 3) media-libs/fontconfig-2.1.94-r1 to /
<snip>
1050633188: *** exiting successfully.
Back to top
View user's profile Send private message
m0sk
n00b
n00b


Joined: 18 Apr 2003
Posts: 39
Location: Belgium

PostPosted: Sat Apr 19, 2003 1:01 am    Post subject: Reply with quote

Ok, discovered that you can change Konsole font via font->custom :roll: Now I'm acutally seeing the ugly double spaced Fixed font. I'm upgrading to freetype 2.1.4 and fontconfig-2.1.94-r1, see if that changes anything.
Back to top
View user's profile Send private message
spbecker
Retired Dev
Retired Dev


Joined: 10 Dec 2002
Posts: 73

PostPosted: Sat Apr 19, 2003 12:24 pm    Post subject: no luck yet... Reply with quote

I have re-emerged fontconfig, xft, kdelibs, and kdebase. My font is still screwed up in konsole. Ugh. By the way...does anyone know why you only get a very short list of fonts to choose front from the font -> custom menu in konsole?
Back to top
View user's profile Send private message
spbecker
Retired Dev
Retired Dev


Joined: 10 Dec 2002
Posts: 73

PostPosted: Sat Apr 19, 2003 12:31 pm    Post subject: Re: Fonts - xft - fontconfig Reply with quote

Attis SH wrote:
Herodot wrote:
I had very nice antialiased fonts. Then I upgraded fontconfig from 2.1 to 2.1-r1 and xft from 2.0.1-r1 to 2.0.1-r2, and everything turned ugly. I tried going back to the earlier versions, and my old /etc/fonts/fonts.conf (which I had backed up), but that didn't help.

I had this problem, and I figured out that the bytecode interpreter was disabled in freetype. The problem was that the fonts were antialiased, but they looked bad.

I have rebuilt freetype with BCI enabled and my fonts are nice again. Someone thought the auto-hinter will do nicely in place of the bytecode interpreter, but it performs rather poorly with high quality TrueType fonts.

Quote:
Helvetica is no longer antialiased. The konsole fonts is small and ugly. Letters everywhere are poorly spaced.

Hmm... helvetica isn't antialiased on my system either. I thought it is a bitmap font? Maybe you have a different problem.


Ok...so how do you build freetype with BCI enabled? Is there a use flag for this?
Back to top
View user's profile Send private message
()
l33t
l33t


Joined: 25 Nov 2002
Posts: 610

PostPosted: Sat Apr 19, 2003 2:01 pm    Post subject: Reply with quote

Isnt BCI enabled by default in the latest FreeType ebuild now? Also, I had problems with fontconfig 2..1.94, fewer fonts to choose from in Opera at least (no Times New Roman for instance).
Back to top
View user's profile Send private message
barlad
l33t
l33t


Joined: 22 Feb 2003
Posts: 673

PostPosted: Sat Apr 19, 2003 2:12 pm    Post subject: Reply with quote

Yes Bytecode is enabled by default in the new freetype ebuild.
To disable it, you have to use "prebuilt" i.e :
Code:
USE="prebuilt" emerge freetype


Helvetica looks ugly for me too after upgrading fontconfig. I think it is due to some new aliases put in fontconfig.
Like someone previously said, helvetica used to be aliased to Verdana, which is an AA font. Most likely, the latest fontconfig removed that alias and you now get the normal Adobe Helvetica which is a fugly bitmap font :).
Back to top
View user's profile Send private message
spbecker
Retired Dev
Retired Dev


Joined: 10 Dec 2002
Posts: 73

PostPosted: Sat Apr 19, 2003 6:43 pm    Post subject: definitely newest version of fontconfig is the problem... Reply with quote

I downgraded fontconfig to the 2.1-r1 ebuild and now the konsole fonts look like they used to again.
Back to top
View user's profile Send private message
()
l33t
l33t


Joined: 25 Nov 2002
Posts: 610

PostPosted: Sat Apr 19, 2003 6:55 pm    Post subject: Reply with quote

There's something weird about the 2.1.94 ebuild, probably to do with the fonts.dtd file (its getting changed)?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum