Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Hint for fixing keyboard problems after XFree 4.3 update!!
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Cryptopsy
n00b
n00b


Joined: 17 Mar 2003
Posts: 3

PostPosted: Mon Mar 17, 2003 7:43 pm    Post subject: Hint for fixing keyboard problems after XFree 4.3 update!! Reply with quote

Hello!

If anybody has keyboard errors like <Alt Gr> is not working or <Backspace> is acting like <Delete> after emerging XFree 4.3, this may fix this error:

cp /usr/X11R6/bin/xkbcomp /usr/X11R6/lib/X11/xkb/

(Don't forget to backup the other xkbcomp first :-))

Both files differed from each other on my system and the file in /usr/X11R6/bin/ was the newer one so I decided to copy it to /usr/X11R6/lib/X11/xkb/ and overwrite the xkbcomp there and finally......i got my alt gr key back :lol:

I hope I could help anybody....
_________________
Fighting for peace is like fucking for virginity
Back to top
View user's profile Send private message
atac
Apprentice
Apprentice


Joined: 04 Jan 2003
Posts: 234
Location: haninge, swe

PostPosted: Mon Mar 17, 2003 10:12 pm    Post subject: Reply with quote

i changed XkbModel from pc101 to pc105, that worked for me.
_________________
1 + 1 + 1 = 11
Back to top
View user's profile Send private message
Cryptopsy
n00b
n00b


Joined: 17 Mar 2003
Posts: 3

PostPosted: Tue Mar 18, 2003 8:56 am    Post subject: Reply with quote

I already had my keyboard configured as pc105 :D
_________________
Fighting for peace is like fucking for virginity
Back to top
View user's profile Send private message
atac
Apprentice
Apprentice


Joined: 04 Jan 2003
Posts: 234
Location: haninge, swe

PostPosted: Tue Mar 18, 2003 8:57 am    Post subject: Reply with quote

ah, okey
well then your way is proablly the way to go :)
_________________
1 + 1 + 1 = 11
Back to top
View user's profile Send private message
bos_mindwarp
Apprentice
Apprentice


Joined: 19 Oct 2002
Posts: 275
Location: stockholm, sweden

PostPosted: Tue Mar 18, 2003 3:15 pm    Post subject: Reply with quote

gah!
it fixed AltGr, but I lost all other keys =)
Back to top
View user's profile Send private message
neptune
n00b
n00b


Joined: 11 Oct 2002
Posts: 49

PostPosted: Mon Jun 02, 2003 8:23 am    Post subject: Reply with quote

I also have this problem with my belgian keyboard, i looked for you tip but before doing it i've checked this:

neptune root # ls -l /usr/X11R6/bin/xkbcomp
-rwxr-xr-x 1 root root 308984 Apr 23 15:04 /usr/X11R6/bin/xkbcomp
neptune root # ls -l /usr/X11R6/lib/X11/xkb/xkbcomp
-rwxr-xr-x 1 root root 308984 Apr 23 15:04 /usr/X11R6/lib/X11/xkb/xkbcomp
neptune root # diff /usr/X11R6/bin/xkbcomp /usr/X11R6/lib/X11/xkb/xkbcomp

The two files are the same :-( I also have pc105 in my config file.
Back to top
View user's profile Send private message
c07
Veteran
Veteran


Joined: 25 Oct 2002
Posts: 1091

PostPosted: Mon Jun 02, 2003 1:42 pm    Post subject: Reply with quote

Does it work after
Code:
setxkbmap -v 10 be '' ''

? Any errors?
Back to top
View user's profile Send private message
neptune
n00b
n00b


Joined: 11 Oct 2002
Posts: 49

PostPosted: Mon Jun 02, 2003 2:31 pm    Post subject: Reply with quote

fabian@neptune fabian $ setxkbmap -v 10 be '' ''
Setting verbose level to 10
locale is C
Warning! Multiple definitions of keyboard layout
Using command line, ignoring X server
Applied rules from xfree86:
model: pc105
layout: be
variant:
Trying to build keymap using the following components:
keycodes: xfree86+aliases(azerty)
types: complete
compat: complete
symbols: en_US(pc105)+be
geometry: pc(pc105)

After that commande, the problem remains. Here's my XF86Config:

> Section "InputDevice"
>     Identifier  "Keyboard1"
>     Driver      "Keyboard"
>     Option "AutoRepeat" "500 30"
>     Option "XkbRules"   "xfree86"
>     Option "XkbModel"   "pc105"
>     Option "XkbLayout"  "be"
> EndSection
Back to top
View user's profile Send private message
c07
Veteran
Veteran


Joined: 25 Oct 2002
Posts: 1091

PostPosted: Mon Jun 02, 2003 3:22 pm    Post subject: Reply with quote

If you just have problems with accents / dead keys, you might want to read here or add Option "XkbVariant" "nodeadkeys" to XF86Config.
Back to top
View user's profile Send private message
PurpleSkunk
n00b
n00b


Joined: 04 Jan 2004
Posts: 65
Location: Le Mans, France

PostPosted: Tue Feb 24, 2004 5:30 pm    Post subject: Re: Hint for fixing keyboard problems after XFree 4.3 update Reply with quote

Cryptopsy wrote:
If anybody has keyboard errors like <Alt Gr> is not working or <Backspace> is acting like <Delete> after emerging XFree 4.3, this may fix this error:

cp /usr/X11R6/bin/xkbcomp /usr/X11R6/lib/X11/xkb/

(Don't forget to backup the other xkbcomp first :-))


It worked for me !!! Got back to fr with my Alt Gr and all the stuff... great !

Thank u very much :D
Back to top
View user's profile Send private message
nightblade
Guru
Guru


Joined: 20 Jul 2004
Posts: 368
Location: back from SE Asia

PostPosted: Tue Jul 20, 2004 10:14 am    Post subject: Reply with quote

Worked for me too.

After upgrading Xfree to 4.3.0-r6 I couldn't switch my keyboard layout anymore. Issuing setxkbmap always generated the message "Error loading new keyboard description".

Now everything works fine

Thanks Cryptopsy
_________________
In God we trust. All the others must provide a valid X.509 certificate
Back to top
View user's profile Send private message
YsndHalf
n00b
n00b


Joined: 14 May 2003
Posts: 53
Location: Barcelona

PostPosted: Tue Jul 20, 2004 10:50 am    Post subject: Thanks!!!!!!! Reply with quote

Thanks, thanks, thanks, Cryptopsy and c07!!! :-D
Now I've got my keyboard OK again!
In a principle, I think that the copy of xkbcomp didn't solve all of the problems, but after executing setxkbmap in an x-console, everything went fine again.
Great info! Regards,
Jordi 8)
_________________
Did you know that we typically make use of only 5% of the power of our personal computers?
Check http://setiathome.berkeley.edu or http://www.seti.cat to use 100%!
Back to top
View user's profile Send private message
YsndHalf
n00b
n00b


Joined: 14 May 2003
Posts: 53
Location: Barcelona

PostPosted: Tue Jul 20, 2004 11:18 am    Post subject: Autoload 'setxkbmap'? Reply with quote

Hi again,
I've seen that, in order to have the correct keymap, I have to do a "setxkbmap <kbmap>" at the beginning of every session (KDE, in my case).
How can I "auto-execute" something (in this case, "setxkbmap es") at the start of every KDE session? (or, even better, at the start of X?)
Many thanks in advance. Regards, Jordi 8)
_________________
Did you know that we typically make use of only 5% of the power of our personal computers?
Check http://setiathome.berkeley.edu or http://www.seti.cat to use 100%!
Back to top
View user's profile Send private message
nightblade
Guru
Guru


Joined: 20 Jul 2004
Posts: 368
Location: back from SE Asia

PostPosted: Tue Jul 20, 2004 12:21 pm    Post subject: Reply with quote

Hola Jordi,

are you using XFree or Xorg ?

In XFree, you have the /etc/X11/XF86Config file with which you can control the default keyboard layout, using the XkbLayout option under the section corresponding to the keyboard itself. e.g.:

Code:
Option "XkbLayout"  "es"


I guess in Xorg things should be quite similar

Hope this helps
_________________
In God we trust. All the others must provide a valid X.509 certificate
Back to top
View user's profile Send private message
YsndHalf
n00b
n00b


Joined: 14 May 2003
Posts: 53
Location: Barcelona

PostPosted: Tue Jul 20, 2004 12:34 pm    Post subject: Reply with quote

Hi Nightblade,
yes, I use XFree, but I already have the XF86Config correct, in the way you say.
Curiously it seems that only the execution of this "setxkbmap" in an x-console solves the problems. Once this is done, all of the software under my kde work perfectly (the keymap is OK). Once I restart the computer (or simpy the kde session), everything fails again.
Therefore the only solution I see is this autoload of the 'setxkbmap es' command...
Regards, Jordi 8)
_________________
Did you know that we typically make use of only 5% of the power of our personal computers?
Check http://setiathome.berkeley.edu or http://www.seti.cat to use 100%!
Back to top
View user's profile Send private message
nightblade
Guru
Guru


Joined: 20 Jul 2004
Posts: 368
Location: back from SE Asia

PostPosted: Tue Jul 20, 2004 7:33 pm    Post subject: Reply with quote

YsndHalf wrote:

I already have the XF86Config correct, in the way you say.
Curiously it seems that only the execution of this "setxkbmap" in an x-console solves the problems. Once I restart the computer (or simpy the kde session), everything fails again.


...uhm... quite weird, as the XkbLayout option always worked perfectly to me. Does your XFree86 log file reveal any hint ?
_________________
In God we trust. All the others must provide a valid X.509 certificate
Back to top
View user's profile Send private message
ande
n00b
n00b


Joined: 31 Jul 2003
Posts: 12

PostPosted: Thu Dec 16, 2004 8:05 am    Post subject: Re: Autoload 'setxkbmap'? Reply with quote

YsndHalf wrote:
Hi again,
I've seen that, in order to have the correct keymap, I have to do a "setxkbmap <kbmap>" at the beginning of every session (KDE, in my case).
How can I "auto-execute" something (in this case, "setxkbmap es") at the start of every KDE session? (or, even better, at the start of X?)
Many thanks in advance. Regards, Jordi 8)


Code:
touch ~/.kde/Autostart/keymap.sh && echo 'setxkbmap es' > ~/.kde/Autostart/keymap.sh

chmod +x ~/.kde/Autostart/keymap.sh


This will load your keymap at the start of every kde session.
Back to top
View user's profile Send private message
ande
n00b
n00b


Joined: 31 Jul 2003
Posts: 12

PostPosted: Thu Dec 16, 2004 9:01 am    Post subject: Reply with quote

I finaly found a way to fix this without having to run setxkbmap:
Add the folowing line to your xorg.conf:
Code:

Option  "XkbSymbols" "pc/pc(pc105)+pc/no+altwin(menu)"


substitute "pc/pc(pc105)+pc/no+altwin(menu)" with whatever "setxkbmap <countrycode> -v 10" outputs on the "symbols:" line.
Atleast this works for me :-)
This is relevant parts my xorg.conf file:

Code:

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
        Option  "CoreKeyboard"

        Option  "XkbModel" "microsoft"
        Option  "XkbLayout" "no-latin1"
        Option  "RightAlt" "ModeShift"
        Option  "XkbOptions" "altwin:menu"
        Option  "XkbVariant" "no-latin1"
        Option  "LeftAlt" "Meta"
        Option  "XkbSymbols" "pc/pc(pc105)+pc/no+altwin(menu)"
EndSection
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum