Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
OK, thought I had it but still stuck
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
bammbamm808
Guru
Guru


Joined: 08 Dec 2002
Posts: 323
Location: Hawaii

PostPosted: Tue Jan 07, 2003 8:29 am    Post subject: OK, thought I had it but still stuck Reply with quote

For some reason, I can only get scsi emulation working with gentoo-sources. I have tried both vanilla 2.4.19 and 2.4.20 kernels with the same config as the gentoo-sources with no luck. Here's some output:

====================================
***DMESG FROM KERNEL W/WORKING SCSI-EMULATION....

Kernel command line: BOOT_IMAGE=Gentoo-2.4.19 ro root=2103 hdc=ide-scsi hda=ide-scsi
ide_setup: hdc=ide-scsi
ide_setup: hda=ide-scsi

***FURTHER DOWN....

SCSI subsystem driver Revision: 1.00
scsi0 : SCSI host adapter emulation for IDE ATAPI devices
Vendor: Model: 50X CD-ROM Rev: 5.3A
Type: CD-ROM ANSI SCSI revision: 02
Vendor: TEAC Model: CD-W516EB Rev: 1.0A
Type: CD-ROM ANSI SCSI revision: 02
Attached scsi CD-ROM sr0 at scsi0, channel 0, id 0, lun 0
Attached scsi CD-ROM sr1 at scsi0, channel 0, id 1, lun 0
sr0: scsi3-mmc drive: 4x/40x cd/rw xa/form2 cdda tray
Uniform CD-ROM driver Revision: 3.12
sr1: scsi3-mmc drive: 40x/40x writer cd/rw xa/form2 cdda tray

***CDRECORD -SCANBUS OUTPUT....

Cdrecord 1.11a33 (i686-pc-linux-gnu) Copyright (C) 1995-2002 Jörg Schilling
Linux sg driver version: 3.1.24
Using libscg version 'schily-0.6'
scsibus0:
cdrecord: Warning: controller returns wrong size for CD capabilities page.
0,0,0 0) ' ' '50X CD-ROM ' '5.3A' Removable CD-ROM
0,1,0 1) 'TEAC ' 'CD-W516EB ' '1.0A' Removable CD-ROM
0,2,0 2) *
0,3,0 3) *
0,4,0 4) *
0,5,0 5) *
0,6,0 6) *
0,7,0 7) *

=======================================
***DMESG FROM KERNEL W/O WORKING SCSI-EMULATION....

Kernel command line: BOOT_IMAGE=19-plain ro root=2103 hdc=ie-scsi hda=ide-scsi

***FURTHER DOWN....

SCSI subsystem driver Revision: 1.00
scsi0 : SCSI host adapter emulation for IDE ATAPI devices

***CDRECORD -SCANBUS OUTPUT....

Cdrecord 1.11a33 (i686-pc-linux-gnu) Copyright (C) 1995-2002 Jörg Schilling
cdrecord: No such file or directory. Cannot open '/dev/pg*'. Cannot open SCSI driver.
cdrecord: For possible targets try 'cdrecord -scanbus'. Make sure you are root.

=====================================
As you can see, for some reason, only my Gentoo-sources kernel is able to get scsi-emulation working. Nothing has changed here except the kernel. I even used the same config for both these and both vanilla 2.4.20/2.4.19 kernels with the result that only the gentoo-2.4.19 kernel works. WTF is going on? I need some help with this please.


EDIT: Removed some of the length from the lines of = to allow for better wrapping. -- kanuslupus
_________________
Asus m5a99x Evo Rev 2
Phenom II X4 965 BE
8Gb DDR3
Geforce GTX 460
Etc....
Back to top
View user's profile Send private message
ctford0
l33t
l33t


Joined: 25 Oct 2002
Posts: 774
Location: Lexington, KY,USA

PostPosted: Wed Jan 08, 2003 8:24 pm    Post subject: Re: OK, thought I had it but still stuck Reply with quote

bammbamm808 wrote:
=======================================
***DMESG FROM KERNEL W/O WORKING SCSI-EMULATION....

Kernel command line: BOOT_IMAGE=19-plain ro root=2103 hdc=ie-scsi hda=ide-scsi



is hdc=ie-scsi just a typo??

Chris
Back to top
View user's profile Send private message
bammbamm808
Guru
Guru


Joined: 08 Dec 2002
Posts: 323
Location: Hawaii

PostPosted: Thu Jan 09, 2003 12:48 am    Post subject: LOL Reply with quote

Yes, it is. I solved the problem by removing ide-cd support from the kernel, and changing nothing else. It worked like a charm after that. This goes against my past experience (I've always had ide-cd support in kernel and it always worked until recently), and one version of conventional wisdom (as typified by a oft-referenced thread in these very forums).
_________________
Asus m5a99x Evo Rev 2
Phenom II X4 965 BE
8Gb DDR3
Geforce GTX 460
Etc....
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum