Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Recompiled Kernel and now can't get Alsa to work
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
Wako
n00b
n00b


Joined: 13 Jul 2002
Posts: 61
Location: Chandler, AZ USA

PostPosted: Tue Jan 07, 2003 4:14 am    Post subject: Recompiled Kernel and now can't get Alsa to work Reply with quote

Ok, I recompiled my kernel (still 2.4.19-gentoo-r7) the other day to try to get my scanner to work, and when I did it, Alsa stopped working (like I knew it would).

I reemerged the alsa-driver as per the docs, but everything was broken. My /etc/modules.d/alsa no longer had my

Maybe this has something to do with my typing ldconfig? I sort of routinely type this after emerging something, but now I am assuming I should be typing etc-update.

Here is my /etc/modules.d/alsa

Code:
# # Alsa 0.9.X kernel modules' configuration file.
# $Header: /home/cvsroot/gentoo-x86/media-sound/alsa-driver/files/alsa-modules.conf,v 1.3 2002/06/24 18:05:58 agenkin Exp $

# ALSA portion
alias char-major-116 snd
options snd snd_major=116 snd_cards_limit=1
# OSS/Free portion
#alias char-major-14 soundcore

##
## IMPORTANT:
## You need to customise this section for your specific sound card(s)
## and then run `update-modules' command.
## Read alsa-driver's INSTALL file in /usr/share/doc for more info.
##
##  ALSA portion
 alias snd-card-0 snd-emu10k1
# alias snd-card-1 snd-emu10k1
# alias snd-card-2 snd-emu10k1
# alias snd-card-3 snd-emu10k1
# alias snd-card-4 snd-emu10k1
# alias snd-card-5 snd-emu10k1
# alias snd-card-6 snd-emu10k1
# alias snd-card-7 snd-emu10k1
##  OSS/Free portion
#alias sound-slot-0 snd-card-0
#alias sound-slot-1 snd-card-1
##

# OSS/Free portion - card #1
#alias sound-service-0-0 snd-mixer-oss
#alias sound-service-0-1 snd-seq-oss
#alias sound-service-0-3 snd-pcm-oss
#alias sound-service-0-8 snd-seq-oss
#alias sound-service-0-12 snd-pcm-oss
##  OSS/Free portion - card #2
#alias sound-service-1-0 snd-mixer-oss
#alias sound-service-1-3 snd-pcm-oss
#alias sound-service-1-12 snd-pcm-oss

alias /dev/mixer snd-mixer-oss
alias /dev/dsp snd-pcm-oss
alias /dev/midi snd-seq-oss



When I issue

/etc/init.d/alsasound restart

I get:
Code:

 * Starting sound driver: snd-emu10k1 Warning: ignoring snd_major=116, no such parameter in this module
Warning: ignoring snd_cards_limit=1, no such parameter in this module
Module snd loaded, with warnings
Module snd-ac97-codec loaded, with warnings
Module snd-seq-device loaded, with warnings
Module snd-hwdep loaded, with warnings
Module snd-util-mem loaded, with warnings
Module snd-rawmidi loaded, with warnings
Module snd-timer loaded, with warnings
Module snd-pcm loaded, with warnings
/lib/modules/2.4.19-gentoo-r7/kernel/sound/pci/emu10k1/snd-emu10k1.o: init_module: No such device
Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters.
      You may find more information in syslog or the output from dmesg
/lib/modules/2.4.19-gentoo-r7/kernel/sound/pci/emu10k1/snd-emu10k1.o: insmod /lib/modules/2.4.19-gentoo-r7/kernel/sound/pci/emu10k1/snd-emu10k1.o failed
/lib/modules/2.4.19-gentoo-r7/kernel/sound/pci/emu10k1/snd-emu10k1.o: insmod snd-emu10k1 failed

lsmod says
Code:

Module                  Size  Used by    Tainted: P 
snd-pcm-oss            36292   0  (unused)
snd-pcm                57952   0  [snd-pcm-oss]
snd-timer              11724   0  [snd-pcm]
snd-mixer-oss          11256   0  [snd-pcm-oss]
snd                    28236   0  [snd-pcm-oss snd-pcm snd-timer snd-mixer-oss]
scanner                 8472   0  (unused)
NVdriver             1066016  10
3c59x                  25456   1
eepro100               17336   0  (unused)

when i run amixer I get
Code:

amixer: Mixer attach default error: No such device

but /dev/mixer exists

if I do
insmod snd-mixer-oss
I get:
Code:

Using /lib/modules/2.4.19-gentoo-r7/kernel/sound/acore/oss/snd-mixer-oss.o
/lib/modules/2.4.19-gentoo-r7/kernel/sound/acore/oss/snd-mixer-oss.o: unresolved symbol snd_verbose_printk_Rsmp_49d4e4d1
/lib/modules/2.4.19-gentoo-r7/kernel/sound/acore/oss/snd-mixer-oss.o: unresolved symbol snd_info_unregister_Rsmp_27c92640
/lib/modules/2.4.19-gentoo-r7/kernel/sound/acore/oss/snd-mixer-oss.o: unresolved symbol snd_iprintf_Rsmp_2f0b152f
/lib/modules/2.4.19-gentoo-r7/kernel/sound/acore/oss/snd-mixer-oss.o: unresolved symbol snd_kcalloc_Rsmp_4da9e78a
/lib/modules/2.4.19-gentoo-r7/kernel/sound/acore/oss/snd-mixer-oss.o: unresolved symbol snd_info_free_entry_Rsmp_0c099669
/lib/modules/2.4.19-gentoo-r7/kernel/sound/acore/oss/snd-mixer-oss.o: unresolved symbol snd_info_get_line_Rsmp_0a6fd27b
/lib/modules/2.4.19-gentoo-r7/kernel/sound/acore/oss/snd-mixer-oss.o: unresolved symbol snd_unregister_oss_device_Rsmp_5a96f354
/lib/modules/2.4.19-gentoo-r7/kernel/sound/acore/oss/snd-mixer-oss.o: unresolved symbol snd_register_oss_device_Rsmp_b9c7248c
/lib/modules/2.4.19-gentoo-r7/kernel/sound/acore/oss/snd-mixer-oss.o: unresolved symbol snd_ctl_find_id_Rsmp_85892a03
/lib/modules/2.4.19-gentoo-r7/kernel/sound/acore/oss/snd-mixer-oss.o: unresolved symbol snd_mixer_oss_notify_callback_Rsmp_37f5cf01
/lib/modules/2.4.19-gentoo-r7/kernel/sound/acore/oss/snd-mixer-oss.o: unresolved symbol snd_info_create_card_entry_Rsmp_e9649867
/lib/modules/2.4.19-gentoo-r7/kernel/sound/acore/oss/snd-mixer-oss.o: unresolved symbol snd_info_get_str_Rsmp_b213fe8b
/lib/modules/2.4.19-gentoo-r7/kernel/sound/acore/oss/snd-mixer-oss.o: unresolved symbol snd_oss_info_register_Rsmp_8df3789f
/lib/modules/2.4.19-gentoo-r7/kernel/sound/acore/oss/snd-mixer-oss.o: unresolved symbol snd_cards_Rsmp_ff0660c0
/lib/modules/2.4.19-gentoo-r7/kernel/sound/acore/oss/snd-mixer-oss.o: unresolved symbol snd_kmalloc_strdup_Rsmp_5dd3bf69
/lib/modules/2.4.19-gentoo-r7/kernel/sound/acore/oss/snd-mixer-oss.o: unresolved symbol snd_info_register_Rsmp_9f95406e
/lib/modules/2.4.19-gentoo-r7/kernel/sound/acore/oss/snd-mixer-oss.o: unresolved symbol snd_ctl_notify_Rsmp_bdca5a9c


Which makes me think something big is hosed...


Any help?

Thanks!
_________________
"I say to you that the MPAA and the RIAA is to the American computer user and the American public as the Boston strangler is to the woman home alone." – me
Back to top
View user's profile Send private message
BonezTheGoon
Bodhisattva
Bodhisattva


Joined: 14 Jun 2002
Posts: 1375
Location: Albuquerque, NM -- birthplace of Microsoft and Gentoo

PostPosted: Tue Jan 07, 2003 5:23 am    Post subject: Reply with quote

Sounds a lot like you somehow got sound support for the card compiled into your newest kernel that is causing the trouble. Check your kernel config to verify that you only have Soundcore support (Sound Card support, without supporting any specifically named cards.)

Regards,
BonezTheGoon
Back to top
View user's profile Send private message
ArturasB
n00b
n00b


Joined: 20 Sep 2002
Posts: 47
Location: Vilnius, Lithuania

PostPosted: Tue Jan 07, 2003 8:55 am    Post subject: Re: Recompiled Kernel and now can't get Alsa to work Reply with quote

Hi.

Just re-emerge alsa. That's all.

Regards,
Arturas B.
Back to top
View user's profile Send private message
crevette
Guru
Guru


Joined: 21 May 2002
Posts: 543
Location: Chrooted in Nice, France

PostPosted: Tue Jan 07, 2003 11:20 am    Post subject: Reply with quote

This guy says truth
just type
Code:

emerge alsa


that's all folks
_________________
http://www.mille-mathias.info
Back to top
View user's profile Send private message
BonezTheGoon
Bodhisattva
Bodhisattva


Joined: 14 Jun 2002
Posts: 1375
Location: Albuquerque, NM -- birthplace of Microsoft and Gentoo

PostPosted: Tue Jan 07, 2003 2:53 pm    Post subject: Reply with quote

I hope that when Wako said this in his post

Wako wrote:
I reemerged the alsa-driver as per the docs . . .


that he did exactly that

Code:
emerge alsa


If he did not re-emerge alsa then yes, quite right--please re-emerge alsa!

Regards,
BonezTheGoon
Back to top
View user's profile Send private message
chh
Tux's lil' helper
Tux's lil' helper


Joined: 16 May 2002
Posts: 131
Location: Germany

PostPosted: Tue Jan 07, 2003 3:05 pm    Post subject: Reply with quote

Try removing the snd- from snd-emu10k1. I am not sure if you need to do it in more places, but I remember that the module names changed.

Chris
Back to top
View user's profile Send private message
relyt
Apprentice
Apprentice


Joined: 29 Aug 2002
Posts: 238
Location: Massachusetts

PostPosted: Tue Jan 07, 2003 4:13 pm    Post subject: Re: Recompiled Kernel and now can't get Alsa to work Reply with quote

Wako wrote:
Here is my /etc/modules.d/alsa

Code:
# # Alsa 0.9.X kernel modules' configuration file.
# $Header: /home/cvsroot/gentoo-x86/media-sound/alsa-driver/files/alsa-modules.conf,v 1.3 2002/06/24 18:05:58 agenkin Exp $

# ALSA portion
alias char-major-116 snd
options snd snd_major=116 snd_cards_limit=1

[...]

/etc/init.d/alsasound restart
Code:

 * Starting sound driver: snd-emu10k1
Warning: ignoring snd_major=116, no such parameter in this module
Warning: ignoring snd_cards_limit=1, no such parameter in this module

[...]


The problem is that with the newest ALSA release, you no longer put "snd-" in front of the options. Change your options to "major" and "cards_limit" and everything should work again.
Back to top
View user's profile Send private message
Wako
n00b
n00b


Joined: 13 Jul 2002
Posts: 61
Location: Chandler, AZ USA

PostPosted: Wed Jan 08, 2003 1:45 pm    Post subject: Reply with quote

Hallelielia!!!!

There were actually 2 things wrong. One, somehow my new kernel was compiling the card into the kernel directly and not as a module.

Two, this last comment about removing snd- was correct. I dd both and it works!!!!!

Thanks Everybody!!!
_________________
"I say to you that the MPAA and the RIAA is to the American computer user and the American public as the Boston strangler is to the woman home alone." – me
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum