Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
What am I missing here?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
bammbamm808
Guru
Guru


Joined: 08 Dec 2002
Posts: 323
Location: Hawaii

PostPosted: Sat Jan 04, 2003 9:31 am    Post subject: What am I missing here? Reply with quote

As root, 'cdrecord -scanbus' returns the following:
Cdrecord 1.11a33 (i686-pc-linux-gnu) Copyright (C)1995-2002 Jörg Schilling
cdrecord: No such file or directory. Cannot open '/dev/pg*'. Cannot open SCSI driver.
cdrecord: For possible targets try 'cdrecord -scanbus'. Make sure you are root.

Following modules are loaded:
ide-scsi
sg
sr-mod
scsi-mod

/etc/lilo.conf contains the follwing line:
append = "hdc=ide-scsi hda=ide-scsi"

I had no trouble getting this to work in Slackware, but apparrently Gentoo does something differently. Do I need some aliases?
_________________
Asus m5a99x Evo Rev 2
Phenom II X4 965 BE
8Gb DDR3
Geforce GTX 460
Etc....
Back to top
View user's profile Send private message
steveb
Advocate
Advocate


Joined: 18 Sep 2002
Posts: 4564

PostPosted: Sat Jan 04, 2003 12:49 pm    Post subject: Reply with quote

do you have devfs activated in your kernel?
do you load it at boot time?

cheers

SteveB
Back to top
View user's profile Send private message
bammbamm808
Guru
Guru


Joined: 08 Dec 2002
Posts: 323
Location: Hawaii

PostPosted: Sun Jan 05, 2003 6:41 am    Post subject: By the way, thanks for the help Reply with quote

Like I said, I've never had this not work, so I'm thinking I'm having a brainfart here, but for the life of me, I can't find what it is.

My kernel config includes both devfs and automatically mount at boot. My /etc/lilo.conf DOES NOT include the devfs=nomount option. Top shows me that devfsd is running.
_________________
Asus m5a99x Evo Rev 2
Phenom II X4 965 BE
8Gb DDR3
Geforce GTX 460
Etc....
Back to top
View user's profile Send private message
rac
Bodhisattva
Bodhisattva


Joined: 30 May 2002
Posts: 6553
Location: Japanifornia

PostPosted: Sun Jan 05, 2003 6:46 am    Post subject: Reply with quote

Have you seen kerframil's Kernel SCSI emulation for CD burning - the truth?
_________________
For every higher wall, there is a taller ladder
Back to top
View user's profile Send private message
bammbamm808
Guru
Guru


Joined: 08 Dec 2002
Posts: 323
Location: Hawaii

PostPosted: Sun Jan 05, 2003 6:54 am    Post subject: Ahh Hah! Reply with quote

Yes, I've seen that. Thank you.

OK I booted the Gentoo-Sources kernel and it works, so I'm definitely out to lunch here somewhere. Which means this has been a waste of your time. My apologies. I prolly just did something weird compiling my 2.4.20 kernel.
_________________
Asus m5a99x Evo Rev 2
Phenom II X4 965 BE
8Gb DDR3
Geforce GTX 460
Etc....
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum