Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Xorg-6.8.0-r4 und Opengl-update-2.1-pre4 incompatibel?
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
schrippe
Guru
Guru


Joined: 03 Mar 2004
Posts: 556
Location: Mülheim

PostPosted: Tue Jan 25, 2005 8:51 am    Post subject: Xorg-6.8.0-r4 und Opengl-update-2.1-pre4 incompatibel? Reply with quote

wollte gerade ein emerge -pvuD machen
doch er möchte mir nicht xorg updaten wenn er openglupdate drauf hat.

Quote:
joker download # emerge -pvuD world

These are the packages that I would merge, in order:

Calculating world dependencies ...done!
[blocks B ] <x11-base/xorg-x11-6.8.0-r4 (from pkg x11-base/opengl-update-2.1_pre1)
[ebuild NS ] sys-devel/autoconf-2.13 0 kB
[ebuild N ] sys-devel/autoconf-wrapper-2 0 kB
[ebuild U ] sys-devel/autoconf-2.59-r6 [2.59-r5] 0 kB
[ebuild UD] sys-devel/automake-1.5 [1.8.5-r1] (-uclibc) 0 kB
[ebuild NS ] sys-devel/automake-1.8.5-r2 (-uclibc) 0 kB
[ebuild NS ] sys-devel/automake-1.6.3 (-uclibc) 0 kB
[ebuild NS ] sys-devel/automake-1.7.9 (-uclibc) 0 kB
[ebuild NS ] sys-devel/automake-1.4_p6 (-uclibc) 0 kB
[ebuild N ] sys-devel/automake-wrapper-1 0 kB
[ebuild NS ] sys-devel/automake-1.9.4 (-uclibc) 734 kB
[ebuild U ] sys-devel/libtool-1.5.10-r3 [1.5.2-r7] (-uclibc) 2,636 kB
[ebuild U ] x11-base/opengl-update-2.1_pre1 [2.0_pre4-r1] 0 kB
[ebuild U ] x11-base/xorg-x11-6.8.0-r4 [6.8.0-r3] -3dfx -3dnow +bitmap-fonts -cjk -debug -dlloader -dmx -doc +font-server* -hardened -insecure-drivers -ipv6 -minimal +mmx +nls +opengl +pam -sdk +sse -static +truetype-fonts* +type1-fonts* (-uclibc) -xprint +xv 175 kB
[ebuild U ] x11-terms/xterm-199 [197] -Xaw3d -debug +truetype -unicode 679 kB
[ebuild U ] dev-db/mysql-4.0.22-r2 [4.0.22] +berkdb -debug -innodb +perl +readline (-selinux) +ssl -static +tcpd 0 kB
[ebuild U ] sys-apps/pciutils-2.1.11-r3 [2.1.11-r1] -debug 84 kB
[ebuild U ] media-libs/taglib-1.3.1 [1.2] -debug 717 kB
[ebuild U ] net-misc/rdiff-backup-0.13.4 [0.12.7] 140 kB
[ebuild U ] app-crypt/qca-1.0-r2 [1.0-r1] 0 kB
[ebuild U ] app-crypt/qca-tls-1.0-r2 [1.0-r1] 0 kB


auch ein emerge opengl-update brachte nur diese fehlermeldung:
Quote:
joker download # emerge x11-base/opengl-update
Calculating dependencies ...done!

!!! Error: the <x11-base/xorg-x11-6.8.0-r4 package conflicts with another package.
!!! both can't be installed on the same system together.
!!! Please use 'emerge --pretend' to determine blockers

_________________
for i in $(seq 1 565); do echo 'A$i: entweder rechts fahren oder rechts überholen dürfen!';done
Back to top
View user's profile Send private message
Anarcho
Advocate
Advocate


Joined: 06 Jun 2004
Posts: 2959
Location: Wuppertal (Germany)

PostPosted: Tue Jan 25, 2005 10:52 am    Post subject: Reply with quote

probier mal vorher opengl-update zu unmergen.
_________________
...it's only Rock'n'Roll, but I like it!
HOWTO:WLAN mit OpenVPN absichern | TOOL:useedit - USE-flag editor/changer
Back to top
View user's profile Send private message
Nori
n00b
n00b


Joined: 18 Nov 2004
Posts: 32

PostPosted: Tue Jan 25, 2005 11:44 am    Post subject: Reply with quote

Bekomme was ähnliches. Unmergen hat nichts geholfen.

Code:
These are the packages that I would merge, in order:

Calculating world dependencies ...done!
[blocks B     ] <media-video/ati-drivers-8.8.25-r3 (from pkg x11-base/opengl-update-2.1_pre1)
[ebuild     U ] media-libs/alsa-lib-1.0.8 [1.0.8_rc1] -doc -jack -static 666 kB
[ebuild     U ] media-sound/alsa-utils-1.0.8 [1.0.7] 219 kB
[ebuild     U ] media-libs/alsa-oss-1.0.8 [1.0.7] 218 kB
[ebuild     U ] app-editors/vim-core-6.3-r4 [6.3-r3] -acl -bash-completion -debug -livecd +ncurses +nls (-selinux) 6,879 kB
[ebuild     U ] app-editors/vim-6.3-r4 [6.3-r2] -acl -bash-completion -cscope -debug +gpm -minimal +ncurses +nls +perl +python -ruby (-selinux) -vim-with-x 0 kB
[ebuild  N    ] app-vim/gentoo-syntax-20041227  -ignore-glep31 13 kB
[ebuild     U ] media-sound/xmms-1.2.10-r10 [1.2.10-r9] +3dnow +alsa -arts -debug -directfb +esd +flac +ipv6 -jack -lirc +mad +mikmod +mmx +nls +oggvorbis +opengl -oss -sndfile +xml 2,942 kB
[ebuild  N    ] x11-base/opengl-update-2.1_pre1  0 kB
[ebuild     U ] media-video/ati-drivers-8.8.25-r3 [8.8.25] 0 kB
[ebuild     U ] dev-libs/libxml2-2.6.17 [2.6.16] -debug +ipv6 +python +readline 2,995 kB
[ebuild     U ] app-crypt/gnupg-1.4.0-r2 [1.4.0-r1] -bzip2 -caps -debug -ecc -idea +ldap +nls +readline (-selinux) -smartcard +zlib 0 kB
[ebuild     U ] mail-client/evolution-2.0.3-r1 [2.0.3] +crypt -debug -doc +ipv6 -kerberos +ldap +mozilla -nntp -pda +spell +ssl 0 kB
[ebuild     U ] media-libs/gst-plugins-0.8.7 [0.8.5-r1] +alsa -debug +esd* -oss 0 kB
[ebuild     U ] media-plugins/gst-plugins-esd-0.8.7 [0.8.5] 0 kB
[ebuild     U ] media-plugins/gst-plugins-alsa-0.8.7-r1 [0.8.5-r1] 0 kB
[ebuild     U ] x11-libs/vte-0.11.11-r3 [0.11.11-r2] -debug -doc +python 867 kB
[ebuild     U ] gnome-base/gnome-2.8.2 [2.8.1-r1] -accessibility +cdr +dvdr -hal 0 kB
[ebuild     U ] dev-util/glade-2.6.8 [2.6.7] -debug +gnome -gnomedb 2,389 kB
[ebuild     U ] sys-devel/flex-2.5.4a-r6 [2.5.4a-r5] -build -debug -static 385 kB
[ebuild     U ] net-im/gaim-1.1.2 [1.1.1] -cjk +crypt -debug -eds -gnutls -nas +nls +perl -silc +spell 5,057 kB
[ebuild     U ] x11-plugins/gaim-encryption-2.34 [2.32-r1] -debug 532 kB
[ebuild     U ] media-sound/easytag-1.99.3 [1.99.2-r1] +flac +nls +oggvorbis 1,082 kB
[ebuild     U ] sys-devel/m4-1.4.2-r1 [1.4.2] +nls 0 kB
Back to top
View user's profile Send private message
Tobiking
Tux's lil' helper
Tux's lil' helper


Joined: 14 Dec 2004
Posts: 109

PostPosted: Tue Jan 25, 2005 11:55 am    Post subject: Reply with quote

Bei mir stresst opengl-update mit den ati treibern:

Code:

[blocks B     ] <media-video/ati-drivers-8.8.25-r3 (from pkg x11-base/opengl-update-2.1_pre1)
[ebuild  NS   ] sys-devel/autoconf-2.13  0 kB
[ebuild  N    ] sys-devel/autoconf-wrapper-2  0 kB
[ebuild     U ] sys-devel/autoconf-2.59-r6 [2.59-r5] 0 kB
[ebuild     UD] sys-devel/automake-1.5 [1.8.5-r1] (-uclibc) 0 kB
[ebuild  NS   ] sys-devel/automake-1.8.5-r2  (-uclibc) 0 kB
[ebuild  NS   ] sys-devel/automake-1.6.3  (-uclibc) 0 kB
[ebuild  NS   ] sys-devel/automake-1.7.9  (-uclibc) 0 kB
[ebuild  NS   ] sys-devel/automake-1.4_p6  (-uclibc) 0 kB
[ebuild  N    ] sys-devel/automake-wrapper-1  0 kB
[ebuild  NS   ] sys-devel/automake-1.9.4  (-uclibc) 734 kB
[ebuild     U ] sys-devel/libtool-1.5.10-r3 [1.5.2-r7] (-uclibc) 2,636 kB
[ebuild     U ] x11-base/opengl-update-2.1_pre1 [2.0_pre4-r1] 0 kB
[ebuild     U ] dev-libs/libxml2-2.6.16 [2.6.15-r1] -debug -ipv6 -python +readline 3,027 kB
[ebuild     U ] media-video/ati-drivers-8.8.25-r3 [8.8.25-r2] 0 kB


Dabei hat ati-drivers extra gefordert das ich opengl-update ~x86 setzen soll wegen den abhängigkeiten.
Back to top
View user's profile Send private message
schrippe
Guru
Guru


Joined: 03 Mar 2004
Posts: 556
Location: Mülheim

PostPosted: Tue Jan 25, 2005 12:04 pm    Post subject: Reply with quote

nachdem ich von xorg und opengl-update beides auf x86 von ~x86 geändert hatte, funzte es!

x11-base/xorg-x11 x86
x11-base/opengl-update x86
_________________
for i in $(seq 1 565); do echo 'A$i: entweder rechts fahren oder rechts überholen dürfen!';done
Back to top
View user's profile Send private message
ZX-81
Guru
Guru


Joined: 23 Jul 2003
Posts: 355
Location: Germany

PostPosted: Tue Jan 25, 2005 12:38 pm    Post subject: Reply with quote

@Nori und @Tobiking: Ihr habt ein etwas anderes Problem wie schrippe.

Bei mir hat

emerge --unmerge ati-drivers
emerge --update --deep world
emerge ati-drivers

geholfen
Back to top
View user's profile Send private message
AngelM
Tux's lil' helper
Tux's lil' helper


Joined: 07 Dec 2004
Posts: 139
Location: Erlangen

PostPosted: Tue Jan 25, 2005 12:44 pm    Post subject: Reply with quote

Nachdem ich opengl-update und die Treiber geunmerged habe sagt er mir immer noch das xorg von openglgl-update geblockt wird.

Er will das opengl-update unbedingt neu installieren.
Back to top
View user's profile Send private message
ZX-81
Guru
Guru


Joined: 23 Jul 2003
Posts: 355
Location: Germany

PostPosted: Tue Jan 25, 2005 1:41 pm    Post subject: Reply with quote

AngelM wrote:
Nachdem ich opengl-update und die Treiber geunmerged habe sagt er mir immer noch das xorg von openglgl-update geblockt wird.

Er will das opengl-update unbedingt neu installieren.


Welche Versionen will er installieren, welche sind installiert, was steht in der /etc/portage/package.keywords... ?
Back to top
View user's profile Send private message
smg
Veteran
Veteran


Joined: 13 Aug 2004
Posts: 1402
Location: /home/stephan

PostPosted: Tue Jan 25, 2005 4:52 pm    Post subject: Reply with quote

Selbes Problem hier, ist es ein Bug im Ebuild?
// Vor 2-3 Tagen hat er mir noch kein Block angezeigt.

Habe alles auf ~x86 opengl-update sowie xorg, jedoch erst wenn ich es als ~x86 bei package.keywords auskommentiere hat er keinen block mehr, jemand ne idee dazu?


MfG
_________________
GnuPG-Key-ID: 0xF8C275D4
Fingerprint: 5B6F 134A 189B A24D 342B 0961 8D4B 0230 F8C2 75D4
Code:
perl -WTe '($")=$/;print qq(@{[reverse('0'..'100')]}$/BOOM!$/);'
Back to top
View user's profile Send private message
body_and_soul
n00b
n00b


Joined: 05 Apr 2004
Posts: 69
Location: Germersheim

PostPosted: Tue Jan 25, 2005 6:33 pm    Post subject: Reply with quote

Hallo,
ZX-81 hat geschrieben
Quote:


emerge --unmerge ati-drivers
emerge --update --deep world
emerge ati-drivers


Das war das einzige was bei mir auch geholfen hat


Gruß Norbert
Back to top
View user's profile Send private message
frary
Guru
Guru


Joined: 27 Jan 2004
Posts: 545

PostPosted: Tue Jan 25, 2005 7:45 pm    Post subject: Reply with quote

Auch bei mir hat nur
Code:
emerge --unmerge ati-drivers
emerge --update --deep world
emerge ati-drivers

geholfen.
Zudem konnten die Treiber nicht gegen meinen aktuellen Kernel kompiliert werden:
Code:
 *     2.6.10-ck5n
 * These sources have not yet been prepared.
 * We cannot build against an unprepared tree.
 * To resolve this, please type the following:
 *
 * # cd /usr/src/linux
 * # make oldconfig
 * # make modules_prepare
 *
 * Then please try merging this module again.


Die beschriebene Vorgehensweise hat zwar funktioniert, aber was war los? Den Kernel benutze ich seit 2-3 Tagen und habe schon die Vorgängerversion der Treiber so kompiliert.

T

[Edit] entgegen meiner Bedenken läuft auch nach dem Neustart alles noch wie vorher, 3D Beschleunigung ist übrigens besser als je zuvor ( 3.14 bzw. KernelModul Radeon ).
Mann, ich bin froh, wenn ein paar meiner ~x86 Pakete stabil werden, in den letzten Tagen hatte ich einige solcher Baustellen. Kommt davon, wenn man nicht warten kann...
_________________
Mitleid bekommt man geschenkt;
Neid muss man sich hart erarbeiten!

I.Walter
Back to top
View user's profile Send private message
smg
Veteran
Veteran


Joined: 13 Aug 2004
Posts: 1402
Location: /home/stephan

PostPosted: Tue Jan 25, 2005 7:58 pm    Post subject: Reply with quote

Btw. ich habe keine ATI, ich benutze Nvidia und 2.6.10.er kernel

MfG
_________________
GnuPG-Key-ID: 0xF8C275D4
Fingerprint: 5B6F 134A 189B A24D 342B 0961 8D4B 0230 F8C2 75D4
Code:
perl -WTe '($")=$/;print qq(@{[reverse('0'..'100')]}$/BOOM!$/);'
Back to top
View user's profile Send private message
ZX-81
Guru
Guru


Joined: 23 Jul 2003
Posts: 355
Location: Germany

PostPosted: Tue Jan 25, 2005 11:06 pm    Post subject: Reply with quote

Stephan - 'ash' wrote:
Selbes Problem hier, ist es ein Bug im Ebuild?
// Vor 2-3 Tagen hat er mir noch kein Block angezeigt.

Habe alles auf ~x86 opengl-update sowie xorg, jedoch erst wenn ich es als ~x86 bei package.keywords auskommentiere hat er keinen block mehr, jemand ne idee dazu?


MfG


Würde erstmal rauskriegen welche Pakete an dem Blocking beteiligt sind. -> Output des entsprechenen emerges mit --pretend und --verbose

Von diesen Pakteten die Versionen rauskriegen die installiert sind und die er installieren will -> emerge -s paketname

Anschliessend in den ebuilds der zu installierenden Pakete die Abhängigkeiten durchchecken. Wahrscheinlich ist es ein Zyklus und den sollte man versuchen mit --unmerge an einer Stelle zu zerbrechen an der es nicht arg weh tut (xorg-x11 compiliert recht lange)

ZX.
Back to top
View user's profile Send private message
mrspam
n00b
n00b


Joined: 10 Aug 2004
Posts: 63

PostPosted: Wed Jan 26, 2005 8:07 am    Post subject: Reply with quote

Servus!

Ich habe hier dasselbe Problem mit NVidia-Treibern. opengl-update wurde gestern noch vom xorg-x11 (alles kleiner als 6.8.0-r4) geblockt. Seit heute früh gibt es einen neuen xorg-x11 (6.8.1.902) im Portage, der sich kompilieren lässt. Das ging gestern abend noch nicht. Es sieht bisher alles sehr vielversprechend aus... *toi* *toi* *toi*

Ich melde mich gleich nochmal.

*tick* *tick* *tick*

Jawoll, es hat funktioniert:
1. neuesten xorg-x11 installieren
2. nvidia-kernel + nvidia-glx kompilieren
3. opengl-update installieren

-> Spass haben
Back to top
View user's profile Send private message
aZZe
l33t
l33t


Joined: 20 Feb 2003
Posts: 955
Location: Dinslaken, Germany

PostPosted: Wed Jan 26, 2005 11:39 am    Post subject: Reply with quote

Problem wurde gefixt! Einfach mal neu syncen und emerge -u world ausführen und glücklich sein.
_________________
ASUS 4A785TD-V EVO with AMD Phenom(tm) II X4 965
4GB RAM DDR3-1333
ATI Radeon HD4870
Back to top
View user's profile Send private message
smg
Veteran
Veteran


Joined: 13 Aug 2004
Posts: 1402
Location: /home/stephan

PostPosted: Wed Jan 26, 2005 1:18 pm    Post subject: Reply with quote

Quote:
emerge -a nvidia-kernel nvidia-glx

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[blocks B ] <x11-base/xorg-x11-6.8.0-r4 (from pkg x11-base/opengl-update-2.1_pre3)
[ebuild U ] media-video/nvidia-kernel-1.0.6629-r3 [1.0.6629-r1]
[ebuild U ] x11-base/opengl-update-2.1_pre3 [1.8.2]
[ebuild U ] media-video/nvidia-glx-1.0.6629-r4 [1.0.6629-r1]

!!! Error: The above package list contains packages which cannot be installed
!!! on the same system.

Das passiert bei mir.
_________________
GnuPG-Key-ID: 0xF8C275D4
Fingerprint: 5B6F 134A 189B A24D 342B 0961 8D4B 0230 F8C2 75D4
Code:
perl -WTe '($")=$/;print qq(@{[reverse('0'..'100')]}$/BOOM!$/);'
Back to top
View user's profile Send private message
smg
Veteran
Veteran


Joined: 13 Aug 2004
Posts: 1402
Location: /home/stephan

PostPosted: Wed Jan 26, 2005 1:35 pm    Post subject: Reply with quote

ich muss xorg und opengl-update in package.keywords auskommentieren, und neuer glx versionen von nvidia größer als 6629-r3 in package.mask maskieren, damit die probleme verschwinden.
gibt es da keien andere lösung?

mfg
_________________
GnuPG-Key-ID: 0xF8C275D4
Fingerprint: 5B6F 134A 189B A24D 342B 0961 8D4B 0230 F8C2 75D4
Code:
perl -WTe '($")=$/;print qq(@{[reverse('0'..'100')]}$/BOOM!$/);'
Back to top
View user's profile Send private message
smg
Veteran
Veteran


Joined: 13 Aug 2004
Posts: 1402
Location: /home/stephan

PostPosted: Wed Jan 26, 2005 2:04 pm    Post subject: Reply with quote

mrspam wrote:
Servus!

Ich habe hier dasselbe Problem mit NVidia-Treibern. opengl-update wurde gestern noch vom xorg-x11 (alles kleiner als 6.8.0-r4) geblockt. Seit heute früh gibt es einen neuen xorg-x11 (6.8.1.902) im Portage, der sich kompilieren lässt. Das ging gestern abend noch nicht. Es sieht bisher alles sehr vielversprechend aus... *toi* *toi* *toi*

Ich melde mich gleich nochmal.

*tick* *tick* *tick*

Jawoll, es hat funktioniert:
1. neuesten xorg-x11 installieren
2. nvidia-kernel + nvidia-glx kompilieren
3. opengl-update installieren

-> Spass haben


emerge -a xorg-x11

These are the packages that I would merge, in order:

Code:
Calculating dependencies      ...done!
[blocks B     ] <x11-base/xorg-x11-6.8.0-r4 (from pkg x11-base/opengl-update-2.1_pre3)
[ebuild     U ] x11-base/opengl-update-2.1_pre3 [1.8.2]
[ebuild     U ] x11-base/xorg-x11-6.8.1.902 [6.8.0-r1]


Bei mir klappt das leider nicht so.
Nachdem xorg und opengl-update von ~x86 zu x86 geändert wird, lässt sich xorg-6.8.0-r4 installieren. Jedoch die neuesten nvida glx versionen nicht.:
Code:
emerge -pvuD world

These are the packages that I would merge, in order:

Calculating world dependencies
!!! All ebuilds that could satisfy ">=x11-base/opengl-update-2.1_pre1" have been masked.
!!! One of the following masked packages is required to complete your request:
- x11-base/opengl-update-2.1_pre3 (masked by: ~x86 keyword)

For more information, see MASKED PACKAGES section in the emerge man page or
section 2.2 "Software Availability" in the Gentoo Handbook.
!!!    (dependency required by "media-video/nvidia-glx-1.0.6629-r4" [ebuild])


!!! Problem with ebuild media-video/nvidia-glx-1.0.6629-r4
!!! Possibly a DEPEND/*DEPEND problem.

!!! Depgraph creation failed.

D.h. ich muss neuere Versionen als 1.0.6629-r1 masken, bzw. ich kann keine neuere nvidia version installieren...

Jemand eine Idee dazu?

MfG
_________________
GnuPG-Key-ID: 0xF8C275D4
Fingerprint: 5B6F 134A 189B A24D 342B 0961 8D4B 0230 F8C2 75D4
Code:
perl -WTe '($")=$/;print qq(@{[reverse('0'..'100')]}$/BOOM!$/);'
Back to top
View user's profile Send private message
aZZe
l33t
l33t


Joined: 20 Feb 2003
Posts: 955
Location: Dinslaken, Germany

PostPosted: Wed Jan 26, 2005 7:21 pm    Post subject: Reply with quote

Unemerge mal opengl-update, danach syncen, opengl-update neu emergen. Dann dürfte es nicht mehr Version 2.1 sein es sei denn du hast natürlich was in die package.keywords und package.unmask gedrückt, dann kein Wunder ;)
_________________
ASUS 4A785TD-V EVO with AMD Phenom(tm) II X4 965
4GB RAM DDR3-1333
ATI Radeon HD4870
Back to top
View user's profile Send private message
lordmat
n00b
n00b


Joined: 30 Jul 2003
Posts: 52
Location: Tübingen

PostPosted: Fri Feb 04, 2005 8:44 pm    Post subject: Reply with quote

Code:
[blocks B     ] <x11-base/xorg-x11-6.8.0-r4 (from pkg x11-base/opengl-update-2.1_pre4)
[blocks B     ] <=dev-php/php-4.99.99 (from pkg dev-php/php-5.0.3)
[blocks B     ] <=dev-php/php-4.99.99 (from pkg dev-php/mod_php-5.0.3)


hmpf egal was hier steht .. in keywords x86 rein oder emerge -C opengl-update | sync | emerge opengl-update klappt alles net :/

hmpf und php klagt auch #$@!
Back to top
View user's profile Send private message
lordmat
n00b
n00b


Joined: 30 Jul 2003
Posts: 52
Location: Tübingen

PostPosted: Thu Feb 17, 2005 12:52 am    Post subject: *hochpusch* Reply with quote

keiner mehr ne info ?

wie gesagt

Code:
emerge -upDv world
[blocks B     ] <x11-base/xorg-x11-6.8.0-r4 (from pkg x11-base/opengl-update-2.1.1-r1)


make.conf = accept_keywords "~x86"


opengl-update wurde removed .. neu installiert nix half.


und

Code:
emerge -upDv world
[blocks B     ] <=dev-php/php-4.99.99 (from pkg dev-php/php-5.0.3)
[blocks B     ] <=dev-php/php-4.99.99 (from pkg dev-php/mod_php-5.0.3)


kommt leider auch arg.

mfg lordmat
Back to top
View user's profile Send private message
lordmat
n00b
n00b


Joined: 30 Jul 2003
Posts: 52
Location: Tübingen

PostPosted: Tue Mar 08, 2005 12:23 pm    Post subject: Reply with quote

!push! ... leider immer noch dieses problem und egal was man mir sagte nix half arg.. kann schon seit ka wie lang nimmer updaten ;/


danke im vorraus

lordmat
_________________
#linux.de @ euIRC | gentoo linux box
Supporter.
Gruß an DerCorny ;]
Back to top
View user's profile Send private message
ZX-81
Guru
Guru


Joined: 23 Jul 2003
Posts: 355
Location: Germany

PostPosted: Tue Mar 08, 2005 8:11 pm    Post subject: Reply with quote

Ich habe die Kombination x11-base/xorg-x11-6.8.0-r4 und x11-base/opengl-update-2.1.1-r1 installiert, wobei bei mir nur opengl-update in meiner /etc/portage/package.keywords eingetragen ist (.=> /xorg-x11-6.8.0-r4 == 'x86')

Was passiert denn, wenn Du folgendes ausführst:
Code:

emerge --unmerge opengl-update
emerge xorg-x11
?

wenn ich xorg-x11 auch noch in die /etc/portage/package.keywords eintrage, würde bei mir xorg-x11-6.8.2 emerged was allerdings mit der freetype-library kollidiert.

Vielleicht kannst Du ja auch xorg-x11-6.8.0-r4 auf 'x86' in der /etc/portage/package.keywords setzen.

ZX
Back to top
View user's profile Send private message
noergeli
Apprentice
Apprentice


Joined: 05 Oct 2004
Posts: 205
Location: Hamburg, Gemany

PostPosted: Tue Mar 08, 2005 11:26 pm    Post subject: Reply with quote

moin,
zu xorg/opengl-update: Hab das Problem auch mal gehabt. Das Problem scheint folgendes zu sein: xorg-x11-6.8.0-r4 braucht opengl-update >1.99 zum installieren. 2.1 lässt sich mit xorg <6.8.0-r4 aber nicht installieren. Das hängt anscheinend mit Veränderungen beim Installationsort bei den xorg-Paketen zusammen. Die einfachste Lösung in diesem Fall ist ein
Code:
emerge =x11-base/opengl-update-2.0_pre5
, da die 2.0 Versionen als einzige mit beidem zurechtkommen. Danach sollten sich dann erst xorg und danach opengl-update updaten lassen.
Bei dem zweiten Problem hilft vielleicht ein unmerge php?
Back to top
View user's profile Send private message
lordmat
n00b
n00b


Joined: 30 Jul 2003
Posts: 52
Location: Tübingen

PostPosted: Sun Mar 13, 2005 9:15 pm    Post subject: Reply with quote

danke für die hilfe !!

ich test gleich mal beides

werde dann meine weiteren probleme berichten :D

hoffe ja das keine kommen :)


danke noch mal :)


edit:
Quote:
* x11-base/opengl-update
Latest version available: 2.1.1-r1
Latest version installed: 2.0_pre5
Size of downloaded files: 37 kB
Homepage: http://www.gentoo.org/
Description: Utility to change the OpenGL interface being used
License: GPL-2


Quote:
[blocks B ] <x11-base/xorg-x11-6.8.0-r4 (from pkg x11-base/opengl-update-2.1.1-r1)


Quote:
lordmat opengl-update # emerge -C opengl-update-2.1.1-r1.ebuild
emerging by path implies --oneshot... adding --oneshot to options.

*** emerging by path is broken and may not always work!!!

!!! Not a valid db dir: /usr/portage/x11-base/opengl-update
lordmat opengl-update #


Quote:
lordmat opengl-update # emerge --unmerge opengl-update
>>> Unmerging x11-base/opengl-update-2.0_pre5...


Quote:
lordmat opengl-update # emerge xorg-x11
--- Invalid atom in /etc/portage/package.keywords: =>
Calculating dependencies ...done!

!!! Error: the <x11-base/xorg-x11-6.8.0-r4 package conflicts with another package.
!!! both can't be installed on the same system together.
!!! Please use 'emerge --pretend' to determine blockers.

lordmat opengl-update #


hmpf so langsam verzweifel ich :/
_________________
#linux.de @ euIRC | gentoo linux box
Supporter.
Gruß an DerCorny ;]
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum