Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
KDEPIM 3.3.1 failing on gpgme
View unanswered posts
View posts from last 24 hours

Goto page 1, 2, 3  Next  
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
Shaman
Apprentice
Apprentice


Joined: 12 Sep 2002
Posts: 167
Location: Kingston, ON

PostPosted: Wed Oct 13, 2004 3:50 pm    Post subject: KDEPIM 3.3.1 failing on gpgme Reply with quote

KDEPIM is failing on gpgme. :( gcc 3.4.2, xorg-x11, NPTL, 686

I've tried unmering gpgme, but it's a dependancy. Oddly it's using 1.0.0 and not 1.0.0-r1 which is also in the portage tree. Anyone else having this issue?

(not filed as a but yet until I figure out if it's just me)
Back to top
View user's profile Send private message
gungholady
Guru
Guru


Joined: 19 Oct 2003
Posts: 392

PostPosted: Wed Oct 13, 2004 5:23 pm    Post subject: Reply with quote

Is the error you are having the same as the one in this bug report?

http://bugs.gentoo.org/show_bug.cgi?id=66362
Back to top
View user's profile Send private message
zerb
Tux's lil' helper
Tux's lil' helper


Joined: 07 Aug 2003
Posts: 145
Location: Germany

PostPosted: Wed Oct 13, 2004 5:47 pm    Post subject: Reply with quote

same problem here.
i'm waiting for the 1.0.0-r2 gpgme ebuild.
Back to top
View user's profile Send private message
gungholady
Guru
Guru


Joined: 19 Oct 2003
Posts: 392

PostPosted: Wed Oct 13, 2004 6:41 pm    Post subject: Reply with quote

It is in portage now. I just did an emerge sync to get it.
Back to top
View user's profile Send private message
troworld
Tux's lil' helper
Tux's lil' helper


Joined: 20 Dec 2003
Posts: 95
Location: ON, CA

PostPosted: Thu Oct 14, 2004 4:07 am    Post subject: Reply with quote

Doesn't work for me:

Code:
g++ -DHAVE_CONFIG_H -I. -I. -I../.. -I../../certmanager/lib -I../../libkdenetwork -I/usr/include/gpgme -I/usr/kde/3.3/include -I/usr/qt/3/include -I/usr/X11R6/include   -DQT_THREAD_SUPPORT  -D_REENTRANT -D_FILE_OFFSET_BITS=64  -Wnon-virtual-dtor -Wno-long-long -Wundef -ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align -Wconversion -Wchar-subscripts -Wall -W -Wpointer-arith -Wwrite-strings -DNDEBUG -DNO_DEBUG -O2 -O2 -march=pentium4 -pipe -fomit-frame-pointer -Wformat-security -Wmissing-format-attribute -fno-exceptions -fno-check-new -fno-common -DQT_CLEAN_NAMESPACE -DQT_NO_ASCII_CAST -DQT_NO_STL -DQT_NO_COMPAT -DQT_NO_TRANSLATION -DLIBKLEOPATRA_NO_COMPAT -c -o kwatchgnupgmainwin.o kwatchgnupgmainwin.cpp
g++ -DHAVE_CONFIG_H -I. -I. -I../.. -I../../certmanager/lib -I../../libkdenetwork -I/usr/include/gpgme -I/usr/kde/3.3/include -I/usr/qt/3/include -I/usr/X11R6/include   -DQT_THREAD_SUPPORT  -D_REENTRANT -D_FILE_OFFSET_BITS=64  -Wnon-virtual-dtor -Wno-long-long -Wundef -ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align -Wconversion -Wchar-subscripts -Wall -W -Wpointer-arith -Wwrite-strings -DNDEBUG -DNO_DEBUG -O2 -O2 -march=pentium4 -pipe -fomit-frame-pointer -Wformat-security -Wmissing-format-attribute -fno-exceptions -fno-check-new -fno-common -DQT_CLEAN_NAMESPACE -DQT_NO_ASCII_CAST -DQT_NO_STL -DQT_NO_COMPAT -DQT_NO_TRANSLATION -DLIBKLEOPATRA_NO_COMPAT -c -o kwatchgnupgconfig.o kwatchgnupgconfig.cpp
g++ -DHAVE_CONFIG_H -I. -I. -I../.. -I../../certmanager/lib -I../../libkdenetwork -I/usr/include/gpgme -I/usr/kde/3.3/include -I/usr/qt/3/include -I/usr/X11R6/include   -DQT_THREAD_SUPPORT  -D_REENTRANT -D_FILE_OFFSET_BITS=64  -Wnon-virtual-dtor -Wno-long-long -Wundef -ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align -Wconversion -Wchar-subscripts -Wall -W -Wpointer-arith -Wwrite-strings -DNDEBUG -DNO_DEBUG -O2 -O2 -march=pentium4 -pipe -fomit-frame-pointer -Wformat-security -Wmissing-format-attribute -fno-exceptions -fno-check-new -fno-common -DQT_CLEAN_NAMESPACE -DQT_NO_ASCII_CAST -DQT_NO_STL -DQT_NO_COMPAT -DQT_NO_TRANSLATION -DLIBKLEOPATRA_NO_COMPAT -c -o tray.o tray.cpp
/bin/sh ../../libtool --silent --mode=link --tag=CXX g++  -Wnon-virtual-dtor -Wno-long-long -Wundef -ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align -Wconversion -Wchar-subscripts -Wall -W -Wpointer-arith -Wwrite-strings -DNDEBUG -DNO_DEBUG -O2 -O2 -march=pentium4 -pipe -fomit-frame-pointer -Wformat-security -Wmissing-format-attribute -fno-exceptions -fno-check-new -fno-common -DQT_CLEAN_NAMESPACE -DQT_NO_ASCII_CAST -DQT_NO_STL -DQT_NO_COMPAT -DQT_NO_TRANSLATION -DLIBKLEOPATRA_NO_COMPAT   -o kwatchgnupg -L/usr/X11R6/lib -L/usr/qt/3/lib -L/usr/kde/3.3/lib  -R /usr/kde/3.3/lib -R /usr/qt/3/lib -R /usr/X11R6/lib kwatchgnupgmainwin.o kwatchgnupgconfig.o aboutdata.o tray.o main.o ../conf/libconf.la ../lib/libkleopatra.la -lkutils -lkabc
/usr/lib/libgpgme.so: undefined reference to `_gpgme_engine_ops_gpgsm'
collect2: ld returned 1 exit status
make[3]: *** [kwatchgnupg] Error 1
make[3]: Leaving directory `/var/tmp/portage/kdepim-3.3.1/work/kdepim-3.3.1/certmanager/kwatchgnupg'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/kdepim-3.3.1/work/kdepim-3.3.1/certmanager'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/kdepim-3.3.1/work/kdepim-3.3.1'
make: *** [all] Error 2

!!! ERROR: kde-base/kdepim-3.3.1 failed.
!!! Function kde_src_compile, Line 142, Exitcode 2
!!! died running emake, kde_src_compile:make
!!! If you need support, post the topmost build error, NOT this status message.
Back to top
View user's profile Send private message
gungholady
Guru
Guru


Joined: 19 Oct 2003
Posts: 392

PostPosted: Thu Oct 14, 2004 6:54 am    Post subject: Reply with quote

It worked for me. Did you emerge the update for gpgme before trying kdepim again?
Back to top
View user's profile Send private message
lpetersen
Tux's lil' helper
Tux's lil' helper


Joined: 07 Jul 2003
Posts: 76
Location: Germany

PostPosted: Thu Oct 14, 2004 7:50 am    Post subject: Reply with quote

gungholady wrote:
It worked for me. Did you emerge the update for gpgme before trying kdepim again?


I get the same error as troworld did. And I do have gpgme-1.0.0-r2 installed. :(

There's also another, old version gpgme-0.4.7 still around, but it doesn't seem likely to interfere, since its libraries are named gpgme4* instead of gpgme*. I'll try and unmerge =gpgme-0.4.7 and then emerge kdepim-3.1.1 again though, just in case... :?
Back to top
View user's profile Send private message
lpetersen
Tux's lil' helper
Tux's lil' helper


Joined: 07 Jul 2003
Posts: 76
Location: Germany

PostPosted: Thu Oct 14, 2004 8:01 am    Post subject: Reply with quote

Ooops... next time I'll look through all possibly relevant threads before answering to the one seeming most relevant... :oops:

As suggested in this thread, the solution seems to be to downgrade gpgme to version 0.9.0-r1 rather than upgrade, as long as version 1.0.1 isn't out yet.

(Or is it out already? Damn, emerge sync takes long these days...)
Back to top
View user's profile Send private message
gungholady
Guru
Guru


Joined: 19 Oct 2003
Posts: 392

PostPosted: Thu Oct 14, 2004 9:11 am    Post subject: Reply with quote

lpetersen wrote:
gungholady wrote:
It worked for me. Did you emerge the update for gpgme before trying kdepim again?


I get the same error as troworld did. And I do have gpgme-1.0.0-r2 installed. :(

There's also another, old version gpgme-0.4.7 still around, but it doesn't seem likely to interfere, since its libraries are named gpgme4* instead of gpgme*. I'll try and unmerge =gpgme-0.4.7 and then emerge kdepim-3.1.1 again though, just in case... :?


Were you getting the same error using gpgme-1.0.0-r2? You may have something else different than I do, because after upgrading to 1.0.0-r2 kdepim emerged without any errors for me.
Back to top
View user's profile Send private message
lpetersen
Tux's lil' helper
Tux's lil' helper


Joined: 07 Jul 2003
Posts: 76
Location: Germany

PostPosted: Thu Oct 14, 2004 9:24 am    Post subject: Reply with quote

gungholady wrote:
Were you getting the same error using gpgme-1.0.0-r2?

Yes, as I said.
gungholady wrote:
You may have something else different than I do, because after upgrading to 1.0.0-r2 kdepim emerged without any errors for me.

Maybe, but at least for me it works with gpgme-0.9.0-r1 whereas it doesn't with gpgme-1.0.0-r2. For what it's worth, the previous kmail (from kde-3.3.0) also ceased working after the upgrade to gpgme-1.0.0 or gpgme-1.0.0-r2, but resumed its service flawlessly with gpgme-0.9.0-r1 installed.

So let's just wait for gpgme-1.0.1 and see what happens then. 8O

Thanks for the info, anyway, gungholady!
Back to top
View user's profile Send private message
cold
n00b
n00b


Joined: 23 Feb 2003
Posts: 66

PostPosted: Thu Oct 14, 2004 12:35 pm    Post subject: Reply with quote

it does work with 1.0.0-r3 gpgme for me :)
Back to top
View user's profile Send private message
lpetersen
Tux's lil' helper
Tux's lil' helper


Joined: 07 Jul 2003
Posts: 76
Location: Germany

PostPosted: Thu Oct 14, 2004 12:56 pm    Post subject: Reply with quote

cold wrote:
it does work with 1.0.0-r3 gpgme for me :)

Still no luck here... :( kmail (1.7.1 from kdepim-3.3.1) says
Code:
kmail: symbol lookup error: /usr/lib/libgpgme.so.11: undefined symbol: _gpgme_engine_ops_gpgsm
at startup when gpgme-1.0.0-r3 is installed.
Back to top
View user's profile Send private message
cold
n00b
n00b


Joined: 23 Feb 2003
Posts: 66

PostPosted: Thu Oct 14, 2004 1:13 pm    Post subject: Reply with quote

weerd with R3 I had a clean build
Back to top
View user's profile Send private message
lpetersen
Tux's lil' helper
Tux's lil' helper


Joined: 07 Jul 2003
Posts: 76
Location: Germany

PostPosted: Thu Oct 14, 2004 3:15 pm    Post subject: Reply with quote

Just a thought: Do you have the 'smime' USE flag set? I do, and the error message suggests that the error might be related to that...
Back to top
View user's profile Send private message
cold
n00b
n00b


Joined: 23 Feb 2003
Posts: 66

PostPosted: Thu Oct 14, 2004 3:25 pm    Post subject: Reply with quote

no I don't
Back to top
View user's profile Send private message
lpetersen
Tux's lil' helper
Tux's lil' helper


Joined: 07 Jul 2003
Posts: 76
Location: Germany

PostPosted: Thu Oct 14, 2004 3:40 pm    Post subject: Reply with quote

Well then, that might be an explanation: S/MIME support might be broken in gpgme-1.0.0* which is no problem when it's not compiled at all in the first place, but makes kmail choke when it is (like on my box).

Hope this helps anyone (the gurus probably have figured it out without us... :wink: ).
Back to top
View user's profile Send private message
firephoto
Veteran
Veteran


Joined: 29 Oct 2003
Posts: 1560
Location: +48° 5' 23.40", -119° 48' 30.00"

PostPosted: Thu Oct 14, 2004 5:54 pm    Post subject: Reply with quote

I can't compile kdepim if I emerge gpgme-1.0.0-r2 or -r3, and kontact/kmail won't start with either of those gpgme versions installed.

Kdepim 3.3.1 is working just fine with gpgme 1.0.0 though, I can send and recieve signed/encrypted emails.

I added to the bug that says it's resolved since it's obviously not resolved. ;)
Back to top
View user's profile Send private message
firephoto
Veteran
Veteran


Joined: 29 Oct 2003
Posts: 1560
Location: +48° 5' 23.40", -119° 48' 30.00"

PostPosted: Thu Oct 14, 2004 5:58 pm    Post subject: Reply with quote

I just noticed there isn't an smime use flag on the newer gpg builds but there is on the older ones. ???

Ok, the masked ones have smime and this is depending on the masked gnupg which I have installed ?

Something's not right, I know I had the masked gnupg for a reason.

Do I even need smime? I don't use any encryption or keys for normal things, just testing to see if it works but if I were to start using the privace encryption things for some email needs would I need smime?
Back to top
View user's profile Send private message
troworld
Tux's lil' helper
Tux's lil' helper


Joined: 20 Dec 2003
Posts: 95
Location: ON, CA

PostPosted: Fri Oct 15, 2004 2:19 am    Post subject: Reply with quote

Nah, I don't really think S/MIME is necessary unless you've got a certificate for it. I think you have to pay to get one. It's a different trust model than PGP/GPG.

I can't compile kdepim with ANY gpgme version right now. It's always giving me the exact same error. Gonna go clean out some stuff and try again. *sigh*
Back to top
View user's profile Send private message
firephoto
Veteran
Veteran


Joined: 29 Oct 2003
Posts: 1560
Location: +48° 5' 23.40", -119° 48' 30.00"

PostPosted: Fri Oct 15, 2004 4:42 am    Post subject: Reply with quote

Check to see if you have dev-libs/libassuan installed, for whatever reason it isn't a dependency but is needed (?) by gnupg.

I'm using only ~arch packages now, no masked packages, I've updated the bug with what I have currently and what is working.

Maybe you could post the configure message from kdepim that says what gpgme version and how it is configured. it's towards the end before it starts compiling.
Back to top
View user's profile Send private message
troworld
Tux's lil' helper
Tux's lil' helper


Joined: 20 Dec 2003
Posts: 95
Location: ON, CA

PostPosted: Fri Oct 15, 2004 3:38 pm    Post subject: Reply with quote

Well, I got kdepim to compile. The problem was in me using the masked version of gnupg. I recompiled everything with the latest stable and kdepim compiled ok. No S/MIME, though.

PGP/MIME also doesn't work when both encrypting and signing. I get the following error:
Code:
Encrypted message (decryption not possible)
Reason: Crypto plug-in "openpgp" could not decrypt the data.
Error: Bad passphrase


It didn't even ask me for a passphrase

[edit]Sending with PGP/MIME is ok. I just can't read the signed/encrypted message that I sent to myself
Back to top
View user's profile Send private message
yamakawa
Guru
Guru


Joined: 28 Jul 2003
Posts: 340

PostPosted: Sat Oct 16, 2004 2:33 pm    Post subject: Reply with quote

I had the same problem with the newest 1.0.0-r3 and sylpheed-0.9.99.
After unemerging gpgme of 0.3.x and 0.4.x, which were also installed, the problem was solved.
Back to top
View user's profile Send private message
gungholady
Guru
Guru


Joined: 19 Oct 2003
Posts: 392

PostPosted: Sat Oct 16, 2004 5:15 pm    Post subject: Reply with quote

yamakawa wrote:
I had the same problem with the newest 1.0.0-r3 and sylpheed-0.9.99.
After unemerging gpgme of 0.3.x and 0.4.x, which were also installed, the problem was solved.


Did you run revdep-rebuild after you did this?

Edit:

Nevermind. I found why revdep-rebuild found a problem with unmerging earlier versions. The dependent software was not depended on by anything so I unmerged it too.
Back to top
View user's profile Send private message
troworld
Tux's lil' helper
Tux's lil' helper


Joined: 20 Dec 2003
Posts: 95
Location: ON, CA

PostPosted: Sat Oct 16, 2004 11:16 pm    Post subject: Reply with quote

I don't have any other version of gpgme installed, though :/
Back to top
View user's profile Send private message
Pralix
n00b
n00b


Joined: 19 Sep 2003
Posts: 30
Location: Seattle, WA

PostPosted: Sun Oct 17, 2004 5:18 am    Post subject: Reply with quote

I figured out how to get kdepim-3.3 to compile on a new system. The problem is with dev-libs/libassuan not being a dependency for libgpg-error or gpgme. You will need to emerge libassuan and then re-emerge libgpg-error and gpgme. It compiled for me after I did this.

These are the versions I am running:

dev-libs/libassuan-0.6.6
app-crypt/gpgme-1.0.0-r3
dev-libs/libgpg-error-1.0-r1
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Goto page 1, 2, 3  Next
Page 1 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum