Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Crazy DNS problem
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
Esquilax
n00b
n00b


Joined: 30 Sep 2004
Posts: 4

PostPosted: Thu Sep 30, 2004 9:39 pm    Post subject: Crazy DNS problem Reply with quote

I have my gentoo box connected to my DSL router that provides DNS. If I do an nslookup or ping a site or even use links to view a site everything works fine. I can even do an emerge sync without a problem. The problem happens when I try to emerge a package. For some reason whatever site it tries to download the package from resolves as 1.0.0.0

I've temporarily fixed this by putting some of the mirrors in my hosts file, but I'm puzzled as to why this only happens when I emerge a package.

Any thoughts?
Back to top
View user's profile Send private message
nobspangle
Veteran
Veteran


Joined: 23 Mar 2004
Posts: 1317
Location: Manchester, UK

PostPosted: Thu Sep 30, 2004 9:57 pm    Post subject: Reply with quote

emerge uses wget to download the packages have you tried using wget to download something to make sure that is the problem.
Check your FETCHCOMMAND isn't set to something strange, or set it to use one of the other downloaders.
Back to top
View user's profile Send private message
Esquilax
n00b
n00b


Joined: 30 Sep 2004
Posts: 4

PostPosted: Fri Oct 01, 2004 2:24 am    Post subject: Reply with quote

FETCHCOMMAND looks fine. wget works fine on its own. It seems that emerge resolves the ip on its own and then hands it off to wget, which tries to use 1.0.0.0

I see:
Resolving some.site... 1.0.0.0
Connect to some.site[1.0.0.0]:80...

This seems to be a DNS server problem I guess, because when I switched to a different one, the problem went away, but I still wonder why it happens.

Is it possible emerge is trying to some weird dns query that the server doesn't understand?
Back to top
View user's profile Send private message
kallamej
Administrator
Administrator


Joined: 27 Jun 2003
Posts: 4836
Location: Gothenburg, Sweden

PostPosted: Sun Dec 26, 2004 11:31 pm    Post subject: Reply with quote

Moved from Networking & Security in favour of http://forums.gentoo.org/viewtopic.php?t=219302
_________________
Please read our FAQ Forum, it answers many of your questions.
irc: #gentoo-forums on irc.freenode.net
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum