Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Working mozilla 1.1 with plugins
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
int1
Tux's lil' helper
Tux's lil' helper


Joined: 08 Nov 2002
Posts: 139

PostPosted: Fri Nov 15, 2002 3:10 pm    Post subject: Working mozilla 1.1 with plugins Reply with quote

For all those still struggling, I finally got mozilla 1.1 to work with flash and java plugins. Here are my steps:
1. Remove openmotif and lesstif temporarily if they are installed:
- emerge -C openmotif
- emerge -C lesstif
2. Install mozilla 1.1:
- cd /usr/portage/net-www/mozilla
- USE="-gtk2" emerge mozilla-1.1-r1.ebuild
3. Install sun-jdk:
- emerge sun-jdk
- java-config -list-available-vms [look for the sun-jdk package]
- java-config --set-system-vm=sun-jdk-1.4.1.01 [or the latest sun-jdk]
4. Install flash plugin:
- emerge netscape-flash
5. Install j2sdk:
- emerge sun-j2sdk [make sure you have the r2 ebuild]
6. Reinstall openmotif and lesstif if they were installed
- emerge openmotif
- emerge lesstif

That's it! I hope this helps!
int1
Back to top
View user's profile Send private message
absi
n00b
n00b


Joined: 06 Nov 2002
Posts: 6

PostPosted: Sat Nov 16, 2002 6:42 pm    Post subject: Reply with quote

yippie, java works again :D - and took only 3 hours to compile...

thx for the instructions,

absi
Back to top
View user's profile Send private message
El_Presidente_Pufferfish
Veteran
Veteran


Joined: 11 Jul 2002
Posts: 1179
Location: Seattle

PostPosted: Sat Nov 16, 2002 9:59 pm    Post subject: Reply with quote

Works for me too :- D
Back to top
View user's profile Send private message
Exci
Apprentice
Apprentice


Joined: 12 Jul 2002
Posts: 265
Location: The Netherlands, Zoetermeer

PostPosted: Sun Nov 17, 2002 12:39 am    Post subject: Reply with quote

forget the script I wrote here, .. stupid post .. it's late :s
Back to top
View user's profile Send private message
TheCoop
Veteran
Veteran


Joined: 15 Jun 2002
Posts: 1814
Location: Where you least expect it

PostPosted: Sun Nov 17, 2002 8:56 am    Post subject: Reply with quote

excellant 8)
_________________
95% of all computer errors occur between chair and keyboard (TM)

"One World, One web, One program" - Microsoft Promo ad.
"Ein Volk, Ein Reich, Ein Führer" - Adolf Hitler

Change the world - move a rock
Back to top
View user's profile Send private message
dompie
n00b
n00b


Joined: 19 Nov 2002
Posts: 1

PostPosted: Tue Nov 19, 2002 3:44 am    Post subject: Re: Working mozilla 1.1 with plugins Reply with quote

int1 wrote:
5. Install j2sdk:
- emerge sun-j2sdk [make sure you have the r2 ebuild]


* Java 2 SDK Source <http://wwws.sun.com/software/java2/download.html>
From Sun's website, download the following files:
- j2sdk-1_4_0-src-scsl.zip
- j2sdk-1_4_0-motif-linux-i386.zip
- j2sdk-1_4_0-mozilla_headers-unix.zip

I tried to register and to download these files, but I didn't succeed. Can somebody mirror these files on a FTP please?
Thanks,
_________________
Michael
Back to top
View user's profile Send private message
zhenlin
Veteran
Veteran


Joined: 09 Nov 2002
Posts: 1361

PostPosted: Tue Nov 19, 2002 12:23 pm    Post subject: Reply with quote

We are bound by law not to do that.

Just go to http://wwws.sun.com/software/java2/download.html and get the files! It's not that difficult! (If you have difficulty, go to http://java.sun.com/j2se, goto Source Licensing, click Download under the Get menu)
Back to top
View user's profile Send private message
wowtip
n00b
n00b


Joined: 03 Oct 2002
Posts: 16

PostPosted: Wed Nov 20, 2002 7:41 pm    Post subject: Hmmm Reply with quote

zhenlin wrote:
Just go to http://wwws.sun.com/software/java2/download.html and get the files! It's not that difficult! (If you have difficulty, go to http://java.sun.com/j2se, goto Source Licensing, click Download under the Get menu)


Hm, the files "j2sdk-1_4_0-src-scsl.zip" and "j2sdk-1_4_0-motif-linux-i386.zip" doesnt't seem to be downloadable from there anymore? I got the first file from there, but can't seem to find the last two on that page. A search in sun's downloads didn't give much info either. :(
Back to top
View user's profile Send private message
pjp
Administrator
Administrator


Joined: 16 Apr 2002
Posts: 16102
Location: Colorado

PostPosted: Wed Nov 20, 2002 8:01 pm    Post subject: Reply with quote

Moved from Newbies.
_________________
lolgov. 'cause where we're going, you don't have civil liberties.

In Loving Memory
1787 - 2008
Back to top
View user's profile Send private message
zhenlin
Veteran
Veteran


Joined: 09 Nov 2002
Posts: 1361

PostPosted: Thu Nov 21, 2002 10:01 am    Post subject: Reply with quote

Try to find the mozilla headers under the Mozilla binaries section. Find the source files under the update-1.4.0 section.
Back to top
View user's profile Send private message
graadz
n00b
n00b


Joined: 12 Aug 2002
Posts: 55
Location: Enschede, Netherlands

PostPosted: Thu Nov 21, 2002 9:32 pm    Post subject: Re: Working mozilla 1.1 with plugins Reply with quote

Just wondering why do you need to install 2 JDKs: 1.4.1_01 and 1.4.0?
One is pre-build: 1.4.1_01 and the other one you compile it yourself. Doesn't seem logical to me.

G

int1 wrote:
For all those still struggling, I finally got mozilla 1.1 to work with flash and java plugins. Here are my steps:
1. Remove openmotif and lesstif temporarily if they are installed:
- emerge -C openmotif
- emerge -C lesstif
2. Install mozilla 1.1:
- cd /usr/portage/net-www/mozilla
- USE="-gtk2" emerge mozilla-1.1-r1.ebuild
3. Install sun-jdk:
- emerge sun-jdk
- java-config -list-available-vms [look for the sun-jdk package]
- java-config --set-system-vm=sun-jdk-1.4.1.01 [or the latest sun-jdk]
4. Install flash plugin:
- emerge netscape-flash
5. Install j2sdk:
- emerge sun-j2sdk [make sure you have the r2 ebuild]
6. Reinstall openmotif and lesstif if they were installed
- emerge openmotif
- emerge lesstif

That's it! I hope this helps!
int1
Back to top
View user's profile Send private message
HotShotDJ
Apprentice
Apprentice


Joined: 06 Nov 2002
Posts: 166

PostPosted: Fri Nov 22, 2002 12:10 am    Post subject: Re: Working mozilla 1.1 with plugins Reply with quote

graadz wrote:
Just wondering why do you need to install 2 JDKs: 1.4.1_01 and 1.4.0?
One is pre-build: 1.4.1_01 and the other one you compile it yourself. Doesn't seem logical to me.
This is because the source code for 1.4.0 has a "circular dependancy." It requires that you have java installed in order to compile java from source. Both sun java 1.4.1_01 and blackdown 1.4.1_beta satisfy this dependancy. Once you have compiled java 1.4.0 from source (and tested it, of course) you can remove the original one.
Back to top
View user's profile Send private message
rajendra82
n00b
n00b


Joined: 04 Aug 2002
Posts: 46

PostPosted: Fri Nov 22, 2002 12:33 am    Post subject: It won't work here Reply with quote

I was able to follow all of these steps. But java and mozilla are still not working together for me. While before, my mozilla just kept prompting me for a plugin when visiting a page with java. Now a visit to the same page just closes it completly 8O . No error reports, no seg fauls, in the blink of an eye mozilla just disappears. So now I have checked the box that says disable java. The end result is no improvement from before. :(
Back to top
View user's profile Send private message
MrJ412
n00b
n00b


Joined: 10 Apr 2002
Posts: 39
Location: Shawnee, KS

PostPosted: Fri Nov 22, 2002 8:06 am    Post subject: Success! Reply with quote

Worked perfectly! Thanks for the little howto! 8)
Back to top
View user's profile Send private message
graadz
n00b
n00b


Joined: 12 Aug 2002
Posts: 55
Location: Enschede, Netherlands

PostPosted: Fri Nov 22, 2002 8:47 am    Post subject: Re: Working mozilla 1.1 with plugins Reply with quote

Understood. But still, why two JVMs? I mean, step 3 already installs a JDK for you. Why would you want a second one?
The only thing you need to do, if you would skip step 5, is to make a softlink to the plugins directory of mozilla:

# ln -sf /opt/sun-jdk-1.4.1.01/jre/plugin/i386/ns600/libjavaplugin_oji.so \
/usr/lib/mozilla/plugins/libjavaplugin_oji.so

G

HotShotDJ wrote:
graadz wrote:
Just wondering why do you need to install 2 JDKs: 1.4.1_01 and 1.4.0?
One is pre-build: 1.4.1_01 and the other one you compile it yourself. Doesn't seem logical to me.
This is because the source code for 1.4.0 has a "circular dependancy." It requires that you have java installed in order to compile java from source. Both sun java 1.4.1_01 and blackdown 1.4.1_beta satisfy this dependancy. Once you have compiled java 1.4.0 from source (and tested it, of course) you can remove the original one.
Back to top
View user's profile Send private message
zhenlin
Veteran
Veteran


Joined: 09 Nov 2002
Posts: 1361

PostPosted: Fri Nov 22, 2002 9:13 am    Post subject: Reply with quote

sun-jdk is gcc-2.9x compatible. In other words, no java plugin.
sun-j2sdk is compatible with any gentoo system.

sun-j2sdk has some java sources that need to be compiled by a java compiler. I think they are probably critical VM or JDK components. Otherwise, it could just use the already compiled javac. It's like needing gcc to make gcc.
Back to top
View user's profile Send private message
int1
Tux's lil' helper
Tux's lil' helper


Joined: 08 Nov 2002
Posts: 139

PostPosted: Fri Nov 22, 2002 10:57 pm    Post subject: Re: Working mozilla 1.1 with plugins Reply with quote

That doesn't work on systems running gcc 3.2, such as the gentoo v1.4rc currently out. Hence the instructions above.

Glad to help everyone out!
int1

graadz wrote:
Understood. But still, why two JVMs? I mean, step 3 already installs a JDK for you. Why would you want a second one?
The only thing you need to do, if you would skip step 5, is to make a softlink to the plugins directory of mozilla:

# ln -sf /opt/sun-jdk-1.4.1.01/jre/plugin/i386/ns600/libjavaplugin_oji.so \
/usr/lib/mozilla/plugins/libjavaplugin_oji.so
Back to top
View user's profile Send private message
rajendra82
n00b
n00b


Joined: 04 Aug 2002
Posts: 46

PostPosted: Sun Nov 24, 2002 2:32 am    Post subject: Working now Reply with quote

I redid the steps and emerged Mozilla 1.2b instead, and now I have working mozilla and java. :D There are a few pages that I visit, that still cause a complete shutdown. If any of you that followed the same steps, to get mozilla and java working together, visit http://www.maharashtratimes.com/, and tell me if mozilla closes down, I'd appreciate it.
Back to top
View user's profile Send private message
int1
Tux's lil' helper
Tux's lil' helper


Joined: 08 Nov 2002
Posts: 139

PostPosted: Sun Nov 24, 2002 3:07 pm    Post subject: well Reply with quote

Just for your info, it doesn't close on 1.1b with the steps above. However, I don't have any of the international language packages installed on my system.

int1
Back to top
View user's profile Send private message
Craigo
Apprentice
Apprentice


Joined: 09 Aug 2002
Posts: 249
Location: /dev/life

PostPosted: Mon Nov 25, 2002 2:42 pm    Post subject: Reply with quote

Brilliant =) Phoenix is showing it all in it AA fonts, flash, java glory! =)

Now I can get on with everything!!
Back to top
View user's profile Send private message
S_aIN_t
Guru
Guru


Joined: 11 May 2002
Posts: 488
Location: Ottawa

PostPosted: Thu Dec 05, 2002 9:07 am    Post subject: Reply with quote

thanks for the little guide.. with the help of those instructions i got Java and flash working for Opera 6.11

now I have AA fonts in Opera + Java + flash.. i good to go. :D
Back to top
View user's profile Send private message
yokem55
Guru
Guru


Joined: 18 Apr 2002
Posts: 360
Location: Oregon

PostPosted: Thu Dec 05, 2002 10:21 am    Post subject: Reply with quote

What about realplayer? I can't even get mozilla to recognize it exists.....
Back to top
View user's profile Send private message
PlatinumCursor
n00b
n00b


Joined: 29 Oct 2002
Posts: 33
Location: Huntsville, AL

PostPosted: Fri Dec 06, 2002 12:01 am    Post subject: Reply with quote

Does this trick work with Mozilla 1.2.1 also? ThIs SoUnDs So ExCiTiNg!
_________________
PlatinumCursor
Blinded by the bling...
Back to top
View user's profile Send private message
robfish
Tux's lil' helper
Tux's lil' helper


Joined: 25 Nov 2002
Posts: 137
Location: New Zealand

PostPosted: Thu Dec 12, 2002 1:22 am    Post subject: Unsuccessful sun-j2sdk emerge Reply with quote

I have gone through steps 1 to 4 OK but with step 5 I have tried twice to get the same result when I emerge sun-j2sdk
I get...
!!! ERROR: dev-java/sun-j2sdk-1.4.0-r2 failed.
!!! Function src_compile, Line 34, Exitcode 2
!!! (no error message)
:cry:
Any ideas?
_________________
RobFish
Back to top
View user's profile Send private message
discostu
Guru
Guru


Joined: 01 Nov 2002
Posts: 333

PostPosted: Thu Dec 19, 2002 12:23 am    Post subject: Re: Unsuccessful sun-j2sdk emerge Reply with quote

I am also getting this error when emerging on a system with sun-jdk and gcc3.2.
robfish wrote:
I have gone through steps 1 to 4 OK but with step 5 I have tried twice to get the same result when I emerge sun-j2sdk
I get...
!!! ERROR: dev-java/sun-j2sdk-1.4.0-r2 failed.
!!! Function src_compile, Line 34, Exitcode 2
!!! (no error message)
:cry:
Any ideas?

See my thread
_________________
"Disco Stu doesn't advertise."
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum