Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
totem freezes under xorg-x11
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
Rieck
n00b
n00b


Joined: 23 Mar 2004
Posts: 5

PostPosted: Wed Aug 25, 2004 8:56 pm    Post subject: totem freezes under xorg-x11 Reply with quote

Hi,

I am having a strange problem with totem when using it under the Xorg
server. If I try to launch totem, nothing happens... no error message,
no window, nothing, nada.

A syscall trace looks like this...

Code:

 $ strace -f totem
execve("/usr/bin/totem", ["totem"], [/* 53 vars */]) = 0
[...]
writev(3, [{"\221\1\6\0\17\0\200\2", 8}, {"XInputExtension", 15}, {"\0", 1}], 3) = 24
read(3, 0xbfffdf70, 32)                 = -1 EAGAIN (Resource temporarily unavailable)
futex(0x80a16d8, FUTEX_WAKE, 1)         = 0
select(4, [3], NULL, NULL, NULL)        = 1 (in [3])
read(3, "\1\1E\0\0\0\0\0\1\0\3\0\1\0\0\0\1\0\0\0\30\0\0\0\10\367"..., 32) = 32
futex(0x80a16d8, FUTEX_WAIT, 2, NULL         [Freeze]


The problem is reproducible on a fresh Xorg emerge, but does not appear
when using Xfree. What could be wrong, any ideas?

Regards,
Rieck

P.S.
It's not a gstreamer problem, I am using USE="-gstreamer"

P.P.S.
I am running an SMP system, thus a deadlock might the problem.
Back to top
View user's profile Send private message
orion2012
n00b
n00b


Joined: 29 Mar 2004
Posts: 28

PostPosted: Thu Aug 26, 2004 2:58 am    Post subject: Reply with quote

Towards the bottom of my strace:
Code:
writev(3, [{"b\0\3\0\4\0\300\2", 8}, {"SYNC", 4}], 2) = 12
read(3, 0xbffff4d0, 32)                 = -1 EAGAIN (Resource temporarily unavailable)
select(4, [3], NULL, NULL, NULL)        = 1 (in [3])
read(3, "\1\0C\0\0\0\0\0\1\203A\200\0\0\0\0\1\0\0\0\37\0\0\0x\25"..., 32) = 32
write(3, "\203\0\2\0\3\0\300\2", 8)     = 8
read(3, 0xbffff590, 32)                 = -1 EAGAIN (Resource temporarily unavailable)
select(4, [3], NULL, NULL, NULL)        = 1 (in [3])
read(3, "\1\212D\0\0\0\0\0\3\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0"..., 32) = 32
writev(3, [{"b\0\4\0\7\0\300\2", 8}, {"MIT-SHM", 7}, {"\0", 1}], 3) = 16
read(3, 0xbffff4a0, 32)                 = -1 EAGAIN (Resource temporarily unavailable)
select(4, [3], NULL, NULL, NULL)        = 1 (in [3])
read(3, "\1\0E\0\0\0\0\0\1\226`\265\0\0\0\0\1\0\0\0\37\0\0\0x\25"..., 32) = 32
write(3, "\226\0\1\0", 4)               = 4
read(3, 0xbffff560, 32)                 = -1 EAGAIN (Resource temporarily unavailable)
select(4, [3], NULL, NULL, NULL)        = 1 (in [3])
read(3, "\1\1F\0\0\0\0\0\1\0\1\0\0\0\0\0\2\0\0\0\37\0\0\0x\25C\t"..., 32) = 32
pipe([4, 5])                            = 0
writev(3, [{"b\0\6\0\17\0\300\2", 8}, {"XInputExtension", 15}, {"\0", 1}], 3) = 24
read(3, 0xbffff530, 32)                 = -1 EAGAIN (Resource temporarily unavailable)
select(4, [3], NULL, NULL, NULL)        = 1 (in [3])
read(3, "\1\0G\0\0\0\0\0\1\227a\266\0\0\0\0\1\0\0\0\37\0\0\0x\25"..., 32) = 32
writev(3, [{"b\0\6\0\17\0\300\2", 8}, {"XInputExtension", 15}, {"\0", 1}], 3) = 24
read(3, 0xbffff400, 32)                 = -1 EAGAIN (Resource temporarily unavailable)
select(4, [3], NULL, NULL, NULL)        = 1 (in [3])
read(3, "\1\0H\0\0\0\0\0\1\227a\266\0\0\0\0\1\0\0\0\37\0\0\0x\25"..., 32) = 32
writev(3, [{"\227\1\6\0\17\0\300\2", 8}, {"XInputExtension", 15}, {"\0", 1}], 3) = 24
read(3, 0xbffff4a0, 32)                 = -1 EAGAIN (Resource temporarily unavailable)
select(4, [3], NULL, NULL, NULL)        = 1 (in [3])
read(3, "\1\1I\0\0\0\0\0\1\0\3\0\1\0\0\0\1\0\0\0\37\0\0\0x\25C\t"..., 32) = 32
rt_sigprocmask(SIG_SETMASK, NULL, [RTMIN], 8) = 0
rt_sigsuspend([]


I've been struggling with totem forever. One time when I got frustrated I just kept double clicking on the file, there were like 12 totem processes running, finally the file opened and started playing.... So that's how I have to watch something with totem, I've since switched to mplayer.
No help from Hadess on bugs.gnome.org. I'll try XFree.
Back to top
View user's profile Send private message
SirJoltalot
n00b
n00b


Joined: 11 Aug 2002
Posts: 30
Location: Toronto, Canada

PostPosted: Wed Sep 22, 2004 4:58 am    Post subject: Re: totem freezes Reply with quote

I'm seeing this too. Very odd. I just upgraded to xorg from xfree, so I thought it might be that this patch:

http://bugzilla.gnome.org/attachment.cgi?id=16145&action=view

was not applied. But looking in the patches tarball for xorg, it is there.

For more info on this bug, see:

http://bugzilla.gnome.org/show_bug.cgi?id=111349 and
http://bugzilla.gnome.org/show_bug.cgi?id=111880

I really like totem, so this is a shame. Anybody have more info on what's going on?
_________________
"The degree to which life sucks is directly proportional to your blood/caffeine ratio"
Back to top
View user's profile Send private message
SirJoltalot
n00b
n00b


Joined: 11 Aug 2002
Posts: 30
Location: Toronto, Canada

PostPosted: Tue Sep 28, 2004 3:20 pm    Post subject: Figured it out Reply with quote

The problem is that the patch to fix the problem is in X.org upstream, and Gentoo was applying another patch. Having both patches in re-introduced the problem (which is not surprising, since it was a locking bug).

If you modify your xorg-x11 ebuild to exclude patch 0155, you should be all good to go. See http://bugs.gentoo.org/show_bug.cgi?id=64929 for an updated ebuild that does that.

Works like a charm for me.
_________________
"The degree to which life sucks is directly proportional to your blood/caffeine ratio"
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum