Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Lirc + 2.6.7 + only works the first time
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
Paladine01
Tux's lil' helper
Tux's lil' helper


Joined: 17 Dec 2003
Posts: 131
Location: Phoenix AZ

PostPosted: Mon Jul 12, 2004 4:28 pm    Post subject: Lirc + 2.6.7 + only works the first time Reply with quote

I am using a vanilla kernel patched with a 2.6.5 lirc patch. Couldn't seem to find a 2.6.7 version one. The patch applies cleanly and I can compile lirc successfully. When I load it and use irxevent, it works for the first time. If I log out and log back in (which reexecutes irxevent), it won't work anymore. I can rmmod lirc_i2c and restart lircd, but that is not a viable solution since I don't want to have to do that manually each time.

Is there another patch set that exists that fixes this problem?
Back to top
View user's profile Send private message
Prefect47
n00b
n00b


Joined: 16 Feb 2004
Posts: 24

PostPosted: Mon Jul 19, 2004 12:32 pm    Post subject: Reply with quote

I have exactly the same problem with mythfrontend. Not a big problem since my box is a pure mythbox where mythfrontend isn't restarted very often. Haven't found a solution and can also not upgrade to 2.6.7 since lirc is missing there.

Has the lirc patch ebuild appeared yet? Can't check from work.

Edit: Found this thread.
Back to top
View user's profile Send private message
andyknownasabu
Apprentice
Apprentice


Joined: 06 Feb 2003
Posts: 281
Location: Zurich, Switzerland

PostPosted: Mon Jul 19, 2004 4:08 pm    Post subject: Reply with quote

What about using the recent love-sources?
They include lirc support afaik...

Have a look at
http://forums.gentoo.org/viewtopic.php?t=199802
Back to top
View user's profile Send private message
oscarwild
l33t
l33t


Joined: 15 Jul 2003
Posts: 857
Location: Memmingen, Germany, Old Europe, Earth

PostPosted: Mon Jul 19, 2004 5:51 pm    Post subject: Reply with quote

forget about patching the kernel for lirc support! Use the CVS version of lirc instead (take a look at http://www.lirc.org/cvs.html for further instructions) :-)

I've experienced problems for weeks now with any patched kernel I tried (love-sources 2.6.2...2.6.7). The lirc always worked for some hours but suddenly died, afterwards I had to do a reboot.
For me, the CVS package has been working fine for a whole day now ;)
Back to top
View user's profile Send private message
Fran
Guru
Guru


Joined: 29 Feb 2004
Posts: 524
Location: Coruña (Spain)

PostPosted: Mon Jul 19, 2004 6:55 pm    Post subject: Reply with quote

You have the same problem that I had with lirc-patch-2.6.5. Try with this patch instead. It's a modified version of the 2.6.2 (i think) patch that works in 2.6.7 kernels. It works perfectly for me.
Back to top
View user's profile Send private message
Zefiro
n00b
n00b


Joined: 19 Aug 2004
Posts: 8
Location: Karlsruhe / Germany

PostPosted: Thu Aug 19, 2004 5:07 am    Post subject: Reply with quote

This patch doesn't work for me (it asks for the location of a file linux/drivers/char/Kconfig which I don't know what to enter), for linux-2.6.7-gentoo-r11. I copied it to /usr/src/linux and said 'patch -p0 < lirc.patch', hoping it would be correct.

I also tried the original lirc CVS, but am clueless how to do it. I created a new directory (not in the kerneltree - should I? where should I put it?), got the CVS data, and followed the instructions. Namely "autogen.sh, setup.sh, make". Well, autogen complained about an old automake (needed 1.5, found 1.4-p6, I'v got 1.8 installed, so it's an problem of the detection wrapper), and when I said "make" it complained about not having and make targets.

I tried the 'lirc' ebuild (0.7.0_pre4), the output looking very similar to the CVS version one, just stating that I would need a kernelpatch (and refering to an URL only having 2.6.4 as latest version)

The mentioned bug in http://bugs.gentoo.org/show_bug.cgi?id=54518 claims it's easy to build an kernel patch ebuild. Since I've never done this and don't even get this to work, I'm stuck here.

Please help and give me a clue. Perhaps it's trivial, I just don't know where to start. And I would really hate so much giving up my shiny remote :)
Back to top
View user's profile Send private message
asiobob
Veteran
Veteran


Joined: 29 Oct 2003
Posts: 1375
Location: Bamboo Creek

PostPosted: Fri Aug 20, 2004 12:08 am    Post subject: Reply with quote

use the cvs version of lirc and you'll be set, look here. No patching required
http://forums.gentoo.org/viewtopic.php?p=1448997
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum