Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Gnome 2 Does not start... Xft ? Starts only in failesafe mod
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Jowilly
Guru
Guru


Joined: 22 Jun 2002
Posts: 319

PostPosted: Sun Oct 20, 2002 4:45 pm    Post subject: Gnome 2 Does not start... Xft ? Starts only in failesafe mod Reply with quote

Hello,

I just did a fresh gentoo 1.4 install, with xfree 4.2.1 and gnome-2.0.2-r2 with gnome-desktop-2.0.9 and gnome-panel-2.0.10.

On boot, xfree and gdm start fine.

But when I start gnome it loads and then holds for a while and restarts X.

Here is my .gnomerc-errors output:

-------------------------------------------------------------------
SESSION_MANAGER=local/Gentoo:/tmp/.ICE-unix/3286
Loaded background '0x80a05b8

** ERROR **: Failed to match any font. This could be due to a broken Xft configuration, or if you run XFree 4.1.0 due to a bug in libXrender. For more information about this, read http://bugzilla.gnome.org/show_bug.cgi?id=68030

aborting...

** ERROR **: Failed to match any font. This could be due to a broken Xft configuration, or if you run XFree 4.1.0 due to a bug in libXrender. For more information about this, read http://bugzilla.gnome.org/show_bug.cgi?id=68030

aborting...

** ERROR **: Failed to match any font. This could be due to a broken Xft configuration, or if you run XFree 4.1.0 due to a bug in libXrender. For more information about this, read http://bugzilla.gnome.org/show_bug.cgi?id=68030

aborting...

and so on... ---CUT--- and :

(gnome_segv2:3424): GLib-WARNING **: getpwuid_r(): failed due to unknown user id (0)

(gnome_segv:3424): Gdk-WARNING **: locale not supported by Xlib

(gnome_segv:3424): Gdk-WARNING **: can not set locale modifiers

(gnome_segv:3424): Gtk-WARNING **: cannot open display: :0
----------------------------------------------------------------------------


When I start gnome in Failsafe mode it works......

What can I do to make it start in normal mode ?

Thanks for your help !
Back to top
View user's profile Send private message
maKKus
Guru
Guru


Joined: 07 Aug 2002
Posts: 356
Location: /Universe/Milky Way/Sol/Earth/Europe/EEC/The Netherlands/Limburg/Beek/Neerbeek

PostPosted: Sun Oct 20, 2002 5:10 pm    Post subject: Reply with quote

Don't have a solution, but I was on the forum to report the same bug. Not from a fresh install but by doing a emerge -up world. I've exactly the same behavior. My other windowmanager xfce doesn't start either.

Failsafe gnome works! I did try a clean home (only a .bashrc) but this doesn't help.
Back to top
View user's profile Send private message
Jowilly
Guru
Guru


Joined: 22 Jun 2002
Posts: 319

PostPosted: Sun Oct 20, 2002 9:15 pm    Post subject: Reply with quote

I have disabled AA with export GDK_USE_XFT=0 in /etc/X11/gdm/Sessions/Gnome.
With this it works.

But how can I fix the problem with AA working ?
Back to top
View user's profile Send private message
Empty_One
n00b
n00b


Joined: 18 Oct 2002
Posts: 32

PostPosted: Mon Oct 21, 2002 11:57 am    Post subject: Reply with quote

I'm having the exact same problem. Fresh install, then did emerge gnome. I can only start gnome in failsafe mode.
Back to top
View user's profile Send private message
maKKus
Guru
Guru


Joined: 07 Aug 2002
Posts: 356
Location: /Universe/Milky Way/Sol/Earth/Europe/EEC/The Netherlands/Limburg/Beek/Neerbeek

PostPosted: Mon Oct 21, 2002 3:36 pm    Post subject: Reply with quote

Okay, disabling of AA works for me too. But this is not really a solution. I guess that rebuilding gnome with --emptytree is not a solution because people with fresh installs have the same problem.

On my systems at work I switched from Mandrake 8.2 to Red Hat 8.0. I was tempted to go for Gentoo, glad I didn't. But it will stay on my home system.
Back to top
View user's profile Send private message
aardvark
Guru
Guru


Joined: 30 Jun 2002
Posts: 576

PostPosted: Mon Oct 21, 2002 3:39 pm    Post subject: Reply with quote

there is apparently also a related problem with kde: kdebase 3.0.4 wont even emerge due to xft issues
Back to top
View user's profile Send private message
Jowilly
Guru
Guru


Joined: 22 Jun 2002
Posts: 319

PostPosted: Mon Oct 21, 2002 6:32 pm    Post subject: Fixed ! Reply with quote

Ok guys, I have killed that BLOODY THING ! :D

Edit : /etc/fonts/fonts.conf

And add your fonts to the list (the font dirs in /etc/X11/XF86Config), like this (cut and paste ready for you :wink: ) :

-------------------------------
<!-- Font directory list configured on Sat Oct 19 07:06:37 CEST 2002 -->

<dir>/usr/share/fonts</dir>
<dir>~/.fonts</dir>
<dir>/usr/X11R6/lib/X11/fonts/local</dir>
<dir>/usr/X11R6/lib/X11/fonts/misc</dir>
<dir>/usr/X11R6/lib/X11/fonts/Type1</dir>
<dir>/usr/X11R6/lib/X11/fonts/Speedo</dir>
<dir>/usr/X11R6/lib/X11/fonts/75dpi</dir>
<dir>/usr/X11R6/lib/X11/fonts/100dpi</dir>
<dir>/usr/X11R6/lib/X11/fonts/sharefont</dir>
<dir> /usr/X11R6/lib/X11/fonts/freefont</dir>
-------------------------------

Also, previously I have run fc-cache in each of those dirs... don't know if it has anything to do with it.... was poking arround....

ahh.... yes... much better with AA !
Back to top
View user's profile Send private message
AlterEgo
Veteran
Veteran


Joined: 25 Apr 2002
Posts: 1619

PostPosted: Mon Oct 21, 2002 7:09 pm    Post subject: Reply with quote

After upgrading to 4.2.1 I suddenly had a nasty 30 seconds-delay just after starting X, waiting for the KDE login-screen.

According to Jowilly's instructions,
I edited /etc/fonts/fonts.conf and fixed my font paths,
followed by 'fc-cache' (su root).

Now startup time's back to normal, thanks!
Back to top
View user's profile Send private message
line72
Apprentice
Apprentice


Joined: 13 Jun 2002
Posts: 212

PostPosted: Mon Oct 21, 2002 8:59 pm    Post subject: Reply with quote

rebuilding fontconfig fixes everything

/Line72
Back to top
View user's profile Send private message
Empty_One
n00b
n00b


Joined: 18 Oct 2002
Posts: 32

PostPosted: Mon Oct 21, 2002 10:00 pm    Post subject: Re: Fixed ! Reply with quote

Jowilly wrote:
Ok guys, I have killed that BLOODY THING ! :D

Edit : /etc/fonts/fonts.conf

And add your fonts to the list (the font dirs in /etc/X11/XF86Config), like this (cut and paste ready for you :wink: ) :



Thanks alot. It fixed my problem.
Back to top
View user's profile Send private message
maKKus
Guru
Guru


Joined: 07 Aug 2002
Posts: 356
Location: /Universe/Milky Way/Sol/Earth/Europe/EEC/The Netherlands/Limburg/Beek/Neerbeek

PostPosted: Mon Oct 21, 2002 10:04 pm    Post subject: Reply with quote

Thank you, worked for me :D
Back to top
View user's profile Send private message
lanalyst
n00b
n00b


Joined: 22 Oct 2002
Posts: 13

PostPosted: Tue Oct 22, 2002 2:38 pm    Post subject: Thanks... Reply with quote

I started installing 1.4 rc1 fresh yesterday and was stuck on this.

Spent the night reading up on Xft/xfs trying to figure out what this was going on... Thanks for the post! I'll check here first!

In addition, there isn't a /etc/X11/XftConfig ... just a symlink to the missing file under /usr/X11R6/lib/X11/XftConfig. I had to copy /usr/portage/x11-base/xfree/files/4.2.1/XftConfig manually.
Back to top
View user's profile Send private message
tobba
n00b
n00b


Joined: 22 Oct 2002
Posts: 4

PostPosted: Tue Oct 22, 2002 8:51 pm    Post subject: Reply with quote

Hello. I thought this thread would help me but no no... AA won't start.
i use gentoo 1.2, pretty fresh install.

I have copied my MS fonts over to /usr/lib/X11/fonts/truetype/, created fonts.scale and fonts.dir files as described in the Font De-Uglyfication HOWTO but i still get :

** ERROR **: Failed to match any font. This could be due to a broken Xft configuration, or if you run XFree 4.1.0 due to a bug in libXrender. For more information about this, read http://bugzilla.gnome.org/show_bug.cgi?id=68030

aborting...


here is the relevant section in /etc/fonts/fonts.conf


<!-- Font directory list configured on Sun Oct 20 21:47:28 CEST 2002 -->

<dir>/usr/share/fonts</dir>
<dir>~/.fonts</dir>


<dir>/usr/X11R6/lib/X11/fonts/truetype/</dir>
<dir>/usr/X11R6/lib/X11/fonts/local/</dir>
<dir>/usr/X11R6/lib/X11/fonts/misc/</dir>
<dir>/usr/X11R6/lib/X11/fonts/100dpi/</dir>
<dir>/usr/X11R6/lib/X11/fonts/75dpi</dir>
<dir>/usr/X11R6/lib/X11/fonts/Type1/</dir>
<dir>/usr/X11R6/lib/X11/fonts/Speedo/</dir>
<!--


I copied /usr/portage/x11-base/xfree/files/4.2.1/XftConfig to /usr/lib/X11/ and to /etc/X11 but no sucess there either..

is it the fact that im running a 1.2 system that causes this?

My Xfree version is 4.2.1 and i have all requrements (RENDER extension in xpdyinfo and so on...)

I'd be happy to supply more information if you need it.

The msfonts works when AA is disabled. but it dont help me much. I wanna AA!! :D
Back to top
View user's profile Send private message
mgirard
n00b
n00b


Joined: 30 Jul 2002
Posts: 64

PostPosted: Tue Oct 22, 2002 9:44 pm    Post subject: Reply with quote

Thanks for the help. Here is what I did to fix my problem.

re-emerge fontconfig
copied Xftconfig to /etc/X11 and edited directories
ran fc-cache in /etc/X11R6/lib/X11/fonts

That was it! Everything seems to look good now except for gnome-terminal which still has a jagged crappy looking font. Not sure why, but I am going to try re-building it.

-Mg


Update: Turns out I was just being dumb. I went into the gnome-terminal preferences and forced it to a specific font and now it looks great. Weird that the default would look so bad though.
Back to top
View user's profile Send private message
tobba
n00b
n00b


Joined: 22 Oct 2002
Posts: 4

PostPosted: Tue Oct 22, 2002 11:23 pm    Post subject: Reply with quote

well i found the problem.

bad filepermissions in /usr/lib/X11/fonts/*

works great now
Back to top
View user's profile Send private message
btregre
n00b
n00b


Joined: 22 Apr 2002
Posts: 11
Location: Louisiana, USA

PostPosted: Sat Oct 26, 2002 11:39 pm    Post subject: after emerging xfree 4.2.1 Reply with quote

after i emerge xfree 4.2.1, when i run startx my computer reboots. anyone have any ideas?
Back to top
View user's profile Send private message
RioFL
Guru
Guru


Joined: 31 Oct 2002
Posts: 407

PostPosted: Mon Nov 04, 2002 2:41 pm    Post subject: Gnome startup probs fixed Reply with quote

I followed MGirard's suggestions and it worked. Gnome now loads normally, however I have yet another problem. Any changes I make to the configuration, MiniCommander crashes every single time I exit Gnome!

any ideas?

Don't these people test these changes before they put something out to the public? My second machine was the first Gentoo install I did because it wasn't that important and I could use it to trash several times if needed:). That used portage 0.38 and everything installed properly and works except gdm authentication which I understand is some changed library somewhere. Gnome loads properly using startx so I wasn't too worried except for the lack of the xnest feature which requires gdm.

I started my good machine figuring I would clone the other machine, and guess what? Different versions of a lot of things! and more trouble than I bargained for. I use this machine for my work every day so this is really getting to me. I am still using my second machine for work because it has taken more than 10 days to figure out many of the bugs in the good machine's install. Not a very happy camper at this point. Gentoo is a great distro as far as its concept and performance is unmatched, my 400 is performing as well as my 800 did under suse, but it appears that there is no central 'clearing house' to actually do installs with these changes made to make sure they work before release.
<off soapbox now> :)

Chuck
Back to top
View user's profile Send private message
m_sylvain
n00b
n00b


Joined: 04 Nov 2002
Posts: 15
Location: France

PostPosted: Fri Nov 08, 2002 3:16 pm    Post subject: Is the <dir> directive recursive ? Reply with quote

Hello !

I just have those lines with the <dir> directive in my /etc/fonts/fonts.conf
<dir>/usr/X11R6/lib/X11/fonts</dir>
<dir>/usr/share/fonts</dir>
<dir>~/.fonts</dir>

But I was wondering if fonts /usr/X11R6/lib/X11/fonts/sharefonts would be
take in charge also ?

Regards

sylvain
Back to top
View user's profile Send private message
hakan
Apprentice
Apprentice


Joined: 11 Jul 2002
Posts: 252
Location: Aachen, Germany

PostPosted: Sun Nov 10, 2002 10:40 pm    Post subject: Reply with quote

I've made the changes in font.conf:
    <dir>/usr/X11R6/lib/X11/fonts</dir>
    <dir>/usr/share/fonts</dir>
    <dir>~/.fonts</dir>
    <dir>/usr/X11R6/lib/X11/fonts/local</dir>
    <dir>/usr/X11R6/lib/X11/fonts/misc</dir>
    <dir>/usr/X11R6/lib/X11/fonts/Type1</dir>
    <dir>/usr/X11R6/lib/X11/fonts/Speedo</dir>
    <dir>/usr/X11R6/lib/X11/fonts/75dpi</dir>
    <dir>/usr/X11R6/lib/X11/fonts/100dpi</dir>
    <dir>/usr/X11R6/lib/X11/fonts/sharefont</dir>
    <dir>/usr/X11R6/lib/X11/fonts/freefont</dir>
    <dir>/usr/X11R6/lib/X11/fonts/truetype</dir>
    <dir>/usr/X11R6/lib/X11/fonts/TTF</dir>


Gnome starts now when I login in GDM , but my nice freetype fonts not there. It looks ugly. If i start without GDM the fonts looking nice. How can I get my nice freetype fonts back, if I login over GDM?
_________________
-der kleine eine-
Back to top
View user's profile Send private message
hakan
Apprentice
Apprentice


Joined: 11 Jul 2002
Posts: 252
Location: Aachen, Germany

PostPosted: Mon Nov 11, 2002 5:55 pm    Post subject: Reply with quote

I dont get the thing with fontconfig. I've build mozilla with gtk2 option (and freetype and truetype) and it looks fine. But why Gnome doesnt look fine, too? Dont both applications use /etc/fonts/font.conf?? I am stuned now. Please Help.....
_________________
-der kleine eine-
Back to top
View user's profile Send private message
alaterale
Apprentice
Apprentice


Joined: 21 Jul 2002
Posts: 223
Location: Podunk

PostPosted: Mon Nov 11, 2002 8:21 pm    Post subject: Reply with quote

[quote="line72"]rebuilding fontconfig fixes everything

/Line72[/quote]

I'm curious, what did your 30 second delay look like after you started x?
I think I have a similar problem, but I don't know if its something else. I can't fix the problem with the font solution (although that did solve my ability to start gnome).

Thanks,
~~JS
_________________
I will maintain a realistic assessment of my strengths and weaknesses. Even though this takes some of the fun out of the job, at least I will never utter the line "No, this cannot be! I AM INVINCIBLE!!!" (After that, death is usually instantaneous.)
Back to top
View user's profile Send private message
hakan
Apprentice
Apprentice


Joined: 11 Jul 2002
Posts: 252
Location: Aachen, Germany

PostPosted: Tue Nov 12, 2002 5:14 pm    Post subject: Reply with quote

@alaterale

Do you start Gnome over GDM?
_________________
-der kleine eine-
Back to top
View user's profile Send private message
alaterale
Apprentice
Apprentice


Joined: 21 Jul 2002
Posts: 223
Location: Podunk

PostPosted: Tue Nov 12, 2002 7:51 pm    Post subject: Reply with quote

Well, I've started gnome through both startx and gdm, and other x window managers as well. I'm stumped still, but I do know now that windows has no similar problem, so it's probably software.
Incidentally, in my windows install (which I unfortunately need due to some software for my classes at school... :-/) my gentoo install became inaccessible. So now I'm going to pick up a floppy drive for my new computer and install gentoo again and make sure to make a boot floppy. Hopefully, the problem I had was just due to the version of x I used (4.2.1.something). If I have it again, I might try emerging an earlier version (any idea what the version before the one that's used now is?--i.e. when you type 'emerge xfree', assuming a fresh sync, what ebuild is used?)
Thanks,
alaterale
_________________
I will maintain a realistic assessment of my strengths and weaknesses. Even though this takes some of the fun out of the job, at least I will never utter the line "No, this cannot be! I AM INVINCIBLE!!!" (After that, death is usually instantaneous.)
Back to top
View user's profile Send private message
crevette
Guru
Guru


Joined: 21 May 2002
Posts: 543
Location: Chrooted in Nice, France

PostPosted: Tue Nov 12, 2002 8:13 pm    Post subject: Ok Reply with quote

Ok It's works better for me.
I have some fonts which make me crash but less than before the workaround.
_________________
http://www.mille-mathias.info
Back to top
View user's profile Send private message
rgzoso
n00b
n00b


Joined: 26 Jun 2002
Posts: 10
Location: Atlanta, GA

PostPosted: Tue Nov 12, 2002 9:51 pm    Post subject: still problems with AA fonts Reply with quote

export GDK_USE_XFT=1
reed@reedo reed $ gaim

** ERROR **: Failed to match any font. This could be due to a broken Xft
configuration, or if you run XFree 4.1.0 due to a bug in libXrender. For more
information about this, read http://bugzilla.gnome.org/show_bug.cgi?id=68030

aborting...
Aborted

I have make the above change to /etc/fonts/font.conf and also run the fc-cache command in eachof my font dirs. I can only start gnome and another gtk application without aa.

Anyone have any idea why my fonts are still messed up. They just got this way a few days ago, it must have been something I emerged. I do have fontconfig reinstalled and also have xft2 installed.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum