Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Warning : many lost ticks, time source seems to be instable
View unanswered posts
View posts from last 24 hours

Goto page 1, 2, 3, 4, 5, 6, 7  Next  
Reply to topic    Gentoo Forums Forum Index Gentoo on AMD64
View previous topic :: View next topic  
Author Message
pokkie
n00b
n00b


Joined: 29 Jun 2004
Posts: 13
Location: Reading, UK

PostPosted: Tue Jun 29, 2004 3:29 pm    Post subject: Warning : many lost ticks, time source seems to be instable Reply with quote

Hello all,

I have recently begun the long process of installing gentoo on my new Athlon 64. When I try to run

Code:
emerge kde


I get the following error msg repeatedly :

Code:
Warning: many lost ticks.
Your time source seems to be instable or some driver is hogging resources.


I am using gcc-3.3.3 on the latest 2.6.7-r6 kernel.

Any help would be greatly appreciated.

Regards,

-- Pokkie
Back to top
View user's profile Send private message
Geoffrey
n00b
n00b


Joined: 25 Jun 2004
Posts: 6

PostPosted: Tue Jun 29, 2004 3:34 pm    Post subject: Reply with quote

I personally don't have an AMD 64, but I think your computer is saying that your system clock is having problems. Try typing "date" on the shell, and then typing it again 1 hour later and seeing if your clock is consistent.
Back to top
View user's profile Send private message
pokkie
n00b
n00b


Joined: 29 Jun 2004
Posts: 13
Location: Reading, UK

PostPosted: Tue Jun 29, 2004 3:36 pm    Post subject: Reply with quote

Righto, will try that.

Thanks for the suggestion.

-- Pokkie
Back to top
View user's profile Send private message
pokkie
n00b
n00b


Joined: 29 Jun 2004
Posts: 13
Location: Reading, UK

PostPosted: Tue Jun 29, 2004 5:34 pm    Post subject: Reply with quote

Rigto, timed my clock for 1 hour and it didn't loose 1 second.

Any other suggestion would be most welcome.

Regards,

-- Pokkie
Back to top
View user's profile Send private message
asjapulk
n00b
n00b


Joined: 15 Apr 2004
Posts: 71

PostPosted: Tue Jun 29, 2004 6:12 pm    Post subject: DOT Reply with quote

I have the same problem. It kind of went away when I disabled dynamic overclocking (MSI Neo FIS2R m/b), but now it's back again.

I also have another problem:
I get

Code:
* Failed to set hardware clock to system clock

at boot time?
I set my time with rdate -s xxx.xx right but at next boot it's wrong again (+3 hours).
Back to top
View user's profile Send private message
Pink
Veteran
Veteran


Joined: 24 Jul 2003
Posts: 1062

PostPosted: Tue Jun 29, 2004 6:14 pm    Post subject: Reply with quote

I don't use a 64 but there is an option in the kernel which the notes say 'fixes' the lost ticks problem.

You may want to try that, (don't forget to mount /boot before copying over the new bzImage :) )

It's under Power Management -> acpi -> Power Management Timer Support.

This may help, but as I say I haven't got a 64...
_________________
usefuljaja.com - VPS Tutorials
Back to top
View user's profile Send private message
pokkie
n00b
n00b


Joined: 29 Jun 2004
Posts: 13
Location: Reading, UK

PostPosted: Tue Jun 29, 2004 9:30 pm    Post subject: Re: DOT Reply with quote

asjapulk wrote:
I have the same problem. It kind of went away when I disabled dynamic overclocking (MSI Neo FIS2R m/b), but now it's back again.


Heh, I just disabled dynamic overclocking on my MSI Neo Platinum and the errors seem to have disapeared. I also changed my memory timing, i think it is called, from T2 to T1.

PickledOnion wrote:
It's under Power Management -> acpi -> Power Management Timer Support.


Should it be enabled or disabled?

Regards,

-- Pokkie
Back to top
View user's profile Send private message
fumtu99
n00b
n00b


Joined: 05 Sep 2002
Posts: 59

PostPosted: Wed Jun 30, 2004 5:05 am    Post subject: Reply with quote

Um, I don't think it makes any difference, if you're running in 64-bit mode: that option ("Power Management Timer Support") doesn't appear in the Power Management->ACPI menu, if you're using the x86_64 architecture, and the only place where the flag would be used is in the arch/i386/kernel part of the source tree. This is bad news for me: I'm getting tons of those messages in my log file. I suspect that the only way I can disable it is by disabling frequency scaling, something I'd sort of like to keep for my notebook, just to keep it from burning up batteries quite so quickly. The funny thing is that if I run in 32-bit mode, I don't seem to need it; it might be time to submit a bug report, but I think that the bug is not in Gentoo, per se, but rather in the current state of the 64-bit kernel, so I'm not sure where I'd submit it.

James
Back to top
View user's profile Send private message
RAPUL
l33t
l33t


Joined: 29 Dec 2002
Posts: 664
Location: Valencia (SPAIN)

PostPosted: Wed Jun 30, 2004 1:46 pm    Post subject: Bios time. Reply with quote

Change time in BIOS.

Sometimes a corruption of CMOS gives unexpected errors.
_________________
Entropy rulz world.
Redundancy sux.
World is full of redundancy.
World sux.
Back to top
View user's profile Send private message
thaldyron
Apprentice
Apprentice


Joined: 25 Sep 2002
Posts: 227
Location: On Earth

PostPosted: Wed Jun 30, 2004 4:07 pm    Post subject: Re: Bios time. Reply with quote

RAPUL wrote:
Change time in BIOS.

Sometimes a corruption of CMOS gives unexpected errors.


I'm having exactly the same problem so I think it's rather a kernel issue than everyones' CMOS clock went nuts.
When I boot 2.6.5-r1 (64bit) the warning doesn't occur so it seems to be a bug that was introduced in gentoo-dev-2.6.7.
Back to top
View user's profile Send private message
asjapulk
n00b
n00b


Joined: 15 Apr 2004
Posts: 71

PostPosted: Wed Jun 30, 2004 4:28 pm    Post subject: still Reply with quote

My "Lost ticks" disappeared when I installed right driver in kernel for my PATA disk.
Thou still got the problem with * Failed to set hardware clock to system clock" at boot and shutdown:(

So if you get
Code:
Warning: many lost ticks.
Your time source seems to be instable or some driver is hogging resources.

You can:

    1. Disable Dynamic overclocking @BIOS
    2. Make sure that you have right device drivers installed in kernel. (IDE etc)
Back to top
View user's profile Send private message
thaldyron
Apprentice
Apprentice


Joined: 25 Sep 2002
Posts: 227
Location: On Earth

PostPosted: Thu Jul 01, 2004 1:54 am    Post subject: Re: still Reply with quote

asjapulk wrote:

You can:

    1. Disable Dynamic overclocking @BIOS
    2. Make sure that you have right device drivers installed in kernel. (IDE etc)

I didn't change any IDE drivers etc, and my notebook isn't overclockable anyways. I really think this is a kernel issue since so _many_ fellows are having the same problems.

Edit: Just tried gentoo-dev-sources-2.6.7-r7 but the problem remains.
Back to top
View user's profile Send private message
jman
n00b
n00b


Joined: 02 Jul 2004
Posts: 2

PostPosted: Fri Jul 02, 2004 6:48 am    Post subject: Asus K8V SE Deluxe, or any VIA chipset board. Reply with quote

I have a hunch that most of you are using a VIA chipset board. I have an Asus K8V SE Deluxe, and as soon as I recompiled my kernel with VIA VP IDE support, and disabled all of the other IDE drivers the problem is gone. I was having a lot of stability issues as well, but they seem to have cleared up. For those with notebooks, it's the speed-step type feature that is causing problems. There is a setting somewhere in the kernel options to fix it. For those with desktops, I guess the "Cool-n-Quiet" feature could cause the same kind of issues, but it's enabled on my system and it seems to be fine. In closing, I'm not so sure this is as much a kernel issue as it is a configuration issue. With new technology we have to worry about bugs in the code, and in our configuration. Good luck everyone. There is no question that Gentoo is the best way to flex your AMD64's muscles!
Back to top
View user's profile Send private message
Flappie
n00b
n00b


Joined: 01 Jul 2004
Posts: 8
Location: Netherlands

PostPosted: Fri Jul 02, 2004 11:29 am    Post subject: Reply with quote

Nopes i have the same problem and i have a sis chipset
Back to top
View user's profile Send private message
torklingberg
Tux's lil' helper
Tux's lil' helper


Joined: 30 May 2004
Posts: 86

PostPosted: Fri Jul 02, 2004 3:23 pm    Post subject: Reply with quote

Similar problem here, but the warning in dmesg is:
Code:

warning: many lost ticks.
Your time source seems to be instable or some driver is hogging [b]interupts[/b].
Losing some ticks... checking if CPU frequency changed.


I have an Asus K8V motherboard, and gentoo-dev-sources-2.6.7-r7. I have frequency scaling enabled in kernel config, but I would like to keep it. I do not get this warning from a 32-bit x86 kernel.

Has anyone filed it in Bugzilla? Or found out what config error causes this?
Back to top
View user's profile Send private message
jman
n00b
n00b


Joined: 02 Jul 2004
Posts: 2

PostPosted: Fri Jul 02, 2004 3:37 pm    Post subject: Reply with quote

For those who are sure they have the right IDE drivers, then it is a frequency scaling issue. "Cool-n-Quiet" on desktops. It does work fine on mine though.
Back to top
View user's profile Send private message
crontab
n00b
n00b


Joined: 13 Aug 2003
Posts: 6
Location: Netherlands

PostPosted: Fri Jul 02, 2004 4:41 pm    Post subject: Reply with quote

Hi,

I've had the same problem.
I solved it by compiling the via82xx into the kernel not as a module.
_________________
#!/usr/bin/perl -w
use Gentoo;
require AMD64 qw(3200+);
Back to top
View user's profile Send private message
thaldyron
Apprentice
Apprentice


Joined: 25 Sep 2002
Posts: 227
Location: On Earth

PostPosted: Fri Jul 02, 2004 5:44 pm    Post subject: Reply with quote

crontab wrote:
Hi,

I've had the same problem.
I solved it by compiling the via82xx into the kernel not as a module.


This didn't help me either. I'm pretty sure i've got the right IDE drivers because I didn't have that problem with 2.6.5... :?

@torklingberg: I'm getting exactly the same error msg.
Back to top
View user's profile Send private message
TiccTech
n00b
n00b


Joined: 13 Jun 2004
Posts: 34
Location: Oregon, US

PostPosted: Sat Jul 03, 2004 6:22 pm    Post subject: Reply with quote

The same problem is biting me -- 2.6.5 kernel works fine; 2.6.7-r6 or 2.6.7-r7 both lose ticks. Kernels compiled with the same (as close as possible) options. SiS760/964 chipset.

I also have a problem on 2.6.7 of the HID module failing to load. I didn't see anyone else mention that so it's not necessarily related.

Anyway, I guess it's time to try building some different kernels to see if that helps...

-TiccTech
Back to top
View user's profile Send private message
thaldyron
Apprentice
Apprentice


Joined: 25 Sep 2002
Posts: 227
Location: On Earth

PostPosted: Sat Jul 03, 2004 9:20 pm    Post subject: Reply with quote

TiccTech wrote:

I also have a problem on 2.6.7 of the HID module failing to load. I didn't see anyone else mention that so it's not necessarily related.

The hid module is called "usbhid" in 2.6.7!
Back to top
View user's profile Send private message
TiccTech
n00b
n00b


Joined: 13 Jun 2004
Posts: 34
Location: Oregon, US

PostPosted: Sat Jul 03, 2004 11:32 pm    Post subject: Reply with quote

thaldyron wrote:
The hid module is called "usbhid" in 2.6.7!

I'd missed that change -- thanks for the tip!
Where is that kind of change usually documented?

And, getting back on topic for this thread, :)

I seem to have gotten rid of my "many lost ticks" problem. I'd gone through my kernel config and attempted to clean up a bunch of stuff. So I don't know exactly which change(s) made the difference, and I probably won't bother to isolate the problem.

Here's a list of what I changed, in case it's of help to anyone still trying to track down this problem on their system. Left-hand .config reports zillions of "many lost ticks" messages, right-hand .config is clean. 2.6.7-r7 kernel, SiS760/964 chipset.

-TiccTech

Code:
# diff .config.old .config
28,29c28,29
< # CONFIG_POSIX_MQUEUE is not set
< # CONFIG_BSD_PROCESS_ACCT is not set
---
> CONFIG_POSIX_MQUEUE=y
> CONFIG_BSD_PROCESS_ACCT=y
55c55
< # CONFIG_KMOD is not set
---
> CONFIG_KMOD=y
167,170c167,168
< CONFIG_BLK_DEV_RAM=y
< CONFIG_BLK_DEV_RAM_SIZE=4096
< CONFIG_BLK_DEV_INITRD=y
< CONFIG_LBD=y
---
> # CONFIG_BLK_DEV_RAM is not set
> # CONFIG_LBD is not set
183c181
< CONFIG_IDEDISK_MULTI_MODE=y
---
> # CONFIG_IDEDISK_MULTI_MODE is not set
315,318c313
< CONFIG_FUSION=y
< CONFIG_FUSION_MAX_SGE=40
< # CONFIG_FUSION_ISENSE is not set
< # CONFIG_FUSION_CTL is not set
---
> # CONFIG_FUSION is not set
449,450c444
< CONFIG_AMD8111_ETH=y
< # CONFIG_AMD8111E_NAPI is not set
---
> # CONFIG_AMD8111_ETH is not set
580c574
< CONFIG_SERIAL_8250_CONSOLE=y
---
> # CONFIG_SERIAL_8250_CONSOLE is not set
589d582
< CONFIG_SERIAL_CORE_CONSOLE=y
620,621c613
< CONFIG_RAW_DRIVER=y
< CONFIG_MAX_RAW_DEVS=256
---
> # CONFIG_RAW_DRIVER is not set
919c911
< CONFIG_USB_HID=y
---
> CONFIG_USB_HID=m
922a915,920
>
> #
> # USB HID Boot Protocol drivers
> #
> # CONFIG_USB_KBD is not set
> # CONFIG_USB_MOUSE is not set
1017,1018c1015,1016
< CONFIG_AUTOFS_FS=y
< # CONFIG_AUTOFS4_FS is not set
---
> # CONFIG_AUTOFS_FS is not set
> CONFIG_AUTOFS4_FS=m
1171c1169
< CONFIG_CRC32=y
---
> CONFIG_CRC32=m
Back to top
View user's profile Send private message
herring
Apprentice
Apprentice


Joined: 22 Jul 2002
Posts: 187
Location: Norway

PostPosted: Mon Jul 12, 2004 10:40 am    Post subject: Reply with quote

MSI K8N Neo platinum, AMD64 3200+ and FX5700ULTRA. stage1 installation from gcc34-amd64-2004.2-test3. Nothing fancy; CFLAGS="-march=k8 -O2 -pipe", CHOST="x86_64-pc-linux-gnu", USE="", ACCEPT_KEYWORDS="amd64".

Im only getting "lost ticks" after starting xorg-x11. I am using nvidia driver (ver 1.0.5332-r1) .

Could it be this driver, or xorg-x11 itself being task-intensive ?
Back to top
View user's profile Send private message
herring
Apprentice
Apprentice


Joined: 22 Jul 2002
Posts: 187
Location: Norway

PostPosted: Mon Jul 12, 2004 11:02 am    Post subject: Reply with quote

Starting xorg-x11 without nvidia (using a vga driver 600x480) produced lost ticks as well...

EDIT> Btw I am using gentoo-dev-sources (linux-2.6.7-gentoo-r7) and fluxbox

Not sure if this info is useful:
From within xorg-x11 (X) running tail -f /var/log/messages in a xterm to monitor new tics
Iam not able to produce lost tics by running intensive tasks as emerging or starting programs like firefox

However, if I run glxinfo or glxgear, I am able to reproduce 2-3 error messages every time.


Last edited by herring on Mon Jul 12, 2004 3:02 pm; edited 1 time in total
Back to top
View user's profile Send private message
vyzivus
Apprentice
Apprentice


Joined: 05 Jul 2004
Posts: 173
Location: Slovakia

PostPosted: Mon Jul 12, 2004 12:41 pm    Post subject: Reply with quote

Yo!
I have exactly the same problem with my acer aspire 1501LMi. I tried all options from .config suggested by TiccTech (thanks for tips for useless devices :-) however the messages didn't disappear. Well I haven't checked them all: I don't see the point in compiling USB_HID as a module.
I tried to turn the CPU frequency scaling off but it was a disaster: avg temp was 5C higher than normal and fan never stopped. Only thing that disappeared was the line:
Losing some ticks... checking if CPU frequency changed.
I already posted the bug to amd64 gentoo devs, just check out
http://bugs.gentoo.org/show_bug.cgi?id=56073
I just compiled with AUTOFS4_FS=m, let's see what it does.
_________________
I thought what I'd do was, I'd pretend I was one of those deaf-mutes or should I?
Back to top
View user's profile Send private message
vyzivus
Apprentice
Apprentice


Joined: 05 Jul 2004
Posts: 173
Location: Slovakia

PostPosted: Mon Jul 12, 2004 1:30 pm    Post subject: Reply with quote

Ok, the avg fan was 15C higher above normal (50C), and compiling with AUTOFS4_FS=m didn't help either. I even tried compiling via8233 sound (i hope that was meant by via82xx :-), but ticks are still merciless. 2.6.7-r9 kernel, "VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE", using "VIA82CXXX chipset support" kernel driver.
_________________
I thought what I'd do was, I'd pretend I was one of those deaf-mutes or should I?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on AMD64 All times are GMT
Goto page 1, 2, 3, 4, 5, 6, 7  Next
Page 1 of 7

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum