Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Mini-HOWTO] X.org & font
View unanswered posts
View posts from last 24 hours

Goto page 1, 2, 3, 4  Next  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
solka
Apprentice
Apprentice


Joined: 25 Jun 2003
Posts: 287
Location: Torino - ITA

PostPosted: Fri Jun 18, 2004 10:43 pm    Post subject: [Mini-HOWTO] X.org & font Reply with quote

Mini-HOWTO X.org & font

Author: solka (solkanar[at]ngi[dot]it)
Version: 1.1
Update 1.1 of 18-06-2004: added Firefox 0.9 and some informations about its installation.
Most updated version: http://gentoo-wiki.com/HOWTO_Xorg_and_Fonts

Summary

  1. Why
  2. emerging the necessary packages
  3. Modify config files
  4. Services restart
  5. Mozilla Firefox 0.8 e 0.9
  6. Useful topics
  7. Thanks



1. Why

After changing the x server from Xfree to X.org many people (as me) had many problems
about the font rendering and the antialiasing. This mini-HOWTO has the purpose to give
a possible solution to the problem.


2. emerging the necessary packages

Supposing x.org installed correctly, you have to emerge the font packages, some of them
are already installed, but I advise to install them again.

These are the necessary packages:

  • media-libs/freetype
  • media-fonts/corefonts
  • media-fonts/freefonts


However I advise to install these fonts too:

  • media-fonts/artwiz-fonts
  • media-fonts/sharefonts
  • media-fonts/terminus-font
  • media-fonts/ttf-bitstream-vera
  • media-fonts/unifont

Emerge them:

Code:

emerge freetype corefonts freefonts artwiz-fonts sharefonts
\ terminus-font ttf-bitstream-vera unifont



3. Modify config files

When fonts are installed, you have to modify the config files in order to make the system
recognize them. These are the files you have to modify:


  • /etc/fonts/local.conf
  • /etc/X11/xorg.conf
  • ~/.fonts.conf


/etc/fonts/local.conf

In /etc/fonts/local.conf are set the font directories which are in the directory
/usr/share/fonts with x.org, so the file should be as the following listed but I advise
to check yours:

Code:

<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<!-- /etc/fonts/local.conf file for local customizations -->
<fontconfig>
<!--   
        <match target="font">
                <edit name="rgba" mode="assign"><const>rgb</const></edit>
        </match>
-->
        <dir>/usr/share/fonts/corefonts/</dir>
        <dir>/usr/share/fonts/terminus/</dir>
        <dir>/usr/share/fonts/unifont/</dir>
        <dir>/usr/share/fonts/Type1/</dir>
        <dir>/usr/share/fonts/freefont/</dir>
        <dir>/usr/share/fonts/artwiz/</dir>
        <dir>/usr/share/fonts/local/</dir>
        <dir>/usr/share/fonts/misc/</dir>
        <dir>/usr/share/fonts/Speedo/</dir>
        <dir>/usr/share/fonts/CID/</dir>
        <dir>/usr/share/fonts/ttf-bitstream-vera/</dir>
        <dir>/usr/share/fonts/util/</dir>
        <dir>/usr/share/fonts/sharefont/</dir>
        <dir>/usr/share/fonts/lfp-fix/</dir>
        <dir>/usr/share/fonts/TTF/</dir>
        <dir>/usr/share/fonts/75dpi/</dir>
        <dir>/usr/share/fonts/100dpi/</dir>
</fontconfig>


/etc/X11/xorg.conf

As the previous file you have to list your font directories in /etc/X11/xorg.conf:

Code:

< cut >

    FontPath   "/usr/share/fonts/ttf-bitstream-vera/"
    FontPath   "/usr/share/fonts/terminus/"
    FontPath   "/usr/share/fonts/corefonts/"   
    FontPath   "/usr/share/fonts/Type1/"
    FontPath   "/usr/share/fonts/freefont/"
    FontPath   "/usr/share/fonts/artwiz/"
    FontPath   "/usr/share/fonts/local/"
    FontPath   "/usr/share/fonts/misc/"
    FontPath   "/usr/share/fonts/75dpi/:unscaled"
    FontPath   "/usr/share/fonts/100dpi/:unscaled"
    FontPath   "/usr/share/fonts/Speedo/"
    FontPath   "/usr/share/fonts/CID/"
    FontPath   "/usr/share/fonts/encodings/"
    FontPath   "/usr/share/fonts/TTF/"
    FontPath   "/usr/share/fonts/util/"
    FontPath   "/usr/share/fonts/sharefont/"
    FontPath   "/usr/share/fonts/lfp-fix/"
    FontPath   "/usr/share/fonts/75dpi/"
    FontPath   "/usr/share/fonts/100dpi/"
    FontPath   "/usr/share/fonts/unifont/"

< cut >


In the same file, please pay attention to the line where the freetype module is loaded, it should be uncommented:

Code:

Load "freetype"


~/.fonts.conf

The config file ~/.fonts.conf is the own one for each user, it should be as the following:

Code:

<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<!-- /etc/fonts.conf file to configure system font access -->
<fontconfig>

<!--  Enable sub-pixel rendering
        <match target="font">
                <test qual="all" name="rgba">
                        <const>unknown</const>
                </test>
                <edit name="rgba" mode="assign"><const>rgb</const></edit>
        </match>
 
 -->
 
<!-- Autohint fonts
        <match target="font">
                <edit name="autohint" mode="assign"><bool>true</bool> </edit>
        </match>
-->
 
<!-- Use Bitstream Vera fonts by default -->
        <alias>
                <family>serif</family>
                <prefer>
                        <family>Bitstream Vera Serif</family>
                </prefer>
        </alias>
        <alias>
                <family>sans-serif</family>
                <prefer>
                        <family>Bitstream Vera Sans</family>
                </prefer>
        </alias>
        <alias>
                <family>monospace</family>
                <prefer>
                        <family>Bitstream Vera Sans Mono</family>
                </prefer>
        </alias>

<!-- Antialias -->

<match target="font">
        <test qual="any" name="size" compare="more">
                <double>8</double>
        </test>
        <test qual="any" name="size" compare="less">
                <double>15</double>
        </test>
        <edit name="antialias" mode="assign">
                <bool>true</bool>
        </edit>
</match>

</fontconfig>


The first option, which is commented with Enable sub-pixel rendering, is useful for those who have a LCD monitor.
However I advise to check by yourself the different configurations with sub-pixel rendering and font autohinting
(second option). The third option tells the system to use instead of the common serif, sans-serif and monospace fonts
the better Bitstreams.
The last option activates the antialiasing and it's quite explicative.


4. Services restart

After modifying config files, you have to restart xfs and x.org (if you use a graphical greeter
as GDM, KDM, XDM, etc. restaring x.org is possible by restarting the xdm service).

Code:

# /etc/init.d/xfs stop
# /etc/init.d/xdm stop
# /etc/init.d/xfs start
# /etc/init.d/xdm start


Then your own graphical greeter should start and entering your system you should have antialiased fonts.

5a. Mozilla Firefox 0.8

In order to have antialiased fonts with Mozilla Firefox 0.8 you have to modify another config file, that is
unix.js present in /usr/lib/MozillaFirefox/defaults/pref/ (if this path isn't yours, try running
locate unix.js).
You have to modify the lines under the // TrueType comment:

Code:

// TrueType
pref("font.FreeType2.enable", true);
pref("font.freetype2.shared-library", "libfreetype.so.6");
// if libfreetype was built without hinting compiled in
// it is best to leave hinting off
pref("font.FreeType2.autohinted", true);
pref("font.FreeType2.unhinted", true);
// below a certian pixel size anti-aliased fonts produce poor results
pref("font.antialias.min",        0);
pref("font.embedded_bitmaps.max", 1000000);
pref("font.scale.tt_bitmap.dark_text.min", 0);
pref("font.scale.tt_bitmap.dark_text.gain", "0.0");
// sample prefs for TrueType font dirs
pref("font.directory.truetype.1", "/usr/share/fonts/ttf-bitstream-vera");
pref("font.directory.truetype.2", "/usr/share/fonts/TTF");
pref("font.directory.truetype.3", "/usr/share/fonts/corefonts");
pref("font.directory.truetype.4", "/usr/share/fonts/freetype");
pref("font.FreeType2.printing", true);


Modify your file as the one listed.

The lines where are indicated the font directories are essential, by following
this HOWTO the previous ones are correct.

Then, in Firefox, go to
Tools --> Options --> General --> Fonts & Colors
and set these parameters:

Code:

Proportional: Serif (Size: 16)
Serif: Bits-bitstream vera serif
Sans-serif: Bits-bitstream vera sans
Monospace: Bits-bitstream vera sans mono (Size: 12)
Minimum font size: 9


You should also check that the following boxes aren't ticked: Always use my: Fonts / Colors

Then restart Firefox and browse www.gentoo.org with antialiased fonts!


5b. Mozilla Firefox 0.9

Before installing Firefox 0.9 I advise to remove, if installed, the old Mozilla Firefox for a correct usage and
then copy bookmarks.html, key3.db and signons.txt files present in the user directory (for Firefox 0.8 they are in
~/.phoenix/default.xxx/) and remove these directories and these files:

  • /usr/lib/MozillaFirefox
  • /usr/bin/firefox
  • ~/.phoenix

After the installation copy again the previous three files in ~/.mozilla/firefox/default.xxx/ .


In order to activate antialiased fonts in Firefox 0.9 I had to compile it with the USE flag "moznoxft".
So before proceeding with the emerging you should check that the flags moznoxft and truetype are set.

Code:

(note: at this time mozilla-firefox-0.9_rc1 is keyword masked)

USE="moznoxft truetype" ACCEPT_KEYWORDS=~x86 emerge mozilla-firefox


After compiling the emerging you should start once Firefox as normal user in order to create personal files in ~. After that,
you have to create the user.js file in ~/.mozilla/firefox/default.xxx/, where xxx are letters or numbers.
In the user.js file you have to insert these lines:

Code:

// TrueType
user_pref ("font.FreeType2.enable", true);
user_pref ("font.freetype2.shared-library", "libfreetype.so.6");
// if libfreetype was built without hinting compiled in
// it is best to leave hinting off
user_pref ("font.FreeType2.autohinted", true);

user_pref ("font.FreeType2.unhinted", true);
// below a certian pixel size anti-aliased fonts produce poor results
user_pref ("font.antialias.min",        0);
user_pref ("font.embedded_bitmaps.max", 1000000);
user_pref ("font.scale.tt_bitmap.dark_text.min", 0);
user_pref ("font.scale.tt_bitmap.dark_text.gain", "0.0");
// sample user_pref s for TrueType font dirs
user_pref ("font.directory.truetype.1", "/usr/share/fonts/ttf-bitstream-vera");
user_pref ("font.directory.truetype.2", "/usr/share/fonts/TTF");
user_pref ("font.directory.truetype.3", "/usr/share/fonts/corefonts");
user_pref ("font.directory.truetype.4", "/usr/share/fonts/freetype");
user_pref ("font.FreeType2.printing", true);


If you have followed this HOWTO you shouldn't have problem with the listed directories, otherwise you can change them.

Then run Firefox and go to
Tools --> Options --> General --> Fonts & Colors
and set these parameters:

Code:

Proportional: Serif (Size: 16)
Serif: Bits-bitstream vera serif
Sans-serif: Bits-bitstream vera sans
Monospace: Bits-bitstream vera sans mono (Size: 12)
Minimum font size: 9


Also check that the following boxes aren't ticked: Always use my: Fonts / Colors

Then restart Firefox and browse www.gentoo.org with antialiased fonts!


6. Useful topics

These are the topics from which I took informations in order to write this HOWTO:




7. Thanks

I want to thank the Gentoo Italian Community and the Gentoo Community, which make Gentoo so powerful and incredible.
A special thank to BlueRaven for his explanation about fonts in [xfree] caratteri sfocati and to FonderiaDigitale who led me to the final solution for my problem.
_________________
"The only reason of the man's sadness
is that he can't stay peacefully in his room."

Blaise Pascal


Last edited by solka on Sat Jul 03, 2004 12:54 pm; edited 2 times in total
Back to top
View user's profile Send private message
RinkyDinks_RJ
n00b
n00b


Joined: 12 Aug 2003
Posts: 42

PostPosted: Sat Jun 19, 2004 4:43 am    Post subject: Reply with quote

In #2, you have media-fonts/freefonts listen twice.

Also, for xfs, there is a config file located at /etc/X11/fs/config

You should also add any new fonts-directories to that file too--as xfs uses it to do whatever it does to the font directories. [Forgot the term(s)].
Back to top
View user's profile Send private message
solka
Apprentice
Apprentice


Joined: 25 Jun 2003
Posts: 287
Location: Torino - ITA

PostPosted: Sat Jun 19, 2004 7:31 am    Post subject: Reply with quote

Thanks for the note.
I think that the config file /etc/X11/fs/config is checked only if there is the FontPath "unix:-1" in xorg.conf so adding font directories in the former file is irrelevant...
_________________
"The only reason of the man's sadness
is that he can't stay peacefully in his room."

Blaise Pascal
Back to top
View user's profile Send private message
knopper
Tux's lil' helper
Tux's lil' helper


Joined: 20 Apr 2002
Posts: 104
Location: The Netherlands

PostPosted: Sat Jun 19, 2004 9:52 am    Post subject: Reply with quote

But it's also not needed to start xfs or am I wrong?
Back to top
View user's profile Send private message
solka
Apprentice
Apprentice


Joined: 25 Jun 2003
Posts: 287
Location: Torino - ITA

PostPosted: Sat Jun 19, 2004 10:30 am    Post subject: Reply with quote

Mmh...you are right. However I tried commenting all font lines in /etc/X11/fs/config, restarting xfs and x.org and it worked the same...well, I'll add the configuration of xfs config file just to make this howto more complete :)
Thank you all.
_________________
"The only reason of the man's sadness
is that he can't stay peacefully in his room."

Blaise Pascal
Back to top
View user's profile Send private message
knopper
Tux's lil' helper
Tux's lil' helper


Joined: 20 Apr 2002
Posts: 104
Location: The Netherlands

PostPosted: Sat Jun 19, 2004 4:43 pm    Post subject: Reply with quote

The howto works like a charm, though there's one thing I encountered.

The fonts weren't anti-aliased in Firefox until I did "fc-cache -fv" as root. This builds some indexes and more stuff for freetype fonts which are used by Firefox as explained by this howto.

Maybe it's something to put in the howto?

Anyway, great howto! (ahum, "mini" howto...)
Back to top
View user's profile Send private message
Sastraxi
Apprentice
Apprentice


Joined: 25 Feb 2003
Posts: 258

PostPosted: Sat Jun 19, 2004 5:09 pm    Post subject: Reply with quote

I'm pretty sure the /etc/init.d/xfs restart command will do that caching for you, though I'm not exceptionally sure.
Back to top
View user's profile Send private message
Master One
l33t
l33t


Joined: 25 Aug 2003
Posts: 754
Location: Austria

PostPosted: Sat Jun 19, 2004 5:17 pm    Post subject: Reply with quote

Nice try to gather all the fonts info spread over many topics in this forum.

You may want to adjust the order of your fonts in xorg.conf, because the first match is used, so it makes sense to have all TTF on top of the list.

As there seem to be no need for XFT at all, you may want to skip any explaination about /etc/X11/fs/config, remove xfs from the default runlevel, and stop xfs once and for all, it likely only eats resources.

I also did a lot of reading about X & fonts, tried a lot of things, and it looks pretty nice now, also there seem to be still some issues, especially as I do not know much about the various fonts themselves. I should have an old Corel Draw CDset here somewhere, with a whole bunch of nice TTF, I think I should try do find and extract the fonts to my Gentoo workstation :wink:
_________________
Las torturas mentales de la CIA
Back to top
View user's profile Send private message
knopper
Tux's lil' helper
Tux's lil' helper


Joined: 20 Apr 2002
Posts: 104
Location: The Netherlands

PostPosted: Sat Jun 19, 2004 5:56 pm    Post subject: Reply with quote

Sastraxi wrote:
I'm pretty sure the /etc/init.d/xfs restart command will do that caching for you, though I'm not exceptionally sure.


I'm not sure, but at least it didn't work for me. I restarted xfs like I should regarding the howto.
Back to top
View user's profile Send private message
Master One
l33t
l33t


Joined: 25 Aug 2003
Posts: 754
Location: Austria

PostPosted: Sat Jun 19, 2004 7:19 pm    Post subject: Reply with quote

Ok, this is weird. I just recompliled mozilla-firefox 0.9-r1 with the option "moznoxft", but then I don't get any antialiasing / hinting / subpixel-rendering at all, as expected. Everything else it set up correctly, and I tried it with xfs turned on and off.

So how do you exect to get antialiased fonts without xft?

I must have missed something. I am gonna recomplile firefox without "nomozxft" again now, it seems to be working this way, except some fonts look a little bulky then, like the menulist on top of this forum page (I mean the "FAQ | Search | ..."), but this may he due to subpixel-rendering & hinting.

It is very strange, it seems not to be possible to get the same look like under WinXP. As I already mentioned in another threat, I have two workstation here side by side, one with Gentoo, the other with WinXP, each using an equal LCD panel.

On WinXP the ClearType rendering is enabled, the main difference is, that some fonts (like the forum-menulist) look clear and sharp, and the rest gets rendered well, but under Gentoo everything gets rendered differently and some a little too much (like the forum-menulist, with then looks a little foggy and bulky). BTW I have copied the WinXP fonts-folder to my Gentoo machine, so I have access to the same TTFs there.

One other thing: With firefox compiled with "moznoxft" the listing of the fonts in the preferences (Edit -> Preferences -> General -> Fonts & Colors) looks totally different. For example instead of
Code:
Bitstream Vera Serif
I get
Code:
bitstream-bitstream vera serif-iso8859-15

Setting up fonts under Linux is still some kind of mystery, this is what I can tell, when also looking at the many topics here in this forum about fonts, which show that most people have no clue how it really works, it's more of a trial & error game,

BTW Do you have compiled freetype with the option BINDIST or without? I tried both, but again everything looked a little more bulky with using BINDIST,
_________________
Las torturas mentales de la CIA
Back to top
View user's profile Send private message
Sastraxi
Apprentice
Apprentice


Joined: 25 Feb 2003
Posts: 258

PostPosted: Sat Jun 19, 2004 9:13 pm    Post subject: Reply with quote

I have the exact same problems with this guide. Everything else is BEAUTIFUL.
Back to top
View user's profile Send private message
solka
Apprentice
Apprentice


Joined: 25 Jun 2003
Posts: 287
Location: Torino - ITA

PostPosted: Sat Jun 19, 2004 10:39 pm    Post subject: Reply with quote

Master One: I noticed that without the use flag moznoxft the fonts of the menubar were antialiased but web page fonts weren't. Recompiling Firefox 0.9 with this flag set gave me the opposite result, that is web page fonts antialiased and normal menu fonts. However please pay attention to the fonts selected in the preferences because they should be Bits-bitstream-* and not bitstream-bistream-*, in fact with the latter font set the web fonts are awful for me.
About freetype, I compiled it without "bindist".
And I must agree with you that fonts in linux are a kind of mistery ;)
Please tell me if compiling Firefox with "moznoxft" and selecting the correct fontset make things better, otherwise I'd like to find a common solution to add in my HOWTO.
_________________
"The only reason of the man's sadness
is that he can't stay peacefully in his room."

Blaise Pascal
Back to top
View user's profile Send private message
solka
Apprentice
Apprentice


Joined: 25 Jun 2003
Posts: 287
Location: Torino - ITA

PostPosted: Sat Jun 19, 2004 10:42 pm    Post subject: Reply with quote

knopper wrote:

The fonts weren't anti-aliased in Firefox until I did "fc-cache -fv" as root. This builds some indexes and more stuff for freetype fonts which are used by Firefox as explained by this howto.


Mumble...as said /etc/init.d/xfs should do this at restart...I'll add a little note for this. Thanks for your feedback :)
_________________
"The only reason of the man's sadness
is that he can't stay peacefully in his room."

Blaise Pascal
Back to top
View user's profile Send private message
Master One
l33t
l33t


Joined: 25 Aug 2003
Posts: 754
Location: Austria

PostPosted: Sun Jun 20, 2004 1:06 pm    Post subject: Reply with quote

solka wrote:
Master One: I noticed that without the use flag moznoxft the fonts of the menubar were antialiased but web page fonts weren't. Recompiling Firefox 0.9 with this flag set gave me the opposite result, that is web page fonts antialiased and normal menu fonts.

I don't understand this. Using "moznoxft" = ugly fonts without antialiasing in the menubar and web pages, without "moznoxft" everthing's fine except some fonts look a little "over-antialiased" and therefore some kind of bulky.

There has to be something different between our systems.

If you compile firefox with "moznoxft", you tell it not to use the X FreeType interface library, therefore you do not get any FreeType fonts rendering, which leeds to the result I mentioned before.

If you nevertheless get nicely rendered fonts also without xft, another component in your setup takes over the fonts rendering.

xfs can also render TTF fonts, but therefore it has to be in use, which means the font paths in xorg.conf would have to be replaced by the xfs fontpath. As I understand it, xfs is not used at all, if not included by
Code:
FontPath  "unix/:-1"
that's why I mentioned, that you do not need to start xfs at all, if not using it this way, as it's just a waste of system resources then.

solka wrote:
However please pay attention to the fonts selected in the preferences because they should be Bits-bitstream-* and not bitstream-bistream-*, in fact with the latter font set the web fonts are awful for me.

Another strange thing, because I have media-fonts/ttf-bitstream-vera-1.10-r3 properly installed on my system, but it's not showing up as Bits-bitstream-*, but only as mentioned before.

We should try to track down, what the main differences between our two installations could be. At the moment, I have no clue how you got to your results.

solka wrote:
Please tell me if compiling Firefox with "moznoxft" and selecting the correct fontset make things better, otherwise I'd like to find a common solution to add in my HOWTO.

I can't select the font the way you mentioned it, as it is not showing up in the fontlist in the firefox font-config menu.

Can it have something to do with the locale? As you can see, I'm using iso8859-15 here, and in the firefox font-menu "Fonts for: Western".

It looks like I again have to play with the fonts setup, I am simply not satisfied with the result until now. There has to be the right mix of subpixel-rendering, hinting and antialiasing.

At the moment I am writing this on my WinXP workstation. I am not sure, how it is solved in WinXP, but maybe it's not using antialiasing at all, but only subpixel-rendering and hinting. This would explain the visual difference in the forum menu-line (I don't know which font is used for it), which looks sharp and clear. Anyone knows what the "ClearType" option is actually doing to the fonts rendering?

BTW These are the firefox font settings unter WinXP:
Code:
Fonts for: "Western"
Proportional: Serif (Size: 16)
Serif: Times New Roman
Sans-serif: Arial
Monospace: Courier New (Size: 13)
Display resolution: 96 dpi
Minimum font size: None


I surely have not the proper knowledge background, when it comes down to the whole fonts management system. Maybe someone can point out some links to good documents, how all this fonts stuff exactly works unter Linux. I especially still do not understand the following points:

- What exactly is the X server doing with fonts, as it is instructed to load the modules "freetype", "type1" and "speedo" in my xorg.conf, besides letting it know the paths to all my fonts?
- How exactly is the X FreeType interface library (= xft) involved? Is this only due to the module "freetype" beeing loaded by the X server? And which configuration options is it using (only Xft.something in .Xresources or .Xdefaults?)?
- How is rendering working exactly, if both FreeType AND xfs are in use?
- How exactly is fontconfig involved, as it only handles fonts, but does not do any rendering itself (but why then give all the options in /etc/fonts/local.conf and /etc/fonts/fonts.conf -> looks like these only get passed on, but where to)?

For me this all looks just like a weird mix of different components, not beeing able to get it all down to one simple and common configuration.

Did you ever thing about, why font paths can be declared in 3 different places (xorg.conf - /etc/fonts/local.conf - /etc/X11/fs/config)?

If not using xfs, you usually have all your font paths in xorg.conf and /etc/fonts/local.conf. When you do then a "fc-cache -fv", you will see, that all your font-dirs get scanned twice, so there has to be a redundancy. Maybe it is not at all intended, to insert all your font-dirs in /etc/fonts/local.conf as well?

Maybe it's possible to gather all this information in this how-to. I would love to be able to finally come to an end playing arround with all that fonts stuff, there are surely more important things to do... :wink:
_________________
Las torturas mentales de la CIA
Back to top
View user's profile Send private message
solka
Apprentice
Apprentice


Joined: 25 Jun 2003
Posts: 287
Location: Torino - ITA

PostPosted: Sun Jun 20, 2004 1:40 pm    Post subject: Reply with quote

Quote:
Another strange thing, because I have media-fonts/ttf-bitstream-vera-1.10-r3 properly installed on my system, but it's not showing up as Bits-bitstream-*, but only as mentioned before.

We should try to track down, what the main differences between our two installations could be. At the moment, I have no clue how you got to your results.


That's another strange thing because I tried using bitstream-bitstream and while in Firefox 0.8 this fontset made web pages awful, in Firefox 0.9 it renders correctly. And a stranger thing, I searched in all fonts.list and fonts.dir but I couldn't find a line mentioning the Bits-bitstream-* fontset, also in xfonstel it doesn't appear...I'm really becoming mad.

About xfs you're right, I only used to restart it to make the system do fc-cache automatically but it can be removed without problems.

Unfortunately (well, it depends by the point-of-view eheh) I'm going to the seaside and I'm coming back on the second of july, so I can't give much time to this HOWTO since I'll come back.

I hope we'll find a good solution to this problem, I think that fonts are one of the few things that linux can't manage properly.
_________________
"The only reason of the man's sadness
is that he can't stay peacefully in his room."

Blaise Pascal
Back to top
View user's profile Send private message
Master One
l33t
l33t


Joined: 25 Aug 2003
Posts: 754
Location: Austria

PostPosted: Sun Jun 20, 2004 3:06 pm    Post subject: Reply with quote

I think we then should open a new threat in the forum (not under documentation, tips & tricks) to have an open discussion, so that other can also contribute to this problem, especially as some other seem to get the same results like me.

I'll be on holliday for about a week from the 2nd July, but we definitely should deal with this fonts issue after I'm back. In the meantime I'll start my own investigation, there is quite a lot to try. Actually I'm using FVWM2, so no additional software (like the gnome-settings-daemon) is involved. I really can't believe, that it's not possible to get a real good fronts setup under linux.
_________________
Las torturas mentales de la CIA
Back to top
View user's profile Send private message
Sastraxi
Apprentice
Apprentice


Joined: 25 Feb 2003
Posts: 258

PostPosted: Sun Jun 20, 2004 3:59 pm    Post subject: Reply with quote

I think part of the reason we're having major problems is that Firefox actually uses *pango* and its xft backend for its fonts, if you don't specify moznoxft. Thus, changing settings in the gnome manager can help, but we do get the stupid glyphs... the stupid smooth 'x', the 'k' with hardly any diagonal stroke, etc... but I think that this *may* just be the font we're using -- I think I've seen that ugly font, it's the sans one they put in for things like "Verdana" when they don't have the actual font to work with.

I guess I didn't say much of use, but I'm really trying to find what fonts in X are all about. If you ask me, "X" in some respects is just too old and confusing to be useful these days.

Just a little addition, ldd says firefox isn't a dynamic executable. If it was statically linked with all of the libraries at compile-time, could this be part of the problem?
_________________
Platypus.
Back to top
View user's profile Send private message
plbe
l33t
l33t


Joined: 01 May 2004
Posts: 661

PostPosted: Sun Jun 20, 2004 6:00 pm    Post subject: Reply with quote

I had the same problem as one of the previous posters I compiled firefox with moznoxft flag and fonts looked like crap, I emerged again without that flag and only truetype and everything worked great although I didn't have xfree previously installed I guess that could be why
Back to top
View user's profile Send private message
Master One
l33t
l33t


Joined: 25 Aug 2003
Posts: 754
Location: Austria

PostPosted: Mon Jun 21, 2004 5:44 pm    Post subject: Reply with quote

I also installed xorg-x11 from scratch, so there was no Xfree on this system before, but I don't think this has something to do with these font problems.

Next I am gonna try to install some more TTFs from an old Corel CD set, it may be due to the selection of fonts here in my workstation.
_________________
Las torturas mentales de la CIA
Back to top
View user's profile Send private message
BlindSpy
Apprentice
Apprentice


Joined: 20 Mar 2004
Posts: 263

PostPosted: Mon Jun 21, 2004 9:11 pm    Post subject: Reply with quote

Just wanted to say GREAT GUIDE. This is very important information and i think it should be made a part of the FAQ. mods?

thanks again for the good work.
_________________
Symlinks to:
xorg.conf
Back to top
View user's profile Send private message
torklingberg
Tux's lil' helper
Tux's lil' helper


Joined: 30 May 2004
Posts: 86

PostPosted: Fri Jun 25, 2004 7:18 pm    Post subject: Reply with quote

media-fonts/corefonts is masked. Nothing to worry about or?
Back to top
View user's profile Send private message
Bash[DevNull]
Guru
Guru


Joined: 10 Oct 2003
Posts: 333

PostPosted: Fri Jun 25, 2004 8:43 pm    Post subject: Reply with quote

Hm, it will be good practice if you all publish screenshot with results, so i and any other can compare results!
_________________
Biomechanical Artificial Sabotage Humanoid
Back to top
View user's profile Send private message
torklingberg
Tux's lil' helper
Tux's lil' helper


Joined: 30 May 2004
Posts: 86

PostPosted: Fri Jun 25, 2004 10:17 pm    Post subject: Reply with quote

I had two issues with the HOWTO:

1. artwiz changed my mouse cursor. Moving FontPath "/usr/share/fonts/artwiz/" to the end of the list fixed that.

2. running "/etc/init.d/xdm stop" from within X made my computer freeze completely.
Back to top
View user's profile Send private message
BlindSpy
Apprentice
Apprentice


Joined: 20 Mar 2004
Posts: 263

PostPosted: Sat Jun 26, 2004 5:32 pm    Post subject: Reply with quote

ISSUES:

1. I've did the 0.9 guide and I didnt have an user.js file so I just made one. It seemed to make some fonts anti-alias but not all.
_________________
Symlinks to:
xorg.conf
Back to top
View user's profile Send private message
Sastraxi
Apprentice
Apprentice


Joined: 25 Feb 2003
Posts: 258

PostPosted: Sat Jun 26, 2004 7:50 pm    Post subject: Reply with quote

From my last post, I recompiled firefox without moznoxft... and it looks amazing. Thanks a lot for the guide, but I still do recommend changing that "moznoxft" tip =)
_________________
Platypus.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page 1, 2, 3, 4  Next
Page 1 of 4

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum