Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
gstreamer not registering any plugins
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
greywolf
n00b
n00b


Joined: 22 Jun 2002
Posts: 18
Location: Scotland

PostPosted: Wed Apr 28, 2004 12:46 am    Post subject: gstreamer not registering any plugins Reply with quote

I should preface this post by admitting that i have dabbled with some breakmygentoo ebuilds recently, which may have contributed to my problem.

When trying to upgrade to the most recent gstreamer and rhythmbox (0.8x), i have managed somehow to break my gst installation. Everytime i run (and re-run) gst-register, it says:

Code:
rebuilding global_registry (/usr/local/var/cache/gstreamer-0.8/registry.xml)
rebuilding user_registry (/root/.gstreamer-0.8/registry.xml)
loaded 0 plugins with 0 features


Running gstreamer-properties naturally is useless because there are no sinks to play through. I have tried re-emerging and unmerging and re-emerging every gst related package, with no progress.

I have no idea what would be causing this, all the 0.8x gst packages compile and install perfectly well, but gstreamer just cannot register any of it's components. There must be a simple fix for this, but I lack the knowledge to find one.
Back to top
View user's profile Send private message
greywolf
n00b
n00b


Joined: 22 Jun 2002
Posts: 18
Location: Scotland

PostPosted: Wed Apr 28, 2004 3:00 pm    Post subject: Reply with quote

**BUMP**
Back to top
View user's profile Send private message
Kabuto
l33t
l33t


Joined: 01 Aug 2002
Posts: 701

PostPosted: Wed Apr 28, 2004 5:30 pm    Post subject: Reply with quote

You running gst-register-0.8 for .8?
It should build /var/lib/cache/gstreamer-0.8/registry.xml and all libs should be in /usr/lib/gstreamer-0.8 subdir.
Back to top
View user's profile Send private message
greywolf
n00b
n00b


Joined: 22 Jun 2002
Posts: 18
Location: Scotland

PostPosted: Wed Apr 28, 2004 5:50 pm    Post subject: Reply with quote

Like I said, all the gstreamer ebuilds appear to build perfectly. The /usr/lib/gstreamer-0.8 dir is full of files.
The /var/lib/cache/gstreamer-0.8/registry.xml is empty and the /root/.gstreamer-0.8/registry.xml file only contains the following:
Code:
<?xml version="1.0"?>
<GST-PluginRegistry>
<gst-plugin-paths>
</gst-plugin-paths>
</GST-PluginRegistry>

There must be something causing gst-register-0.8 to look in the wrong dir (not /usr/lib/gstreamer-0.8) and thus finding no plugins. Is it as simple as changing a file to tell it to look somewhere else?
Back to top
View user's profile Send private message
greywolf
n00b
n00b


Joined: 22 Jun 2002
Posts: 18
Location: Scotland

PostPosted: Wed Apr 28, 2004 6:37 pm    Post subject: Reply with quote

Hmm.. I seem to have fixed it. Not sure exactly what changed this time.

I deleted both the /var/cache/gstreamer-0.8 dir and the /root/.gstreamer-0.8 dir and then reinstalled all the gst* packages.

This time, it installed the registry.xml file to /usr/local/var/cache/gstreamer-0.8. It also contains a line reading:
Code:
<path>/usr/local/lib/gstreamer-0.8</path>

I just did a
Code:
ln -s /usr/lib/gstreamer-0.8 /usr/local/lib/gstreamer-0.8

A gst-register-0.8 now registers all the components as expected now.

Strange...
Back to top
View user's profile Send private message
robmoss
Retired Dev
Retired Dev


Joined: 27 May 2003
Posts: 2634
Location: Jesus College, Oxford

PostPosted: Wed May 12, 2004 1:41 pm    Post subject: Reply with quote

I'm having the same problems you did. I'll see if I can follow your solution; if I can I'll post back exactly what I did.
_________________
Reality is for those who can't face Science Fiction.

emerge -U will kill your Gentoo
ecatmur, Lord of Portage Bash Scripts
Back to top
View user's profile Send private message
infirit
l33t
l33t


Joined: 11 Jan 2003
Posts: 774
Location: Hoofddorp / The Netherlands

PostPosted: Sun May 16, 2004 12:10 pm    Post subject: Reply with quote

greywolf wrote:
This time, it installed the registry.xml file to /usr/local/var/cache/gstreamer-0.8.
How did you install the plugins to /usr/local/....... ? did you copy it or did you modify the ebuild?

Thanks
_________________
EASY TO INSTALL = Difficult to install, but instruction manual has pictures.
Join the adopt an unanswered post initiative today
Back to top
View user's profile Send private message
miklid
n00b
n00b


Joined: 19 Nov 2003
Posts: 15
Location: Sweden

PostPosted: Mon May 17, 2004 9:44 am    Post subject: Reply with quote

I've got the same problem here;

Code:
miklid@manta miklid $ gst-register-0.8
trying to load global_registry
rebuilding user_registry (/home/miklid/.gstreamer-0.8/registry.xml)
loaded 0 plugins with 0 features


Ideas anyone??
Back to top
View user's profile Send private message
MK
Tux's lil' helper
Tux's lil' helper


Joined: 27 Nov 2002
Posts: 97
Location: Bærum, Norway

PostPosted: Mon May 17, 2004 10:09 am    Post subject: Reply with quote

I got the same problem, tried a lot of things, but nothing seems to work, gst-register-0.8 --gst-plugin-path=/usr/lib/gstreamer-0.8 should work I'd hope, but no success. :(
Back to top
View user's profile Send private message
leartist
n00b
n00b


Joined: 21 May 2004
Posts: 5
Location: Karlsruhe, Germany

PostPosted: Fri May 21, 2004 7:53 pm    Post subject: Same problem as the one noted here? Reply with quote

anyone use reiser4?

http://forums.gentoo.org/viewtopic.php?t=175794
_________________
-- one step beyond --
linux-2.6 + gentoo + reiser4 + udev + nptl
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum